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Installation notes 
For the workshop, following programs are necessary: 

• Jana2006 for most tasks 
• Diamond for plotting crystal structures 
• Superflip (part of Jana2006 distribution) for solution of phase problem 
• Vesta for visualization of electron density with isosurfaces and for magnetic structures 
• PETS for data processing of electron diffraction patterns 
• ImageJ for viewing graphical output from PETS 

 
Diamond can be replaced by any other plotting software capable to read CIF in command line. For the 
workshop we recommend Diamond because the connection with Jana2006 is very well tested. 
 

Installation of Diamond 
Install demo version of Diamond from the directory Setup\Diamond installation in the flash disk. 

Copy the licence file “yourlicence.lic” to the same directory where Diamond.exe has been installed. 
Usually it will be c:\Program files\Diamond 4 
This time limited license has been kindly provided by Crystal Impact for this workshop. 

Note: Diamond started from Jana2006 may behave differently than when started separately. For 
instance, it doesn’t offer automatic wizards. 
 
Installation of Vesta 
Unpack the archive “Vesta_2.1.2.zip” from the directory Setup\Vesta to a directory of your choice 

 
Installation of Jana2006 
Execute janainst.msi from the directory 
Setup\Jana2006 and follow instructions. 
The installation creates shortcut to Jana2006 in the 
desktop and in Start → Programs 

Start Jana2006, go to “Tools → About Jana2006” and 
verify the version string. 
The version date should be close to the workshop date 
 
 
Configuration of Jana2006 
Start Jana2006 
Go to “Tools → Preferences”, adjust size of the window (for instance 60% of the screen height) and font 
height (about 11 points) 
Go to “Tools → Programs”; focus with mouse the textbox “Graphic viewer”; press “Browse” and localize 
Diamond.exe (usually in Program Files x86) 
Focus "3d visualization of maps"; press “Browse” and localize VESTA.exe 
(VESTA is needed for examples 9.x, 10.x, 12.x and 13.x) 
For using a different text editor than Notepad define its pathname in the textbox “Editor name”.  
  

• Don’t use your “old” preinstalled 
versions of Jana2006 

• Don’t use flash disk for calculation. 
Copy the example files to hard disk. 

• Don’t install Jana2006 to desktop or 
flash disk 
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Installation of ImageJ (only for electron diffraction) 
Install ImageJ from the installer in the directory Setup\ImageJ to a directory of your choice. Use ij148-
jdk6-64bit-setup.exe, if you have a 64-bit system. Use ij148-jdk6-setup.exe for a 32-bit system, or if you 
are not sure. 
 
Installation of PETS (only for electron diffraction) 

Copy the file pets.exe from the directory Setup\PETS to a directory of your choice.  
 
Add ImageJ and PETS in the system variable PATH: 
Under Windows XP: 
Go to “Start → Settings → Control Panel” 
Double click “System” 
Go to “Advanced → Environment variables” 
In the list “System variables” find and double click “Path” 
In the small window that opens, add the full paths to the files ImageJ.exe and pets.exe (without 
the file names), separated by a semicolon 
Under Windows 7: 
Right click on the Computer icon on your Desktop and choose “Properties → Advanced system settings 
→ Environment variables 
In the list “System variables” find and double click “Path” 
In the small window that opens, add the full paths to the files ImageJ.exe and pets.exe (without 
the file names), separated by a semicolon 
 
Launching PETS: 
PETS must be called with the input file as a command-line argument. There are several ways of launching 
PETS: 
Method 1 – the most convenient: 
Locate the file .pts (input to PETS) on your system 
Right-click to open context menu 
 “Open → Select program from a list → Browse…” 
Locate the file pets.exe on your system; Open 
Make sure the checkbox next to “Always use the selected program to open this kind of file” is checked 
OK 
PETS starts. Next time you want to run PETS, it is sufficient to double click the icon of the pts file you 
want to run. Unfortunately, this method fails on some systems, notably if the extension pts is already 
associated with another software. 
Method 2: 
Place the shortcut to PETS on Desktop: 
Locate the file pets.exe on your system 
Select it and copy it to clipboard (Ctrl+C) 
Place cursor on the place on the desktop where you want to place the icon of PETS 
Right-click → Paste shortcut 
Now you can run PETS by drag-and-dropping the file .pts on the icon on the desktop. Unfortunately, even 
this method does not work on all systems. 
Method 3 – works always: 
Open DOS terminal (Start → All programs → Accessories → Command Prompt) 
Move to the directory with the file .pts you want to use (use command cd) 
Run PETS by typing “pets filename.pts”, where filename.pts is the file you want to use. 
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Upgrade of Jana2006 installed from janainst.msi (new way of installation) 
Execute janainst.msi and follow instructions. Make sure the installation directory is the same like for the 
previous version. 
The installation wizard will reinstall Jana2006. For the same version it will offer “Modify – Repair – 
Remove”. 
 

Upgrade of Jana2006 installed from janainst.exe (old way of installation) 
Previously Jana2006 was installed from the self extracting archive janainst.exe. The user had to define 
“by hand” the system environment variable JANA2006DIR. The installation from janainst.msi in some 
cases cannot reinstall Jana2006 installed from janainst.exe. 

Start Jana2006 (old installation) 
Go to “Tools → About Jana2006” and note the version string. 

Start janainst.msi and follow instructions. Make sure the installation directory is the same like for the 
old version. 

Start Jana2006 (new installation) 
Go to “Tools → About Jana2006” and verify the version string is new. 

Troubleshooting (for upgrade of Jana2006 installed from janainst.exe) 

1. Installation from janainst.msi was running without warnings but the version string of 
Jana2006 remains old 

Start janainst.msi again. It will offer “Modify – Repair – Remove”. Used “Remove” and uninstall old 
version of Jana2006. 

Start janainst.msi (the third time) and follow instructions. Make sure the installation directory is the 
same like for the old version. 

Start Jana2006 (new installation) 
Go to “Tools → About Jana2006” and verify the version string is new. 

2. Another issues or when method 1 fails 

Localize installation directory of Jana2006 and make backup copy of jana2006.ini and jana2006.hst 

Delete installation directory of Jana2006 

Go to “Start → Settings → Control Panel → System” 
Go to page “Advanced” 
Press “Environment variables” 
Delete all instances of JANA2006DIR in User variables as well as in System variables 

Start janainst.msi and follow instructions. 

Return files jana2006.hst and jana2006.ini to the installation directory (where jana2006.exe is located) 

Start Jana2006 (new installation) 
Go to “Tools → About Jana2006” and verify the version string is new. 
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Example 1.1: Zn 
Revised: 4 March 2019 
 

Data Topic  Level 

X-ray single crystal data Solution of a simple crystal structure 
from single crystal data 

Basic  

Tasks 
Solving a simple structure from single crystal X-ray data 

- creating new jobname 

- reading input files 

- determination of symmetry 

- solving a structure with charge flipping 

- editing of atomic parameters 

- refinement 

- hydrogen assignment 

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
Zn.hkl, Zn_red.sum 
Additional information: 
Chemical formula: (NH3CH2CH2NH3)2ZnCl6 
Frame scaling, absorption correction: done by the diffractometer software  
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step1) 
Left pane: locate directory with input files; Right pane: double-click Zn (Step2) 

Notes  
Right pane detects possible Jana files and shows the jobname for each group of files 

Step 1 Step 2 

  

2. Import wizard 

Select “Known diffractometer formats”; NEXT (Step1) 
Select “Oxford Diffraction → CCD”; NEXT (Step2) 
Select “Input from “sum” file”; OK (Step3) 

Step 1 Step 2&3 

  
 
Leave all settings unchanged; NEXT (Step4) 
Leave all settings unchanged; NEXT; OK; (Step5) 
The program reads 24240 reflections from the hkl file 
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Step 4 Step 5 

  

For the absorption correction select “None or done before importing”; NEXT (Step6) 
FINISH  (Step7) 

Step 6 Step 7 

  
 

3. Data Repository 
 

Notes  
Each line in the data repository window corresponds to one data set converted to Jana 
format. In this case, we use only one data set. Data repository is saved in the file Zn.m95. 

OK; YES to accept the data set (Step1) 
Next; (Step2) 
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Step 1 Step 2 

 

 

II. Symmetry and data merging  

1. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 

Notes  
Symmetry Wizard can be started separately by “File → Reflection file → Make space group 
test”. 

Leave all settings default; NEXT; OK (Step1) 
[On the screen: Select Laue symmetry] 
Select Orthorhombic Laue symmetry; NEXT (Step2) 

Select primitive unit cell; NEXT (Step3) 
[On the screen: Select space group] 

 

 

Step 1 Step 2 
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Notes  
The window shows possible space groups. 
“Obs/all” column shows, for each space group, the number of reflections, which should be 
systematically extinct. For instance, Pbnm has “Obs/all”=2/1677, which means that 1677 
reflections in the reflection file should be systematically absent, i.e. with intensity below 
the 3σ limit. Nevertheless, two of them have intensity above the 3σ limit and, therefore, 
violate the rules for systematic absences. 
“Ave(I/sig(I)” lists average ratio I/σ (I) for columns “Obs/all”. For Pbnm this means that the 
1677 theoretically absent reflections have the average I/σ (I) = 0.153, and the two of them 
violating the systematic absences have the average I/σ (I) = 4.783. 
The limits for the average ratio I/σ (I) were defined previously in “Tolerances” window. 
Space groups exceeding the limits are not offered. 
For selecting the proper space group, we are looking for the cases with high number of 
unobserved systematically absent reflections and having reasonably low average I/σ (I) for 
reflections violating the extinction rules. In our example, Pbnm is more likely than Pbmm 
because the number of experimentally confirmed absent reflections is much larger.  
The list of the strongest reflections contradicting the selected space group can be displayed 
by “Details” button. 
Jana2006 does not test data for center of symmetry. At this point, a centrosymmetric 
space group should be preferred unless we have already a strong reason to select a non-
centrosymmetric space group. Thus, we select Pbnm and not Pbn21. Centrosymmetry is 
usually confirmed or denied in following steps by the symmetry analysis by Superflip (see 
Step 6). 

Select Pbnm; NEXT (Step4) 

 
Accept the space group in the standard setting, i.e. like Pnma; FINISH (Step5) 
Symmetry is saved in file Zn.m50. 
  

Step 3 Step 4 
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2. Creating refinement reflection file 

Notes  
In this step, the program creates file Zn.m90 containing the data set merged by symmetry 
and discarded forbidden reflections. M90 will be used for refinement. 

NEXT to confirm threshold 3sigma; OK; OK (to confirm Information windows) (Step1) 

[On the screen: settings for merging the reflections] 
Check “Display graph sig(Icount)/sig(Istat)”; NEXT (Step2) 
[On the screen: graphs of sigma] 

Notes  
The vertical axis shows the sigma of reflections calculated from merging statistics. 
The horizontal axis for black circles (white on the screen): sigma as obtained from the 
diffractometer file 
The horizontal axis for blue circles (green on the screen): sigma obtained from the 
diffractometer file and corrected by the “instability factor” calculated such that the values 
from the diffractometer file are fitted to the values from merging statistics.  

Step 5  

 

 

Step 1 Step 1b 
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For highly redundant data sets with reliable merging statistics, it is recommended to use 
such “instability factor” for the weighting scheme during refinement (done at the end of 
this example). 

QUIT 
Step 2 graphs of sigma 

 
 

The program reports Rint 3.97% for 1259 observed reflections merged from 12466 observed 
reflections. 
Select "Accept the new DatBlock and calculate coverage"; FINISH (Step3) 

Step 2b Step 3 
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III. Structure solution  

1. Structure solution wizard  

 [On the screen: Structure solution] 
Notes  
Structure solution wizard can be executed separately through “Run  → Structure solution” 
or by double clicking the icon “Structure solution” in the main window. 
Jana2006 does not contain solution procedures, it calls external programs. The program 
used in most our examples is Superflip (using the charge flipping algorithm) because it is 
distributed together with Jana2006. For standard structures, a good alternative is SHELXT 
but it cannot be distributed without registration so (users should connect it individually).  

In “Formula” textbox type list of chemical elements: Zn Cl C N H (Step1) 
Notes  
Superflip as well as SHELXT does not need exact information about chemical elements 
because it is required only for analysis of the resulting electron density. Other solution 
methods like SIR may need the correct formula and number of formula units. 

Select “Use Superflip”; leave other settings default; press “Run solution” 
[On the screen: window of Superflip replaced after reaching the convergence with listing of 
Superflip] 

Notes  
Superflip converges (after noise suppression) with R value ~15%. For charge flipping, this is 
a very good result. The space group suggested from the symmetry search in the electron 
density map is Pnma, i.e. the same obtained previously in Jana2006. The low agreement 
factors at the bottom of the listing indicate good fit of the user-defined symmetry elements 
(here Pnma) with the resulting electron density map. 

 
Step 1  

 

 

Press CLOSE to leave the listing 
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2. Verification of the structure solution from the structure solution wizard 

[On the screen: Structure solution] 
Press “Draw structure” (Step1) 
Press "Draw + continue" 

Step 1  

 

 

 
[On the screen: window of Diamond] 
Start “Build  Get molecules” or use  on the bottom toolbar 
Rotate the molecule (  and  on the bottom toolbar) to get an optimal view. 
Move the mouse pointer over the terminal carbon atoms. Diamond will show the labels of 
the atoms. Note the labels (probably C1,C2) of the terminal carbons. 
 

Notes  
By comparison with the chemical diagram, it is clear that the terminal carbon atoms are 
in fact nitrogen atoms. We have to note their labels in order to change them later to 
nitrogen. 

[On the screen: plot of the structure in Diamond] 
 

 
Quit Diamond (without saving changes) 

[On the screen: Structure solution] 
Press “Draw 3d map” (Step1b) 

Step 1b  
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[On the screen: window of VESTA] 
 

Notes  
This button starts Vesta (requires path to Vesta set in Tools  →  Programs), which plots 
the electron density produced by Superflip together with atomic positions found by 
Jana2006.   

 

 
Quit VESTA without saving the plot 

 
Press “Accept last solution”. This action will also close the structure solution wizard 

3. Assignment of correct chemical types 

[On the screen: basic Jana window] 
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Start EditM50; (Step1) 
Go to page Composition; enter 4 for “Formula units”, press “Formula from M40” (Step2) 

Notes  
It displays the formula Zn Cl6 C8 (for Z=4). However, the expected composition (without 
hydrogens) is Zn Cl6 C4 N4. This means that some nitrogens have been falsely assigned as 
carbons.The expected chemical formula also suggests that nitrogens should be at the 
terminal positions of the organic part. 

 
[On the screen: Information about formula] 

OK; YES for updating the formula. 
Notes  
Number of elements in the formula are not important for refinement. This information is 
useful only for interpretation of difference Fourier maps and for creating the final CIF. The 
chemical types in m40 are defined by their sequence numbers in the chemical formula. 
Nevertheless, the order of atoms in the formula can be arbitrarily changed if it is done 
through EditM50. Also new chemical elements can be included at an arbitrary position of 
the formula. 

OK; YES to rewrite M50 
Start “Edit atoms” (Step3) 
[On the screen: list of atoms] 
Select (with Ctrl-left mouse button) the previously noted terminal carbon atoms 

Notes  
Plotting of the structure can be repeated by “Plot structure” icon 

Start “Action → Edit/define” (Step4) 
  

Step 1 Step 2 
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Step 3 Step 4 

 

 

Choose “Type” nitrogen; OK (Step5) 
[On the screen: list of atoms. The labels are still the original ones but the chemical type of 
two selected atoms is nitrogen] 
Press “Select All” 
Press “Action” or right-click on one of the selected atoms 
Choose “Rename selected atoms to atom_type + number” (Step6) 

Step 5 Step 6 

  
 
[On the screen: list of atoms with labels corresponding to chemical types] 
You should see one zinc, four chlorines, two nitrogens and two carbons. 
Press “Select All” 
Press “Action” or right-click on one of the selected atoms 
Choose “Make symmetrically contiguous motifs” (Step7) 

Notes  
This makes editors of Acta E happy and it is necessary for using some special tools like rigid 
body (later in this Cookbook). The symmetrically contiguous motif means that the atoms 
are at bonding distances without applying symmetry operations. 
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Step 7  

 

 

OK; YES to save the changes 

IV. Refinement and model improvement  

1. Refinement 

 [On the screen: basic window of Jana] 
Right-click the icon of Refine. (Step1) 
[On the screen: refinement options] 
Define 100 of cycles; OK (Step2) 
Choose “YES+START” 
Refinement converges with Robs value about 6% 

Step 1 Step 2 

 
 

Start “Edit atoms” (Step3) 
[On the screen: list of atoms] 
Press “Select all” and “Action → Edit/define” 
Choose “harmonic” for ADP parameters. (Step4) 

Notes  
This defines anisotropic temperature parameters for all atoms.  
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OK, OK, Yes to save changes 
Refinement converges with Robs value about 4 % for 73 refined parameters. 

Step 3 Step 4 

 

 

Double-click the icon Refine. 

2. Adding of hydrogen atoms 

[On the screen: basic window of Jana] 
Start “Edit atoms” 
Select carbons and nitrogens 
Start “Action → Adding of hydrogen atoms” (Step1) 
[On the screen: Adding of hydrogen atoms dialogue] 
Leave all settings default; OK (Step2) 
The procedure adds automatically C-H hydrogen atoms, while for adding hydrogens to the 
terminal NH3 groups it goes to the manual mode.  
[On the screen: Adding of hydrogen atoms for N1] 

Step 1 Step 2 

  

For the type of coordination select “Tetrahedral”, change number of neighbors to 1 
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Notes  
Using tetrahedral geometry instead of trigonal around nitrogen follows from the 
chemistry. The terminal groups must be protonated to reach the charge balance. 
The only neighbor of N1 is C1 (or C2 depending on how the maxima were assigned after 
running Superflip). You can verify this by focusing the textbox with C1 (or C2) and pressing 
“Select neighbors”. 

Define names of hydrogens, for instance H1N1, H2N1 and H3N1 (Step3) 
Start “Locate position in the map” 
[On the screen: difference Fourier map showing the hydrogen maxima]  
Press “Optimal” and “Apply” (Step4) 

Notes  
Locating position in the map is not necessary. In most cases, the proper rotation of NH3 or 
CH3 group is correctly refined from the initial positions. However, in this case the map helps 
us to confirm the NH3 groups. 

 [On the screen: Adding of hydrogen atoms to N1] 
“Apply → Go to next” 

Step 3 Step 4 

 
 

Repeat the procedure for N2 
[On the screen: list of atoms] 

Notes  
Total number of atoms should be 19 (can be verified with Select All). 
The ideal geometry of hydrogen atoms is kept by commands, which can be viewed or 
edited in “Refinement commands → Various → Keep commands”. 

OK to close Atoms-Edit; Yes to save changes 
“Plot structure” to check results of hydrogen assignment 

[On the screen: window of Diamond] 

Start “Build → Connectivity” or press button  
[On the screen: Connectivity dialogue] 
Press "Evaluate" to see which bonds will be used by Diamond. Bonds between Cl and H 
should be disabled.  
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Plot the structure with  

Use  at the bottom toolbar of Diamond to see ADP ellipsoids. 
Quit Diamond 

[On the screen: basic window of Jana2006] 
Double-click Refine and refine the final structure 

Notes  
Refinement converges with R factor 2.5%, goodness of fit 1.9. Number of refined 
parameters is still 73 because the positions of hydrogen atoms are defined geometrically. 

3. Extinction correction 

[On the screen: basic window of Jana2006] 
Open listing of Refine (by “Edit/View → View of Refine”) 
Press “Go to” and select “Statistics Fo, sin(th)/lambda after refinement” (Step1) 

Notes  
R value should decrease with increasing intensity or with lowering the diffraction angle. Here 
the R value for the strongest reflections, as well as for the lowest angle reflections, is higher 
than in the neighboring shell. This suggests that extinction correction is required. 

Step 1 

 
Close the refinement listing 
“Parameters → Extinction” (Step2) 
Select “Isotropic-Becker&Coppens” “Type 1” “Gaussion”; OK  (Step3) 
Refinement of the extinction coefficient is enabled by default 
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Step 2 Step 3 

 

 

[On the screen: basic window of Jana2006] 
Double-click Refine and refine the final structure  
Refinement converges with R factor 2.24%, goodness of fit 1.77, 74 parameters. 
Check the extinction coefficient through “Parameters → Extinction” 
View listing of Refine; Go to “Statistics”; check improved R value for strongest reflections.  

Notes  
The resulting structure 

 

Right-click the icon of Refine. 
[On the screen: refinement options] 
Check “Refinements on F(obs)**2”; OK; YES to start the program 

Notes  
Standard refinement calculates with F2 while Jana2006 is still using F by default. In order to 
get a standard result, we will re-refine the structure on F2. 
Refinement converges with R factor 2.19%, goodness of fit 1.61, 74 parameters. 
For good data, refinement on F and F2 usually gives very similar results. 
Jana2006 does not refine the weighting scheme. The goodness of fit therefore corresponds 
to the experimental sigma of reflections corrected by the instability factor. For the 
moment, we are using the default instability factor 0.01. In the next step, we will use the 
instability factor calculated during merging of reflections (see above): 

 
Right-click the icon of Refine. 
[On the screen: refinement options] 
Check “Instability factor from reflection statistics”; OK; YES to start the program 
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Notes  
There are almost no changes in the refinement results because the calculated instability 
factor is close to the default one. Its value can be seen in Edit/View → View of Reflection 
report (search for the string “instability”). 
 

 

References  
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Example 2.1.1: PbSO4 
Revised: 8 March 2019 
 

Data Topic  Level 

X-ray powder data Simple structure from powder Basic  

Tasks 
Profile refinement 

Ab-initio structure solution  

Structure solution using Histogram matching  

Initial data 
Data 

Powder data measured with laboratory diffractometer  

X-ray Cu Kalpha1/Kalpha2 

Input files:  

PbSO4.mac (powder profile data) 

PbSO4.txt (additional information) 

Additional information: 

Chemical formula: Pb S O4   

Unit cell: 8.48 5.4 6.96 90 90 90 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step 1) 
Left pane: locate directory with input files;  
Right pane: double-click PbSO4 (Step 2) 

Notes  
Right pane detects possible Jana files and shows the jobname for each group of files 

 
Step 1 Step 2 

  

2. Import wizard 

Select “Various CW formats”; NEXT (Step 1) 
CW stands for constant wavelength 
Select “MAC format” and “Another/unknown method”; NEXT (Step 2) 

Step 1 Step 2 

  
Enter cell parameters 8.48 5.4 6.96 90 90 90;  
For wavelength type first select Kalpha1/Kalpha2 doublet and then select X-rays Cu; NEXT 
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(Step 3) 
FINISH  (Step 4) 

Step 3 Step 4 

  
OK;YES (Step 5) 
Select "Yes, I would like to continue with the wizard"; OK (Step 6) 

Notes  
At this point Jana2006 offers wizard for determining powder profile parameters, space 
group and structure. We shall use the wizard but all its tools could be also started 
separately. 

 
Step 5 Step 6 

 

 

II. Le Bail refinement/pattern matching 
[On the screen: Refinement of the powder profile by the le Bail algorithm] (Step 1) 
“Show powder profile” (Step 2) 

Notes  
Profile viewer shows experimental powder profile 

Quit; Leave profile viewer 
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Step 1 Step 2 

 

 
“Edit refinement commands”; set 0 cycles; leave other settings default; OK (Step 3) 
“Run Refine” (Step 4) 

Step 3 Step 4 

 

 

“Show powder profile” (Step5) 

Notes  
Now the profile viewer shows both experimental and calculated powder profile, and the 
difference curve. 
The calculated profile is based on default profile parameters. 
The calculated profile is stored in PbSO4.prf 

Leave profile viewer by QUIT 
“Edit profile parameters” 
[On the screen: Powder options] 
In “Cell” page select refinement of a, b and c (Step 6) 

Step 5 Step 6 
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In “Profile” page select Cutoff to 12*FWHM; activate refinement of GW; (Step 7) 
In “Corrections” page activate refinement of “shift”; 
In “Corrections” page select “Legendre polynomials” with 5 terms for background 
calculation (Step 8) 

Notes  
Refinement of background terms is enabled by default 

 
Step 7 Step 8 

  
Leave Powder options (OK), save changes (YES) 
“Edit refinement commands”; set 10 refinement cycles; OK (Step 9) 
“Run Refine” 

Notes  
After 10 refinement cycles, refinement converges with profile parameters GOF ~ 3, Rp ~ 
11.4, wRp ~ 16.4.  
The refinement may be slow because at this point we are using symmetry P1 

 “Show powder profile” (Step 10) 
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Step 9 Step 10 

  
In Powder profile viewer press “Default” and move close to theta 20° (Step 11) 

Notes  
The observed peaks are systematically broader which may indicate that Lorentzian 
broadening is to be combined with the Gaussian profiles. 

Leave profile viewer 
“Edit profile parameters” 
[On the screen: Powder options] 
In page “Profile” select Pseudo-Voigt and activate refinement of LY; (Step 12) 

Step 11 Step 12 

  
OK; YES; 
“Run Refine” 

Notes  
After 10 refinement cycles, refinement converges with profile parameters GOF ≈ 2.3 Rp 
≈ 8.0 wRp ≈ 11.39.  

“Show powder profile” (Step 13) 
“Quit” 
“Edit profile parameters” 
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[On the screen: Powder options] 
In page “Profile” activate refinement of LX. (Step 14) 
OK;YES; 

Step 13 Step 14 

  

“Run Refine” 

Notes  
After 10 refinement cycles, refinement converges with profile parameters GOF ~ 1.8, Rp 
~ 6.3, wRp ~ 8.7.  

“Show powder profile” (Step 15) 

“Quit” 

Step 15  

 

 

 
Notes  
The observed peaks at low angles still have some asymmetry. (Use “X+” and “X-“ 
buttons to see it better) 
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“Edit profile parameters” 
[On the screen: Powder options] 
In page “Asymmetry” select the Berar-Baldinozzi correction and activate refinement of 
asym1, asym2, asym3, asym4; (Step 16) 
OK; Yes; 
The asymmetry can be described by several functions, see Example 2.2 For this case Berar-
Baldinozzi function with four parameters sufficiently describes the asymmetry. 
“Run Refine” 

Notes  
After 10 refinement cycles, refinement converges with profile parameters GOF ~ 1.5, Rp 
~ 5.5, wRp ~ 7.6.  

FINISH; YES to close the refinement tool;  
CANCEL to skip the space group wizard; (Step 17) 

Notes  
In this example, we will use Superflip for the space group determination. You may also 
perform the space group test here and compare the results, which should be the same. 

OK; 

Step 16 Step 17 

  

III. Structure solution and Rietveld refinement  

3. Structure solution 

[On the screen: Structure solution] 

Notes  
This part of wizard can be also started separately by  “Run → Solution” 

Type formula Pb S O4; Formula units 4 
Select “Use Superflip” 
Check “allow manual editing of the command file before start” 
Check “Repeat Superflip: number of runs” 
Set “Maxcycles” to 2000 (Step 1) 
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Step 1  

 

 

Press “Run solution” to start Superflip 

Notes  
Jana makes le Bail decomposition and then it opens the text editor to see the prepared 
input file for Superflip. 
  

 
Using the text editor, replace the command “bestdensities 1 symmetry” for “bestdensities 
1 rvalue” 

Notes  
The command Bestdensities defines the criterion for selecting the best density from the ten 
subsequent runs. “1” means that only one best result will be saved. “Symmetry” means that 
the best mach with the user-defined symmetry will be saved, but this is not applicable for P1 
symmetry. “rvalue” means that the result with the best R value will be saved.  
Full description of the Superflip commands is available here:  
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http://superflip.fzu.cz/download/superflip_user_manual.pdf 
Save and close the file 
Superflip will start automatically and create this output file:  
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Notes  
The output of Superflip contains 10 independent Superflip runs. At the end of each run we 
can see the space group derived from the electron density. In most cases, it is Pnma; 
therefore we will redefine space group and repeat the solution. 

Close the Superflip output 
[On the screen:  “Structure solution” window] 
Press “Change the space group” button and write Pnma instead of P1. OK; YES; (Step 2) 
Press “Run solution”; 

Notes  
Check the input file again and see the difference. Now, the command “bestdensities 1 
symmetry” can be used because we need the best match with the symmetry Pnma. 

Close the file 
Superflip will start automatically 
Read the log file and close it; 
[On the screen: “Structure solution”] 
Press “Draw structure” to see the result in the external 3d viewer. (Step 3) 

  



43 Jana2006 Cookbook, version September 2019 
 
 

You may also press the “Draw 3D map” to see the resulted ELD map of Superflip. 

Notes  
The correct solution must show the SO4 tetrahedron. If it is not present, you can run the ten 
trials again. Since Superflip starts from randomly generated phases, the result of the next 
run may be better. On the other hand, if you get more than 4 oxygen atoms for one 
Sulphur, the additional oxygen will be probably discarded during refinement by getting 
inacceptably large Uiso.  

Press “Accept last solution”. This action will also close the structure solution wizard. 

4. Refinement of the structure 

“File → Structure” → Save As” to make backup copy 
[On the screen: basic window of Jana] 
Open refinement options (by the right-click on the icon of Refine). (Step 1) 
[On the screen: refinement options] 
Uncheck “Make only profile matching”, OK, Yes+start (Step 2) 

Step 1 Step 2 

  
Wait for convergence and open the listing. (You can access the listing of Refine also by 
“Edit/View → View of Refine”) 

Step 2 Step 3 
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Notes  
After 10 refinement cycles refinement converges with structure factors  R(obs) ~ 3.5, 
wR(obs) ~ 4, R(all) ~ 3.6, wR(all) ~ 4; and profile factors GOF ~ 1.8, Rp ~ 6.8, wRp ~ 9. 
It may happen that refinement fails due to wrong structure model. In such case, use “Tools 
-> Recover files” to get the original profile parameters and repeat Structure solution. 
Superflip starts from random phases and may return better result in the next attempt. The 
Recover files can only make one-step recovery. If you would run two subsequent 
refinements, the original files would be inaccessible. In such case, “File → Structure” → 
Copy In” can be used for recovery.  

Press “Go to” and select “Changes overview”: 

 
 

Notes  
At the beginning of “Changes overview” there might be list of disabled atoms 
automatically excluded from the refinement as their ADP is larger than the allowed limit. 
The excluded atoms are still present in M40 file with zero occupation. In order to delete 
them: 

Run “Edit atoms”, (Step 3) 
press “Select rejected” (Step 4) 
“Action → Delete selected atoms”; Yes to all; OK 

Step 3 Step 4 

  

Start EditM50,  (Step 5) 
Select page "Composition" and press "Formula from M40". It should display "Pb S O4". 
(Step 6) 
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Step 5 Step 6 

 

 

5. Using difference Fourier for completing structure model 

Notes  
In the case that some of oxygen atoms are still missing they can be localized from the 
difference Fourier. 
If your structure is complete (EditM50 displays the correct formula) but you would like to 
try this part, please start "Edit Atoms" and delete some oxygen and refine the structure. 
The refinement step (possibly with zero cycles) is necessary because it prepares structure 
factors for Fourier calculation.  

Right-click on the Fourier icon opens the command editing procedure for Fourier. 
Select “F(obs)-F(calc) – difference Fourier”; OK; “Yes + Start”; (Step 1) 
“Do you want to start the procedure for including of new atoms ? Yes; 

Step 1 Step 2 

 

 

[On the screen: Inserting/replacing atoms] 

Notes  
The program transforms each found maximum to various symmetry equivalent positions 
where it is close to some already existing atoms. Only atoms at the user defined distance 
from the maximum (here between 1 and 3 Å) are considered. By selecting a particular line 
we select the maximum in the corresponding symmetry transformation. 
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Include all missing atoms, i.e. the maxima with large enough charge and reasonable 
distance to some of already existing atoms; Use O* for atom names (Step 3) 
OK; FINISH  

Step 3 Step 4 

 

 
Verify the formula with “Editm50 → Composition → Formula from M40” 
Repeat refinement (in case of changes) 

Notes  
After 10 refinement cycles refinement converges with structure factor R(obs) ~ 3.5, 
wR(obs) ~ 4, R(all) ~ 3.6, wR(all) ~ 4.0; and profile factors GOF ~ 1.8, Rp ~ 6.*, wRp ~ 
9.0. 

“Edit/View → View of Refine” 
“GoTo → List of serious warnings” (Step 4) 
This list should be empty, indicating no problems with ADP parameters 
Plot structure (Step 5) 
“Draw+continue” (Step 6) 

 
Step 5 Step 6 

 

 

 
 

 

  



47 Jana2006 Cookbook, version September 2019 
 
 

[On the screen: window of Diamond] 
Use button  at the bottom toolbar and plot only Pb and S (Step 7). 
In Build → Connectivity adjust limits for S-O distances. Then complete coordination of 
Pb and S with . 
 

Step 8 My resulting structure 

 

 

 

 

The final R values in Jana 

  
The final powder pattern 
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Example 2.1.2: 17equ 
Revised: 15 October 2018 
 

Data Topic  Level 

X-ray Powder synchrotron data Simple organic structure Basic  

Tasks 
Solving a simple organic structure from high quality synchrotron powder data using Jana2006 
and Superflip  

1. Import data to JANA2006 

2. Perform Le Bail refinement (extraction of intensities) 

3. Run Superflip to solve the crystal structure 

Initial data 
Data 

synchrotron difractometer λ = 0.41334 Å, capillary 

Input files:  

17equ.xy  

Additional information: 

Chemical formula: C18H22O2 (17 α-Dihydroequilin) 

Unit cell: 6.77 8.97 23.39 90 90 90 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click 17equ.xy 

2. Import Wizard 

Select “Powder data – various CW formats”; NEXT (Step 1) 
[On the screen: Powder data form]  
Select "Free format of 2th, I, [sig(I)]"  
For method select “Debye-Scherrer”; NEXT ( Step 2) 

Step 1 Step 2 

  
[On the screen: Complete/correct experimental parameters]  
Fill unit cell parameters: 6.77 8.97 23.39 90 90 90 
Radiation: X-ray; wavelength is 0.41334; uncheck Kalpha1/Kalpha2 doublet 
For “Polarization correction” select “Linearly polarized beam” (Step 3) 
NEXT; FINISH; OK to close data repository; (Step 4) 
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Step 3 Step 4 

 

 

YES to accept the data set 
[On the screen: question how to continue]  
Select “Yes, I would like to continue with the wizard”; OK (Step 5) 

Step 5  

 

 

II. Le Bail refinement  

1. Profil matching (extraction of intensities) 

 [On the screen: Refinement of the powder profile by the le Bail algorithm] (Step 1) 

Step 1  

 

 

Press "Show powder profile" – just to see how it looks like 
Press “Edit profile parameters”  
In page "Cell" activate refinement of a, b, c  (Step 2) 
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In page “Profile” select Pseudo-Voight  function and activate refinement of GW, LX and LY 
(Step 3) 

Step 2 Step 3 

  
In page "Asymmetry/Diffractometer" select "correction by divergence", set HpS/L to 0.004 
and HmS/L to 0; enable refinement of HpS/L (Step 4) 
In page Corrections: Activate refinement of “shift”; Change number of Legendre terms for 
background to 30; (Step 5) 

Step 4 Step 5 

  
In page Corrections: click on “Define excluded regions” and set from 25 to 50 (Step 6) 
OK; Yes to rewrite 
Press “Edit refinement commands”  
Set 30 refinement cycles and set Damping factor to 0.3; OK; (Step 7) 
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Step 6 Step 7 

  
Press “Run Refine”  

Notes  
In many cases, refinement of all profile parameters from the scratch could not be done 
simultaneously. In such cases, we start refinement with a few most important profile 
parameters and allow the other parameters in next refinement runs. In this example, we 
can refine immediately all profile parameters but with damping factor of 0.3.  
 
Refinement of 38 profile parameters slowly converges to the profile R value Rp~5.5% and 
GOF ~ 1.1. Waiting for the full convergence is not necessary. Refinement can be 
interrupted by End. Do not use Cancel – in such case the profile viewer would not display 
the latest difference curve.. 

2. Space group determination  

FINISH;YES;NEXT; NEXT (Step 8); NEXT (Step 9) 
[On the screen: Select Laue symmetry] 
Select Orthorhombic mmm Laue symmetry; NEXT 

Step 8 Step 9 

  

Select P centering ; NEXT (Step 10) 

Notes  
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For testing of A centring (and similarly for other cases) the program removes Bragg 
positions absent due to A centering and calculates Rp. In case Rp is similar to that of the 
primitive unit cell, the removed reflections did not contribute to the measured profile – this 
means A centering is correct. On the other hands, increased Rp means the reflection 
absent for A centering were needed for the profile description – this means A centering 
does not occur.  

Select P212121 ; ( Step 11)  

Notes  
Space group determination is based on the same logic like determination of centering, 
using systematicly absent reflection due to space group.  

 

Step 10 Step 11 

  
NEXT; FINISH (Step 12) 
YES to run le Bail refinement again (Step 13) 

Notes  
Le Bail refinement is now repeated without reflections absent due to the selected space 
group 

Step 12 Step 13 
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III. Rietveld refinement  

1. Superflip solution  

[On the screen: Structure solution] (Step 1) 

Step 1 

 
Set formula to " C18 H22 O2" 
(just to see the input file for this moment) 
Check "Repeat Superflip: Number of runs" and set 20 (it will change max cycles to 2000) 
Select Iteration scheme "CF" 
Start by "Run solution" 

Notes  
By default, Superflip recognizes the best solution like the electron density conforming with 
the user-defined symmetry. It might happen that no such good fit is found within the 
twenty trials – this can be seen either from the poor fit of symmetry elements in the 
Superflip output, or by plotting the resulting structure model. In case the solution is not 
found, repeat the 20 runs again with “Use local normalization” option. If troubles 
continue, try also AAR and LDE iteration schemes.  

"Draw Structure" using diamond 
“Accept last solution”  
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2. Refinement 

If needed, correct chemical types in Edit Atoms.  
“File → Structure → Save As” to make a backup copy 
Start “Edit profile” and fix all profile parameters except shift and background 
Righ click; “Refine”  
Uncheck Make only profile matching (le Bail refinement); Number of cycles 30; Damping 
factor 0.3 
OK; Yes+start 
Robs ≈ 9.6, wR(obs)≈ 10.2, GoF ≈ 1.5, Rp ≈ 7.4  
Start Profile viewer and check the profile 
“Plot structure” to see the structure model and size of isotropic ADP(Step 2) 

Step 2  

 

 

3. Add hydrogen atoms  

Edit atoms -> Select all carbon atoms 
Action -> adding of hydrogen atoms; OK (Step 4) 
Apply-> Go to next (Step 5) 
OK 
Hydrogen atoms of OH will remain undetermined. The structure refinement did not use any 
geometry restraints. With powder data, this means that even geometry of carbon atoms is 
inexact. The procedure for adding hydrogen atoms relies on proper geometry, therefore 
some hydrogen atoms will be added improperly.  
“Plot Structure” and identify inproperly added hydrogen atoms 
Start “Edit atoms”; delete improper hydrogen atoms; select their carbon atoms 
Action -> adding of hydrogen atoms; clear “try automatic run”; OK 
 
“Refine” 
Robs ≈ 7.4, wR(obs)≈ 8.0, GoF ≈ 1.4, Rp ≈ 6.5 
Adding of hydrogen atoms improved the refinement factors as well as the geometry of 
carbon atoms  
Start “Edit profile” and enable refinement of the previously fixed profile parameters  
“Refine” 
Robs ≈ 7.4, wR(obs)≈ 8.0, GoF ≈ 1.4, Rp ≈ 6.5 
 
Edit atoms -> Select all oxygen atoms 
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Action -> adding of hydrogen atoms; OK 
Add hydrogen atoms of OH to apical positions 
“Refine” 
Robs ≈ 6.8, wR(obs)≈ 7.1, GoF ≈ 1.3, Rp ≈ 6.4 
Although this is not correct OH geometry, adding of hydrogen atoms nevertheless improved 
considerably the fit.  
 
The final powder profile: 

 
 
The resulting structure model: 

 
 

References  

Kaduk et al. (Crystals 2017, 7, 218; doi:10.3390/cryst7070218) 
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Example 2.1.3: Ochlor 
Revised: 16 October 2018 
 

Data Topic  Level 

X-ray Powder data Simple organic structure Basic  

Tasks 
Solving a simple organic structure from home-lab X-ray powder data using Jana2006 software 
and Superflip  

1. Import data to JANA2006 

2. Perform Le Bail refinement (extraction of intensities) 

3. Run Superflip to solve the crystal structure 

4. Use MCE to add atoms  

Example 2.7, which shows the process of structure solution and refinement for high quality 
synchrotron data. This example focuses to troubles cause by lower data quality.  

Initial data 
Data 
Laboratory difractometer Empyrean of PANalytical, wavelength CuKα1,2 
Input files:  
ochlor.xy  
Additional information: 
Chemical formula: C9ONH18Cl (N,N-dimethyl(2-oxocyclohexyl)methanamine chloride) 
Unit cell found: 8.26 18.85 6.71 90 92.58 90 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → StructureNew” opens the file manager 
Left pane: locate directory with input files 
Right pane: double-click ochlor.xy 

2. Import Wizard 

Select “Powder data – various CW formats”; NEXT 
[On the screen: Powder data from]  
Select "Free format of 2th, I, [sig(I)]"  
For method select “Debye-Scherrer”; NEXT 

[On the screen: Complete/correct experimental parameters]  
Enter unit cell parameters: 8.26 18.85 6.71 90 92.58 90 
Radiation: “X-rays”;” X-ray tube”; select Cu; check Kalpha1/Kalpha2 doublet (Step 1) 
NEXT; FINISH; OK to close data repository; 

 
Step 1  

 

 

YES to accept the data set 
[On the screen: question how to continue]  
Select “Yes, I would like to continue with the wizard”; OK 

II. Le Bail refinement  

1. Profile matching (extraction of intensities) 

[On the screen: Refinement of the powder profile by the le Bail algorithm] 

Press "Show powder profile" – just to see how it looks like 
Press “Edit profile parameters”  
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In page "Cell" activate refinement of a, b, c and beta  
In page “Profile” select Pseudo-Voight  function and activate refinement of GW, LX and LY 
In page "Asymmetry/Diffractometer" select "correction by divergence", set HpS/L to 0.01 
and HmS/L to 0; enable only refinement of HpS/L 
In page Corrections: Activate refinement of “shift”; Change number of Legendre terms for 
background to 30 
OK; Yes to rewrite  
Press “Edit refinement commands”  
Set 30 refinement cycles and set Damping factor to 0.3; OK 
Press “Run Refine” 

Notes  
In many cases, refinement of all profile parameters from the scratch could not be done 
simultaneously. In such cases, we start refinement with a few most important profile 
parameters and allow other parameters in next refinement runs. In this example, we can 
refine immediately all profile parameters but with damping factor of 0.3.  
 
Refinement  slowly converges to the profile R value Rp~2.9% and GOF ~ 1.2. Waiting for 
the full convergence is not necessary. Refinement can be interrupted by End. Do not use 
Cancel – in such case the profile viewer would not display the latest difference curve. 

“Show Powder profile”  
Zoom at high angles; Press "Details ON"; YES to plot many component functions." (Step 1) 

Step 1 

 
 

Notes  
The calculated profile revels problem with background. The too low background is 
compensated by too high calculated Bragg peaks, resulting in good fit achieved with 
incorrect parameters. We shall therefore use the manual background. 

Press "Details OFF"  
Press "Create new" (lower right corner of the Powder profile viewer)  
[On the screen: Options for generating background profile]  
Use 60 background points and significance intensity level 1; OK (Step 2) 
Check the manual background. It can be edited by dragging the points by mouse. 
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Press "Quit"  
[On the screen: A manual background has been created]  
Select "Accept the new manual background" and "Suppress using of polynomial terms"  
OK (Step 3) 

Step 2 Step 3 

 
 

Now we are back in the le Bail wizard  
Press "Run Refine"  
The refinement swiftly converges with Rp~2.9%, GOF~1.2. 

2. Space group determination  

FINISH; YES; NEXT; 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
NEXT 
Select Monoclinic 2/m Laue symmetry; NEXT 
Select P centering; NEXT (Step 12) 

Notes  
For A centring (and similarly for other cases) the program removes Bragg positions absent 
due to A centering and calculates Rp. In case Rp is similar to that of the primitive unit cell, 
the removed reflections were not needed for profile description – this means A centering is 
correct. On the other hands, increased Rp means the reflection absent for A centering were 
needed for the profile description – this means A centering does not occur.  

Select P21/n space group (because it has low Rp factors and high extinction); (Step 13) 

Notes  
Space group determination uses the same logic like determination of centering, using 
systematicly absent reflection due to space group.  

 NEXT; FINISH 
YES to run le Bail refinement for the new symmetry  
Profile is now refined without reflections absent due to symmetryOK; 
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III. Rietveld refinement  

1. Superflip solution  

[On the screen: Structure solution] (Step 1) 

Step 1 

 
Set formula to "C9 O N H18 Cl" 
Check "Repeat Superflip: Number of runs" and set 10 (it will change max cycles to 2000) 
Select Iteration scheme "CF" 
Press "Run solution" 

Notes  
We are looking for solution which confirms the space group P21/n. The screw axis has 
worse agreement factor and Superflip sometimes suggests (for the best selected run) the 
space group Pn. In such case, run solution again, possibly with increased number of cycles 
(3000) and/or with “Use local normalization”. Sometimes using LDE or AAR iteration 
scheme instead of CF makes the job.  

 

"Draw Structure" to see the resulting “best” structure model 
"Draw 3D map" to see the resulting “best” density 
 Accept last solution 

2. Improve your model using MCE  

The result of the automatic peak search will most probably be just a fragment of the 
molecule. Some missing atoms must be added manually. 
Double-click "Contour" icon; “New plot”  
Select Fourier map check ‘Calcule new ones’ and ‘Draw maps as calculated’ ; OK  
In page Basic select the map type F(obs)-Fourier; 
In page Scope Select the whole cell; 
OK to calculate Fourier map 

6  
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Usually, Fourier calculation uses structure factors (file M80) prepared by Refine. In 
this case, M80 has been prepared by Superflip.  

 

Press “Run MCE”; 

[On the screen: window of MCE] 

Program MCE allows to interpret the ELD map manually. The procedure is as follow: (I) set 
the proper map iso levels, (ii) switch to the “adding mode”, (iii) place atoms, (iv) save 
atomic positions. 
Rotate the model by dragging the left mouse button, zoom by the mouse-wheel (or by 
zooming on your touch-pad, if supported). Use keyboard arrows to move the scene. 
View → Level control primary map 

 

In the Map mode section, Select “Contour lines”.  
Change the layer value of the green layer to an appropriate 
level (e.g. 0.35) 
Apply 
OK to close the dialogue 

Preferences → Add-atom mode 
Right-click at the place you want to add an atom. 
Another right-click will redefine the position. 



66 Jana2006 Cookbook, version September 2019 
 
 

Peaks → Add new peak 
Repeat the procedure for other missing atoms 
Notes 
peaks → Clear peak list deletes all added peaks 
Preferences → Selection mode enables deleting a selected atom by pressing “d” on the keyboard 
File → Save peaks list 
for format select “General XYZ format” 
Exit MCE 

[On the screen: Do you want to start the procedure for including of new atoms?] 
YES 
[On the screen: Inserting/Replacing of atoms] 
Select “From the list of peaks localized in MCE” (Step 2) 
OK 
Include peaks having reasonable distances to existing atoms (Step 3) 

Step 2 Step 3 

 
 

Finish; YES; QUIT (to leave Contour) 
“Plot structure” to see the structure in Diamond 
The structure model is very inaccurate at this moment and C-C distances may be too long. 
To see the molecule, adjust limit for C-C distances in Build - Connectivity 
Compare the displayed molecule with the chemical scheme 
In case of missing atoms return to Contour and MCE and try to complete the structure 
model 
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Start “Edit atoms” 
correct chemical types  
OK; YES;   
“Plot structure” to see the molecule  in Diamond, compare again with the chemical 
scheme 
File → Structure → Save as → name “Backup”  

3. Refinement 

Notes  
For this structure, we can refine all parameters simultaneously with damping factor of 0.3. 

Righ click on “Refine” 
Uncheck Make only profile matching (le Bail refinement); Number of cycles 30; Damping 
factor 0.3 
OK, Yes+start 
Refinement converges with Robs ≈ 10, Rp ≈ 4, GoF ≈ 1.7  
“Profile viewer” 
“Edit atoms”; Select all; Action; Make symmetrically contiguous motifs; 
“Plot structure” (Step 1) 

Step 1  

 

 

4. Add hydrogen atoms  

Edit atoms -> Select all carbon atoms and N  
Action -> adding of hydrogen atom; OK  
Apply-> Go to next 
OK; YES to rewrite the files 
“Plot Structure” to verify positions of hydrogen atoms 

Notes  
The structure refinement did not use any geometry restraints. With powder data, this means 
that even geometry of carbon atoms is inexact. The procedure for adding hydrogen atoms 
relies on proper geometry, therefore some hydrogen atoms might be added improperly. 

“Refine” 
The final refinement converges with Robs ≈ 8, Rp ≈ 3.5, GoF ≈ 1.5, 9 profile paraeters, 49 
structure parameters  
“Profile viewer” 
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The final profile: 

 

References  
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Example 2.2: Y2O3 
Revised: 03 October 2018 
 

Data Topic  Level 

X-ray powder crystal data Powder data with strong 
asymmetry of peaks 

Basic  

Tasks 
Profile functions for an X-ray powder structure with strong asymmetry of peaks 

Initial data 
Data 

Powder data measured with laboratory diffractometer experimental setup with Johannson-
type monochromator and transmission mode in asymmetric Guinier type arrangement. 

Input files:  

Y2O3-icsd.cif (crystal structure from data base) 

Y2O3.dat (powder diffraction data) 

Additional information: 

Chemical formula: Y2O3 
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Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure  →  New” opens the file manager 
Left pane: locate directory with input files;  
Right pane: double-click Y2O3 

2. Import procedure 

Select “Structure: from CIF”; NEXT (Step1) 
[On the screen: Select input CIF file] 
Select “Y2O3-icsd.cif”; OK (Step2) 

Step 1 Step 2 

  
[On the screen: “CIF file does not contain any reflection block”] 
Answer “Yes” (you want to import data from file) (Step 3) 
[On the screen: Specify type of the file to be imported] 
Select “Powder data: various CW formats” (CW = constant wavelength); NEXT (Step 4) 

Step 3 Step 4 

 

 
[On the screen: Powder data from:] 
Select “Riet7 formats”; NEXT (Step 5) 
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[On the screen: Complete/correct experimental parameters] 
For wavelength type use “X-ray tube” Cu, without Kalpha1/Kalpha2 doublet (wavelength 
1.54051) 
Select “Parallel setting”, “Glancing angle” 13.65232 (CuKα, Ge[111]) “Perfectness 1”; NEXT; 
(Step 6) 

Step 5 Step 6 

  
FINISH 
Accept the data in Data repository 

  

II. Le Bail refinement 

1. Refinement of the powder profile 

[On the screen: Basic Jana window] 
Start "Edit profile"  
[On the screen: Powder options] 
In “Cell” page select refinement of the parameter a (Step 1) 
In “Profile” page select Cutoff to 12*FWHM; activate refinement of “GW” (Step 2) 
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Step 1 Step 2 

  
In “Corrections” page activate refinement of “shift” 
In “Corrections” page select “Legendre polynomials” with 5 terms for background 
calculation (Step 3) 
Refinement of background terms is enabled by default 
OK to leave Powder options, YES to save changes;  
[On the screen: Basic Jana window] 
Right click “Refine”  
Check “Make only profile matching”; (Step 4) 
Keep default values for other parameters; OK; 
[On the screen: Do you want to save new command?] 
Select “Yes+start” 

Step 3 Step 4 

  
 

Notes  
Refinement after 10 cycles finishes with 
GOF ≈ 16.5, Rp ≈7.7, wRP ≈ 12.9 

Start “Profile viewer” 
[On the screen: Jana 2006 profile viewer] 
Press “X exactly” and select the 2θ interval from 19 to 35.(Step 5)  
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Notes  
The observed peaks are systematically broader which can indicate that Lorentzian broadening 
should be combined with the Gaussian profiles. 

QUIT 
Start “Edit profile”  
[On the screen: Powder options] 
In page “Profile” select Pseudo-Voigt and activate refinement of LY; OK (Step 6) 
Yes to rewrite changes 
Run “Refine” 

Step 5 Step 6 

  
 

Notes  
Refinement after 10 cycles finishes with 
GOF ≈ 15.6, Rp ≈7.1, wRp ≈ 12.2 

Start “Edit profile”  
[On the screen: Powder options] 
In page “Profile” activate refinement of “GU”; OK 
Yes to rewrite changes 
Run “Refine” 

Notes  
Refinement after 10 cycles finishes with 
GOF ≈ 14.6, Rp ≈7.0, wRp ≈ 1.5 

Start “Profile viewer” 
[On the screen: Jana 2006 profile viewer] 
Press “X exactly” and select the 2θ interval from 19 to 35. 
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Notes  
The experimental peaks have still strong asymmetry, which is not explained by the 
current profile model. 

2. Asymmetry correction by the Howard's model 

[On the screen: Basic Jana window] 

Notes  
In the following, we will test various asymmetry models, each of them with a different 
job name. 

Start “File → Structure → Save As” (Step 1) 
[On the screen: File manager for saving structure] 
In File manager focus the right-bottom textbox and define a name for testing the Howard’s 
model, for instance “Y2O3-Howard”; OK (Step 2) 
“Yes” (to continue with the new structure) 
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Step 1 Step 2 

  

[On the screen: Basic Jana window] 
Start “Edit profile” 
[On the screen: Powder options] 
In page “Asymmetry” select “Howard (Boole’s rule)”, use the default value and activate 
refinement of the “asym1” parameter; OK; 
Yes to rewrite changed files 
[On the screen: Basic Jana window] 
Run “Refine”. 

Notes  
Refinement after 10 cycles finishes with 
GOF ≈ 11.8, Rp ≈ 6.1, wRp ≈ 9.2 

Start “Profile viewer” 
[On the screen: Jana 2006 profile viewer] 
Press “X exactly” and select the 2θ interval from 19 to 35. 
QUIT 

Notes  
The Howard's model improves considerably the profile fit. However, some discrepancies 
due to asymmetry are still visible. 

3. Asymmetry by Berar-Baldinozzi1 

[On the screen: Basic Jana window] 
Start “File → Structure → History” 
[On the screen: History] 
Select the original structure Y2O3; OK 
[On the screen: Basic Jana window] 
Start “File → Structure → Save As 
[On the screen: File manager for saving structure] 
In File manager focus the right-bottom textbox and define a name for testing of the Berar-
Baldinozzi model, e.g. “Y2O3-BB”; OK 
“Yes” to continue with the new structure 
[On the screen: Basic Jana window] 
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Start “Edit profile”  
[On the screen: Powder options] 
In page “Asymmetry” select “Berar-Baldinozzi”, use the default value and activate 
refinement of the “asym1, asym2, asym3 and asym4” parameters; OK 
“Yes” to rewrite changed files 
[On the screen: Basic Jana window] 
Start "Refine commands" (right-click on the icon "Refine") 
In page "Basic" set 100 refinement cycles and Damping factor 0.3 
OK; YES+START to save commands and start refinement. 

Notes  
Refinement after 100 cycles finishes with 
GOF ≈ 11.0, Rp ≈ 5.7, wRp ≈ 8.6 

Start “Profile viewer” 
[On the screen: Jana 2006 profile viewer] 
Press “X exactly” and select the 2θ interval from 19 to 35. (Step 1) 

Step 1  

 

 

 
Notes  
The fit is better than for the previous method but the number of asymmetry parameters 
is now four. 

4. Asymmetry by axial divergence2 

[On the screen: Basic Jana window] 
Start “File → Structure → History” 
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Select the original structure Y2O3; OK 
Start “File → Structure → Save As” 
Save the structure like ,e.g. “Y2O3-FCJ”; OK  
“Yes” to continue with the new structure 
Start “Edit profile”  
[On the screen: Powder options] 
In page “Asymmetry” select “correction by divergence”, use the default values and 
activate refinement of the “HpS/L” and “HmS/L” parameters; OK;  
Yes to rewrite changed files 
[On the screen: Basic Jana window] 
Right-click the icon Refine  
[On the screen: Refine commands] 
In page "Basic" set 30 refinement cycles and Damping factor 0.5 
OK; YES+START to save the changes and start refinement 

Notes  
Refinement after 30 cycles finishes with 
GOF ≈ 8.2, Rp ≈ 4.7, wRp ≈ 6.4 
Open the refinement listing. (You can access the listing of Refine also by “Edit/View → 
View of Refine”). 
Press “Go to” and select “Changes overview”: 

 
The parameter HmS/L oscillates, within three times the standard uncertainty is about 
zero which induces instability in the refinement. For this reason, we can change it to 
zero and keep it fixed. 

Start “Edit profile” 
In page “Asymmetry” set HmS/L to 0 and unselect it; OK; ”Refine” 

Notes  
Resulting factors are almost the same like before 

Start “Profile viewer” 
Press “X exactly” and select the 2θ interval from 19 to 35. 
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Step 1  

 

 

 
Notes  
With only one additional free parameter, the fit is significantly better than for the 
previous methods.  
 
In Jana2006 there is also implemented the fundamental approach following closely the 
approach described by Cheary and Coelho (Example 2.8). This method was not applied 
in our example because it was developed for Bragg-Brentano geometry. 

 

References  

[1] J.-F. BERAR and G. BALDINOZZi J. Appl. Cryst. (1993). 26, 128-129 

[2] Finger, Cox, Jephcoat, J.Appl.Cryst.(1994). 24, 892-900 
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Example 2.3.1: MagCag 
Solution of simple organometallic structure from powder data 
Revised: 4 October 2015 
 

Powder data measured with diffractometer Empyrean (PANalytical) using CuKα radiation, 
focusing mirror and Debye-Scherrer geometry (sample in capillary), at ambient temperature. 
 
Input files: magcag.xrdml with powder profile 
Additional information: 
unit cell 9.19 21.38 8.12 90 113.78 90 
composition Mg2 O20 H80 Br4 N16 C28 
Expected chemical scheme: 
 

 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click magcag 

2. Import procedure 
Select “Powder data – various CW formats”; NEXT 
[On the screen: Powder data form] 
Select "PANalytical XRDML" 
For method select “Debye-Scherrer” 
[On the screen: Complete/correct experimental parameters] 
Fill cell parameters 9.19 21.38 8.12 90 113.78 90 
Check the radiation (should be interpreted from the xrdml file as Copper with doublet): 
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NEXT; FINISH; OK to close data repository; YES to accept the data set 
[On the screen: question how to continue] 
Select “Yes, I would like to continue with the wizard”; OK 
The typical steps for refinement of powder profile will be offered in the wizard. However, all 
steps can be also done separately from the basic window of Jana2006.  

3. Refinement of the powder profile 
[On the screen: refinement of the powder profile by the le Bail algorithm] 
Press “Show powder profile” – just to see how it looks like 
Press “Default” to see more details 
Quit powder viewer 
Press “Edit profile parameters” 
Unlike for structure parameters, refinement keys of profile parameters are not set 
automatically 
 In page “Cell” activate refinement of a,b,c,beta  
In page “Profile” activate refinement of GW 
In page “Corrections” activate refinement of “shift”; 
Change number of Legendre terms for background to 30; 
OK; Yes to rewrite 
Press “Edit refinement commands” 
Set 100 refinement cycles and Damping factor 
OK 
Press “Run Refine” 
Refinement of profile slowly converges to the profile R value Rp~3.4% and GOF ~ 7.5. 
Waiting for the full convergence is not necessary. Refinement can be interrupted by End or 
Cancel - in this case End should be used in order to see the latest difference curve in the 
powder profile  viewer. 
In page “Profile” activate refinement of GV 
OK, YES to save changes 
Run several cycles of Refine 
Refinement of profile slowly converges to the profile R value Rp~3.0% and GOF ~ 7.0 
For Gaussian parameters an important rule is that they cannot be refined all together 
because they are linearly dependent. Usually we refine GW, then GV and finally GU. In our 
case GU would not improve the fit. 
 “Show Powder profile” 
The calculated profile fits quite well with the experimental one but some profiles are too 
narrow, especially for low angles 
Quit profile viewer 
“Edit profile parameters” 
In page “Profile” change the type of the peak-shape function to “Pseudo-Voigt” , activate 
refinement of LX and LY 
OK, YES to save changes 
“Run Refine” 
Refinement of profile slowly converges to the profile R value Rp~1.6% and GOF ~4.2. 
“Show Powder profile” 
Enlarge the profile and investigate details of the fit between the calculated and 
experimental profile. 
We are especially interesting whether asymmetry of peaks has been correctly described. Not 
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correctly described asymmetry can be found for  low angle reflections: 

 
“Edit profile parameters” 
In page “Asymmetry/Diffractometer” select “correction by divergence” 
Activate refinement of “HpS/L”, set HmS/L to zero and do not refine it  
OK; YES to save changes 
 
“Run Refine” 
Refinement of profile slowly converges to the profile R value Rp=1.4 and GOF ~3.0.  
“Show Powder profile” 
 
 

 
 
Description of asymmetry seems to be better than before 
Quit the profile viewer 
Press "Save As" and make a backup copy of the structure 
FINISH to close the Powder wizard 
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4. Space group determination 
[On the screen: Tolerances for crystal system recognition] 
Use default; NEXT 
[On the screen: Select Laue symmetry] 
Select the highest one – monoclinic; NEXT 
[On the screen: Select cell centering] 
Select P centering as it gives the best profile fit; NEXT 
[On the screen: Select space group] 
Select space group P21/a; NEXT 
[On the screen: Final step of the space group test]; 
Accept the space group transformed into the original cell; FINISH 
YES to refine profile parameters once more. 
This new profile refinement uses only independent Bragg reflections compatible with  P21/a. 
The results are almost the same like for P-1 but calculation taking into the account the 
symmetry is faster. 

5. Structure solution 
[On the screen: information that the solution wizard will start] 
OK 
Type formula Mg O10 H40 Br2 N8 C14; Formula units 2 
Select “Use Superflip” 
Check "Repeat Superflip: Number of runs" and choose 10 runs 
With this setting Superflip will run ten times and a solution with the best fit will be used 
OK 
The agreement factors of the symmetry printed at the bottom of the Superflip listing will be 
between 10-20, indicating rather worse fit for the screw axis. 
Press the button “Draw structure”  
The initial structure model should display octahedrally coordinated Mg located in one of 
inversion centers, isolated Br, two oxygens of the water molecules, a fragment of the N4C7 
cage and probably some false maxima. For instance: 

 
 
Press button “Accept last solution” 
Start File → Structure → Save as and make a backup copy 
 

6. Completing structure without hydrogen atoms 
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In this part the task is to finalize the N4C7 cage from the difference Fourier. 
 
Rietveld refinement with initial structure model could destroy profile parameters: 
Start Parameters → Powder 
Clear refinement keys for all refined powder parameters in page "Cell", "Profile", 
"Asymmetry/Diffractometer" and "Corrections" 
 
The stability of the structure model refined with powder data requires binding together ADP 
parameters of some atoms and keeping them isotropic. For instance, carbon and nitrogen 
atoms will all have the same isotropic ADP.  
Plot the structure and note atoms around Mg 
Start “Edit atoms”; 
change the atoms around Mg to oxygen O1, O2, O3; 
change all other atoms except Br and Mg to carbon. 
Start Refinement options, page “Various” 
Start “Restrictions” and define: 
The same ADP for O* 
The same ADP for C* 
 
Be careful not to make by mistake identical their coordinates 
 

 
OK; 
 
In page Basic change number of refinement cycles to 100 and damping factor to 0.5 
Clear “Disable atoms having too large isotropic ADP parameter” 
Clear “Make only profile matching” 
OK; Yes+Start 
Rietveld refinement slowly converges with Robs=9%, Rp=6%, and GOF=13. 
The numbers are only indicative! 
In case of oscillations, note the label of the oscillating atom. Plot the structure and try to 
identify and delete false maxima. In case of troubles, repeat charge flipping. 
Change ADP of Br to anisotropic and repeat refinement 
Br is slightly disordered and it can be described with an ellipsoid even from powder data 
For isolated carbon atoms out of the fragment of the cage change their chemical type to 
oxygen 
Repeat refinement 
Two of the isolated positions will be oxygens of water. The others will probably move to the 
cage during the refinement. 
Start Fourier option 
In the page “Basic” define “F(obs)-F(calc) – difference Fourier) 
OK; YES+START 
OK to start procedure for including new atoms 
The charge of difference maxima will be extremely low comparing with single crystal 
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diffraction, however some of them will be carbon or nitrogen atoms. It is advisable to plot 
the maxima before refinement and to delete any strange position as false maxima. 
Repeat refinement 
Repeat plotting and deleting false maxima 
Repeat difference Fourier 
Repeat adding of atoms 
Finally, the structure will be completed like this: 

 
Rietveld refinement converges with Robs~3.6%, Rp~2.8%, and GOF~6.3. 
ADP of carbon atoms of the cage may be negative at this stage 
In the cage the atoms with three bonds are nitrogens. 
Start “Edit atoms” and correct chemical types of the cage 
Start Refinement options and add a restriction nitrogen atoms to have the same ADP: 

 
Run refinement 
Rietveld refinement converges with Robs~3.2%, Rp~2.4%, and GOF~5.2. 
At this point ADP of nitrogens should be positive while ADP of carbons may still be close to 
zero 
Start “Edit atoms” 
Add hydrogen atoms to carbons of the cage (automatic mode) 
Run refinement 
Rietveld refinement converges with Robs~3.2%, Rp~2.5%, and GOF~5.4.These value are 
slightly worse than in the previous step but ADP of carbon atoms become positive 
Start File → Structure → Save As and make a backup copy 
Start Parameters → Powder 
Activate refinement of all powder parameters which were fixed before starting with the 
Rietveld refinement 
Run refinement 
Rietveld refinement converges with almost the same Robs, Rp and GOF. 
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All oxygen atoms belong to water. In order to include scattering power of hydrogen atoms 
without adding them explicitly, their occupancy must be refined. 
Activate refinement of occupancy of O1 
Start refinement options, page “Various” 
Start “Equations” and define the following equations: 

 
Run refinement 
Rietveld refinement converges with Robs~2.5%, Rp~2.0%, and GOF~4.0.These value are 
significantly better. 
 
Oxygen atoms of water, which is not coordinated to Mg, may have different ADP 
Start refinement options, page Various 
Start  "Restrictions" 
Delete the restriction for O* 
Define separately the same ADP for O1, O2, O3 and for O4, O5: 

 
Run refinement 
The results are almost the same. Visual inspection of the powder profile shows good fit 
between the calculated and observed lines. 
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Example 2.3.2: MagCag 
Preparation of the rigid body template in M45 
Revised: 4 March 2015 
 

The purpose of this example is to prepare a template of the cage C7N4H14, which will be used 
for the solution of the example 2.3.3 as a rigid body. The template will be defined in the file 
M45 and used in solution of the example 2.3.3. 
 
The preparation of M45 has no special support in the current version of Jana2006. Part of the 
job must be done with a text editor.  
 
In the following steps we shall use the CSD structure HICTOD and we shall prepare two versions 
of the cage: with C1 symmetry and Cs symmetry.  
 
Input files: HICTOD.cif from the CSD database 
 
Expected chemical scheme: 
 

 
 

1. Reading structure from CIF 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory the input file 
Right pane: double-click HICTOD 
[On the screen: Specify type of the file to be imported] 
Select : Structure → From CIF; NEXT 
Select: HICTOD.CIF 
NO to import data 

2. Deleting symmetry equivalent atoms 
It happens with some CSD CIF files that symmetry equivalent atoms are also present, which 
leads to their multiple occurrences when symmetry is applied. In the next step, we shall 
delete these atoms 
Start "Edit Atoms" 
Select atoms ending with “g” and “d” 
Start "Action → Delete selected atoms" 
OK; YES to save changes 
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3. Getting the cage from HICTOD 
Start "Plot structure"; "Draw + continue" 
Use  ,  and  to plot atoms from M40 
Use Picture → Viewing direction → c 
Use  to display the unit cell 
Use  to complete the fragments 
Now the cage is clearly visible 
The atoms of the cage are symmetry related by a mirror plane at y=0.25 
Press Undo, to see again only the symmetry independent atoms 
Select atoms (symmetry independent) not belonging the cage 
Using the right mouse button activate ploting of their labels; note the labels 
Quit Diamond and return to Jana 
Start "Edit Atoms" 
Delete the atoms not belonging to the cage; OK; YES to rewrite changes 
Start "Plot structure" and verify that only atoms of the cage are present 
Return to Jana 

4. Transformations 
M45 templates contain information about the point group symmetry. The axis c is used as 
the unique axis of the point group. For this reason the unit cell taken from CSD must be 
transformed in order to get the mirror plane of the cage perpendicular to c and located at 
z=0. Moreover, all atoms of the cage (not only symmetry independent atoms) must be 
present in the template.  
Start "Tools → Transformations → Origin shift" 
Move the origin to point 0, 0.25, 0 
Now the mirror plane of the cage is located at y=0 (can be verified in M40) 
Start "Edit Atoms" 
Press "Select all" 
Start "Action → Expand selected atoms" 
Press "Next matrix" ; "Fill by a symmetry operation" 
Select "x, -y, z"; OK;  
OK; OK; YES to rewrite changes 
Start "EditM50" 
Change symmetry to P1; OK; YES to rewrite M50 
Start "Edit Atoms" 
Press "Select all" 
Start "Action → Merge selected atoms"; use default merging distance;  
The program merges 7 atoms, resulting in 25 atoms of the cage 
Start "Tools → Transformations → Cell transformation" 
Press "by a matrix" 
Define transformation matrix -1 0 0 / 0 0 1 / 0 1 0 
OK; OK; select "rewrite the old structure"; OK 
Start "Edit Atoms" 
Press "Select all" 
Start "Action → Transform selected atoms" 
Use unit transformation matrix and translation vector 1, 0, 0 
This transforms the x coordinates back to the unit cell 
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Start "Plot structure"; "Draw + continue" 
Use  ,  and  to plot atoms from M40 
Use Picture → Viewing direction → b 
Use  and  to display the unit cell 
This shows the resulting cage of 25 atoms with mirror plane located at z=0 

 

5. Labels 
Quit Diamond 
Start "Edit Atoms" 
Double-click the first atom 
Using "Define" and "Edit" page change the suffix to "m" if z=0, "1" if z<0 and "2" if z>0 
Arrows close to the "List" button can be used to move between atoms in the editing mode  
Renaming can also be done in a text editor (Edit/View → Edit of M40 file). 
The resulting labels will have "m" for atoms at the mirror plane, "1" for atoms below the 
mirror plane and "2" for atoms above the mirror plane. The suffixes "1" and "2" resulted 
from the previous expansion by the mirror plane.  

 
 



92 Jana2006 Cookbook, version September 2019 
 
 

6. Text editor 
Quit Diamond and Jana 
Copy M40 to Magcag-symmC1.m45 
Open Magcag-symmC1.m45 in a text editor 
Delete five header lines 
Delete the s.u. block 
Delete every second line (i.e. the lines without atom label) 
Add two spaces and "0" at the end of each line 
Add the following header lines: 
"cell 7.585 10.837 16.065 90 90 90" (this can be copied from M50) 
"pgroup C1" 
"scdist C-C 1.52" 
Save the file and quit the editor.  
 
This is the resulting file Magcag-symmC1.m45: 
 
cell 7.585 10.837 16.065 90 90 90 
pgroup C1 
scdist C-C 1.52 
N1_m      3  1     1.000000 0.250500 0.132420 0.000000  0 
N2_m      3  1     1.000000 0.194100-0.129200 0.000000  0 
N3_1      3  1     1.000000 0.011590 0.024260-0.075730  0 
N3_2      3  1     1.000000 0.011590 0.024260 0.075730  0 
C1_m      1  1     1.000000 0.373700-0.084900 0.000000  0 
C2_m      1  1     1.000000 0.403100 0.054200 0.000000  0 
C3_1      1  1     1.000000 0.142500 0.125210-0.074590  0 
C3_2      1  1     1.000000 0.142500 0.125210 0.074590  0 
H1_1      2  1     1.000000 0.219800 0.115500-0.122300  0 
H1_2      2  1     1.000000 0.219800 0.115500 0.122300  0 
H2_1      2  1     1.000000 0.080600 0.202900-0.081200  0 
H2_2      2  1     1.000000 0.080600 0.202900 0.081200  0 
C4_m      1  1     1.000000-0.095500 0.035800 0.000000  0 
H3_m      2  1     1.000000-0.185600-0.027800 0.000000  0 
H4_m      2  1     1.000000-0.154200 0.115300 0.000000  0 
C5_1      1  1     1.000000 0.093300-0.099710-0.074750  0 
C5_2      1  1     1.000000 0.093300-0.099710 0.074750  0 
H5_1      2  1     1.000000 0.000900-0.160900-0.081200  0 
H5_2      2  1     1.000000 0.000900-0.160900 0.081200  0 
H6_1      2  1     1.000000 0.170800-0.106700-0.122500  0 
H6_2      2  1     1.000000 0.170800-0.106700 0.122500  0 
H9_2      2  1     1.000000 0.427000-0.121100 0.053300  0 
H9_1      2  1     1.000000 0.427000-0.121100-0.053300  0 
H10_2     2  1     1.000000 0.473000 0.074000 0.051500  0 
H10_1     2  1     1.000000 0.473000 0.074000-0.051500  0 
 
The keyword scdist is used for scaling of the complete object  using arbitrary number 
described with arbitrary identifier (without spaces). In our case the identifier is “C-C” and the 
number is a typical C-C distance in the cage. But the identifier could be also “scale” and the 
number could be, e.g.,  100.  
Each line except header lines contains the following items: label, number of chemical type 
(indicates that chemical types are different - they will be specified during application of the 
rigid body in Jana2006), unused, site occupancy, x, y, z, symmetry identifier (0 means 
symmetry independent with respect to the used point group). 
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Copy Magcag-symmC1.m45 to Magcag-symmCs.m45 
Open Magcag-symmCs.m45 in a text editor 
Replace the point group C1 with Cs 
For atoms with the suffix "1", i.e. those with z<0, replace "0" at the end of each line with 
"1". This indicates the atoms are symmetry dependent 
For atoms with the suffix "m" change the site occupancy to 0.5, because they are located at 
mirror plane 
 
This is the resulting file Magcag-symmCs.m45: 
 
cell 7.585 10.837 16.065 90 90 90 
pgroup Cs 
scdist C-C 1.52 
N1_m      3  1     0.500000 0.250500 0.132420 0.000000  0 
N2_m      3  1     0.500000 0.194100-0.129200 0.000000  0 
N3_1      3  1     1.000000 0.011590 0.024260-0.075730  1 
N3_2      3  1     1.000000 0.011590 0.024260 0.075730  0 
C1_m      1  1     0.500000 0.373700-0.084900 0.000000  0 
C2_m      1  1     0.500000 0.403100 0.054200 0.000000  0 
C3_1      1  1     1.000000 0.142500 0.125210-0.074590  1 
C3_2      1  1     1.000000 0.142500 0.125210 0.074590  0 
H1_1      2  1     1.000000 0.219800 0.115500-0.122300  1 
H1_2      2  1     1.000000 0.219800 0.115500 0.122300  0 
H2_1      2  1     1.000000 0.080600 0.202900-0.081200  1 
H2_2      2  1     1.000000 0.080600 0.202900 0.081200  0 
C4_m      1  1     0.500000-0.095500 0.035800 0.000000  0 
H3_m      2  1     0.500000-0.185600-0.027800 0.000000  0 
H4_m      2  1     0.500000-0.154200 0.115300 0.000000  0 
C5_1      1  1     1.000000 0.093300-0.099710-0.074750  1 
C5_2      1  1     1.000000 0.093300-0.099710 0.074750  0 
H5_1      2  1     1.000000 0.000900-0.160900-0.081200  1 
H5_2      2  1     1.000000 0.000900-0.160900 0.081200  0 
H6_1      2  1     1.000000 0.170800-0.106700-0.122500  1 
H6_2      2  1     1.000000 0.170800-0.106700 0.122500  0 
H9_2      2  1     1.000000 0.427000-0.121100 0.053300  0 
H9_1      2  1     1.000000 0.427000-0.121100-0.053300  1 
H10_2     2  1     1.000000 0.473000 0.074000 0.051500  0 
H10_1     2  1     1.000000 0.473000 0.074000-0.051500  1 
 
The created templates, Magcag-symmC1.m45 and Magcag-symmCs.m45, could be 
accompanied with plots in jpeg format, Magcag-symmC1.jpg and Magcag-symmCs.jpg. In 
our example we don’t need them.  
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Example 2.3.3: MagCag 
Solution of simple organometallic structure from powder data, using the rigid 
body template from M45 
Revised: 4 October 2015 
 

Powder data measured with diffractometer Empyrean (PANalytical) using CuKα radiation, 
focusing mirror and Debye-Scherrer geometry (sample in capillary), at ambient temperature. 
 
Input files: magcag.xrdml with powder profile 
Magcag-symmC1.m45 and Magcag-symmCs.m45: rigid body templates prepared in Example 
2.3.2 
Additional information: 
unit cell 9.19 21.38 8.12 90 113.78 90 
Expected scheme: 
 

 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click magcag 

2. Import procedure 
Select “Powder data – various CW formats”; NEXT 
[On the screen: Powder data form] 
Select "PANalytical XRDML" 
For method select “Debye-Scherrer” 
[On the screen: Complete/correct experimental parameters] 
Fill cell parameters 
Check the radiation (should be interpreted from the xrdml file as Copper with doublet): 
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NEXT; FINISH; OK to close data repository; YES to accept the data set 
[On the screen: question how to continue] 
Select “Yes, I would like to continue with the wizard”; OK 
The typical steps for refinement of powder profile will be offered in the wizard. However, all 
steps can be also done separately from the basic window of Jana2006.  

3. Refinement of the powder profile 
[On the screen: refinement of the powder profile by the le Bail algorithm] 
Press “Show powder profile” 
Press “Default” to see more details 
Press “Create new” to create a manual background 
[On the screen: Options for generating background profile] 
For “Number of manual background points” set 60 
OK; Quit powder viewer 
[On the screen: A manual background has been created] 
Select “Accept the new background” and “Reset polynomial coefficients to zero” 
The manual background was created because with this data background calculated with 
Legendre polynomials would not be correct for high angle reflections.(For detail see example 
2.4 – PFPhenyl) 
Press “Edit profile parameters” 
In page “Profile” activate refinement of GW 
Unlike for structure parameters, refinement keys of profile parameters are not set 
automatically 
In page Corrections: 
Set 30 for “Number of terms” of Legendre polynomials 
Polynomial background will be refined in addition to the manual one 
Activate refinement of “shift”; 
OK; Yes to rewrite 
Press “Edit refinement commands” 
Set 100 refinement cycles 
OK 
Press “Run Refine” 
Refinement of profile slowly converges to the profile R value Rp~2.9% and GOF ~ 7.3. 
Waiting for the full convergence is not necessary. Refinement can be interrupted by End or 
Cancel - in this case End should be used in order to see the latest difference curve in the 
powder profile  viewer. 
“Show Powder profile”; “Default” 
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Move the slider towards low angles; “Fit Y” 
The calculated profile fits quite well with the experimental one but some profiles are too 
narrow, especially for low angles 
Quit profile viewer 
“Edit profile parameters” 
In page “Cell” activate refinement of a,b,c,beta 
In page “Profile” activate refinement of GV 
OK, YES to save changes 
Run several cycles of Refine 
Refinement of profile slowly converges to the profile R value Rp~2.8% and GOF ~ 7 
For Gaussian parameters an important rule is that they cannot be refined all together 
because they are linearly dependent. Usually we refine GW, then GV and finally GU. In our 
case GU would not improve the fit. 
In page “Profile” change the type of the peak-shape function to “Pseudo-Voigt” , activate 
refinement of LX and LY 
OK, YES to save changes 
“Run Refine” 
In case of oscillations press “Parameters” (during the refinement) and change “Damping 
factor” to 0.5 
Refinement of profile slowly converges to the profile R value Rp~1.7% and GOF ~4.3. 
“Show Powder profile” 
Enlarge the profile and investigate details of the fit between the calculated and 
experimental profile. 
We are especially interesting whether asymmetry of peaks has been correctly described. Not 
correctly described asymmetry can be found for  low angle reflections: 

 
“Edit profile parameters” 
In page “Asymmetry/Diffractometer” select “correction by divergence” 
Activate refinement of “HpS/L” (do not refine HmS/L) 
“Run Refine” 
Refinement of profile slowly converges to the profile R value Rp=1.4% and GOF ~3.1. “Show 
Powder profile” 



98 Jana2006 Cookbook, version September 2019 
 
 

The description of asymmetry for the low angle peak is considerably improved: 

 
 
Quit the profile viewer 
Press "Save As" and make a backup copy of the structure 
FINISH to close the Powder wizard 

4. Space group determination 
[On the screen: Tolerances for crystal system recognition] 
Use default; NEXT 
[On the screen: Select Laue symmetry] 
Select the highest one – monoclinic; NEXT 
[On the screen: Select cell centering] 
Select P centering as it gives the best profile fit; NEXT 
[On the screen: Select space group] 
Select space group P21/a; NEXT 
[On the screen: Final step of the space group test]; 
Accept the space group transformed into the original cell; FINISH 
YES to refine profile parameters once more. 
This new profile refinement uses only independent Bragg reflections compatible with P21/a. 
The results are almost the same like for P-1 but calculation taking into the account the 
symmetry is faster. 

5. Structure solution 
[On the screen: information that the solution wizard will start] 
OK 
Type formula Mg O10 H40 Br2 N8 C14; Formula units 2 
Select “Use Superflip” 
Check "Repeat Superflip: Number of runs" and choose 10 runs 
With this setting Superflip will run ten times and a solution with best R value will be used 
“Run Solution” 
In case that Superflip does not converge interrupt the calculation, discard the results and 
repeat it. It will start from a new set of random phases and the result may be different. The 
agreement factors of the symmetry printed at the bottom of the Superflip listing will be 
between 10-20, indicating rather worse fit for the screw axis. 
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Press the button “Draw structure” 
The initial structure model contains octahedrally coordinated Mg located in one of inversion 
centers, isolated Br, two oxygens of the water molecules, a fragment of the N4C7 cage and 
probably some false maxima. For instance: 

 
Press button “Accept last solution” 
 

6. Preparation of the starting Rietveld refinement 
Start “Edit atoms” and change chemical types of atoms coordinated to Mg to oxygen 
Change to oxygen also the two carbon atoms, which are in fact lattice water molecules 
Rename the changed atoms according to their chemical types 
OK; YES to save changes 
Start “Refine commads”; go to page “Basic” 
Set 100 refinement cycles with Damping factor 0.1 
Uncheck “Make only profile matching” 
OK; YES to save changes without starting refinement 
Start “Edit profile” 
Fix all profile parameters: a, b, c, beta, GW, GP, LX, LY, HpS/L, shift 
This means that only Legendre background will be refined  
OK, YES to save changes 
Start File → Structure → Save as and make a backup copy named “start” 

7. Completing the cage 
Start “Refine commands”; go to page “Various” 
Press “Fixed commands” 
Fix all parameters for O* Mg* Br*; OK 
Press “Restrictions” 
Restrict ADP of C* to be the same; OK 
Be careful not to restrict coordinates! 
OK; YES+Start 
During refinement you may change damping from 0.1 to 0.5 
Refinement converges with R~11%, Rp~10%, GOF~23 
Run difference Fourier, YES to start procedure for inserting atoms 
Insert new maxima in reasonable distances to the atoms of the cage 
Repeat refinement 
Repeat difference Fourier and inserting of maxima until 11 carbon atoms is present 
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“Reasonable distance” should not be taken too strictly for Fourier maxima from powder 
data 
Refinement converges with R~5%, Rp~4%, GOF~8 
Start File → Structure → Save as and make a backup copy named “cage_atomic” 

8. Placing the cage template with point group symmetry C1 
Start “Plot structure” 

Using the button  plot the atoms of the cage and ensure they make a symmetry 
contiguous motif. If not, return to Jana, start Edit atoms and put C* to symmetry contiguous 
motif. Otherwise placing of the molecule will not work.  

   
Plot the cage and compare with the template prepared in the previous example. Probably 
C9 corresponds to C1_m; C3 corresponds to C2_m; C8 corresponds to C4_m (your labels 
can be different!) 
Return to Jana2006 
Start “Parameters → Molecules →  New molecule” 
[On the screen: Atoms of the new molecule from:”] 
Select “Model file” 
For name of the molecule type “kage” 
We need a name not starting with C, N, O, B, H and M 
For “Model name” browse for “Magcag-symmC1.m45” created in the previous example 
Keep the scaling distance unchanged 
“Show the model molecule” is disabled because we don’t have Magcag-symmC1.jpg 
NEXT 
[On the screen: Specify atomic types in the model molecule] 
Do not change the suggested atomic types; NEXT 
[On the screen: Define the molecular reference point] 
Select “Explicit” 
In “Reference point” textbox type N1_m 
The reference point should be some atom from the mirror plane in order to reflect the 
symmetry of the molecule. Such atoms in the model molecule have suffix _m (see Example 
2.3.2) 
NEXT 
[On the screen: Define and complete molecular position #1] 
For the pairs “model atoms” – “actual positions” choose c1_m and C9;  C2_m and C3; C4_m 
and C8 (with actual names taken previously from Diamond) 
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For “Maximal coincidence distance” type 0.5 
The coincidence ration should be 11/25 but it depends on the previous refinement 
Try to adjust the coincidence distance to reach 11 coinciding carbons. 
If carbons of the model molecule coincide e.g. with oxygens this means that the cage has 
been positioned incorrectly, probably because the carbon atoms in the atomic part do not 
form a symmetry contiguous motif.  
Press “Apply+End” 
Start “Edit atoms” 
Ensure that the atomic part does not contain carbon atoms. 
OK, YES to save changes 
Start “Plot structure” 
The structure with the cage should look like this (depending which carbon positions were 
used for placing the cage): 

 
In this example one water oxygen is too close to the cage but it may change during the 
refinement 
 
Return to Jana2006 
Start “Refine commands”; go to page “Various” 
Press “Fixed commands” 
Fix “all parameters” for C*, H*, N* (i.e. for atoms of the cage) 
Because the molecule is called “kage”, the wild character C* does not include the molecule 
and therefore molecular parameters (rotations and translation of the cage),  will not be 
fixed.  
OK; OK; YES+START to save changes and start refinement 
During refinement you may change damping from 0.1 to 0.5 
After many cycles refinement converges with R~4.5%, Rp~4%, GOF~9 
Start “Plot structure” 
The cage should be now in better position, i.e. without short distances to lattice water 

9. Refinement of Mg, O and Br 
Start “Refine commands”; go to page “Various” 
Press “Fixed commands” 
Disable or delete the “fixed all” commands for Mg* O* Br* 
OK 
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Go to page “Equations” and define the following equations: 

 
All oxygens belong to water; refinement of their occupancy mimics the missing hydrogens 
OK 
Go to page “Various”, press “restrictions” 
Define the same ADP for all oxygen atoms (O*); OK 
Be careful not to make identical coordinates! 
OK; YES to save commands without starting Refine 
Start “Edit atoms”  
Set harmonic ADP for Br1 
This works because Br is slightly disordered 
Activate refinement of occupancy (ai) of O1 
OK, YES to save changes 
Start “Refine” 
The refinement converges with R~3%, Rp~2.3%, GOF~5 
 

10. Refinement of atoms of the cage 
Start “Edit atoms” 
Select all carbon atoms of the cage (blue carbons) 
Press “Action → Adding of hydrogen atoms” 
This procedure will not add hydrogens, because they are already present, but it will 
introduce Keep commands necessary for fixing of their geometry 
OK; YES to save changes 
Start “Refine commads”; go to page “Various” 
Press “Restrictions” 
Define the same ADP for all nitrogen atoms (N*) 
Be careful not to make identical coordinates! 
OK 
Press “Fixed commands” 
Disable or delete the “fixed all” command for C* N* H* 
OK; go to page Basic 
Set “Damping factor” 0.1 
OK; YES+START 
The refinement converges with R~2.8%, Rp~2.1%, GOF~4.3 
Start “Plot structure” verify the structure 
 
Final plot: 
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Make backup copy 

11. Placing the cage template with point group symmetry Cs 
Now we shall test how the cage with Cs point symmetry would fit 
Start "Edit atoms" 
Select the model molecule (blue atoms) 
Start "Action → Atoms from molecule to atomic part" 
OK; YES to rewrite changes 
The molecule had only one actual position and therefore this atomic structure model is 
equivalent with the previous one 
Start "Refine" 
R values must be the same like with the molecule 
Now we shall place the template Cs in such a way that it coincides with the cage present in 
the atomic part 
This is the template how it was created in the example 2.3.2: 

 
Start "Plot structure" and try to orient your cage similarly. Make use of the fact that there is 
only one C-C bond in the cage.  
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From the comparison we can see which pairs of atoms should be used for placing the 
molecule  
Return to Jana2006 
Start "Parameters → Molecule → New molecule" 
[On the screen: Atoms of the new molecule from:”] 
Select “Model file” 
For name of the molecule type “kage” 
For “Model name” browse for “Magcag-symmCs.m45” created in the previous example 
Keep the scaling distance unchanged 
“Show the model molecule” is disabled because we don’t have Magcag-symmC1.jpg 
NEXT 
[On the screen: Specify atomic types in the model molecule] 
Do not change the defaults atomic types; NEXT 
[On the screen: Define the molecular reference point] 
Select “Explicit” 
In “Reference point” textbox type N1_m 
This should be some atom from the mirror plane 
NEXT 
[On the screen: Define and complete molecular position #1] 
For the pairs “model atoms” – “actual positions” type the three previously noted pairs 
For "Maximal coincidence distance" type 0.6 
Press "Show coinciding atoms" 
We should see the complete coincidence 25/25 and the coinciding atoms should have the 
same chemical types. 

   
Press “Apply+End” 
Start "Edit atoms" 
The atomic part should contain only Br1, Mg1 and five oxygens 
Start "Plot structure" 
The cage should be correctly placed – verify by plotting 
In a plot slash "/" means the atoms is transformed by the point group symmetry of the 
molecule, while "a" indicates  the first actual position of the molecule.  

12. Refinement of the cage with Cs point symmetry 
Make backup copy 
Start "Refine commands"; go to page "Various" 
Press "Keep commands" and delete all of them 
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OK; OK; YES to save commands without starting Refine 
Start "Edit Atoms" 
Select all carbons 
Start "Action → Adding of hydrogen atoms" 
Select  "Try automatic run" 
The procedure should not add any new hydrogen atoms 
OK; YES to quit “Edit atoms”and save changes 
Start "Refine Commands" 
Set zero refinement cycles; OK; YES+START 
This applies the previously created keep commands 
Start "Plot structure" and verify hydrogen positions 
Start "Refine commands", set 100 refinement cycles with Damping factor 0.5 
OK; YES+START to save commands and run refinement 
The refinement has difficulties to reach convergence 
The fit is R~3.2%, Rp~2.3%, GOF~5, 53 structure parameters; i.e. only slightly worse fit 
comparing with the asymmetric cage 
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Example 2.4: PFPhenyl 
Revised: 16 October 2018 
 

Data Topic  Level 

X-ray powder crystal data organometallic structure from 
powder data using geometry 
constrains 

Intermediate 

Tasks 
Refinement of moderately sized organometallic structure from powder data with help of 
geometry constrains. 

Initial data 
Data 

Powder data measured with diffractometer Empyrean (PANalytical) using CuKα1 radiation and 
Debye-Scherrer geometry (sample in capillary), at ambient temperature. 

Input files:  

pfphenyl.xrdml with powder profile 

pfphenyl.cif with solution obtained by the program FOX 
Additional information: 

unit cell 10.77024 9.957075 26.70771 90 91.683 90 

expected symmetry P21/n 

 
Chemical formula: C30 N3 H29 P O2 F3 (Z=4)  
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Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step 1) 
Left pane: locate directory with input files 
Right textbox: type "pfphenyl"; OK (Step 2)  

2. Import procedure 

[On the screen: Specify type of the file to be imported] 
Select “Structure – from CIF”; NEXT (Step 1) 
[On the screen: select input CIF file] 
Select pfphenyl.cif; OK (Step 2) 
[On the screen: CIF does not contain any reflection block] 
YES to import data from file 
[On the screen: Specify type of the file to be imported] 
Select "various CW formats"; NEXT 
[On the screen: Powder data from:] 
Select "PANalytical XRDML"  
For method select “Debye-Scherrer”; NEXT 

[On the screen: Complete/correct experimental parameters] 

Notes  
Cell parameters were taken from CIF 
Radiation was interpreted from the xrdml file as CuKα1

 
NEXT; FINISH; OK to close data repository; YES to accept the data set 

II. Le Bail refinement 

1. Refinement of the powder profile 

Notes  
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For refinement of the powder profile we will use the le Bail wizard.All steps of the wizard 
could also be done without the wizard using the badic tools of Jana2006. 

[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press “Profile viewer” – just to see how it looks like 
Press “Default” to see more details 
Quit powder viewer 
Press “Edit profile” 
In page “Profile” activate refinement of “GW” 

Notes  
Unlike for structure parameters, refinement keys of profile parameters are not set 
automatically 

In page “Corrections”: 
Activate refinement of “shift”; 
Change number of “Legendre terms” for background to 30; (Step 3) 
OK; Yes to rewrite 
Right click on Refine; select the page “Basic” 
Make sure that "Make only profile matching" is activated  
The structure previously imported from CIF will not be used in this refinement, only profile 
parameters will be refined 
Set 100 refinement cycles (Step 1) 
OK; Yes + start 

Step 1  
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Notes  
Refinement finishes with: GOF ≈ 3.5, Rp ≈ 2.9, wRp ≈ 5.1.  
Waiting for the full convergence is not necessary. Refinement can be interrupted by End or 
Cancel - in this case End should be used in order to see the latest difference curve in the 
powder profile  viewer. 

“Profile viewer” 
Press "Default" 
Move the theta slider towards high angles 
Press "Details ON"; YES to plot many component functions 
Press "Fit Y" (Step 2) 

Notes  
The calculated profile shows problem with background. The background is too low and the 
Bragg peaks are too high, giving together good fit between calculated and observed line, 
which is unfortunately false. We shall therefore use the manual background. This problem 
only occurs with profile fitting. For Rietveld refinement, this problem cannot happen because 
intensities of peaks are given by the structure.  

Press "Details OFF" 
Press "Create new" button (lower right corner of the Powder profile viewer) 
[On the screen: Options for generating background profile] 
Use 60 background points and significance intensity level 1; OK 
Using the slider check the manual background. It can be edited by dragging the points by 
mouse. (Step 3) 

Step 2 Step 3 

  
Press "Quit" 
[On the screen: A manual background has been created] 
Select "Accept the new manual background" and "Suppress using of polynomial terms" 
OK 
Run "Refine" 

Notes  
Refinement finishes with GOF ≈ 3.6, Rp ≈ 2.8, wRp ≈ 5.2  

“Edit profile parameters” 
In page “Cell” activate refinement of “a, b, c, beta” 
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In page “Profile” activate refinement of “GV” 
OK, YES to save changes 
Run “Refine” 

Notes  
Refinement finishes with GOF ≈ 3.1, Rp ≈ 2.5, wRp ≈ 4.5 
For Gaussian parameters an important rule is that they cannot be refined all together 
because they are linearly dependent. Usually we refine GW, then GV and finally GU. In our 
case GU would not improve the fit. 

“Edit profile parameters” 
In page “Profile” change the type of the peak-shape function to “Pseudo-Voigt”, activate 
refinement of “LY” 
OK, YES to save changes 
Run “Refine” 

Notes  
Refinement finishes with  GOF ≈ 3.0, Rp ≈ 2.5, wRp ≈ 4.6 

“Show Powder profile” 
Enlarge the profile and investigate details of the fit between the calculated and 
experimental profile.  

Notes  
Some low angle peaks exhibit strong asymmetry: 

 
 

“Edit profile parameters” 
In page “Asymmetry/Diffractometer” select “correction by divergence” 
Activate refinement of “HpS/L” and fix to zero “HmS/L” 
OK; YES to save changes 
Right click Refine 
In page "Basic" set "Damping factor" to 0.5  
OK;  
Run “Refine” 

Notes  
Refinement finishes with GOF ≈ 1.7, Rp ≈ 1.8, wRp ≈ 2.5 
Waiting for full convergence is not necessary. 
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 “Show Powder profile” 

Notes  
Asymmetry seems to be well described 

Quit the profile viewer 
“File → Structure → Save as → Backup” 
NO (do not continue with the new structure) 

III. Rietveld refinement  

1. Refinement of the free atomic model 

Make sure that the backup copy really exists 
Start "Plot structure" 
In Diamond use "Build → Connectivity" and suppress F-H and F-O bonds 
Use  to plot the structure 

Notes  
The structure from FOX solution is looking like this: 

  
Before refinement we have to fix geometry for hydrogen atoms. Hydrogen positions cannot 
be determined from this powder data set. 

Return to Jana 
Start "Edit atoms" 
Select all carbon atoms and N9 
Start "Action → Adding of hydrogen atoms" (Step 1) 
[On the screen: Adding of "hydrogen" atoms"] 
Use default settings; OK 

Notes  
Hydrogen atoms of carbon have been fixed automatically while for N9 the program offers a 
dialogue 

[On the screen: Adding "hydrogen" atoms for "N9"] 
Select "Trigonal"; C28 and P1 for neighbors; H54 for hydrogen (Step 2) 
Press "Apply → Go to next" 

Step 1 Step 2 
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OK; YES to save changes 

Notes  
Adding of hydrogen atoms results in no new atoms in the list of atoms. The reason is that the 
hydrogen positions calculated by Jana2006 coincide with positions of already existing 
hydrogens. However, each hydrogen atom has now the corresponding keep command fixing 
its geometry. 

Start Refinement options (Right-click on the “Refine” icon) 
Select the page "Basic" 
Set 0 refinement cycles 
Uncheck "Make only profile matching" 

Notes  
This changes le Bail fitting into Rietveld refinement, where intensities of the profile points are 
calculated from the structure model 

OK; YES+START 

Notes  
R values are bad because the scale remains unrefined. However, positions of hydrogen atoms 
were updated according to the previously introduced keep commands and now we can check 
in the plotting program correctness of hydrogen positions. 

Start "Plot structure" 
Verify hydrogen positions 
Quit Diamond 
Start "Edit Profile" and fix all profile parameters: “a, b, c, beta, GV, GW, LY, HpS/L and 
shift”. 
OK, YES to save changes 
Using "File → Structure → Save as" make a backup copy named "pfphenyl_free" 
No (You don’t want to continue with the new structure) 
Start Refinement options; set 100 refinement cycles; set Damping factor 0.2 
In page "Various" start "Restrictions" 
Set the same ADP for all carbon atoms (C*) 
Set the same ADP for all nitrogen atoms (N*) 
Set the same ADP for all oxygen atoms (O*) 
Set the same ADP for all fluorine atoms (F*) (Step 3) 

Step 3  
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OK; YES (i.e. DO NOT start refinement) 
Using "File → Structure → Save as→ Backup_2" make a backup copy 
NO (Do not continue with the new structure) 
Start "Refine" 

Notes  
Now the structure is refined but the originally obtained profile parameters are fixed 
Refinement finish with:  
Resulting structure factors R(obs) ≈ 6.3, wR(obs) ≈ 5.0, R(all) ≈ 8.6, wR(all) ≈ 5.3  
Resulting profile factors GOF ≈ 2.0, Rp ≈ 2.1, wRp ≈ 2.9 

Start "Plot structure" and plot the refined structure 

Notes  

 
We can see that the PN3O group has been refined correctly but phenyl groups are not planar 
and the CF3 group has been destroyed 

2. Fixing geometry with keep commands 

Start "Tools → Recover files"  

 
Notes  
This returns the previous structure model (one step back). In case refinement would be started 
more than once, "File → Structure → Copy in" would be used for importing the previously 
created backup file.  
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Start "Plot structure" in order to see atom labels.  

Notes  
With "Draw+continue" Jana2006 and Diamond run independently, and atom labels seen in 
Diamond can be immediately used in Jana. Otherwise it is necessary to note the labels in 
Diamond for later use, or use the figure from the Cookbook. 

 
 

Start Refine Commands 
In page Various start "Keep commands" 
The already existing 50 commands keep the geometry of hydrogen atoms 
Select "Geometry" and "Plane" 
For "List of atoms" type labels of carbons in one of the Phenyl rings (without hydrogens) 
C17 C20 C23 C27 C31 C25 (step 1) 
Press "Add" 
Repeat the process for the remaining Phenyl rings 
C14 C18 C30 C32 C26 C21 
C57 C56 C58 C60 C61 C59 
C10 C11 C12 C29 C22 C16 
Switch from "Plane" to "Rigid" 
For "List of atoms" type C28 O6 C24 F2 F4 F5 

Step 1 The introduced keep commands: 
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Press "Add" 
OK; OK; YES+START 

Notes  
The resulting structure factors: R(obs) ≈ 7.4, wR(obs) ≈ 6.6, R(all) ≈ 10.1, wR(all) ≈ 7.0 
The resulting profile factors: GOF ≈ 2.3, Rp ≈ 2.5, wRp ≈ 3.3  
i.e. slightly worse results compared with the unrestricted geometry 
Damping factor may be changed to 1 

Start "Plot structure" and verify the result 
The geometry is now much more reasonable, but some angles in the phenyl rings are too 
much different of 120°.  
Make backup copy of this refinement named (for instance) phphenyl_keepgeom 
NO (do not continue with the new structure) 

 

3. Application of rigid body to phenyl rings 

Start "Refinement options", go to the page "Various" 
Start "Keep commands" and delete or disable the four "keep geom plane" commands 
("keep geom rigid" should be retained) 
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OK; OK; YES to save commands without starting Refine 
Start "Parameters → Molecules → New molecule" (Step 1) 
[On the screen: Atoms of the new molecule from:] 
Select "Atomic part" 
Write "Phenyl" for the name of the molecule (Step 2) 
NEXT 

 
Step 1 Step 2 

 

 

[On the screen: Select atoms for the molecule] 
Select “C10, C11, C12, C29, C22, C16, H46, H50, H33, H34, H35” (i.e. one of the phenyl 
rings) (Step 3) 
OK 
[On the screen: Define the molecular reference point:] 
Select “Geom. Center” (Step 4) 
NEXT 

Step 3 Step 4 

 

 

 
Notes  
For molecules not located in a special position the position of the reference point is not 
important. For symmetrical molecules, the reference point is used for derivation of symmetry 
restrictions and its definition is important. 
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[On the screen: Complete molecular position #1:] 
Use Occupancy 1 
Press "Apply+Next position" (Step 5) 

Notes  
The Coincidence ratio 11/11 means that all atoms of the actual position #1 coincide with 
atoms in the atomic part. This is obviously fulfilled, because the model molecule has been 
taken from the atomic part 

 
Step 5 

Step 6 

 

 
[On the screen: Define and complete the molecular position #2:] 
For model atoms select three carbons from the model molecule:  C16, C11 and C29 
For the actual position choose three corresponding carbons from another existing phenyl 
group, for instance C57, C58 and C61 
For "Maximal coincidence distance" type 0.6 (in Angstroms) (Step 6) 
Press "Show coinciding atoms"  

Notes  
It shows that the actual molecular position #2 coincides with another 11 atoms from the 
atomic part. These atoms will be automatically deleted in the atomic part. 
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Press "Apply+Next position" 
For model atoms re-use C16, C11 and C29 
For actual position #3 use C26, C30 and C14 
Calculate molecular parameters 
Number of coinciding atoms should be again 11 
Press "Apply+Next position" 
For model atoms re-use C16, C11 and C29 
For the last actual position #4 use C20, C25 and C27 
Calculate molecular parameters 
Number of coinciding atoms should be again 11 
Press "Apply+End" 
Start "Edit atoms" 
The free atoms are black, the atoms of the model molecule are blue (Step 7) 

Step 7 Step 8 

 

 
OK 
Start "Plot structure" 

Notes  
The structure should look more or less like before (with the difference that now we have four 
identical phenyl groups) 
The old keep commands acting for atoms replaced by some of the  molecular positions were 
automatically deleted. Keep commands acting for atoms of the model molecule were 
retained. 
However, we have also used keep commands involving atoms from the phenyl groups and N-
CH2- group. The command defining positions of two hydrogen atoms bonded to C19 has not 
been deleted, and it still contains the atom C16, which belongs to the model molecule and not 
to some actual position. Therefore, C16 must be changed to C16a (atoms of molecular 
positions #1, #2, #3 and #4 have suffixes a,b,c and d. : 

Start Refine Commands 
In page Various start "Keep commands" and load the keep command for C19: 
Change C16 to C16a; Add 
OK; OK; YES to save commands without starting Refine 

Notes  
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The commands for keeping the geometry of hydrogen atoms in N-CH2- groups for remaining 
three atoms (C55, C15 and C13) have to be re-defined, too. Another way how to do it uses the 
tool for adding hydrogen atoms: 

Start "Edit atoms" 
Select C55, C15 and C13 
Start "Action → Adding of hydrogen atoms" 
Use default settings; OK 
(number of atoms should not change) 

 
Notes  

Here are the final keep commands: 
 

  keep hydro triang C10 2 1 C16 C11 0.96 H33 
  keep ADP riding C10 1.2 H33 
  keep hydro triang C11 2 1 C12 C10 0.96 H34 
  keep ADP riding C11 1.2 H34 
  keep hydro triang C12 2 1 C11 C29 0.96 H35 
  keep ADP riding C12 1.2 H35 
  keep ADP riding C13 1.2 H36 H37 
  keep ADP riding C15 1.2 H40 H39 
  keep hydro tetrahed C19 2 2 N7 C16a 0.96 H44 H43 
  keep ADP riding C19 1.2 H44 H43 
  keep hydro triang C22 2 1 C29 C16 0.96 H46 
  keep ADP riding C22 1.2 H46 
  keep hydro triang C29 2 1 C22 C12 0.96 H50 
  keep ADP riding C29 1.2 H50 
  keep ADP riding C55 1.2 H68 H67 
  keep hydro triang N9 2 1 C28 P1 0.87 H54 
  keep ADP riding N9 1.2 H54 
  keep geom rigid C28 O6 C24 F2 F4 F5 
  keep hydro tetrahed C13 2 2 C16d N8 0.96 H36 H37 
  keep hydro tetrahed C15 2 2 N8 C16c 0.96 H40 H39 
  keep hydro tetrahed C55 2 2 C16b N7 0.96 H68 H67 
 

OK 
Open the page "Basic" 
Set number of cycles to 0; OK; YES+START to save commands and start refinement 
This will apply keep commands without any further changes 
Start "Plot structure" 
Verify the structure after application of the new keep commands 
There should be only small changes 
Start "Refine Commands" 
Change number of refinement cycles back to 100 
OK; YES+START to save commands and start refinement 

Notes  
The resulting structure factors: R(obs) ≈ 7.9, wR(obs) ≈ 7.0, R(all) ≈ 10.5, wR(all) ≈ 7.3 
The resulting profile factors: GOF ≈ 2.4, Rp ≈ 2.6, wRp ≈ 3.4 

Start "Plot structure" 

Notes  
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The resulting structure has much better geometry of phenyl groups  
However, the distance C13-N8 is too large 

 
Make backup copy pfphenyl_rigid 
NO (do not continue with the new structure) 

4. Releasing the geometry of COCF3 

Start "Refine commands" 
In page "Various" start "Keep commands" 
Delete or disable the "keep geom rigid" command; OK (Step 1) 
Start "Distance restrains" 
Define the following restrains (with default s.u.): 
"Keep a value equal for all items": C24 F5; C24 F2; C24 F4 
"Fix to the specified value": C24 C28 to 1.526 
"Fix to the specified value": C28 N9 to 1.35 (Step 2) 

Step 1 Step 2 

  
OK; OK; YES+START to save commands and start refinement 
“Use all” 

 
Notes  
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The resulting structure factors: R(obs) ≈ 7.4,wR(obs) ≈ 6.6, R(all) ≈ 10.0, wR(all) ≈ 6.9 
The resulting profilefactors: GOF ≈ 2.2, Rp ≈ 2.5, wRp ≈ 3.3 

Start "Plot structure" 

Notes  
The geometry is correct and (as a side effect) the distance N8-C13 is now also correct 

Make backup copy as phenyl_rigid_final 

5. Refinement of structure and profile parameters together 

Notes  
Up to now the profile parameters were fixed on values obtained in Le Bail refinement 

Start "Edit profile" 
Activate refinement of “a, b, c, beta, GW, GV, LY, HpS/L and shift” 
OK; YES to save changes 
Start "Refine" 

Notes  
The refinement finish with:  
the structure factore R(obs) ≈ 7.9 wR(obs) ≈ 7.0 R(all) ≈ 10.5 wR(all) ≈ 7.3 
the profile GOF ≈ 2.4 Rp ≈ 2.6 wRp ≈ 3.4 

Start "Edit profile" 
Go to page “Corrections” 
Change number of Legendre polynomial terms to 20 
OK; YES to save changes 
Start "Refine" 

Notes  
Now the manual background is combined with the polynomial background 
The problem with the background refinement, which we have seen at the beginning of this 
example, cannot occur with Rietveld refinement because the intensities of the profile points 
are calculated from the structure factors 
The resulting structure factors: R(obs) ≈ 7.4, wR(obs) ≈ 6.5, R(all) ≈ 10.0, wR(all) ≈ 6.8 
The resulting profile factors: GOF ≈ 2.2, Rp ≈ 2.4, wRp ≈ 3.2 

6. Fixing planarity of phenyl 

Start "Plot structure" 

Notes  
The structure is correct except that the phenyl rings are not perfectly planar 

Start "Profile viewer" 

 
Notes  
The profile is correctly described 

Start "Refine commands" 
In page "Various" start "Keep commands" 
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Define "keep - geometry - plane" for C10, C11, C12, C16, C22 and C29, i.e. for the carbon 
atoms of the model molecule 
OK; OK; YES+START 

Notes  
The resulting structure factors: R(obs) ≈ 7.6, wR(obs) ≈ 6.7, R(all) ≈ 10.2, wR(all) ≈ 7.0 
The resulting profile factors: GOF ≈ 2.3, Rp ≈ 2.5, wRp ≈ 3.3 

Start "Plot structure" 

Notes  
The phenyl rings are now perfectly planar, with reasonable distances and angles, although 
only the planarity has been kept.  
 

 
Plot with default radii    Plot with radii scaled by isotropic ADP 
 

References  
 
Favre-Nicolin, Vincent & Cerny, Radovan. (2002). FOX, 'free objects for crystallography': A 
modular approach to ab initio structure determination from powder diffraction. Journal of 
Applied Crystallography. 35. 734-743. 10.1107/S0021889802015236. 
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Example 2.5.1: Twoph 

Revised: 16 October 2018 
 

Data Topic  Level 

X-ray powder crystal data Multiphase powder refinement Intermediate 

Tasks 
Multiphase powder refinement  
Entering two phases in Jana2006 manually  
Refinement using Le Bail method 
Entering two phases in Jana2006 from cif file  
Refinement using Rietveld method  
Rigid body refinement  
Preferential orientation  
 

Initial data 
Data 
Powder measurement was done with Empyrean (PANalytical) using CuKα radiation, focusing 
mirror and Debye-Scherrer geometry (sample in a capillary) 
Input files:  
twoph.xrdml with powder profile 
RT.cif crystal structure of the room temperature phase solved and refined from single-crystal 
LT.cif crystal structure of the low temperature phase solved from powder data by FOX. 
Additional information: 
Room temperature (RT) phase of this sample is known from single crystal data. At cooling, a 
phase transition occurred, which was repeatedly destroing the single crystals. Therefore, the 
low temperature (LT) phase was measured at 150K as a powder. The powder sample at 150K 
still contained an admixture of the room temperature phase.  
Unit cell of the LT phase was determined with CRYSFIRE 2004. Its structure was solved by direct 
methods implemented in the program FOX, using the RT structure as a starting template.   
RT phase unit cell: 6.81 8.56 17.78 90 96.8 90 
RT phase symmetry: P21/n 
LT phase unit cell: 8.54 17.68 7.15 90 111.25 90  
LT phase symmetry: P21/a 
 

Chemical formula: RT and LT  
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Instructions  

I. Data import 

1. Creating new job name 

Start Jana2006 
“File  →  Structure → New” opens the file manager 
Left pane: locate directory with input files 
Right pane: double-click twoph 
OK; 

2. Import procedure  

[On the screen: Specify type of the file to be imported]  
Select “Powder data – various CW formats”; NEXT 
[On the screen: Powder data from:] 
Select "PANalytical XRDML" 
Select “Debye-Scherrer method”; NEXT 
[On the screen: Complete/correct experimental parameters] 
For “Cell parameters” type “6.81 8.56 17.78 90 96.8 90”  
(cell parameters of the RT phase) 
X-ray tube Cu 
Check the radiation Kalpha1/Kalpha2 doublet (Step 1) 
(should be interpreted from the xrdml file as Copper with doublet):  
NEXT; FINISH;  
OK to close data repository 
YES to accept the data set  
[On the screen: question how to continue]  
Select “No, I shall go by my own way”; OK  

Step 3  
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II. Le Bail refinement 

1. Powder profile indicates a multiphase 

Start “Tools → Powder → Make Le Bail” (Step 1) 
YES to start “profile viewer” 
Press “Default” and move the slider to beginning of the powder profile (Step 2)  

Step 1 Step 2 

  
 

Notes  
Some peaks, for example at 12.22°, do not have corresponding Bragg position. This is the 
indication of a multiphase (we believe our unit cell) 

Quit 

2. Importing of the second phase 

Start "Tools → Phases → New phase" (Step 1) 
[On the screen: New phase] 
Select "Manually"; OK (Step 2)  

Step 1 Step 2 
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[On the screen: Define/ modify basic structural parameters for phase: Phase#2] 
For “Cell parameters” type “8.54 17.68 7.15 90 111.25 90” (unit cell of the LT phase);  
For E.s.d.’s “0 0 0 0 0 0”(Step 3) 
OK; YES to rewrite M50 

Step 3 Multiphase 

  
 

Notes  
In the lower left corner of the Jana2006 basic window two new thumbnails appear: 
"Phase#1" and "Phase#2".  
They are used for switching between the two phases. Many tools of Jana2006 work only 
with the active phase, for instance “Fourier”, “Dist”, “Contour” and “Plot structure”. Before 
starting these tools, the required phase must be activated.  
 
Some other tools like “EditM50” and “Edit profile” can switch the phase internally.  

EditM50 Edit profile 

  
 
"Refine" and "Profile viewer" work independently on the active phase. 
 

The tool "Structure solution" places results to the first phase and deletes atoms of the 
other phases. 
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3. Set Phase labels and symmetry 

Start "EditM50" 
[On the screen: Define/ modify basic structural parameters for phase: Phase#1] 
Ensure that Phase#1 is selected at the bottom of the EditM50 window. 
For “Phase label” type "RT" (Step 1) 
Still in the EditM50 window, switch to the Phase#2 
For “Phase label” type "LT" (Step 2) 

Step 1 Step 2 

  
Go to the page "Symmetry"  
Select the phase RT and for “Space group” type “P21/n”; choose 21 along b; TAB; OK  (step 
3) 
Select the phase LT and for “Space group” type “P21/a”; choose 21 along b; TAB (step 4) 

Step 3 Step 4 

  
OK; YES to rewrite M50 

4. Le Bail refinement 

Start "Edit profile" 
[On the screen: Powder options for phase: RT] 
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Ensure that the RT phase is selected at the bottom of the form. 
In page “Cell” activate refinement of “a, b, c and beta” (RT phase) (Step 1) 
Select LT phase 
In page “Cell” activate refinement keys of “a, b, c and beta” (LT phase) (Step 2) 
Go to the page “Profile” 

Step 1 Step 2 

  
For each phase, select page “Profile”; “Pseudo-Voigt”; activate refinement keys for GW 
and LY 
Go to the page "Corrections" 
Corrections are independent on a phase selection 
For “Background”, select “Legendre polynomials” and for "Number of terms" type 25 (Step 
6) 
OK; YES to rewrite changes 
Right-Click on “Refine” 
[On the screen: Refine commands] 
Set "Number of cycles" to 30  
Select LeBail refinement for each phase; OK (Step 6) 
OK; Yes+start 

Step 5 Step 6 

  
 

Notes  
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Refinement [5788/37+1] finishes with GOF ≈ 3.3, Rp ≈ 1.3, wRp ≈ 2.0 

5. Correction for asymmetry 

Start “Profile viewer” and investigate the powder profile 

Notes  
The peaks at low angles are slightly asymmetric, otherwise the profile fits very well 
Two rows of Bragg positions correspond to two phases, the second phase (LT) is the top 
row. Clicking on some of the Bragg positions gives information about h k l, 2Theta position 
and about the corresponding phase. 

Quit the profile viewer 
Start "Edit profile" 
[On the screen: Powder options for phase: RT] 
Go to "Asymmetry/Diffractometer" 
Select "correction by divergence"  
Enable refining of HpS/L , set HmS/L to 0 and do not refine it. 
Go to "Corrections" 
Check "shift" 
OK; YES;  
Right click on Refine  
In page “Basic” change the Damping factor to 0.5. OK; Yes + Start 

Notes  
Refinement finishes with GOF ≈ 2.8, Rp ≈ 1.2, wRp ≈ 1.7 
Waiting for the full convergence is not necessary 

The Le Bail fitting is now complete, create a backup copy! 
Start “File → Structure → Save as" 
Make a backup copy "twoph_lebail" 
OK; NO (Do not continue with the new structure) 

III. Rietveld refinement  

1. Importing structure models for RT and LT 

Notes  
In this example, we could have imported the structure models of both phases at the 
beginning and make Le Bail fit with “Make only profile matching” refinement option. 
However, we want to demonstrate that structures can also be imported later on, e.g., in 
case when we need to test more structure models. 
Structure models cannot be imported through “File - Import model from” because this 
would destroy the phases. 
In next steps, we rely on the previously created backup copy! 

Start “Tools → Phases → Delete Phase” and delete the phase LT 
Start “File → Structure → Import model from  CIF” and import the file “RT.cif” 

 
Notes  
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The program retains the original unit cell, i.e. the one refined by the previous Le Bail fitting. 
This is important because the unit cell in RT.cif corresponds to the room temperature 
measurement of a single crystal while the powder data set was acquired at 150K 

 
Start “Tools → Phases → New Phase” 
[On the screen: New phase”] 
Select “Import from CIF format”  
Import the file “LT.cif”; OK; OK 
Start “EditM50” and rename “Phase#1” to “RT”, “Phase#2” to “LT” 
Start “File → Structure → Copy In” and copy only M41 from the backup copy 
"twoph_lebail" 
By this, we obtain the previously refined profile parameters 
Start refinement options, page “Basic”, press “Select leBail/Rietveld refinement for each 
phase”; select le Bail for both phases 
OK; Yes+Start  

Notes  
Refinement results should be the same like in previous profile refinement:  
GOF ≈ 2.7, Rp ≈ 1.2, wRp ≈ 1.7 

Start “File → Structure → Save as" 
Make a backup copy "twoph_rietveld_start" 
OK; NO (Do not continue with the new structure)  

2. Rietveld refinement of both phases with fixed parameters 

Notes  
In this example, we will use combination of rigid body with bond and bond-angle 
restraints. The rigid body approach will be applied on the RT phase because (i) this phase 
was known from single-crystal measurement and (ii) this is the minor phase. In fact, we are 
refining the RT phase only to get better results for the LT phase. 

Start "Edit profile" 
Uncheck a, b, c and beta for both phases  
Uncheck GW and LY for both phases 
Uncheck asymmetry correction  
uncheck shift  
OK; YES 

Right-Click on Refine 
[On the screen: Refine commands] 
Set "Number of cycles" to 100  
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“Select leBail/Rietveld refinement for each phase” select “Rietveld” for both phases 
Go to "Various" and open "Fixed commands" 
For Atoms/Parameters” type *; select “All parameters”; “Add” 
By this, we created command “fixed all *” fixing all structure parameters except scales 
OK; OK; YES (saving new refinement commands without starting refinement) 

Parameters->Phase fraction (Step 7) 
Check phvol2 
 

“Refine” 

Notes  
Refinement finishes with  
RT [627=624+3/2]: R(obs) ≈ 10.2 wR(obs) ≈ 11.9 R(all) ≈10.3 wR(all) ≈ 11.9 
LT [609=609+0/2]: R(obs) ≈ 9.7 wR(obs) ≈ 13.0 R(all) ≈ 9.7 wR(all) ≈ 13.0 
Profile [5788/25+2]: GOF ≈ 13.9, Rp ≈ 5.8, wRp ≈ 8.6 
The factor phvol2 refines to 0.83 

3. Keep commands for hydrogen atoms of the LT phase 

[On the screen: Basic window of Jana2006] 
Go to "Edit Atoms" 
“Switch phase” - Select LT phase 
Select “all carbon atoms, N2_2 and N3_2→ action→ adding of hydrogen atoms” 
N1_2, Cl1_2 and Cl2_2 should not be selected 
OK 
[On the screen: Adding "hydrogen" atoms for "N2_2"] 
Geometry is "Trigonal" and neighbors are (C7_2, N1_2); "Apply->Go to next"(Step 1) 
[On the screen: Adding "hydrogen" atoms for "N3_2"] 
Geometry is "Trigonal" and there is only one neighbor C7_2; "Apply " (Step 2) 
OK; YES 

Step 1 Step 2 
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Notes  
By this we have generated fixed commands for hydrogen atoms. Total number of atoms 
should be 21 

4. Rigid body for the RT phase 

Right-Click on Refine 
[On the screen: Refine commands] 
Go to the page "Basic" 
Set Damping factor to 0.1  
Go to the page “Various”; start "Keep commands" 
Select "Geometry" and "Rigid" and click "Select atoms" button. 
[On the screen: "Select atoms to define rigid body unit"] 
Select all atoms of the RT phase (atoms without “_2”) (Step 1); OK; Add 

 
Step 3  

 

 

 
Notes  
The new keep command has the following form: “keep geom rigid Cl1 Cl2 S1 N1 N2 N3 C2 
C3 C4 C5 C6 7 C8 C9 H1c2 H1c4 H1c6 H1c9 H1n3 H1n2 H2n3” 

OK; 

5. Set bond and bond-angle restraints for LT phase 

Notes  
In the next we will use pre-prepared “distfix” and “anglefix” commands based on the 
geometry of the RT phase.  RT phase was solved from single crystal; hence, we suppose 
that its geometry is correct. The format of the commands is: key word, value of the 
restraint, sigma (connected to the weight of the restraint in the refinement), list of atoms 

[On the screen: Refine commands] 
Go to "Distance restraints"  
Click "Edit" to open the text file editor. 
Paste all lines from distfix.txt or from this Cookbook  
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Close the text file editor and save changes 
OK 

Notes  
distfix 1.736 0.001 C5_2 Cl1_2 
distfix 1.401 0.001 C3_2 C5_2 
distfix 1.376 0.001 C4_2 C5_2 
distfix 1.460 0.001 C2_2 C3_2 
distfix 1.400 0.001 C8_2 C3_2 
distfix 1.369 0.001 C6_2 C4_2 
distfix 1.265 0.001 N1_2 C2_2 
distfix 1.741 0.001 Cl2_2 C8_2 
distfix 1.375 0.001 C9_2 C8_2 
distfix 1.371 0.001 C9_2 C6_2 
distfix 1.371 0.001 N2_2 N1_2 
distfix 1.345 0.001 C7_2 N2_2 
distfix 1.685 0.001 S1_2 C7_2 
distfix 1.313 0.001 N3_2 C7_2 

 
[On the screen: Refine commands] 
Go to "Angles restraints" 
Click "Edit" to open the text file editor. 
Paste all lines from the file anglefix.txt or from this Cookbook) 
Close the text file editor and save changes 
OK 

Notes  
anglefix 121.977 0.01 C3_2 C5_2 Cl1_2 
anglefix 115.676 0.01 C4_2 C5_2 Cl1_2 
anglefix 122.347 0.01 C4_2 C5_2 C3_2 
anglefix 126.236 0.01 C2_2 C3_2 C5_2 
anglefix 114.761 0.01 C8_2 C3_2 C5_2 
anglefix 120.262 0.01 C6_2 C4_2 C5_2 
anglefix 118.989 0.01 C8_2 C3_2 C2_2 
anglefix 124.469 0.01 N1_2 C2_2 C3_2 
anglefix 120.003 0.01 Cl2_2 C8_2 C3_2 
anglefix 123.439 0.01 C9_2 C8_2 C3_2 
anglefix 119.969 0.01 C9_2 C6_2 C4_2 
anglefix 116.048 0.01 N2_2 N1_2 C2_2 
anglefix 116.553 0.01 C9_2 C8_2 Cl2_2 
anglefix 119.211 0.01 C6_2 C9_2 C8_2 
anglefix 119.412 0.01 C7_2 N2_2 N1_2 
anglefix 119.203 0.01 S1_2 C7_2 N2_2 
anglefix 116.961 0.01 N3_2 C7_2 N2_2 
anglefix 123.835 0.01 N3_2 C7_2 S1_2 
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6. ADP for the RT and LT phase 

[On the screen: Refine commands] 
Start "Fixed commands" 
Delete the "fixed all *" command created previously 
Select “ADP harmonic parameters” 
For “Atoms/Parameters” type “Cl1 Cl2 S1 N1 N2 N3 C2 C3 C4 C5 C6 C7 C8 C9 H1c2 H1c4 
H1c6 H1c9 H1n3 H1n2 H2n3” 
Add; OK 

Notes  
This fixes ADP of all atoms of the RT phase to the values refined from the single crystal 
data 

[On the screen: Refine commands] 
Go to "Restrictions"  

Notes  
We will define one common ADP parameter for all non-hydrogen atoms of LT phase 

Uncheck "Make identical coordinates" 
Check “For atoms/molecules” 
Check  "Make identical ADP parameters" 
For occupancies use “not restricted” 
For “Atoms/Parameters” type “C5_2 C4_2 C6_2 C9_2 C8_2 C3_2 C2_2 N1_2 N2_2 C7_2 
S1_2 N3_2 Cl1_2 Cl2_2” (Step 1) 
Add; OK 
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Step 1  

 

 

  

OK; OK; YES; (saving refinement commands without starting refinement) 
Make a backup copy 
“Refine” 
Press "Use all" as a reply to the message about significant discrepancy 

Notes  
Refinement finishes with 
RT [627=622+5/8]: R(obs) ≈ 4.2 wR(obs) ≈4.9 R(all) ≈ 4.2 wR(all) ≈ 4.9 
LT [609=608+1/45]:R(obs) ≈ 3.7 wR(obs) ≈ 5.0 R(all) ≈ 3.7 wR(all) ≈ 5.0 
Profile [5788/25+51: GOF ≈ 6.3, Rp ≈ 2.6, wRp ≈ 3.9 

Plot both structures by "Plot structure" and check them 
[On the screen: main windows Jana2006] 
Select RT phase -> Plot structure-> Draw+continue 
Repeat the procedure for LT phase 

[On the screen: window of Diamond] 
To draw the structure press  then right click on on atom and select all molecule(s). 
Right click again then Add -> Atom labels   

RT Phase LT Phase 

   

7. Fine tuning the profile parameters 

Start "Edit Profile" 
Switch to the “LT” phase 
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Activate refinement of “a, b, c, and beta” 
Go to the page "Profile" 
Activate refinement of “GW” and “LY”of LT phase 
Go to the page "Corrections" 
Activate refinement of “shift” 
Go to the page "Sample" 
For Preferred orientation select “March-Dollase” 
Set “pref1” to 1, activate its refinement and for “Direction” type “0 1 0” 

Notes  
This corresponds to the longest unit cell parameter of the LT phase 

Still in the Sample page, switch to the RT phase 
For Preferred orientation select “March-Dollase” 
Set “pref1” to 1, activate its refinement and for “Direction” type “0 0 1” 
Activate refinement of “a, b, c, and beta”  
Go to the page "Profile" 
Activate refinement of “GW” and “LY” of LT phase  

Notes  
This corresponds to the longest unit cell parameter of the RT phase 

OK; YES (to save profile parameters) 
Run “Refine” 
Yes Use all 

Notes  
Refinement finishes with 
RT :R(obs) ≈ 3.7, wR(obs) ≈ 4.3, R(all) ≈3.7, wR(all) ≈4.3 
LT :R(obs) ≈ 3.2, wR(obs) ≈ 4.3, R(all)= 3.2, wR(all) ≈4.3 
Profile:GOF ≈ 5.5, Rp ≈ 2.4, wRp ≈ 3.4 

8. The final model 

Notes  
Finally, we will remove ADP restrictions for heavy atoms of the LT phase 

Right-click on Refine 
[On the screen: Refine commands] 
Go to the page "Various" and start "Restrictions" 
Load the restriction command, delete Cl1_2, Cl2_2 and S1_2, rewrite the command 
OK; OK; Yes+start 

Notes  
Refinement finishes with  
RT :R(obs) ≈ 3.6 wR(obs) ≈ 4.2 R(all) ≈ 3.6 wR(all) ≈ 4.2 
LT :R(obs) ≈ 3.1 wR(obs) ≈ 4.3 R(all) ≈ 3.1 wR(all) ≈ 4.3 
Profile : GOF ≈ 5.5, Rp ≈ 2.4, wRp ≈ 3.3 
 
In case the convergence is too slow, Marquardt refinement can be activated by pressing 
“Parameters” during the refinement. In such case damping factor can be increased to 0.5. 
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Example 2.5.2: CandAt 
Revised 6 March 2019 
 

Data Topic  Level 

Simulated X-ray powder data Refinement of the mixture Basic 

Tasks 
Multiphase powder refinement of a mixture of calcite with aragonite 

Load data and known crystal structure of calcite from the cif file 

Adding second phase with unknown crystal structure manually  

Le Bail refinement of both phases 

Structure solution of the unknown phase 

Rietveld refinement of the unknown phase   

Initial data 
Data 
Powder diffraction profile was simulated by program JANA2006 for Debye-Scherrer geometry 
(capillary), Cu Kα1 and focusing mirror. 
Input files:  
CandAt.xy 
calcite.cif 
Additional information: 
unit cell of the unknown phase is 4.96 7.97 5.74 90 90 90, Pmcn 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File -> Structure -> New” opens the file manager 
Left pane: locate directory with input files 
Right pane: double-click CandAt 
OK; 

2. Import wizard 

[On the screen: Specify type of the file to be imported] 
Select “from CIF”; NEXT 
[On the screen: Select input CIF file] 
Double-click on calcite.cif;  
YES (to import data from file) 
[On the screen: Specify type of the file to be imported] 
Select “Powder data – various CW formats”; NEXT 
[On the screen: Powder data from:] 
Browse and double-click on CandAt.xy file 
Select "Free format of 2th, I, [sig(I)]" 
Select “Debye-Scherrer method”; NEXT 
[On the screen: Complete/correct experimental parameters] 
Click on “X-ray tube” and select Cu 
(unit cell should be loaded from the cif file as 4.9907 4.9907 17.0634 90 90 120) 
NEXT;FINISH;OK;YES 
(You should be in the main JANA’s window) 

II. Le Bail refinement 

3. Fast check of the powder diffraction profile 

[On the basic JANA2006 window] 
Right-click on “Refine” 
[On the screen: Refine commands] 
Check “Make only profile matching (le Bail refinement)” (Step 1) 
OK; YES+start 
Let it converge and press NO 
[On the basic JANA2006 window] 
Double click in “Profile viewer” 
Zoom for example to the low angles and see unexplained reflections (Step 2) 
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Step 1 Step 2 

  

 
 
 
 

 
Leave profile viewer by “QUIT” 

 
 

4. Importing the second phase 

Start "Tools -> Phases -> New phase" (Step 3) 
[On the screen: New phase] 
Select "Manually"; OK (Step 4) 
 
[On the screen: Define/ modify basic structural parameters for phase: Phase#2] 
For “Cell parameters” type “4.96 7.97 5.74 90 90 90”; 
OK; YES to rewrite M50 

  

Notes  
Some peaks do not have corresponding Bragg position. This is the indication of a 
multiphase (we believe our unit cell) 



145 Jana2006 Cookbook, version September 2019 
 
 

 
Step 3 Step 4 

  

 
 
 
 
 
 
 
 
 
 
 
 
 

 

5. Set Phase labels and symmetry 

Start "EditM50" 
[On the screen: Define/ modify basic structural parameters for phase: Phase#1] 
Ensure that Phase#1 is selected at the bottom of the EditM50 window. 
For “Phase label” type "CA" like calcite (Step 1) 
Still in the EditM50 window, switch to the Phase#2 
For “Phase label” type "AR" like aragonite (Step 2) 
[On the tab: Composition] 
Switch to the CA phase and check the composition (Formula – list of atomic types).  
It should be there “C Ca O3” 
Switch to the AR phase and write the composition (Formula – list of atomic types) in the 
same atomic order “C Ca O3”.  
(Keep the same order of atomic types!)  
OK; YES to rewrite M50 

 

6. Le Bail refinement 

Start "Edit profile" 

Notes  
In the lower left corner of the Jana2006 basic window two new thumbnails appear: 
"Phase#1" and "Phase#2". 
They are used for switching between the two phases. Many tools of Jana2006 work only 
with the active phase, for instance “Fourier”, “Dist”, “Contour” and “Plot structure”. 
Before 
starting these tools, the required phase must be activated. 
Some other tools like “EditM50” and “Edit profile” can switch the phase internally. 
EditM50 Edit profile 
"Refine" and "Profile viewer" work independently on the active phase. 
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[On the screen: Powder options for phase: CA] 
Ensure that the CA phase is selected at the bottom of the form. 
In page “Cell” activate refinement of a and c  
Select AR phase 
In page “Cell” activate refinement keys of a, b and c 
[On the tab: Profile] 
Go to the page “Profile” 
For each phase select “Pseudo-Voigt” and activate refinement keys for GW and LY 
[On the tab: Asymmetry/Diffractometer] 
Asymmetry is independent on a phase selection 
Select asymmetry model for “correction by divergence” 
Set HpS/L to 0.03  
Set HmS/L to 0 
[On the tab: Corrections] 
Corrections are independent on a phase selection 
For “Background”, select “Legendre polynomials” and for "Number of terms" type 15  
Activate refinement of “shift” 
OK; YES to rewrite changes 
 
[On the basic JANA2006 window] 
Right-Click on “Refine” 
[On the screen: Refine commands] 
Set "Number of cycles" to 15 
Set Damping factor to 0.5 
Press “Select LeBail/Rietveld refinement for each phase” and choose le Bail for both; OK  
OK; Yes+start 

 
 
 
 
 

 
[On the basic JANA2006 window] 
Go to the “Profile viewer” and check the resulted profile fit (Step 5) 

 
 
 
 
 
 
 
 
 
 

Step 5 

Notes  
Refinement finishes with GOF = 2.27 , Rp = 1.73, wRp = 2.72  
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The Le Bail fitting is now complete, create a backup copy! 
Start “File -> Structure -> Save as" 
Make a backup copy "CandAt_lebail" 
OK; NO (Do not continue with the new structure) 

 

III. Structure solution of the AR phase 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Notes  
In our case, calcite represents impurity and it is also the known phase. Aragonite 
represents the unknown phase, that we would like to solve and refine. To start the 
structure solution process in Superflip, we have to eliminate contribution of reflections 
from the impurity (calcite) to the reflections of the unknown phase (aragonite). There are 
basically two possibilities, how to do that: (i) in the case of negligible peak overlap or 
without the knowledge of the crystal structure of the impurity, we can simply remove the 
contribution of the impurity by pure Le Bail refinement where all intensities are extracted 
just from the measured pattern . (ii) However, it is much better to use the known crystal 
structure of the impurity and remove its contributions according to its calculated 
intensities. Combined Rietveld and Le Bail refinement can do this. We are going to do the 
second (ii) method. 
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7. definition of the combined Rietvled/Le Bail refinement 

[On the basic JANA2006 window] 
Right-click on “Refine” 
[On the screen: Refine commands] 
Set "Number of cycles" to 30 
Press “Select LeBail/Rietveld refinement for each phase” and choose Rietveld for Ca phase 
and le Bail for AR phase; OK  
[On the tab: Various] 
Go to “Fixed commands” 
Write “*” to the Atoms/parameters and press “Add” to 
fix all atomic parameters (to fix structure of the CA phase for this moment) (Step 1) 
OK; OK; Yes+start 
 

Step 1 
 

 
 

 
 
 
 
 

 
 
 
 
 
 
 

Notes  
Refinement finishes with GOF = 2.30 , Rp = 1.77, wRp = 2.75  
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8. Structure solution of the AR phase 

[On the basic JANA2006 window] 
Important: Switch to the AR phase (left bottom). 
 
Go to “Structure solution” to solve structure of AR 
 
[On the screen: Structure solution] 
Check “Repeat Superflip: Until the convergence detected” 
Set “Maxcycles” to 2000 
Press “Run solution” 
OK (accept the error message, that AR phase does not contain any atom) 

 
 
 
 
 

Close 
 
[On the screen: Structure solution] 
Press “Change the space group” 
[On the screen: Define space group] 
Write “Pmcn” to Space group 
OK; YES 
 
REPEAT 
[On the screen: Structure solution] 
Check “Repeat Superflip: Until the convergence detected” 
Set “Maxcycles” to 2000 
Select “EDMA – fixed number of atoms” for the peaks search method and leave there the 
default value of 40. 
Press “Run solution” 
OK (accept the error message, that AR phase does not contain any atom) 
 
[After finishing Superflip] 
Press “Draw structure”; “Draw+continue” 
 
If the crystal structure does not contain CO3 groups and Ca cation is not coordinated by 9 
oxygen atoms return to REPEAT and try to solve it again. Result of structure solution 
process is unpredictable and it may happend that you end up with some partial solution, 
which will complicate you the rest part of the example. 
 
Press “Accept last solution” 
 
 
 
 
 

Notes  
Check the Superflip’s output file and find there the derived space group. It should be 
Pmcn. 
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[On the screen: Atom names are not unique, please make corrections:] 
Change atom names of first three atoms to Ca1_1, C2_1, O3_1 that correspond to calcite 
phase (Step 2) 
OK 

 
Step 2 

 
 
The structure solution is now complete, create a backup copy! 
Start “File -> Structure -> Save as" 
Make a backup copy "CandAt_solution" 
OK; NO (Do not continue with the new structure) 

 
 

IV. Rietveld refinement  
  

9. Carefully initialize Rietveld refinement – refine scale, phase fraction and background 

[On the basic JANA2006 window] 
Go to “Edit Profile” 
[On the screen: Powder options for phase: AR] 
Go to Cell tab: 
Uncheck refinement of unit cell parameters for both phases CA and AR 
Go to Profile 
Uncheck all profile parameters for both phases CA and AR 
OK; YES 
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[On the basic JANA2006 window] 
Menu -> Parameters -> Phase fraction 
[On the screen: Edit phase fraction] 
Allow refinement of the phvol2 
OK; YES 
 
 
[On the basic JANA2006 window] 
Right-click on “Refine” 
[On the screen: Refine commands] 
Press “Select LeBail/Rietveld refinement for each phase” and choose Rietveld for both 
phases; OK  
[On the tab: Various] 
Go to “Fixed commands” 
Ensure, that the command for fixing all atomic parameters is still there, otherwise create it: 
Write “*” to the Atoms/parameters and press “Add” to fix all atomic parameters of both 
phases 
OK; OK; Yes+start 

 
 
 
 

 
 
1. Perform Rietveld refinement of the AR phase 
 
[On the basic JANA2006 window] 
Right-click on “Refine” 
[On the tab: Various] 
Go to “Fixed commands” 
Delete the previous fixed command 
Write “*_1” to the Atoms/parameters and press “Add” to fix all atomic parameters of CA 
phase (because all atomic labels in this phase ended up with _1) 
OK; OK; Yes+start 

  
 
[On the basic JANA2006 window] 
Go to “Edit Profile” 
[On the screen: Powder options for phase: AR] 
Go to Cell tab: 
Allow refinement of unit cell parameters for both phases 
Go to Profile 
Allow GW and LY parameters for both phases 
OK; YES 

Notes  
Refinement finishes with GOF = 3.19 , Rp = 2.31, wRp = 3.83 

 

Notes  
Refinement finishes with GOF = 2.39 , Rp = 1.84, wRp = 2.86 
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[On the basic JANA2006 window] 
Right-click on “Refine” 
[On the screen: Refine commands] 
Set "Number of cycles" to 30 
OK; Yes+start 
 

 
 
 
 
 
 

 
 

[On the basic JANA2006 window] 
Go to “Plot structure”; “Draw+continue” to draw the crystal structure 

 
[On the basic JANA2006 window] 
Menu -> Edit/View -> View of Refine 
Phase ratio is on the last page of the log file (Step 3) 
 
 

Step 3 

 
 

Notes  
Refinement finishes with GOF = 2.36 , Rp = 1.83, wRp = 2.83 
If the refinement does not converge, disable refinement of the unit cell and profile 
parameters of the CA phase 
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Example 2.6: CaTeO3 cyclic 

 
Revised: 8 March 2019 
 

Data Topic  Level 

X-ray Powder data Cyclic refinement Intermediate 

Tasks 
We will study the dehydration of CaTeO3(H2O) as function of the temperature. 
Room temperature phase: α-CaTeO3(H2O):   
Cell parameters: 14.78125 6.78762 8.059512 90 90 90, Space group: P21cn 
High temperature phase at 330°C:  δ-CaTeO3  
Cell parameters:  13.32299 6.528064 8.171151 90 90 90, Space group: P21ca 
  

Initial data 
Data 
Laboratory diffractometer Bruker D8, λ CuKα1  
Input files:  
NB-LM01MO_030, NB-LM01MO_060, NB-LM01MO_090, NB-LM01MO_120, NB-LM01MO_150, 
NB-LM01MO_180, NB-LM01MO_210, NB-LM01MO_240, NB-LM01MO_270, NB-LM01MO_300, 
NB-LM01MO_330, NB-LM01MO_360, NB-LM01MO_390, NB-LM01MO_420, 
+ two directories with pre-refined structures of both phases  
 
Additional information – powder profiles: 
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Instructions  

I. Data import  

1. Creating new jobname for cyclic refinement 

Start Jana2006 
[On the screen: Basic Jana window] 
“File → Cyclic refinement → New” opens a file manager 
[On the screen: New : Select the master file for cyclic refinement] 
Left pane: locate directory with input files 
Right pane: Use any job name, for example “CaTeO3”; 
OK; 

2. Creation of the master file and specifying data files for cyclic refinement 

[On the screen: Create the master file and define/import data files] 
Press “Define/Copy data files”; 

 

 

 

 

 

 
[On the screen: Select/import data files”] 
Select all files with extension “XRDML”; OK 
[On the screen: Create the master file and define/import data files] 
Change the units from K to C;  
Press “Define individual temperatures”; 
 
[On the screen: Define temperature for imported files] 
Select “Derive them from file names”; 
Rewrite the substring in the file name, which defines the actual temperature by the 
question marks: NB-LM01MO_030.XRDML→ NB-LM01MO_???.XRDML;  
OK; 
 

 

Notes  
All files for cyclic refinement must be present in the working directory. In the case, that 
files are located in different directory, the program will copy them to the actual working 
directory. 
 

Notes  
Once you define the place in the file name where the temperature is located, Jana will 
assign the temerature to every input file automatically, see the following figure. 
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OK; YES to continue with cyclic refinement right now. 

 

II. Le Bail refinement  

1. Preparing the starting point based on the α phase 

 
[On the screen: Actions with individual item:] 
Select the data labeled as 30C; 
Press “Run le Bail wizard”; 

 
[On the screen: Specify type of the file to be imported:] 
Select “various CW formats”; Next; 
Select “PANalytical XRDML”; 
For method select “Bragg-Brentano method- Fixed Divergence Slit”; Next; 
[On the screen: Complete/correct experimental parameters] 
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Enter cell parameters: 14.78125 6.78762 8.059512 90 90 90; 
Radiation: X-ray; Cu wavelength is 1.540598  
Uncheck Kaplha1/Kalpha2 doublet; 
Press “Set glancing angle”; for Material select Ge;  for Reflection plane type 1 1 1; Press 
“=>” to calculate the glancing angle; OK  
Rewrite temperature to 303 (it is in Kelvins); Next; Finish; OK; 
“Yes” to accept made changes; 
“Yes” to continue with wizard; 
 

 
 
 
 
 
 
 

[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press the button “Copy in”; 
[On the screen: Select the name from where to read] 
Go to the subdirectory “alpha” and select the structure “NB-LM01MO_030”; 
OK 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press “Edit profile parameters”; Go to page “Asymmetry/Diffractometer” to see 
parameters used for fundamental approach: 
 

fundamental approach:  

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

In page “correction ”unselect “shift” and select “sycos” 
In page “profile” allow refinement of CSizeL (value arround 552) and StrainG (0.2), keep 
fixed CSizeG (10000) and StrainL (0) 
In page “Cell” allow refinement of the unit cell 

Notes  
The le Bail refinement for the starting point can be done manually step by step by using 
the wizard. However, as the main purpose of this example is to show how the cyclic 
refinement works, we shall import the already completed refinement that was made in 
advance. This will save the time for now. Importing can be made from the subdirectory 
“alpha” by using “copy in” button. 
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OK 
Press “Edit refine parameters”; 
Number of cycle 15; Damping factor 0.5 
OK; YES to save changes 
 “Run Refine”; 
 

 
  

When the refinement is done, go to Edit Profile again and uncheck Csize and StrainG. 
Uncheck “sycos”; OK; YES 
Finish; “Yes” to close the refinement tool. 

2. Cyclic refinement with a single-phase starting point 

[On the screen: Actions with individual item] 
Press “Run cyclic refinement”; 
After several minutes, all powder profiles are refined. 
Press “Graph”; 
Press “New graph”; 
[On the screen: Define parameter to be drawn] 
Select “R factors” and “GOF”; 

 

 

 

 

 

Select the temperature 120C; 
Press “Go to the basic Jana window”; 
Run “Profile viewer”; 
Press “X exactly” and select the range 10-30 in 2th: 
QUIT 
Press “Return to cyclic wizard” in the lower right corner of the Jana2006 basic window 

Notes  
The refinement result shows that we have properly described profile. 

 

Notes  

The GOF values for the range of temperatures 30-120°C indicate a very good fit 
GOF~1. For higher temperatures, the fit is considerably worse GOF~3. This means 
the profile parameters refined at 30 C are not good starting point for higher 
temperatures. 
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Repeat the same for the temperature 150C: 
 

 

 
 

Quit; Return to cyclic wizard; 

3. Cyclic refinement with a multi-phase starting point 

[On the screen: Actions with individual item:] 
Select the temperature 30C; 
Press the button “Go to the basic Jana window”; 
[On the screen: Basic Jana window] 

Notes  

This clearly indicates the presence of the second phase in the pattern, that has to me 
introduced. Check also the diffraction patterns at other temperatures. This will show 
you that the phase transition due to dehydration runs over a certain range of 
temperatures. 
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Run “Tools→Phases→New phase;” 
[On the screen: New phase] 
Use “Import from Jana2006 format”; 
Browse for the directory “delta” and select the file NB-LM01MO_330.m50; 
OK; OK 
Right-Click on Refine 
[On the screen: Refine commands] 

Set number of cycle 15; Damping factor 0.3 
Go to "Various" and open "Restrictions" 
Select “For powder profile”; 
Write to the window of phases with identical profiles: Phase#1 Phase#2; “Add”;OK 

 

 
 

In page “Basic” press “Select leBail/Rietveld refinement for each phase” and select “leBail” 
for both phases 
OK; Yes; (to save refinement commands without starting refinement); 
Run “Edit profile” 
On the page “Cell” ensure that for the Phase#2 the refinement of cell parameters is not 
allowed;  

On the page “Profile” enable refinement of Csize and StrainG for both phases. 

Ok; “Yes” to rewrite files; 

Run “Refine”; 

 

 

 
press “Return to the cyclic wizard”; 
“Run cyclic refinement”; 
After a few minutes, all powder profiles are refined like a multiphase. 
Press “Graph”; 
Press “New graph”; 
[On the screen: Define parameter to be drawn] 
Select “R factors” and “GOF”; 
OK 

Notes  

This restriction will make the profile parameters of both phases identical. 

Notes  

This makes multiphase refinement of the low temperature phase (despite the high 
temperature phase is missing at this temperature) 
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4. Cyclic refinement with three multi-phase starting points 

Quit (leave the graph) 
[On the screen: Action with individual item:] 
Select the temperature 30C; 
Press the button “Go to the basic Jana window”; 
[On the screen: Basic Jana window] 
Run “Profile viewer”; Press “X exactly” and select the range 10-30 in 2th; 
Quit, 
Press “Return to cyclic wizard” 

[On the screen: Action with individual item:] 
Select another temperature to see difference; 
Repeat the process several times to find the above mentioned regions; 

 

 
Here are the powder profiles for all temperatures: 

30°C 60°C 

5 0 1 5 0 2 5 0 3 5 0 Te m p  [C]

1 .0 0

1 .2 0

1 .4 0

GOF

Notes  

The GOF values are betweent 0.95 to 1.24 which indicates a good fit. However, as 
mentioned above, cell parameters of the phase#2 were fixed and profile parameters 
of both phases were kept equal. In order to make more accurate refinement, we have 
to find regions where occupations of the α or δ phase are negligible, and the region 
where both phases are coexisting.  
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90°C 120°C 

 

 

150°C 180°C 
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210°C 240°C 

  

270°C 300°C 

  

330°C 360°C 
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420°C  

 

 

 

 

 

 

 

 

 

 

 
Return to cyclic wizard; 

 
Set starting point for the region (30-120) where only the α phase is present 

Select the temperature 30C; 
Press “Run le Bail wizard” 
Press “Edit refinement commands”;  
In the page “Basic” change “Number of cycles” to 30 (damping factor 0.3) 
In the page “Various”; Press “Restrictions”; Delete or disable the command “restric 
Phase#1 profile Phase#2”; 
OK; OK; 
Press “Edit profile parameters” 
In page “Profile” and ensure that refinement of StrainG and CSizeL is activated for the 
Phase#1; ensure that refinement of StrainG and CSizeL is not activated for the Phase#2  
OK; Yes to save changes; 
Press “Run Refine”; 
Finish;Yes 
 
Starting point for the region (150-270) where both δ and α-phases coexist  
[On the screen: Action with individual item:] 
Select the temperature 150C; 
Press “Run le Bail wizard”; 

Notes  

The reflection in the blue rectangle is (1,1,0) of the α phase and the two reflections in 
the red rectangle are (1,1,1) and (2,1,0) of the δ phase.  
From these figures follows:  
in the region (30-120) only the α phase exists. 
in the region (150-270) both phases are present   
in the region (330-420) the δ phase exists 
In order to make the full cyclic refinement, two other starting points will be 
introduced – for 150°C and for 300 °C. 
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[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press “Edit refinement commands”; 
In the page “Basic” change “Number of cycles” to 30 (damping factor 0.3) 
In the page “Various”; Press “Restrictions”; Delete or disable the command “restric 
Phase#1 profile Phase#2”; 
OK; OK; 
Press “Edit profile parameters” and  
In page “Cell”, activate the refinement of cell parameters a,b,c for the Phase#2 and check 
Skip Friedel pairs (Unit cell parameters for Phase#1 are already activated) 
In page “Profile”, activate the refinement of StrainG and CSizeL for both phases  
OK; YES to save changes; 
Press “Run Refine”; 

 

 

 
 

 
OK; Finish; YES to close the refinement tool; 
YES to the question “Do you want to use this file as a new starting point?” 

Starting point for the region (330-420) where only the δ phase is present 
 
[On the screen: Action with individual item:] 
Select the temperature 330C; 
Press “Run le Bail wizard”; 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press “Edit refinement commands”;  
In the page “Basic” change “Number of cycles” to 30 (damping factor 0.3) 
In page “Various”, “Restrictions”, delete command “restric Phase#1 profile Phase#2” 

OK; OK; 
Press “Edit profile parameters” and  
In page “Cell”, deactivate refinement of cell parameters a,b,c for the Phase#1 and activate 
refinement of cell parameters a,b,c for the Phase#2; check Skip Friedel pairs for the 
Phase#2; 
In the page “Profile”, activate refinement of StrainG and CSizeL for the Phase#2; and 
deactivate refinement of these parameters for the Phase#1. For Phase#1, change the 
StrainG value to 1.164657 and CSizeL value to 125.5208 for the Phase#1  

 

 

 
 

OK; 
Yes to save changes; 

Notes  

Repeat the refinement if the changes of parameters are too large; 
Interrupt the refinement by pressing “End” if changes are small (about 3 s.u.) 

Notes  

This change will have no effect on refinement because manout of the Phase#1 is 
neglible at this temperature. These values will be aproximately refined values at the 
300°C temperature and will be helpful only for drawing the results at the end of this 
example. 
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Press “Run Refine”; 
 

 

 

 

 
OK; Finish; “Yes” to close the refinement tool; 
[On the screen: Action with individual item:] 
“Yes” to the question “Do you want to use this file as a new starting point?” 

 

 
 
“Run cyclic refinement”; 

 

 

 

 

  

 

 

 

 

Notes  

Repeat the refinement if the changes of parameters are too large; 
Interrupt the refinement by pressing “End” if changes are small (about 3 s.u.); 

Notes  

Most probably the refinement resulted with an error at 300°C due to the unrealistic 
profile parameters of the Phase#1. In such a case, continue by adding the fourth 
starting point at 300C. Otherwise continue by “Analyse results” 
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Add the fourth starting point at 300C 

[On the screen: Action with individual item:] 
Select the temperature 270C; 
Press “Run le Bail wizard”; 

[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press “Edit profile parameters” and  
In the page “Profile”, just remmember StrainG (0.21) and CSizeL (35) parameters of 
Phase#1. 
ESC;YES; 
NO – don’t set it as a new starting point 
 

On the screen: Action with individual item:] 
Select the temperature 300C; 
Press “Run le Bail wizard”; 

[On the screen: Refinement of the powder profile by the le Bail algorithm] 
Press “Edit profile parameters” and  
In the page “Profile”, set StrainG and CSizeL according to the tempereature 270C (0.21 and 
35) and disable its refinement 
OK; YES; 
FINISH; YES 
 
[On the screen: Action with individual item:] 
YES to create a new starting point 
Press “Run cyclic refinement” 

 

After several minutes, all powder profiles are refined. 

 

Analyse results 
 
[On the screen: Action with individual item:] 
Press “Graph”; 
Press “New graph”; 
[On the screen: Define parameter to be drawn] 
Select “R factors” and “GOF”;   
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The GOF values are in the interval 0.89 to 1.1 which means slightly better results than in the 
previous cyclic refinement.  
Press “New graph”; 
Select “Cell parameter”, “a”, “b” and “c” for the Phase#1: 

a parameter b parameter 

 
 

c parameter  

 

 

Repeat the process for the Phase#2: 
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a parameter b parameter 

  

c parameter  

 

 

Select “Profile parameter”,  “CSizeL” and“StrainG” for both Phase#1 and Phase#2  
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CSizeL Phase#1 CSizeL Phase#2 

 
 

StrainG Phase#1 StrainG Phase#2 

  

 
 

 
 
 
 

References  

Inorg. Chem., 2015, 54 (12), pp 5660–5670 

Notes  
The crystallite size of phase#1 is stable until 150°C, then due to the dehydratation 
occurring at this temperature, it decreases below 100 nm. The value after 330 deg has 
no meaning since this phase has completely desappeared. Regarding Phase#2, the 
crystallite size below 150 deg has no meaning for the same reasons. At this 
temperature the phase appears and its crystallite size increases due to the temperature 
from 40 nm to 80 nm.  
The strain for the phase#1 is stable until 150°C as expected. Then, the value of strain 
increases during the dehydratation (150-330) The value after 330 deg has no meaning 
since this phase has completely desappeared. Regarding Phase#2, the strain below 150 
deg has no meaning for the same reason. Above 150°C, the strain deacreases as a 
function of temperature.  
 
For phase#2, both the crystallite size and microstrain evolution indicate an 
improvement of the crystallite quality.  
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Example 2.7.1: LaPO4 
Revised: 17 October 2018 
 

Data Topic  Level 

X-ray Powder data Crystallite size by Fundamental 
approach 

intermediate 

Tasks 
Determine the crystallite size (coherent diffraction domain length)  

A.Coelho and R.W.Cheary developed the fundamental parameter approach to fit the 
instrumental part of the diffraction pattern of a conventional diffractometer. The aim of this 
method is to model the instrumental part in order to extract microstructural information of the 
sample: crystallite sizes and strain.  

 
In case of divergent beam, Bruker D8 ADVANCE configuration, we should take into account:  

o the aperture of the divergence slit (fixed FDS angle or variable VDS angle) 
o the width (RS width) and axial length (RS length) of receiving slit  
o the length (Source length) and projected width of the X-ray source 
o the absorption coefficient and axial length (Sample length) of the sample  
o angular aperture of Soller slit (Primary Soller and Secondary Soller)  
o emission x-ray profile (File with radiation profile)  
 

The LAM subfolder of Jana2006 installation folder contains emission profile files for different 
wavelengths  as well as for different monochromators. 
 

Initial data 
Data 
Bruker D8 ADVANCE Diffractometer Cu Kα1 = 1.540598 Å 
Johansson monochromator Ge(111)  
Bragg-Brentano method- Fixed Divergence slit  
Primary/Secondary radius: 217.5 mm 
Receiving slit width = 0.2 mm  
Fixed divergence slit = 0.3° 
Source length = 12 mm  
Sample length = 15 mm  
Receiving slit length = 16 (192*0.075 for Lynxeye detector) 
Primary/Secondary Soller slit = 2.5° (0.02 rad*2) 
Input files:  
LaPO4-SharpLines.xy 
LaPo4-Nano.xy 
Additional information: 
The structural information is given in the following cif file: 
LaPO4-ICSD.cif (this file comes from the ICSD database) 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens the file manager 
Left pane: locate directory with input files 
Right pane: LaPO4-SharpLines  

2. Import Wizard 

Select “structure – from cif”; NEXT  
Select “LaPO4-ICSD.cif” in the directory; OK 
YES to import data from file 
CIF does not contain the powder profile, it must be imported form other file 
Select “Powder data – various CW formats”; NEXT  
[On the screen: Powder data from]  
Select "Free format of 2th, I, [sig(I)]"  
For method select “Bragg-Brentano method- Fixed Divergence slit”;  
For “Filename” type or browse for LaPO4-SharpLines.xy 
NEXT  

Notes  
For this example, the difference between Fixed Divergence Slit (FDS) or Variable Divergence 
Slit (VDS) is important. In case you would select. If here you would select Another/unknown 
method, the program will request the slit type later on.  

[On the screen: Complete/correct experimental parameters]  
Radiation: X-ray; Cu wavelength is 1.540598;  
Press “Set glancing angle”; for Material select Ge;  for Reflection plane type 1 1 1; Press 
“=>” to calculate the glancing angle; OK  
Keep the perfectness at 0.5 
NEXT; FINISH; OK to close data repository;  
Do you want to accept made changes? Yes 

II. Rietveld refinement 

1. The fundamental approach  

Notes  
The structure is already known. Hence, the refinement can be directly done the Rietveld 
instead of Le Bail method. At the beginning, the structure model will be fixed and only 
profile parameters will be refined. 

 [On the screen: Basic Jana window]  
Check the profile: “Profile viewer" – just to see how it looks like  
Quit powder pattern profile 
Right click on “Refine” 
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In page “Various” select “Fixed commands”; select “All parameters”; in Atoms/parameters 
write *, press “Add”; OK; OK 
This fixes all parameters of the structure model except scales. 
YES to save refinement commands without starting refinement 
Add; OK; OK  

Press “Edit profile”  
In page “Asymmetry/Diffractometer” select “fundamental approach” and enter following 
parameters (Step 1) 
Primary/Secondary radius: 217.5 mm 
Receiving slit width = 0.2 mm  
Fixed divergence slit angle = 0.3° 
Source length = 12 mm  
Sample length = 15 mm  
Receiving slit length = 14 (192*0.075 = Lynxeye detector ) 
Primary/Secondary Soller slit = 2.5° 
In page “Various” check “Use predefined radiation profile” and select from the list 
CuKa1.lam (Step 2) 

Step 1 Step 2 

 
 

 
 

Notes  
The fundamental parameter depends on the used diffractometer  
 

1) Primary and Secondary radii are given in mm and correspond to the goniometer 
radius. In conventional diffractometers, both radii are identical  
Example:  
Empyrean PANalytical 240 mm,  
Smartlab Rigaku 310 mm,  
Bruker D8 217.5 mm 
 

2) Receiving slit (RS) width is given in mm. This value depends on your detector.  
In case of a scintillator detector (or 0D mode of other detectors), the width will 
correspond to the width of the receiving slit placed just before the detector. This slit 
reduces the horizontal divergence of the beam due to the flat sample. The 
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Fundamental approach parameter was originally developed for 0D detectors. In 
case of Lynxeye (or 1D mode of other detectors) the width of RS should be 
estimated using a standard with known crystallite size, e.g.,LaB6 .  
Example: 
Lynxeye detector: 0.2 mm 
 

3) The Fixed Divergence Slit (FDS) or the Variable Divergence Slit (VDS) is given in deg.  
Example: 
Smartlab Rigaku: value of FDS is given like a value of the Incidence slit (deg) 
Bruker: value of the fixed divergence slit is defined directly(deg) 
 

4) The source length is given in mm, and its value lies between 10 and 14 mm. This 
parameter has a negligible effect on the refinement; you can use the default value.  
 

5) Sample length is given in mm, and corresponds to the illuminated part of the 
sample. This value has a negligible effect; you can use the default value.   

 
6) Receiving slit (RS) length is given in mm. This value depends on the detector. 

In case of a scintillator detector (or 0D mode of other detectors), the length will 
correspond to the length of the receiving slit placed just in front of the detector. 
This slit reduces the vertical divergence of the beam due to the flat sample. The 
Fundamental approach parameter was originally developed for 0D detectors. In 
case of Lynxeye (or 1D mode of other detectors) the RS length can be calculated as 
a product of the number of pixels in one silicone strip and the pixel size (Pixcel 3D 
detector) or the product of the spatial resolution and the number of channels on 
silicon strips (Lynxeye detector).  
Example:  
Pixcel 3D : 0.055 mm* 256 pixels -> 14 mm 
D/teX Ultra 250: 0.075 mm*256 channels -> 19.2 mm    
Lynxeye detector: 0.075 mm* 192 channels -> 14.4 mm 
 

7) Primary and Secondary Soller slit angles are given in deg. The primary Soller slit is 
placed before the sample while the secondary one after the sample. You should be 
careful as a function of the constructor the definition of the angle is different. This 
slit reduces the axial divergence due to the beam divergence.   
Example:  
Empyrean Panalytical 0.02 rad = 1.14deg*2 = 2.3 deg,  
Smartlab Rigaku 2.5 deg  
Bruker D8 2.5 deg 

 
 
 
The predefined radiation profiles:  
For Copper radiation, Jana2006 offers nine different rasiation profiles  

Name Ratio between 
wavelength 

Wavelength Å Lorentzian halfwidth 

Cuka1.lam 1 1.5405960 0.5000000 
Cuk1sharp.lam 1 1.5405960 0.4018440 
Cuka2.lam 0.6538 1.5405960 0.5018440 
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 0.3462 1.5444930 0.6265790 
CuKa2_analyt.lam 0.6605 1.5405980 0.5000000 
 0.3395 1.5444426 0.5000000 
CuKa4_holzer.lam 0.5790 1.5405909 0.4374157 
 0.0800 1.5410639 0.6432140 
 0.2360 1.5443990 0.5128764 
 0.1050 1.5446855 0.6872322 
Cuka5.lam 0.0159 1.5347530 3.5999999 
 0.5791 1.5405960 0.4370000 
 0.0762 1.5410579 0.6000000 
 0.2417 1.5444100 0.5200000 
 0.0871 1.5447210 0.6200000 
Cuka5_berger.lam 0.0159 1.5347530 3.6854000 
 0.5691 1.5405960 0.4370000 
 0.0762 1.5410579 0.6000000 
 0.2517 1.5444100 0.5200000 
 0.0871 1.5447210 0.6200000 
Cuka5_t.lam 0.0159 1.5347530 3.5999999 
 0.5791 1.5405960 0.2370000 
 0.0762 1.5410579 0.4000000 
 0.2417 1.5444100 0.3200000 
 0.0871 1.5447210 0.4200000 
CuKb4_holzer.lam 0.4850 1.3922160 0.5502872 
 0.2480 1.3925949 0.5505868 
 0.1100 1.3917581 0.5546122 
 0.1000 1.3934906 1.2654732 
 0.0550 1.3913004 0.8290293 

 
The two first profiles are used for diffractometers with monochromator, the others except 
CuKb4) for diffractometers without monochromator  

In page “Profile” select “Pseudo Voigt” with CSizeL = 100, StrainL = 0, CSizeG = 10000 and 
StrainG = 0 (Step 3) 
OK; YES 

Notes  
The peak broadening due to the small size of crystallites is fitted with a Lorentzian function 
whereas the peak broadening due to micro strain inside the crystallite is fitted with a 
Gaussian function. In the case of LaPO4, no strain is present, and we use zero for both 
strain components. We also want to suppress the Gaussian component of the profile by 
setting a very large crystallite size (Csize G= 10000). 
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Step 3 Step 4 

  
Right click “Refine” 
Set 50 refinement cycles and set Damping factor to 0.8 (Step 4) 
OK; YES to save refinement commands without starting refinement 
“Edit Profile” 
In page "Cell" activate refinement of unit cell prameters a, b c and beta (Step 5) 
In page “Corrections”: Activate refinement of “sycos” 
In page “Profile” activate “Csize L” (Step 6) 
OK; Yes to save profile parameters 
“Refine” 

Step 5 Step 6 

  
The refinement converges with  
Structural factor R(obs)≈3.0 wR(obs) ≈ 3.1 R(all) ≈3.0 wR(all) ≈3.1  
Profile factor GOF ≈ 1.4 RP ≈ 3.6 Rwp ≈ 4.7 
The refined crystallite size CSizeL ≈ 36 nm  
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2. Structure refinement  

Notes  
Lanthanum is the heaviest atom in the structure, therefore its position will be refined first. 

Right click “Refine” 
In page “Various”, press “Fixed commands” and delete “fixed all *” 
Select “ADP harmonic parameters”, in “Atoms/parameters” type *, press “Add “(at that 
point the ADP are fixed for all the atoms)  
Select “coordinates”, in “Atoms/parameters” type P* O*, press “Add” (to keep the position 
of phosphorus and oxygen atoms fixed) 
OK; OK; Yes+Start 

Right click “Refine” 
In page “Various” in “Fixed commands” delete “fixed xyz P* O*” 
OK; OK; Yes+Start 

At this stage, profile plot at low angles shows that we need more background parameters 
“Edit profile” 
In page “Corrections” change number of terms for 10; OK; YES 
Run “Refine” 
Check profile using “Profile viewer” 
Check structure using “plot structure” 

Notes  
The refinement converges with  
R factors [242=239+3/19]: R(obs)≈2.4; wR(obs) ≈ 2.6 R(all) ≈2.4 wR(all) ≈2.6  
Profile R factors [2723/16+19]: GOF ≈ 1.2, Rp ≈ 3.2, Rwp ≈ 4.3 

3. Refinement of nano-powder 

In the following, we will use the structure and profile refined for the standard powder as a 
template for refinement against the nano-powder. 
File → structure → Save as→LaPo4-nano 
“Yes” (You want to continue with the new structure) 
(At that point the observed pattern is still LaPo4-SharpLines. It has to be changed for LaPo4-
Nano) 
File → Reflection file → Import/modify the reflection file 
Select “Reimport”, Browse for the new pattern “LaPo4-nano.xy” 
NEXT; NEXT; FINISH; OK 

Right click on “Refine” 
In page “Various” select “Fixed commands” 
Select “All parameters”; in Atoms/parameters write “*”; “Add”; OK; OK (“fixed all *” is not 
in contradiction with “fixed u *”, therefore both commands can be retained) 
Yes + Start (to run refine) 

 

 

Notes  
The refinement converges with  
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Structural factor R(obs)≈1.0 wR(obs) ≈ 1.0 R(all) ≈1.0 wR(all) ≈1.0  
Profile factor GOF ≈ 1.3 RP ≈ 2.6 Rwp ≈ 3.3 

Press “Edit profile” 
Go to the page “Profile” to see the new refined crystallite size: CSizeL ≈ 4 nm 
Check the profile using “Profile viewer”(Step 1) 

 
TEM picture (Step 1) 

 
 

 
Notes  
Because of severe overlapps of Bragg reflections and low intensity, the structure 
refinement cannot be done 

Final result 

LaPO4-SharpLines.xy LaPo4-nano.xy 

  
Crystallite size = 36 nm Crystallite size = 4 nm 

 

References  
J. Appl. Cryst. (1992). 25, 109-121.  
J. Appl. Cryst. (1998). 31, 851-861.  
J. Appl. Cryst. (1998). 31, 862-868. 
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Example 2.7.2: MnWO4 
Revised: 17 October 2018 
 

Data Topic  Level 

X-ray Powder data Strain by Stephens’ formalism Intermediate 

Tasks 
Using the Stephens’formalism to model the anisotropic broadening due to the microstrain 

Initial data 
Data 

Bruker D8 ADVANCE Diffractometer Cu Kα1 = 1.540598 Å 
Johansson monochromator Ge(111)  
Bragg-Brentano method- Fixed Divergence slit  
Primary/Secondary radius: 217.5 mm 
Receiving slit width = 0.2 mm  
Fixed divergence slit = 0.3° 
Source length = 12 mm  
Sample length = 15 mm  
Receiving slit length = 16 (192*0.075 = Lynxeye detector) 
Primary/Secondary Soller slit = 2.5° (0.02 rad*2) 

Input files:  

MnWO4.m50; MnWO4.m40; MnWO4.m41; MnWO4.m90; MnWO4.m95  

Additional information: 

CuxMn(1-x)WO4 is a solid solution. The actual composition of the compound under study was 
determined from chemical analysis (Cu0.3Mn0.7WO4). A phase transition occurs for x = 0.3. At 
this composition, the compound experiences huge anisotropic microstrain. The monoclinic 
MnWO4 structure presents the same arrangement of atoms as that of the triclinic CuWO4. The 
two structures are mainly related by a stretching along the 1 1 0 direction. 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → open” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click MnWO4 

II. Rietveld refinement  

1. Rietveld refinement using fundamental approach only 

Select “Edit profile” 
In page “Cell” select unit cell parameter a, b, c and beta (Step 1) 
In page “Profile” select CSizeL (Step 2) 
In page “Asymmetry/Diffractometer” use “fundamental parameters” (Step 3) 
In page “Corrections” type 5 for “Number of terms”; check sycos (Step 4) 
OK  

Step 1 Step 2 

  
Step 3 Step 4 
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Right click on “Refine” 
Uncheck “Make only profile matching”  
In page “Various” go to “Fixed commands”; select “All parameters”; for  
“Atoms/parameters” write *; “Add” (This fixes all structure parameters except scales) 
OK; OK; “Yes+start”  

Notes 
The refinement converge with  
Structure factors: R(obs) ≈ 10.2, wR(obs) ≈ 15.7, R(all) ≈ 10.2, wR(all) ≈ 15.7  
Profile factors: GOF ≈ 8.3, Rp ≈ 27.3, wRP ≈ 34.4 

Start “Profile viewer”; press “Defaut” and examine peaks between 27and 33 degrees  (Step 
5) 

Notes 
We can see two different types of peak broadening. It is impossible to fit it using only the 
fundamental parameters. In this case, the different peak broadening is caused by an 
anistropic strain broadening. 

 
Step 5  

 

 

 

2. Rietveld refinement using fundamental approach and axial method  

Notes 
In Powder options, page Profile, we can see possibilities available for description of 
anisotropic strain broadening.  

The axial method cannot work because the strain broadening is not due to a simple uniaxial 
strain. Try to see if it is possible to find a simple hkl value presenting a broadening peaks.  



185 Jana2006 Cookbook, version September 2019 
 
 

3. Le Bail refinement using fundamental approach and tensor method (Stephens’ method)  

Notes 
The Stephens’ method is used to describe anisotropic strain broadening taking into account 
the crystal symmetry.  
The maximum number of SHKL parameters to be refined is given in the right column  
Mhkl is linked to d-spacing with the following relation: 

hkhlkllkhMd hkl 654
2

3
2

2
2

1
2/1 αααααα +++++==  

with αi reciprocal lattice parameters. 
The variance of Mhkl is written by : 

( ) ∑=
HKL

LKH
HKLhkl lkhSM2σ  with SHKL defined for H + K + L = 4 

Table from Peter W.Stephens publication: 
Restrictions on anisotropic strain parameters for the seven crystal systems 

Those SHKL not listed in the last column must be zero 
Crystal system Restrictions on metric 

parameters 
Anisotropic strain 
parameters  

Cubic  A = B = C, D = E = F = 0  S400 = S040 = S004, S220 = S202 = S022 
Tetragonal A = B, D = E = F = 0  S400 = S040, S202 = S022, S004, S220 
Orthorhombic  D = E = F = 0 S400, S040, S004, S220, S202, S022 
Monoclinic D = F = 0  S400, S301, S220, S202, S121, S103, 

S040, S022, S004 
Trigonal (R3 etc.)  A = B = C, D = E = F  Rhombohedral indices:  

S400 = S040 = S004, S220 = S202 = 

S022, 
S211 = S121 = S112, 
S310 = S130 = S301 = S103 = S031 = 

S013 
 Hexagonal indices: 

S400 = S040 = S310/2 = S130/2 = 

S220/3, 
S202 = S022 = S112, S004, 
S301/2 = -S031/2 = S211/3 = -S121/3 

Hexagonal, trigonal (P3 
etc.) 

A = B = F, D = E = 0  S400 = S040 = S310/2 = S130/2 = 

S220/3, 
 S202 = S022 = S112, S004 

Triclinic   All 15 SHKL allowed  
 
In Jana2006, these symmetry restriction are automatically calculated 
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Start “Edit profile” 
In page “Profile” select “Tensor method” and press “Refine all” (Step 1)  
(During refinement, Jana will automatically apply restrictions to refine only St400, St220, 
St103, St022, St121, St040, St301, St202, St004.)  
OK; Yes 
Run “Refine”(On singularity warnings, select “Skip warnings”) 

Notes 
The refinement converges with  
Structure factors R(obs) ≈ 3.4, wR(obs) ≈ 5.1, R(all) ≈ 3.4, wR(all) ≈ 5.08  
Profile factors GOF ≈ 3.4, Rp ≈ 10.3, wRp ≈ 14.0 

Run “Edit Profile” 
Run “Profile viewer” 
Press “Defaut” and examine peaks between 27 and 33 degrees (Step 2) 

Step 1 Step 2 

  
Right click on “Refine” 
In page “Various”, “Fixed commands”: 
Delete “fixed all *” 
Fix positions of oxygen atoms (“fixed xyz O*”) 
Fix ADP parameters for all atoms (“fixed u *”) 
OK; OK; “Yes + Start” 

Right click “Refine” 
In page “Various”, “Fixed commands”, ”delete fixed xyz O* 
OK; OK; “Yes +start” 

Right click “Refine” 
In page “Various”, “Fixed commands”, delete “fixed u *” 
OK; OK; “Yes +start”  
(Now we are refining all structure parameters) 
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(Warning about negative ADP for Mn1) 

Notes 
The refinement converges with  
Structure factors R(obs) ≈ 3.5, wR(obs) ≈ 4.9, R(all) ≈ 3.5, wR(all) ≈ 4.9  
Profile factors GOF ≈ 3.4, Rp ≈ 10.4, wRp ≈ 14.1  
 
There are warnings about negative ADP for Mn1: 

 
 
Actually, this compound is not exactly MnWO4 but Cu0.3Mn0.7WO4, as follows from chemical 
analysis. In the next part, we will create a mixed site for these two elements. However, Cu and 
Mn are very close in the periodic table and refinement of ther partial site occupancies would 
not be possible. Thus the composition will be fixed to that determined by chemical analysis. 

4. Split atomic position 

File → Structure → Save as →CuMnWO4  
OK; “YES” (You want to continue with the new structure)  
Start “EditM50” 
In page “Composition”, “Formula – list of atomic types” , type Mn O4 W Cu 
OK; YES 

“Edit Atoms “→ Right click on Mn1  
“Split atomic position” (Step 1)  
Change “Atomic Type” for Cu ; “Name of the split atom”: Cu1 ; “Relative occupancy of the 
split atom”:0.3 (Step 2)  
“Apply”; OK 

 
Step 1 Step 2 
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Run “Refine”  
In case of oscillations, press “Parameters” and decrease “Damping factor” to 0.5   

Notes 
The refinement converges with  
Structure factors R(obs) ≈ 3.1, wR(obs) ≈ 4.1, R(all) ≈ 3.1, wR(all) ≈ 4.1  
Profile factors GOF ≈ 2.8, Rp ≈ 8.9, wRp ≈ 11.6  

 

[On the screen: window of Diamond] 
Start “Build -> Get molecules” or use  on the bottom toolbar 
Rotate the molecule (  and  on the bottom toolbar) to get an optimal view. 

 
 
Quit Diamond (without saving changes) 

Right click on “Dist” 
Uncheck d(max) derived from atomic radii and typical distances  
Change value to d(max) from 2.5 to 3 (step 4)  
Press “Define coefficients for bond valences”  
Select 1st atom type Mn, 2nd atom type O  
Press From file -> Mn2+ O2- coefficients 1.74 0.417 OK; Add 
Select 1st atom type Cu, 2nd atom type O  
Press From file -> Cu2+ O2- coefficients 1.649 0.37 OK; Add 
Select 1st atom type W, 2nd atom type O  
Press From file -> W6+ O2- coefficients 1.909 0.339 OK; Add 
OK; (Step 5)  
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Step 4 Step 5 

  
OK; Yes + start 
Yes to open the listing 
Go to list of distances (Step 6)  
Go to list of bond valence sums (Step 7)  

Step 6 Step 7 

 

 

Notes 
The Mn-O and Cu-O distances are generaly between 1.7 Å and 2.5 Å and for that of W-O 
between 1.17 Å and2.34 Å 
The bond valence sums for Cu Mn and O are close to 2 and close to 6 for W.  
This corresponds with valencies expected for this structure.  
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Check the final profile fit in Profile viewer 
In “Edit profile”, page “Profile”, look at the resulting crystallite size: 664 nm 
In “Edit profile”, page “Profile”, press “Edit tensor parameters” and look at the resulting 
strain parameters. Press “Show p/sig(p)” to see their significance in terms of sigma.  

Notes 

 
The largest value corresponds to the expected strain direction because of stretching of the 
structure along the 1 1 0 direction during the transition from monoclinic to triclinic phase. 
However, some other strain parameters are also fairly above the 3 sigma limit, and this is the 
reason why the classical uniaxial method fails.  

 

References  

Journal of Applied Crystallography 32, 281–289 (1999). 
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Example 3.1: AD3 

Revised: 4 March 2019 
 

Data Topic  Level 

X-ray single crystal data structure of a pseudo-
merohedric twin 

Basic  

Tasks 
Solving structure with pseudo-merohedric twinning and unequal twin volume fractions 

- Finding twinning matrix using Symmetry wizard  

- Creating publication CIF.  

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
AD3.hkl, AD3_red.sum 
Additional information: 
Frame scaling, absorption correction: done by the diffractometer software  
Chemical formula: Bis[N-(2-benzylidenepropylidene)phenyl]ether 
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Instructions  

III. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step1) 
Left pane: locate directory with input files; Right pane: double-click AD3 (Step2) 

Step 1 Step 2 

  

2. Import wizard 

Select “Known diffractometer formats”; NEXT (Step1) 
Select “Oxford Diffraction → CCD”; NEXT (Step2) 
Select “Input from “sum” file”; OK (Step3) 

Step 1 Step 2&3 

  
Leave all settings unchanged; NEXT (Step4) 
Leave all settings unchanged; NEXT; OK; (Step5)  
The program reads 15611 reflections from hkl file 
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Step 4 Step 5 

  
For absorption correction, select “None or done before importing”; NEXT (Step6) 
FINISH (Step7)  

Step 6 Step 7 

  

3. Data Repository 

OK; YES to accept the data set (Step1) 
Next; (Step2) 

Step 1 Step 2 
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IV. Symmetry and data merging 

1. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Select "Introduce twin laws in case of subgroups" 
Leave all other settings default; NEXT (Step 1) 
[On the screen: Select Laue symmetry] 
Select Monoclinic – setting “c”; NEXT (Step 2) 

Notes  
The highest Laue symmetry consistent with cell parameters is orthorhombic. It has rather 
high Rint (~17%) which indicates that orthorhombic symmetry is violated. Typical reason for 
such violation is presence of twinning where the structure of twins has lower symmetry 
and the twin domain fractions are not equal.  
The selected Laue symmetry is monoclinic. In the previous step, we have activated an 
option "Introduce twin laws in case of subgroups". This means that the symmetry 
operation generating the orthorhombic symmetry from the selected monoclinic symmetry 
will be used as the twinning operation and considered in the merging process. 

Select primitive unit cell; NEXT (Step 3) 
[On the screen: Select space group] 
Using the criteria described in the first example select P21/n, (Step4) 

  

Step 1 Step 2 
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Press “Details” to verify it is really acceptable; NEXT (Step 5) 

Notes  
The 46 reflections violating the extinction rules have mostly low I/ρ. Some additional spots 
in the diffraction pattern from e.g. a small crystal attached at the surface of the measured 
sample might cause the violations.  

Select "Accept twinning matrices induced by the space group test" 
Select "Accept the space group in the standard setting"; FINISH (Step 6) 

2.  Creating refinement reflection file 

NEXT to confirm threshold 3sigma; OK; OK (Step1) 

  

Step 3 Step 4 

  

Step 5 Step 6 
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[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT (Step 2) 
Accept the new DatBlock and calculate coverage; FINISH (Step3) 

Step 2 Step 3 

  

V. Structure solution  

3. Structure solution wizard  

[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for AD3: C N O H 
Select “Superflip”, “Peaks from Jana2006”; "Repeat Superflip: Number of runs" and 15 for 
number of runs; limit Maxcycles to 1000; leave other settings default 
Press “Run Solution” (Step 1) 

  

Step 1 Step 1b 
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Step 1  

 

 

[On the screen: listing of Superflip] 

Notes  
With this setting Superflip repeats calculation 15 times (from different randomly generated 
set of phases) and returns the result with the best fit between the electron density map and 
the user-defined symmetry. Because of twinning the fit of symmetry generators is worse and 
it may happen that Superflip suggests P21 instead of P21/n - please ignore this fact, "n" is 
confirmed by systematic extictions. With this structure, the results of Superflip are 
significantly better when "Biso" is set to 3 in the charge flipping options; however, this would 
be an empirical step useless for other structures. 

Close listing of Superflip 
Press “Draw structure” to see result of charge flipping (Step 2) 

Notes  
It may happen that Diamond shows two molecules instead of one. This is because twinning 
also biases the bond lengths, some distances are too long and some atoms are not properly 
assigned. To see the complete molecules, change the bonding limits in Diamond through 
Build  → Connectivity 
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Quit Diamond without saving changes 
In case of doubts repeat structure solution and plotting 
Finally press “Acccept last solution” to close the structure solution wizard 

4. Verification of the structure solution  

Start “Edit atoms” (Step 1) 
[On the screen: list of atoms] 
Press “Select all” 
Start “Action → Edit/define” (Step 2) 

Step 1 Step 2 

 
 

Double-click “Type” textbox 

  

Step 2  
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Notes  
Double-click unlocks the yellow textboxes. They are locked for security reasons because the 
selected atoms have different parameters (here chemical types). 

Select Carbon, OK (Step3) 
[On the screen: list of atoms. ]  
The labels are still the original ones but the chemical type of all atoms is carbon 
Start “Action → Rename selected atoms to atom type + number” (Step4)  

Step 3 Step 4 

  
Press “Select all” 
Start “Action → Make symmetrically contiguous motifs” (Step5) 
OK; YES to save changes 

Notes  
These steps help to get a reasonable plot in Diamond (next step) even with biased 
distances and improper chemical types 

Start “Plot structure” (Step6) 
Press “Draw+continue” 

Notes  
In this mode Jana will launch Diamond but it will not wait for its end 

Step 5 Step 6 

 

 



201 Jana2006 Cookbook, version September 2019 
 
 

 
[On the screen: window of Diamond] 
Start “Build  →  Molecules  →  Get molecules  → OK” or use  on the bottom toolbar 
Rotate the molecule (  and  on the bottom toolbar) to get an optimal view 
Draw rectangle to select all atoms of the molecule or press Ctrl-A 
Right-click on one of the selected atoms, choose “Add  Atom labels” 
 
[On the screen: dialogue of Diamond for atom labeling] 
For “Content” select: “Atom symbol” 
Define relative position of labels 0.3,0.3,10 
Define text size ~0.8Å; OK 
Rotate the molecule to similar orientation like has the chemical scheme 
[On the screen: plot of the molecule with atom labels] 
 

Notes  
The results may be slightly different for each run of Superflip. This is because Superflip 
starts from random phases and the resulting electron density map differs for each run. In 
our case, chemical types of some atoms need to be corrected. 

 
 

 

 
 
Compare the plot with the chemical scheme and note labels of atoms, which must be 
oxygen or nitrogen. 
  

Notes  
In our example, C2 and C3 should be nitrogen and C1 should be oxygen. 

 
Quit Diamond 

5. Assignment of correct chemical types 

[On the screen: basic Jana window] 
Start “Edit atoms” 
[On the screen: list of atoms] 
Select the atom which should be oxygen (C1 in our example) 
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Editing of one atom can be also started by right mouse button or by double-click 
Start “Action → Edit/define” and choose chemical type “O”; OK 
Press “Refresh” 
Hold Ctrl and select atoms which should be nitrogen (C2,C3 in our example) 
Start “Action → Edit/define” and choose chemical type “N”; OK 
[On the screen: list of atoms, labels are still the original ones but chemical types are 
correct] 
Press “Select All” 
Press “Action” or right-click on one of the selected atoms 
Choose “Rename selected atoms to atom_type + number” 
[On the screen: list of atoms with labels corresponding to chemical types] 

Notes  
You should see one oxygen, two nitrogens and carbons. If not press ESC and start again  

OK; YES to save the changes 
Check chemical types with Diamond 

VI. Refinements and model improvement  

1. Refinement 

[On the screen: basic window of Jana] 
Right-click the icon of Refine. (Step1) 
[On the screen: refinement options] 
Define 100 of cycles, Damping factor 1 and Instability factor 0.02; OK (Step2) 

Notes  
This instability factor slightly lowers goodness of fit, which makes happy editors used for 
SHELX. However, we cannot change this number arbitrarily because values below 0.01 or 
above 0.02 are usually in contradiction with the instrument characteristics. 

Choose “YES+START”  
Refinement converges with R value about 16%, GOF about 8, 141 refined parameters 

Step 1 Step 2 
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2. Twin volume fraction 

Start “parameters → Twin fractions” (Step1) 

Notes  
The volume fraction of the twin domain introduced by the Symmetry wizard is 0.5 and 
twinning matrix relating the monoclinic and orthorhombic symmetry is 
 (1 0 0 | 0 1 0 | 0 0 -1). 

Activate refinement of the twin fraction (Step2) 

Step 1 Step 2 

 

 

Repeat refinement  
Refinement converges with R value about 11%, GOF about 7 
Twin volume fraction drops to 0.29. 
Start “Edit atoms” 
[On the screen: list of atoms] 
Press “Select all” and “Action → Edit/define” (Step3) 
Choose “harmonic” for ADP parameters.  (Step4) 
This defines anisotropic temperature parameters for all atoms. 
OK, OK, YES to save changes 

Step 3 Step 4 
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Double-click the icon Refine. 
Refinement converges with R value about 9%, GOF about 6, 317 refined parameters. 

3. Adding of hydrogen atoms & Final refinement 

[On the screen: basic window of Jana] 
Start “Edit atoms”  
In the textbox type “C*”; TAB. (Step1) 

Notes  
This will select atoms starting with C, i.e. carbons 

Start “Action → Adding of hydrogen atoms” (Step2) 

Step 1 Step 2 

  
[On the screen: Adding of hydrogen atoms dialogue] 
Leave all settings default; OK (Step3) 
[On the screen: list of atoms with new hydrogens] 

Notes  
Total number of atoms should be 63 (can be verified using “Select All”) 
The hydrogens are kept in ideal geometry by commands which can be viewed or edited in 
“Refinement commands → Various → Keep commands”. 

 

Step 3 Refinement commands → Various  
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OK to close “Edit atoms”; Yes to save changes 
“Plot structure” to check results of automatic hydrogen assignment 
Make refinement of the final structure 

Notes  
Oscillation may occur during the refinement. In such case do not break refinement, press 
Parameters, change Damping factor to 0.5 and close the dialogue. Refinement will 
continue with damping. 
Refinement converges with R value 3.7%, GOF 2.7, 317 refined parameters. 

VII. Creating CIF file   
 

Notes  
The information for the CIF file is cumulated in the file M70 during the data processing as 
well as solution and refinement steps. For creating a publication CIF, repetition of the basic 
steps is recommended in order to refresh the information in M70. In our case, we have 
started from the *.sum file so M70 does not contain any information about the experiment 

Start “File → Reflection file → Create refinement reflection file” 

Notes  
In our case this step is not necessary because it has been already done 

Repeat refinement 

Notes  
In our case this step is not necessary because it has been already done 

Right-click Fourier; (Step1) 
Select “F(obs)-F(calc) - difference Fourier”; make sure that “Weighting of reflections” is 
checked and “Apply sin(th)/lambda limits” unchecked; (Step2) 

Step 1 Step 2 

 
 

In the page “Scope” press “Reset to default”; (Step3) 
In the page “Peaks” choose “in a fixed sphere of radius 0.8” (Step4) 
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Step 3 Step 4 

  
OK; YES+START; NO to include new atoms; NO to see the listing 
Right-click Dist icon (Step 5) 
Select “d(max) derived from atomic radii and typical distances and adjust “expanded by” 
value” when needed; check “Calculate angles”; in needed, adjust limits for H-bonds; 
(Step 6) 

Step 5 Step 6 

  
In the page “Select atoms” check central atoms and neighbor atoms – usually we want to 
have all atoms in both roles; (Step 7) 
OK; YES+START; Close;  
Start EditM50; (Step 8) 
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Step 7 Step 8 

  

Go to page Composition; enter 4 for “Formula units”, press “Formula from M40” (Step9) 
OK; YES for updating the formula. 
OK; YES to rewrite M50  
Start “File → CIF utilities → Make CIF file” (Step10) 

Step 9 Step 10 

  
  

Notes  
When formula to be listed in CIF differs of the formula generated from the structure model, 
it can be defined in the “Chemical formula – for CIF” textbox 

 

References  
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Example 3.2: PyNinit 

Revised: 07 March 2018 
 

Data Topic  Level 

X-ray single crystal data structure with pseudo-
merohedric 3-fold twinning 

Advance  

Tasks 
Solving simple structure with non-merohedric twinning using Jana2006 

- Handling twin overlaps in Jana2006.  

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
1st twin domain: pyNinit_twin1.hkl, pyNinit_twin1_red.sum 
2nd twin domain: pyNinit_twin2.hkl, pyNinit_twin2_red.sum 
hklf5: pyNinit_twin1_hklf5.hkl 
Additional information: 
Frame scaling, absorption correction: done by the diffractometer software  

Chemical formula: Twinning matrix: (-1 0 -0.733| 0 -1 0| 0 0 1) 

 

 
This figure shows diffraction pattern of pyNinit – peak 

positions projected along b* with unit cells of both 
twins related by the above-mentioned twinning matrix 
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Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step1) 
Left pane: locate directory with input files; Right pane: double-pyNinit_twin1 (Step2) 

Step 1 Step 2 

  

2. Import wizard (for the 1st twin domain)  

Select “Known diffractometer formats”; NEXT (Step1) 
Select “Oxford Diffraction → CCD”; NEXT (Step2) 
Select “Input from “sum” file”; OK (Step3) 

Step 1 Step 2&3 

  

Warning; (Step 4) 
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Step 4 Notes 

 

Old input files (sum) cumulated 
information from subsequent data 
reductions.  

Leave all settings unchanged; NEXT (Step5) 
Leave all settings unchanged (leave Twinning checkbox clear); NEXT; OK; (Step6)  
The program reads 34630 reflections from hkl file 

Step 5 Step 6 

  

For absorption correction select “None or done before importing”; NEXT (Step7) 
FINISH (Step8)   

Step 7 Step 8 

  

3. Data Repository 

OK; YES to accept the data set (Step1) 
Nest; (Step2) 
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Step 1 Step 2 

 

 

II. Symmetry and data merging  

1. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Leave all other settings default; NEXT (Step1) 
[On the screen: Select Laue symmetry] 
Select continue with the basic cell; NEXT (Step2) 

[On the screen: Select Laue symmetry] 
Select Monoclicnic; NEXT (Step3) 
[On the screen: Select cell centering] 
Select primitive unit cell; NEXT (Step4) 

  

Step 1 Step 2 
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[On the screen: Select space group] 
Using the criteria described in the first example Select P21/c; NEXT (Step5) 
[On the screen: Final step of the space group test] 
Accept the space group transformed into the original cell; FINISH (Step6) 
Follow the wizard for creation of the refinement reflection file  

 

III. Structure solution  

“Run → Structure solution” 
[On the screen: window of Structure solution] 
In “Formula” textbox check list of chemical elements for PyNinit: Ni C N O H 
Select “Superflip”, “Peaks from Jana2006”; leave other settings default; “Run solution” 
 

Notes  
Superflip converges (after noise suppression) with R value ≈ 23%. 
Fit of symmetry elements is very good for c, slightly worse for 21 

 

Step 3 Step 4 

  

Step 5 Step 6 
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Step 1 Superflip 

  

Press CLOSE to leave the listing 
Press “Draw structure” 
Press “Accept last solution” 

IV. Refinements and model improvement   

1. Refinement 

[On the screen: basic window of Jana] 
Right-click the icon of Refine. (Step1) 
[On the screen: refinement options] 
Define 100 of cycles, (Step2) 
Choose “YES+START”  
Refinement converges with R value about 19%, GOF about 10, 145 refined parameters 
Serious warnings appear in the listing. 

Step 1 Step 2 

  

2. Assignment of the correct chemical types  

Use “Edit atoms” (Step1) 
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And “Select rejected” to delete atoms which may be automatically rejected during the 
refinement because of too large Uiso (Step2) 
(The button is disabled when there are no such atoms) 

Step 1 Step 2 

  
 

Using “Plot structure” identify the incorrectly assigned chemical types by comparison of the 
plot with the chemical scheme 
Using “Edit atoms” (Step1) 
Correct the chemical types, delete wrong atoms, “rename atoms according to chemical 
type” and “create symmetrically contiguous motifs” (Step3)  
Repeat refinement 
Run difference Fourier and complete the possibly missing atoms (Step3) 
Repeat refinement 
Refinement converges with R value about 17%. 
Using “Edit atoms” set harmonic ADP for all atoms 
Refinement converges with R value about 17%. 
Serious warnings appear in the listing due to non-positive definite ADP of some atoms 

Step 3 Step 4 
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3. Adding hydrogen atoms  

Using “Edit atoms” add hydrogens to carbon and nitrogen atoms (Step1) 
Notes  
For nitrogen atoms skip cases when Ni is listed as a neighbor (this is the nitrogen 
coordinated to Ni) and skip also cases when nitrogen has three oxygen atoms as neighbors 
(this is NO3 group).  
Check the hydrogen atoms by plotting. The geometry is slightly distorted due to unresolved 
twinning which may confuse the automatic procedure for adding hydrogens. 
Finally, the structure model should have 53 atoms 

 
Step 1  

 

 

 
Repeat refinement 

Notes  
Refinement converges with R value around 16.6% and GOF 8.5, 316 parameters 
Several non-positive definite ADPs are indicated in the List of serious warnings in the 
refinement listing 

 

4. Add a twinning matrix  

In “EditM50” check “Twinning” (Step1) 
And define twinning matrix (-1 0 -0.733| 0 -1 0| 0 0 1); OK; Yes; OK; Yes (Step2) 

Notes  
The twinning matrix is known from the diffractometer software and represents a rotation 
by 180º around c. The program offers re-creation of the refinement reflection file because 
twinning may change rules for merging of symmetrically equivalent reflections. In this 
case, it is not necessary. 
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“Do You want to re-create refinement reflection file just now”? No 
In “Parameters → Twin fractions” check refinement of “twvol2” 
Repeat refinement 
Refinement converges with R value around 15% and GOF 8  for 317 parameters 
Open listing of Refine (Edit/View→View of Refine→Go to→List of serious warnings) 
ADP tensors are still not positive definite for some atoms. 

Notes  
This twin has a diffraction pattern where some reflections are partially overlapped. In 
refinement options there are two limits available for treating partial overlaps. The 
reflections with difference in theta smaller than “Maximal angular difference for twin 
overlap” are treated as fully overlapped; the reflections with theta difference larger than 
“Minimal angular difference for full separation” are treated as fully separated; the 
reflections between the limits are discarded. The limits should be adjusted carefully not to 
discard too many reflections. 

 
In Refinement command options change values of “Maximal angular difference for twin 
overlap” (L1 in the table) and “Minimal angular difference for full separation” (L2 in the 
table) and watch their impact on R factors, number of excluded reflections and ADP tensors. 
Find an optimal combination. (Step3) 

  

Step 1 Step 2 
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Step 3 Step 3b 

  
 

Notes  
(This table is calculated for refinement on F and instability factor 0.01) 

L1 L2 Robs GOF discarded 
0 0 15.3 8.2 0 
0.1 0 12.8 7.4 0 
0.2 0 7.4 3.6 0 
0.3 0 7.1 3.5 0 
0.4 0 9.8 5.5 0 
0.35 0 9.6 5.4 0 
0.31 0 9.3 5.3 0 
0.3 0.4 6.9 3.6 778 
0.3 0.5 7.4 3.8 1264 
0.3 0.6 7.9 4.1 1916 
0.2 0.3 6.2 3.0 415 
0.2 0.4 5.7 3.0 1193 
0.15 0.3 5.3 2.4 709 
0.1 0.3 4.8 1.9 1120 
0.1 0.4 3.9 1.4 1898 

 
With maximal angular difference for twin overlap 0.1 and minimal angular difference for 
full separation 0.4, refinement converges with R value 3.9% and GOF 1.4, all ADP tensors 
are positive definite, the fraction of the second twin domain refines as 0.468(2) (see 
“Parameters → Twin fractions)”. 
 

 
Using “Structure → Save as”, create a backup copy, for instance pyNinit_1domain (Step4) 
“Do you want to continue with the new structure?”; No 
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Step 4 Step 4b 

  
 

5. Add data of the second domain 

Notes  
Usually (and also in this case) the first twin domain + twinning matrix is sufficient for the 
refinement. If data of the second domain are good, we can add it as another data set to 
get better refinement of the twin fraction. 

“File → Reflection file → Import/modify the reflection file”; (Step1) 
Import new (Step2) 

Step 1 Step 2 

 

 

Known diffractometer formats; Oxford Diffraction-CCD 
Browse for PyNinit_twin2.hkl 
Select “Input from “sum” file”; OK ; OK 
Leave all settings unchanged; NEXT 
[On the screen: Relationship to the reference cell/split by twinning] 

Notes  
Here we have to define that reflections of the second domain were indexed according to 
orientation matrix of the second domain. 
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Data related to domain #2; NEXT; Accept cell parameters (Step3) 
[On the screen: Information about difference in cell parameters] 
Select “Continue with the old reference cell parameters” 
YES to suppress possibly duplicate reflections (Step4) 

Step 3 Step 4 

  
 

Notes  
Data processing of each twin was done on the same experimental frames. Therefore, 
overlapped reflections are processed twice with the same result. Merging of duplicitely 
processed reflections would lead to very low sigma and unrealistic high weight in the 
refinement.  

For absorption correction select “None or done before importing”; NEXT 
FINISH 
[On the screen: Data repository] 
Each line in data repository window corresponds to one data set. 
OK; YES to accept the data set;  (Step5) 
Set Data collection block #1 for both datasets (Step6) 

Step 5 Step 6 

 

 

 
Notes  
In this step the program offers sorting of the data sets to data blocks. Each data block has 
an independent scale factor. In our case, both twin domains come from the same 
measurement and they should be used as one data block. 

Select “on the same scale” for both data sets 
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Step 7  

 

 

Follow the wizard for creation of the refinement reflection file;  
Refine 

Notes  
Refinement converges with R 4.1%, GOF 1.36, 3800 excluded reflections, fraction of the 
second domain is 0.4641(6) (the number with s.u. is printed in the refinement listing).  

Create a backup copy, e.g., pyNinit_2domains (File→Structure → Save as) 
“Do you want to continue with the new structure?”; No 

6. Are both domains really on the same scale? 

Notes  
It may be unclear whether both data sets are on the same scale. Different scales would 
bias refinement of the volume fraction. 

 “File → Reflection file → Import/modify the reflection file” (Step1) 
In Data repository highlight pyNinit_twin2.hkl  and use “Reimport” (Step2) 

Step 1 Step 2 

 

 

Follow the import wizard as previously, but do NOT suppress possibly duplicate reflections 
Duplicate reflections will be used to find the common scale (Step3) 
Follow the steps the wizard for creation of the refinement reflection file; select “on 
different scales” for both data sets (Step4) 
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Step 3 Step 4 

  
 

In the next step, Jana will determine the unique scale based on the duplicate reflections 
(Step5) 
The scale is calculated from 4334 pairs of equivalent reflections, which should have the 
same intensity in both data sets after the scaling. 

Step 5  

 

 

Refine 
Notes  
Refinement converges with R about 4.1%, GOF 1.39, 3800 excluded reflections, fraction of 
the second twin domain is 0.4716(6). However, in this refinement we have unrealistic 
weight of the duplicate reflections because they were entered two times with the same 
sigma. 

7. Use of HKLF5 
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Notes  
The diffractometer software should better detect overlaps of diffraction spots than the 
simple criterion in Jana2006. HKLF5 file produced by diffractometer software contains flags 
saying which reflections are overlapped. Jana2006 can work with HKLF5 if twinning is 
activated (twinning matrix can be arbitrary). 

 “File → Reflection file → Import/modify the reflection file”; Delete both datasets; 
Import new 
[On the screen: Specify type of the file to be imported] 
Choose “reflection file corrected for LP and absorption”, NEXT (Step1) 
Select “SHELX hklf5”  
Browse for pyNinit_twin_hklf5.hkl; NEXT (Step2) 

Step 1 Step 2 

  

Leave all settings unchanged; NEXT 
Leave all settings unchanged; do not select “HKLF5 file by Jana tools”;  (Step5) 
NEXT;  
OK to confirm information about 68907 imported reflections 

Step 3  

 

 

FINISH 
OK; YES to close and save Data repository 
Follow the wizard for averaging of reflections and creation of the refinement reflection file 
Jana2006 merges only fully separated reflections from both domains 
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Refine 
 

Notes  
Refinement converges with R 5.4%, GOF 1.6, fraction of the second domain is 0.4728(5). 
The R value is slightly larger than previously but we are using all reflections. Results based 
on this refinement should be considered the most reliable.  
 
The following table summarizes refinement of the twin volume fraction 

 twvol2 
First twin domain, L1 = 0.1, L2 = 0.4 0.468(2) 
Both domains, L1 = 0.1, L2 = 0.4 0.4644(6) 
Both domains, L1 = 0.1, L2 = 0.4, scaling 0.4716(6) 
HKLF5 0.4728(5) 

 

 

References  
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Example 3.3.1: CsLiSO4 
Revised: 02 December 2018 
 

Data Topic  Level 

X-ray single crystal data structure with pseudo-
merohedric 3-fold twinning 

Advanced 

Tasks 
Solving a structure with pseudo-merohedric 3-fold twinning using Jana2006 software 

- Finding twinning matrix from group → subgroup transformation.  

- Transformation to four times larger reciprocal cell.  

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
CsLiSO4.hkl, CsLiSO4_red.sum 
Additional information: 
Frame scaling, absorption correction: done by the diffractometer software  
Chemical formula: CsLiSO4 
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Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step1) 
Left pane: locate directory with input files; Right pane: double-click CsLiSO4 (Step2) 

Step 1 Step 2 

  

2. Import wizard 

Select “Known diffractometer formats”; NEXT (Step1) 
Select “Oxford Diffraction → CCD”; NEXT (Step2) 
Select “Input from “sum” file”; OK (Step3) 

Step 1 Step 2&3 

  

Warning; (Step 4) 
Leave all settings unchanged; NEXT (Step5) 
Leave all settings unchanged (leave Twinning checkbox clear); NEXT; OK; (Step6)  
The program reads 15611 reflections from hkl file 
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Step 5 Step 6 

  
For absorption correction select “None or done before importing”; NEXT (Step7) 
FINISH (Step8)  

Step 7 Step 8 

  

3. Data Repository 

OK; YES to accept the data set (Step1) 
Nest; (Step2) 

Step 1 Step 2 
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II. Symmetry and data merging  

1. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Leave all other settings default; NEXT (Step 1) 
[On the screen: Select Laue symmetry] (Step 2) 

 

Press BACK 
Check „Introduce twin laws in case of subgroups“ ;NEXT (Step 3) 

  

Step 1 Step 2 

  

Notes  
We can see that hexagonal symmetry is slightly violated, because corresponding Rint is 
about 14%. On the other hand, an orthorhombic symmetry with setting “-a-b,a+b” has Rint 
comparable with the triclinic symmetry, given much higher redundancy of equivalent 
reflections.  
 
For exactly hexagonal cell parameters, merohedric twinning is highly probable. Another 
indication of twinning is the fact that the three equivalent orthorhombic settings have 
quite different Rint. It might be caused by merging reflections belonging to different 
unequally populated twin domains.  
 
In the next step, we will repeat test of Laue symmetry but this time considering twinning. 
That means for any subgroup of 6/mmm the program will generate corresponding pseudo-
merohedric twinning matrices and it will merge reflections using only the symmetry 
elements present in a twinned structure for general case of not equally populated twin 
domains. 
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This time, the three orthorhombic cases give the same internal R factor. 
Select the highlighted orthorhombic Laue symmetry; NEXT (Step 4) 

Notes  
The three orthorhombic cases correspond to the three twin domains. The selected one 
gave us in the previous test the lowest Rint. This means that this domain is more populated 
than the others are. 

Select C centering; NEXT (Step 5) 

Notes  
Hexagonal unit cell transformed to an orthorhombic one should be C centered. There is 
also some non-standard X centering, which we will investigate later on.  

[On the screen: Select space group] 
Select Ccce space group; NEXT (Step 6) 

 
Notes  
There are several possibilities for selecting space group and at this stage it is unclear which 
is the correct one.  

Step 3 Step 4 

  

Step 5 Step 6 
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Accept the space group in the standard setting; FINISH (Step 7) 
Follow wizard for creation of the refinement reflection file 
QUIT the wizard for structure solution without solving the structure (Step 8) 

2. Space group test results 

[On the screen: basic window of Jana] 
Check new cell parameters and symmetry with EditM50 (Step 1) 
Cell parameters 10.8919 18.8653 8.8048 90 90 90 
Space group Ccce 
ESC 
[On the screen: basic window of Jana] 
Start “Parameters → Twin fractions” (Step 2) 

Step 1 Step 2 

 

 

 
Notes  
The initial volume fractions are equal but we already know they must be different; 
otherwise, Rint for hexagonal Laue symmetry would be lower.   

Step 7 Step 8 
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Click inside the textbox “twvol2” and press “Show twinning matrix” (Step 3) 
0.5 -0.5 0 / 1.5 0.5 0 / 0 0 1 
Click inside the textbox “twvol3” and press “Show twinning matrix” (Step 4) 
-0.5 -0.5 0 / 1.5 -0.5 0 / 0 0 1 
These twinning matrices are related to the current orthorhombic unit cell 

Step 3 Step 4 

  
Return to the basic window  
Start “Edit/view → Editing of M90 file” (Step 5) 

Step 5 M90 

 

 

Notes  
The numbers inside the orange rectangle are twin flags. All flags except several reflections 
at the end of the file have the twin flags equal to “1” because most reflections can be 
indexed in the first domain. The reflections at the end of the file with the twin flag “2” and 
“3” are the ones, which cannot be transformed to the first domain because after such 
transformation they would violate systematic absences. 

3. The attempt to solve the twinned orthorhombic structure 

[On the screen: basic window of Jana] 
“Run → Structure solution”  
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for CsLiSO4: Cs Li S O (Step 1) 
Select “Superflip”, “Peaks from Jana2006”; leave other settings default; “Run Solution” 

Notes  
Repeat it several times. The selected space group has never been confirmed by Superflip, it 
mostly suggests Cmcm. 
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Step 1 Superflip 

 

 
Press Change the space group; (Step 2) 
For Space group type Cmcm; (Step 3) 
OK, YES to rewrite M50 file 
Follow steps of the wizard for creation of the refinement reflection file until the program 
returns to the Structure solution wizard 
[On the screen: window of Structure solution] 
Press “Run solution” 
Repeat it several times until Superflip confirms Cmcm. In some runs, Superflip might suggest 
different symmetry, which is indication of some structure solution troubles. 

Step 2 Step 3 

  
Press “Draw structure”; Select “Draw+Continue”; 

[On the screen: window of Diamond] 

Start “Build → Get molecules” or use  on the bottom toolbar 
The solution looks unreasonably and other attempts to solve the structure (direct 
methods, SHELXT, use of different symmetry etc.) would fail as well. 
Quit Diamond 

Quit the Structure solution wizard (YES to discard the last solution) 
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4. Application of X centering 

“Tools → Transformation → Cell transformation” (Step 1) 
Press “to those from data collection”; OK (Step 2) 

Step 1 Step 2 

 

 

Select “rewrite the old structure”; OK 
Follow steps of the wizard for creation of the refinement reflection file 

Notes  
We are now back at the original hexagonal unit cell. In EditM50, you can see there is no 
standard symbol for the transformed symmetry operation. However, we will check for the 
symmetry again. 

“File → Reflection file → Make space group test” (Step 3) 
This manually starts the Symmetry wizard. 
[On the screen: Tolerances for crystal system recognition] 
Check „Introduce twin laws in case of subgroups” 
NEXT; OK “ 

Step 3  
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Select the highlighted orthorhombic Laue symmetry (like before); NEXT 
[On the screen: Select cell centering] (Step 4) 
This time, we will accept X centering instead of C centering 
Press “Show/modify X centering” to see the individual centering vectors (Step 5) 

Notes  
We can see the centering vector (½ ½ 0) corresponding to the C centering but also 
additional vectors (½ 0 0) and (0 ½ 0) suggesting that a and b unit cell parameters could be 
halved. 

OK;  
Select X centering; NEXT 

Step 4 Step 5 

  
Select space group Pmcn; NEXT (Step 6) 
Accept space group in the standard setting; FINISH (Step 7) 

Step 6 Step 7 

  
NO we don’t want to repeat the test  
YES to create refinement reflection file 
Follow steps of the wizard for creation of the refinement reflection file 
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Notes  
83 observed reflections will be discarded due to the selected space group. This is probably 
caused by spurious peaks, which are present in the diffraction pattern 
The transformation suggested at the final step of the space group test produces an 
orthorhombic unit cell with four times smaller volume compared with the previously 
tested orthorhombic unit cell. Such unit cell alone could not index all diffraction spots, but 
combined with a three-fold twinning it can. The indexing of the hexagonal diffraction 
pattern with a three-fold twin of this small orthorhombic unit cell is indicated in the next 
figure.  

 
 

III. Structure solution  
“Run → Structure solution” 
[On the screen: window of Structure solution] 
In “Formula” textbox check list of chemical elements for CsLiSO4: Cs Li S O 
Select “Superflip”, “Peaks from Jana2006”; leave other settings default; “Run solution” 

Notes  
Superflip converges (after noise suppression) with R value 22%. The suggested space group 
by Superflip is Imma but for twins such prediction is unreliable. On the other hand, 
Superflip confirms the symmetry elements of the current space group symmetry Pnma. 

Press CLOSE to leave the listing 
Press “Draw structure” 
Press “Accept last solution” 
Start EditM50; (Step 1) 
Go to page Composition; change Formula units to 4; press Formula from M40; (Step2) 
OK; Yes; OK 



239 Jana2006 Cookbook, version September 2019 
 
 

Step 1 Step 2 

  

 

Notes  
In most cases, the formula should be Cs Lin S O4, where “n” can be zero, 1 or more. This 
means all heavy atoms except Li have been properly interpreted. If not, repeat the 
structure solution. 

Start “Edit atoms”; delete all Li atoms 
“Plot structure” 

Notes  
Diamond should show SO4 tetrahedron and Cs. For this plot, all bonds to Cs will need to be 
disabled through “Build – Connectivity” 

 

IV. Refinements and model improvement   

1. Refinement 

[On the screen: basic window of Jana] 
Right-click the icon of Refine. (Step1) 
[On the screen: refinement options] 
Define 100 of cycles, (Step2) 
Choose “YES+START”  
Refinement converges with R value about 9%, GOF about 9, 17 refined parameters 
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Step 1 Step 2 

  

2. Twin volume fraction 

Start “parameters → Twin fractions” (Step 1) 
Activate refinement of both twin fractions (Step 2) 

Step 1 Step 2 

 

 

Repeat refinement  
Refinement converges with R value about 5%, GOF about 5 
Twin volume fraction drops to 0.26 (twvol2) and 0.30 (twvol3). 
Start “Edit atoms” 
[On the screen: list of atoms] 
Press “Select all” and “Action → Edit/define” (Step3) 
Choose “harmonic” for ADP parameters.  (Step4) 
This defines anisotropic temperature parameters for all atoms. 
OK, OK, YES to save changes 
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Step 3 Step 4 

  
Run Refine. 
Refinement converges with R value about 4.4%, GOF about 4.4, 36 refined parameters. 

3. Find remaining atoms using Fourier  

[On the screen: basic window of Jana] 
Right-click Fourier (Step1) 
Select “Map type” = “F(obs)-F(calc) – difference Fourier” (Step2) 

Step 1 Step 2 

  
OK; YES+START; YES to include new atoms  
[On the screen: Inserting/replacing of atoms] 
OK(Step3) 
[On the screen: List of peaks] (Step4) 
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Step 3 Step 4 

 

 
 

Notes  
The strongest difference peak (Max1) has reasonable Li-O distances to oxygen atoms. We 
can add it as Lithium in the first highlighted symmetry position. 

Press “Include selected peak” 
For “Name of atom” type Li*; (Step5)  
TAB; OK; FINISH; YES to include the new atom.  

Step 5  

 

 

Run refinement 
Refinement converges with GOF ~ 3 and R(obs) ~ 2.7% for 39 parameters 

4. Extinction correction 

[On the screen: basic window of Jana2006] 
Open listing of Refine (by “Edit/View → View of Refine”) 
Press “Go to” and select “Statistics Fo, sin(th)/lambda after refinement” (Step1) 
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Step 1 

 
 

Notes  
The Statistics show that the strongest low-angle reflections are systematically weaker. This 
is an indication that extinction correction is needed. 

Close the refinement listing 
“Parameters → Extinction” (Step2) 
Select “Isotropic-Becker&Coppens” “Type 1” “Gaussian”; OK  (Step3) 
Refinement of extinction coefficient is enabled by default 

Step 2 Step 3 

 

 

[On the screen: basic window of Jana2006] 
Run Refine 
Refinement converges with GOF ~ 2.7 and R(obs) ~ 2.2% for 40 parameters 
Start “Edit atoms”; change ADP of Lithium to harmonic 
Refinement converges with GOF ~ 2.6 and R(obs) ~ 2.2% for 43 parameters 
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Right-click Refine; go to the page Basic 
Check “Instability factor from reflection statistics” (Step4) 

Step 4  

 

 

OK; YES+START 

Notes  

 
The final structure 
 
Refinement converges with R value around 2.3% and GOF 1.4, for 43 parameters 
In this case, the instability factor from reflection statistics seems to be reasonable because 
the structure of a three-fold twin is fully solved and data are not expected to contain more 
information. 

References  
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Example: kamotoite-(Y) 
Revised: 9 March 2019 
 
Complex structure with pseudo-merohedric twinning and unequal twin volume 
fractions 
 

 
Single crystal data measured with Rigaku SuperNova four-circle diffractometer (kappa geometry) 
with Atlas S2 CCD detector.   
Input files: kamotoite_abs.hkl, kamotoite_abs.cif_od  
Frame scaling, absorption correction: done with software of diffractometer 
 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left panel: locate directory with input files 
Right panel: double-click kamotoite  

 
2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction → CCD”; NEXT 
Select “Input from “cif_od” file”; OK 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT FINISH  

 
3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set  

 
4. Symmetry Wizard, twinning  
[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT; OK 
Leave with „Continue with basic cell“, press „Next“ 
[On the screen: Select Laue symmetry] 
Select monoclinic  
NEXT Select P-centered unit cell; NEXT 
[On the screen: Select space group] 
Select the space group P21/n; NEXT 
 (Differences between P2/n and P21/n support the existence of the 21 symmetry) NEXT 
Select „Accept the space group transformed into original cell "; FINISH  
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5. Creating refinement reflection file 
NEXT to confirm threshold 3σ 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Accept the new DataBlock and calculate coverage; FINISH  

 
6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
Select „use SHELXT“ 
In “Formula” text box type list of chemical elements for kamotoite: Y U O 
Notice: Kamotoite-(Y) contains also C as a fundamental element in the structure, nevertheless, 
such ligh atom would make the solution overnoisy – instead of O atoms you would get C 
atoms. It is simpler to introduce C atoms into the refinement later and assign them to the 
corresponding correct sites. 
Leave all other fields empty 
Press „Run solution“ 

 
[On the screen: output of SHELXT] 
SHELXT converged and provided us a list of possible solutions. 
Among them the first and suggested is our choice => P21/n (despite of higher R value) 
 
Press “Draw structure” to see result of SHELXT 
 

 
You can see that some O atoms have been assigned to false Fourier peaks, and some of the O 
atoms actually correspond to C atom instead (marked by circles). 

 
Quit Diamond without saving changes 
In case of doubts repeat structure solution and plotting 
Finally press “Acccept last solution” to close the structure solution wizard  
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7. Refinement [On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: refinement options] 
Define 100 of cycles, damping factor 0.5, Instability factor 0.01; Refinement on F(obs)**2, 
OK; Choose “YES+START” 
Refinement converges with R value about 17%, GOF about 5, 161 refined parameters  
During refinement, number of refined parameters decreases becase some atoms get too high 
Uiso are are automatically rejected. This feature can be controlled on the Basic page of Refine 
commands.  

 
8. Editing of atoms 
[On the screen: basic Jana window] 
Start “Edit atoms” 
Press „Select rejected“, Press „Action“ or right-click at one of the selected [highlighted in red 
color] atom; Choose „Delete selected atoms“, choose „Yes to all“. 
Press „Select all“, right-click, choose „Rename selected atoms to atom_type“+number. 
Select U1 to U4 atoms [with shift or one each another], double-click and switch to the 
harmonic approach to the ADP parameters [ADP will be refined anisotropically] – by double 
clicking on the corresponding field. OK; OK; YES to save changes 
 
9. Refinement [On the screen: basic window of Jana] 
Start refinement double-clicking „Refine“ 
You can see that R values drop down to ~12% (GOF ~4) 
 
10. Assignment of correct chemical types 
Start “EditM50”; switch to the page Composition 
[On the screen: Composition]  
Add in the row „Formula – list of atomic types“: C, Dy [at the end after O; C is essential, while 
Dy is minor]; OK, OK 
Start Diamond double-clicking “Plot structure” 
 

The best way to deal with is to add only oxygen atoms (by clicking  or starting Build → 
„Add atoms“). Then click  or start Build → Connectivity, and select O-O pairs only. Click 
„Fill coordination spheres directly“  ; and click „Model“   to plot ellipsoids. Inspect the 
molecular fragment you get by rotation to view it approx. along b. Now you can read out 
which O atoms are in fact C atoms: they have three bonds to neigboring oxygen atoms, and 
large Uiso. Notice their labelling to be changed later, or rename them in Jana immediatelly. 
Some other oxygen atoms with large Uiso might still be false Fourier peaks.  
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Start “Edit atoms” 
Select the atoms which should be carbons (O21, O23, O27, O28 in our example) 
Start “Action → Edit/define” and choose chemical type “C”; OK 
Press “Select all”, right-click „Rename selected atoms to atom_type“+number. 
We can proceed with refinement of ADP of Y atoms using harmonic description. 
select Y1 and Y2, turn on the harmonic (anisotropic) ADPs; OK, OK, Yes. 
 
11. Refinement [On the screen: basic window of Jana] 
Start refinement double-clicking „Refine“ 
You can see that refinement converged to slightly lower R values then previous, ~11%, 
however, one the last screen that appered after the last-cycle, the warnings appeared. You 
can find them at the end of the listing 
Press „Open the listing“ 
Press „Go to“ → „List of serious warnings“ 
 You can see that serious warnings concern harmonic ADPs of the Y atoms, which turned out 
to reach the physically unreasonable values. We have to inspect them in a greater detail. 
 
12. Inspection of the ADPs and site-scattering refinement 
Start “Edit atoms” 
Select Y1 and Y2 atoms; double-click, choose „Edit“, allow refinement of the occupation 
factors (labelled „ai“); OK, OK, Yes. 
 
Start the refinement 
 
You can see that ai especially for Y2 is changing significantly. Refinement converged to ~10.5% 
with GOF ~3.75. 
 
We have to check how the refined values of the Y atoms look like. You can do that in this case 
right in the panel for editing atoms. You can see that ai for both Y atoms has risen up, which 
means that there is a heavier atom substituting for Y at both atom sites. From the results of 
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the electron-microprobe analysis we are quite sure that it goes about Dy. Therefore we can 
introduce it to the refinement and treat both Y sites as a mix sites. First you have to rest values 
of site-occupancies for both sites. 
 
 Start “Edit atoms” 
in Edit window, Y1, press „Show/reset site occupancy“, press Yes. Do the same for Y2. Press 
OK. 
Right-click on Y1, choose „Split atomic positions“, choose „Atomic type“ as Dy, click onto 
„defined manually" („shift of the split atom“), leave „0,0,0“, untick „reset ADP to isotropic“, 
Apply 

 
Repeat the same procedure also with Y2. 
Check, if the refinement of occupation factors for all involved atoms is allowed 
OK, Yes 
 
Start the refinement 
Refinement converged to 10.6% and there are no serious warnings after the last cycle. 
 
13. Completing oxygen atoms 
 
Plot the structure with „ellipsoids“ for all atoms 
Note oxygen atoms with large Uiso and unreasonable geometry and delete them using Edit 
atoms 
Refine the structure 
Right-click on „Fourier“ 
Select from „Map type“ „Fobs-Fcalc difference Fourier“, leave all settings default, OK, 
Yes+Start 
Start procedure  for including new atoms 
Tick „Skip peaks being to close to existing atoms“, fill in the minimal distance 1 Å. OK 
[The window with list of peaks appeared] 
Click on the maximum Max1 
The bottom left part shows the charge of this maximum (about five). The right pane shows 
distances of Max1 to atoms of the structure. The distance to Y1/Y1‘ is about 2.5 Å so this 
maximum correspond to one of missing oxygen atoms 
Press „Include selected peak“, fill in the „name of the atom“ „O*“. 
Repeat the procedure with rest of the peaks you want to include. 
There should be four missing oxygen atoms. In case of smaller number, it is possible that 
some of these atoms were either included in the initial structure model or will be found in the 
next step.  
Press „Finish“, Yes 
Start refinement 
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Run a difference Fourier again to localize all resting atoms; include the maximum with ~2.8 Å 
to one of existing oxygen atoms (without any shorter distances). 
 
Start the refinement 
Refinement converged to R ~9.2% (GOF ~3.06), 217 refined parameters 
It is important to see 217 as number of refines parameters. In case of lower number, some 
oxygen atoms are missing (each of them adds 4 parameters) 
 
You can check the structure in Diamond, and see that it looks quite complete.  
 
Run a difference Fourier 
Start“Edit → View of Fourier” to open Fourier listing 
In the listing, use the Go to button to see the list of positive peaks 
Although there are no additional reasonable peaks in the difference Fourier, nevertheless, 
there is a lot of resting electron density with the maximal difference Fourier density peak 
corresponding to 12.18 eÅ–3, which is a rather high value. With the complete structure model, 
we are still missing something. The high final R values (as a consequence) is due to twinning 
present in the crystal analyzed. 
 
14. Identification and introduction of twinning 
 
The fact the sample is a twin is evident from the diffraction experiment. Here we are going to 
show how to find the twinning matrix directly from the supercell data we have been using in 
previous steps.  
 
Experimental indication of twinning: 

  
 
 
 
 
 
 
Start File → Structure → Save As 
Save the structure under the new name, kamotoite_abs_twin, and continue with the new 
structure 
Go to „Tools“ →“Special tools“ → „Search for reticular twinning“ 

peaks along b* reconstruction of h4l plane 
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[On the screen: Look for reticular twinning] 
Keep the default settings, press „Test for higher symmetrical supercell(s)“ 
[On the screen: Select supercell] 
Choose orthorhombic, n*Volume = 4*3063.51 
Click OK 
You can see that the twin actually is the miror in (101) and corresponding twining matrix. 

 
Proceed with OK, Yes, and re-create refinement reflection file, which will change due to 
presence of twinning. OK. 
Go to „Parameters“ → „Twin fractions“ and allow the refinement of the „twvol2“. OK, Yes 
 
Start refinement 
 
You can see that the twin fractions are changing dramatically and R values drop down 
significantly to ~5.03% and GOF ~1.6 for 218 parameters. The refined twin ratios are about 
85/15. 
 
Check difference Fourier 
Include the resting maximum Max1 (~ 2.6 Å to oxygen), as O atom. Reduce its occypancy to 
0.5. 

 
 
Run the refinement 
 
The refinement converged to the final values of 4.96% and GOF = 1.5 for 222 refined 
parameters; highest difference Fourier peak is now about 4 eÅ–3.  
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Refinement of anisotropic ADP for oxygen cannot be done from this data set. Making O* 
anisotropic introduces 185 new parameters but leads to negligible decrease of R-factor and 
non-positive definite ADPs.  
 
Crystal structure of kamotoite-(Y) possesses many H atoms, present both as (OH) and 
molecules of H2O, however, they cannot be localized from this X-ray dataset. Therefore the 
model we obtained is a final one.  
 
You can obtain the information about atomic composition in 
 „Edit atoms“ → „Composition“ → click on „Formula from M40“ → Y1.375 U4 O36.5 C4 
Dy0.625. 
 
Both twins can be visualized in Jana, using Reciprocal space viewer in Tools. The way how to 
visualize corresponding observed reflections for the second (and vice versa) twin-domain is not 
straightforward and will be skipped here. 
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Reciprocal-space view of the two contributing twin domains in kamotoite-(Y) crystal; yellow = 
reflections of the larger domain, green = smaller domain. The grid corresponds to the 
simulated orthorhombic super-lattice. 
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Example 3.4: Ca2Fe2O5 
 
HT structural phase transition, coexistence of two phases in single crystal with 
strong overlaps. 
 
H. Kruger, V. Kahlenberg, V. Petříček, F. Phillipp & W. Wertl, J. Solid State Chem., 182, (2009), 
1515-1523. 
 
LT phase – orthorhombic, Pnma, cell parameters ~ 5.4707, 14.9897, 5.6302 Å 
In one layer of Fe tetrahedrons there is only one type orientation (e.g. Left) 
 

 
 
HT phase (>710⁰C) – orthorhombic, modulated, Imma(00γ)s00, cell parameters ~ 5.4707, 
14.9897, 5.6302 Å, q=(0,0,0.58). In one layer of Fe tetrahedrons there are two different 
orientations (Left and Right) alternating with the period incommensurate to the basic cell. 
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Diffraction pattern: Strong 1st order, no 2nd order and some weak 3rd order satellites → crenel 
like modulation with 21≈∆ . 
 
Main features of the solution for the HT phase: The atoms Fe2 and O3 are occupying the 
positions close to the Wyckoff position 4(e), point group mm2. The mirror m, with normal along 
a axis, having half shift along the internal x4 axis, transforms the “left” oriented ribbon of Fe 
tetrahedrons to the “right” ones and the occupational modulations of both atoms have a crenel 
like shape. 
 
During the first order phase transition both phases (LT and HT) are coexisting in a wide region 
of temperatures and with x-ray diffraction they both contribute to the same diffraction pattern. 
In this example we shall start from the known structures of both phases and we shall 
demonstrate that the generalized twinning option in Jana2006 can also be applied to single 
crystals composed from two or more phases. 
 
As a starting point you have at disposal the HT structure refined against the data set having the 
highest possible fraction of the HT phase from all measured data sets. In the first part of the 
example it is demonstrated main features of the solution. In the second part the LT phase will 
be read in from the supplied CIF file and then the final refinement will be performed. 
 
Input files: HT_phase.m40, HT_phase.m50, HT_phase.m90, HT_phase.m95 and 
LT_phase.cif. 

1. Open the modulated phase 
Start Jana2006 
“File → Structure → Open” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click HT_Phase 

2. Check systematically extinct reflections 
“File → Reflection file → Create refinement reflection file” 

 

There are 381 observed reflections, some of them relatively strong, which do not follow the 
extinction rules for Imma(00γ)s00. This means that the reflections of the second 
“P-centered” phase are really present. 
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3. Run refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: refinement options] 
Define 100 of cycles, Damping factor 1; OK 
Choose “YES+START” 
The refinement converges with R(obs) about 5.98%, 4.48% and 9.12%. 

4. Check the refinement model 
[On the screen: basic Jana window] 
Start “Edit atoms” 
[On the screen: list of atoms] 
Double-click on the first atom Fe1 
[On the screen: list of atoms] 
Go though all atoms (using arrows of the top-left text box) and check the modulation 
model. 
All atoms except Fe2 and O3 have just one harmonic positional wave. Atoms Fe2 and O3 
have one crenel function. 
Write down coordinates of Fe2 and O3 and then go to “Edit” thumbnail, press the button 
“Occupancy” and write down also the values of delta and x40 
Fe2 (-0.052,0.25,0.568) delta=0.5 (fixed) x40~0.6404 
O3 (-0.402,0.25,0.625) delta=0.5 (fixed) x40~0.6755 
Escape the form; 

5. Run dist 
[On the screen: basic Jana window] 
Right-click the icon of Dist. 
[On the screen: distance commands] 
Use the default parameters except for the listing form which should be changed to “With 
symmetry code”. 
OK; Start the program; 
Open the listing and look for Fe2 coordination; 
The atom Fe2 is coordinated by the atom O2, O2#s2, O3 and O3#s4c2t0,0,1. 

6. Draw modulation curves in Contour for Fe2 and O3 
[On the screen: basic Jana window] 
Double-click the icon Contour; Press the button “New plot” if active; 
Select “Fourier map” and “Draw maps as calculated”; OK 
In thumbnail “Basic” select “F(obs) – Fourier” and in thumbnail “Scope” select “by a central 
point”; 
Center “0 0.25 0.568”; Section 1st → x1, 2nd → x4, 3rd → x2, 4th → x3; 
 x4 minimum → 0, maximum → 2, step 0.02 
Scope → 3 0 0; Step → 0.02; OK 
[On the screen: the following map] 
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Press “Atom edit” and add two atoms Fe2 and Fe2#s8. The second one is the position 
generated by the eighth symmetry operation i.e. by -x1 x2 x3 x4+1/2; 

[On the screen: the following map] 
 

 

 

Repeat it for the center at -0.5 0.25 0.625 (a position close to O3); 
Press the button “Atoms edit” to show the modulation curves for O3 and the symmetry 
related atom O3#s8t-1,0,0. The translation part -1,0,0 returns the symmetry related atom 
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back to vicinity of O3. 
[On the screen: the following map] 

 
The crenel function for atoms Fe2 and O3 assures the alternation between the “Left” and 
“Right” configurations of Fe tetrahedrons. During the refinement the “delta” values were 
fixed to 0.5 for both atoms. But there were no restrictions applied to x40. Now we have to 
check: 

(a) if there is no overlap between two symmetry related positions of Fe2 and Fe2#s8 and O3 
and O3#s8t-1,0,0. 
 
The symmetry operation #8 has the following form: -x1, x2, x3, x4+1/2 
for the atom Fe2 we have: rqrq ⋅−∆+=⋅−∆−= 22 40max40min xtxt  and for the 
symmetry related Fe2#s8: rqrq ′⋅−∆++=′⋅−∆−+= 221221 40max40min xtxt  
From the fact that the modulation vector is ( )γ,0,0  and that the third component of the 
symmetry related atoms remains the same for both positions, it follows that the t intervals 
are fully separated with no overlaps. 
The same conclusion is valid also for the atom O3. 

(b) if the t intervals in which exist atom Fe2, O3 and O3#s4c2t0,0,1 are identical. 

For Fe2 and O3 this means: 

( ) ( ) ( ) ( ) ( ) ( ) ( ) ( )3O23O3O3O2Fe22Fe2Fe2Fe 40min40min rqrq ⋅−∆−==⋅−∆−= xtxt = 
 
taking into account the fact that ( ) ( ) 213O2Fe =∆=∆  we have: 
 

( ) ( ) ( ) ( ) ( ) ( ) ( ) ( )[ ]3O2Fe2Fe3O3O3O2Fe2Fe 40404040 rrqrqrq −⋅−=⇒⋅−=⋅− xxxx  

and finally ( ) ( ) ( ) ( )[ ]3O2Fe2Fe3O 4040 zzxx −⋅−= γ  (1) 
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Numerically: ( ) [ ] 6752.0625.0568.06101.00.64046755.03O40 =−⋅−≈=x  and 
( ) 0442.00.6250.6101-0.67553Omin =⋅=t  

 
This means that the refined value was really close to the ideal value 

For O3#s4c2t0,0,1 the symmetry operation 1,0,024 tcs  is x1+1/2 -x2+1/2 -x3+3/2 -x4+1/2 
modifies tmin to: 

( ) ( ) ( )1,0,0243#O21,0,0243#O1,0,0243#O40min tcstcstcsxt rq ⋅−∆−=  

Numerically: 
( ) ( )

( ) ( ) 1755.03O211,0,0243#O
825.03O231,0,0243#O

4040 −=−=
=−=

xtcsx
ztcsz

 

This means that: 959.025.0875.06101.01755.0min −=−⋅−−=t  and therefore we have to 
modify the equation by adding one: 

( ) ( ) ( ) ( )
( ) ( ) ( ) ⇒+⋅−∆−

=⋅−∆−=
11,0,0243#O21,0,0243#O1,0,0243#O

2Fe22Fe2Fe2Fe

40

40min

tcstcstcsx
xt

rq
rq

 

 

( ) ( ) ( ) ( )[ ]1,0,0243#O2Fe2Fe1,0,0243#O 4040 tcsxtcsx rrq −⋅−= -1 

and by applying the symmetry operation 1,0,024 tcs  ~ x1+1/2 -x2+1/2 -x3+3/2 -x4+1/2: 

( ) ( ) ( ) ( )[ ] ⇒−+−⋅−=− 13O232Fe2Fe3O21 4040 zzxx γ  
 

( ) ( ) ( ) ( )[ ] 233O232Fe2Fe3O 4040 ++−⋅+−= zzxx γ  (2) 

 
 

 
Combining (2) with the previous one we have for ( )2Fe40x : 

( ) ( ) ( ) ( ) ( )γγγ −⋅=⇒⋅+−⋅= 1432Fe2Fe1432Fe 4040 tzx  

( ) ( ) ( ) ( ) ( )γγγ −⋅=⇒⋅+−⋅= 1433O3O1433O 4040 tzx  
 
Numerically: ( ) 6737.0625.06101.03899.075.06755.03O40 =⋅+⋅≈=x  
This means that both t40 parameters can be fixed to the same constant value as Fe2. 
 

7. Run restricted refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: refinement options] 
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Select thumbnail “Various” and press the button “Equations”: 
Define equations: 
t40[Fe2]=0.75-0.75*cq3 
t40[O3]=0.75-0.75*cq3 
OK; Start Refinement; 
The refinement converges with R(obs) about 5.99%, 4.49% and 9.14% which means that it 
had almost no effect. 
Open the listing to check the applied equation: 
 
Equations defined by user: 
 
x40[Fe2]=0.2924+0.6101*z[Fe2] 
x40[O3]=0.2924+0.6101*z[O3] 

8. Continue with a new structure name 
[On the screen: basic window of Jana] 
Start Jana2006 
“File → Structure → Save as” opens a file manager 
Right pane: Write a new structure name e.g. “Both_Phases” 
[On the screen: “Continue with the new structure?”] 
Yes; 

9. Adding of the LT phase 
[On the screen: basic window of Jana] 
“Tools → Phases → New phase”; 
Select “Import from CIF format”; Press “Browse” and select the file LT_Phase.cif; 
OK 

10. Define the twinning matrices 
[On the screen: the form for defining of twinning matrices] 
The “twinning” matrices define relationship between the phases and the reference cell 
parameters. Unlike real twinning they may change the unit cell. In our case both phases are 
defined in the same cell. 
Both matrices are unit ones. The first is to be applied to the first phase and the second to 
the second phase. 
OK; follow the wizard for creating the refinement reflection file 
Systematic extinctions are now much better fulfilled: 
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11. Run refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: refinement options] 
Change the damping factor to 0.5. 
OK; Save and run the refinement; 
The refinement converges with R(obs) about 4.99%, 4.09% and 7.37%. 

12. Refine anisotropic ADP of atoms from the second phase 
[On the screen: basic window of Jana] 
Switch the phase to the Phase#2 (thumbnails in the lower-left corner) 
Using “Edit atoms”: select all atoms and change ADP to harmonic; 
OK; 

13. Run refinement 
[On the screen: basic window of Jana] 
Double-click the icon of Refine. 
The refinement converges with R(obs) about 4.60%, 3.78% and 6.75%. 

14. Check the phase fraction factor 
[On the screen: basic window of Jana] 
“Parameters → Twin fractions” 
The fraction of the second domain was refined to 0.276 
 

  



263 Jana2006 Cookbook, version September 2019 
 
 

Example 3.5: Cd-HPO 

Updated 9 March 2019 
 

Data Topic  Level 

X-ray single crystal data Local disorder Intermediate  

Tasks 
Group-subgroup transformation with application of local symmetry.  

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-cycle diffractometer 
Input files:  
Cd-HPO.hkl 
Cd-HPO.cif_od 
Additional information: 
Chemical formula: Cd(H2PO3)(HPO3)(CH3OH) 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager  
Left pane: locate directory with input files;  
Right pane: double-click Cd-HPO  

2. Import wizard 

Select “Known diffractometer formats”; NEXT  
Select “Oxford Diffraction → CCD”; NEXT  
Select “Input from “cif_od” file”; OK  
Leave all settings unchanged; NEXT  
Leave all settings unchanged; NEXT; OK;  
The program reads 5291 reflections from hkl file 
For absorption correction select “None or done before importing”; NEXT  
FINISH;  

3. Data Repository 

OK; YES to accept the data set  
NEXT;  

4. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT; OK  
[On the screen: Select Laue symmetry] 
Select Hexagonal 6/mmm Laue symmetry; NEXT (Step 1) 

Step 1  
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Select centering P unit cell; NEXT  
[On the screen: Select space group] 
Select P63/mmc; NEXT (Step 2) 

Notes  
Superflip will give us hexagonal space group during processing that is why we chose 
hexagonal setting even if the trigonal setting seems better. Another reason for starting 
with hexagonal setting is that we get possibility to transform the structure to a trigonal 
twin.  

Leave all settings unchanged; FINISH  

Step 2  

 

 

5. Creating refinement reflection file  

NEXT to confirm threshold 3sigma; OK; OK  

Notes  

 
[On the screen: settings for merging of reflections] 
NEXT 
The program reports Rint 13.30% for 203 observed reflections merged from 217 reflections.  

Notes  
We have a high value of Rint, which may be due to the presence of twinning, which may 
explain why Jana2006 found the trigonal setting better. We will try this approach later in 
this exercise.  

OK;  
Select "Accept the new data block and calculate coverage"; FINISH; OK 
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II. Structure solution and Refinement model 1 

1. Structure solutions wizard 

[On the screen: Structure solution] 
In “Formula” textbox type list of chemical elements: Cd P O C H 
Select “Use Superflip”; 
Check “Repeat Superflip: Number of runs” leave 10  
Leave other settings default; press “Run solution.” 
[On the screen: first, you will see the window of Superflip and, after the calculation reaches 
convergence, it is replaced the listing of Superflip resuls] 
Press CLOSE to leave the listing (Step 1) 
Press Accept last solution 

Step 1  

 

 

2. Refinement 

Diamond 
Press Plot structure   
Draw + continue  
In my case I obtained the following model  

 
We need to transform C1 to oxygen 

Start Edit atoms;  
Select C1 → “Action” → “Edit/Define atoms” → Type O; OK 
Press “Select all” → Action → Rename selected atoms to “atom_type” + number 
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OK; YES 
Run Refine; 

Notes  
R factors [217=203+14/9] 
GoF(obs) ≈ 9.64; R(obs) ≈ 8.85; wR(obs) ≈ 12.89; R(all) ≈ 9.26; wR(all) ≈ 12.94  

Start Edit atoms; 
Press “Select all” → “Action” → “Edit/Define atoms.”  
Change the ADP parameter(s) from isotropic to harmonic (anisotropic); (Step 2) 
OK; OK; YES 
Run Refine; 

Step 2 Step 3 

  
  

  

Notes  
R factors [217=203+14/16] 
GoF(obs) ≈ 6.13; R(obs) ≈ 5.14 wR(obs) ≈ 8.05; R(all) ≈ 5.51; wR(all) ≈ 8.10   
Warning due to Negative ADP of some atoms  
 
We have a negative ADP on some atoms. Due to the initial high value of Rint ≈ 13%, we 
should try to determine if the presence of twin might be the cause of this negative value.  

File → structure → Save as (Create backup copy) Cd-HPO_hexa 
NO (you don’t want to continue with the new structure) 

III. Structure solution and Refinement model 2 

1. Change space group 

Notes  
There are two options for lowering the symmetry, both of them being able to generate 
corresponding twinning matrices: 
- Transformation of the current structure model to subgroup 
- New symmetry check and structure solution 
Here, we will use the second approach as solution of the hexagonal structure model was 
effortless and might be biased by using improper symmetry.   
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File → reflection file → make space group test; Yes 
[On the screen: “Tolerances for crystal system recognition”] 
Check “Introduce twin laws in case of subgroups”; NEXT; OK  
[On the screen: Select Laue symmetry] 
Select Trigonal -31m Laue symmetry; NEXT (Step 1) 

 
Step 1  

 

 

Select centering P unit cell; NEXT  
[On the screen: Select space group] 
Select P-31c; NEXT  
Tick “Accept twinning matrices induced by the space group test”, leave all other settings 
unchanged; FINISH; YES  

2. Creating refinement reflection file  

NEXT to confirm threshold 3sigma; OK; OK  

Notes  

 
We obtained the same values and errors as for the hexagonal unit cell 

[On the screen: settings for merging of reflections] 
NEXT 
The program reports Rint 2.97% for 297 observed reflections merged from 327 reflections. 
OK;  
Select "Accept the new data block and calculate coverage"; FINISH; OK 

Notes  
The twin matric was automatically added corresponding to the twinning by merohedry, 
with the twin law:  
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�
1 1 0
−1 0 0
0 0 1

� 

3. Structure solutions wizard 

Notes  
In case the Structure solution tab does not open automatically, you can open it manually 
from Run – Structure solution.  

 

[On the screen: Structure solution] 
In “Formula” textbox type list of chemical elements: Cd P O C H 
Select “Use Superflip”; 
Check “Repeat Superflip: Number of runs” leave 10  
Leave other settings default; press “Run solution.” 
[On the screen: the window of Superflip replaced after reaching the convergence with the 
listing of Superflip] 
Press CLOSE to leave the listing  
Press Accept last solution 

4. Refinement 

Notes  
We obtain similar solution as previously  

Start Edit atoms;  
Select C1 → “Action” → “Edit/Define atoms” → Type O; OK 
Press “Select all” → Action → Rename selected atoms to “atom_type” + number 
Press “Select all” → “Action” → “Edit/Define atoms.”  
Change the ADP parameter(s) from isotropic to harmonic (anisotropic); 
OK; OK; YES 
Run Refine; 

Notes  
R factors [327=297+30/20] 
GoF(obs) ≈ 13.10; R(obs) ≈ 11.44; wR(obs) ≈ 18.53; R(all) ≈ 12.47; wR(all) ≈ 18.58  
There are still warnings about negative ADP of some atoms 

Select Parameters  →  Twin fractions and check twvol2  
Run Refine 

Notes  
R factors [327=297+30/20] 
GoF(obs) ≈ 2.82; R(obs) ≈ 2.84; wR(obs) ≈ 3.99; R(all) ≈ 3.43; wR(all) ≈ 4.01  
 
Using Parameters → Twin fraction, you can see the refined twvol2 is nearly zero and the 
structure corresponds to trigonal structure without twinning. No atoms has negative ADP! 

Start EditM50 
Uncheck Twinning ; OK 
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Yes “Re-create refinement reflection file” and follow the ensuing procedure. 
Run Refine 

Notes  
R factors [327=297+30/20] 
GoF(obs) ≈ 2.83; R(obs) ≈ 2.83; wR(obs) ≈ 4.01; R(all) ≈ 3.40; wR(all) ≈ 4.11 
No atom has negative ADP but C1 exhibits disorder manifested by a huge ADP ellipsoid. 
This corresponds to a disordered methanol and will be further analyzed.  

File → structure → Save as (Create backup copy) Cd-HPO_trigo1 
NO (you don’t want to continue with the new structure) 

5. Solvent modelling 

Notes  
C1 exhibits a large ADP but even from difference Fourier map it is not clear if this is a split 
position. However, modelling this electron density with anharmonic ADP will clearly show 
the particular atomic positions.  

 

Start Edit atoms;  
Select C1 → “Action” → “Edit/Define atoms”  
Change the ADP parameter(s) from harmonic to anharmonic. 
We will make different tests with different numbers of anharmonic terms  
OK; OK; YES 
Run Refine; 

Notes  
With the 3rd order anharmonic tensors  
R factors [327=297+30/24] 
GoF(obs) ≈ 2.76; R(obs) ≈ 2.79; wR(obs) ≈ 3.88; R(all) ≈ 3.40; wR(all) ≈ 3.99  
 
With the 4th order anharmonics tensors 
R factors [327=297+30/33] 
GoF(obs) ≈ 2.35; R(obs) ≈ 2.15; wR(obs) ≈ 3.25; R(all) ≈ 2.67; wR(all) ≈ 3.36  
 
With 4 anharmonics we arrived at the maximum number of parameters that we can refine. 
To refine 1 parameter we generally need 10 independent reflections. Here we need to 
refine 33 parameters and we have 327 independent reflections. If we increase once more 
the number of anharmonics, we would need to refine 42 parameters in total.  

Start Contour; 
Press New plot and draw j.p.d.f map; OK(Step 2) 
Refresh  and select C1 and check Calculate deformation j.p.d.f (joint probability density 
function); Next; (Step 3) 
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Step 2 Step 3 

 

 
Next; (Step 4) 
 

Step 4 Step 5 

   
1st atom “C1”, 2nd as difference to 1st “1 0 0”, 3rd as difference to 1st “0 1 0”; Scope of 
section “4 4 4”, 1st point put to “2 2 2”; NEXT (Step 5) 

Next; (Step 6) 
Press Run 3d maps to open Vesta (Step 7) 

Step 6 Step 7: Vesta 

  

Quit Vesta  

Notes  
The joint probability density function shows a clear split of carbon into two maxima. Due to 
the trigonal symmetry, we can see three pairs od atoms.  

Start Edit atoms  
Select C1 → Action → Edit define atoms  
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In Page Define, change ADP parameter(s) to harmonic 
OK; OK; Yes 
Run Refine  
Start Edit atoms 
Select C1 → Action → Select C1 → Action → Split atomic position 
Press Apply; OK 
Run Refine 

Notes  
R factors [327=297+30/22] 
GoF(obs) ≈ 2.58; R(obs) ≈ 2.33; wR(obs) ≈ 3.64; R(all) ≈ 2.87; wR(all) ≈ 3.76 

Skip warnings, OK 

Notes  
The special position of C1 and C1‘ atom are at the origin of this warning   

Start Edit atoms  
Select C1/C1’ → Action → Edit/Define atoms  
In page Edit check ai refinement  
OK; OK; YES 
Run Refine (Here use only 10 cycles) 

Notes  
R factors [327=297+30/23] 
GoF(obs) ≈ 2.69; R(obs) ≈ 2.34; wR(obs) ≈ 3.79; R(all) ≈ 2.88; wR(all) ≈ 3.91 
 
Due to the splitting, C1 leaves the special position and therefore 12 instead of six atoms is 
generated. After occupation refinement, occupancy of one of the atoms (C1 or C1’) 
decreases to zero, giving rise to the expected six atoms like indicated in the previous VESTA 
plot j.p.d.f. 

Start Edit atoms  
Select C1 → Action → Edit/Define atoms  
In page Edit uncheck ai refinement and change the value to 0.5 
Select C1’ → Action → Delete selected atoms→ Yes to all 
OK; Yes 
Run Refine 

Notes  
R factors [327=297+30/19] 
GoF(obs) ≈ 2.59; R(obs) ≈ 2.35; wR(obs) ≈ 3.67; R(all) ≈ 2.89; wR(all) ≈ 3.79 

Start Edit atoms;  
Select C1 → “Action” → “Edit/Define atoms”  
Change the ADP parameter(s) from isotropic to harmonic. 
OK; OK; Yes 
Run Refine  

Notes  
R factors [327=297+30/24] 
GoF(obs) ≈ 2.57; R(obs) ≈ 2.32; wR(obs) ≈ 3.60; R(all) ≈ 2.88; wR(all) ≈ 3.72 
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At the end of this step, C1 is split with occupation 0.5 like this following picture (Diamond) 
which is similar to the previous Vesta representation.   

 
The distance between C1 (x,y,z) and C1(1-y, 1-x, ½-z) correspond to the distance between 
C-C or C-O.   

6. Add Hydrogen   

Start Edit atoms;  
Select C1 → Action → Adding of hydrogen atoms  
Uncheck “try automatic run for carbon atoms”; OK 
Select Tetrahedral configuration with 1 Neighbour(s) 
Click into the box “1st”, Press select neighbours and chose C1 with distance 1.469 Å; OK 
(Step 8) 
Press Locate position in map;  
Press Optimal and Apply(Step 9) we can observe the presence of hydrogen  

Step 8 Step 9 

  
Press Apply ; OK; Yes 
Run Refine 

Notes  
R factors [327=297+30/24] 
GoF(obs) ≈ 3.28; R(obs) ≈ 2.66; wR(obs) ≈ 4.61; R(all) ≈ 3.23; wR(all) ≈ 4.71 
 
You will obtain this following configuration:  
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Adding hydrogen increased the value of R-factor. This model corresponds to an ethane 
molecule but we know that the solvent is a methanol molecule. However, it is impossible to 
make difference between C and O atoms because they are symmetry equivalent. In order 
to stay at the trigonal symmetry, we have to accept that each separated molecule at the 
figure consists of two methanol molecules with CH3 in one and opposite side. This is 
possible but first we should test if this is reality or just result of improper trigonal 
symmetry. In the next step, we will transform the structure model to a monoclinic 
subgroup to see what is happening with the disordered methanol.  

File → structure → Save as (Create backup copy) Cd-HPO_trigo2 
NO (you don’t want to continue with the new structure) 

IV. Refinement model 3 

1. Group subgroup transformation 

Start Edit atoms;  
Select All H → Action → Delete selected atoms → Yes to all 
OK; Yes 
Run Refine 

Notes  
R factors [327=297+30/24] 
GoF(obs) ≈ 2.57; R(obs) ≈ 2.33; wR(obs) ≈ 3.60; R(all) ≈ 2.88; wR(all) ≈ 3.72 
 
We deleted the hydrogen atoms to get a simpler initial disordered model .  

Select Tools → Transformations → Go to subgroup structure  
Press Select non-isomorphic subgroup (Step 1) 
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Step 1 Step 2 

 
 

 
Select the first monoclinic subgroup (all the three are equivalent) ; OK 
Next; Next; Next; Next 
Check “save the selected coset representative as local operators”  

Notes  
This option is very important because the nearly trigonal structure could not be refined for 
technical reasons. The omitted but in fact existing for most atoms trigonal symmetry 
would cause oscillating refinement and almost singular normal matrix. Thus, in the 
formally monoclinic structure positions and ADP of all atoms will still be connected with 
the trigonal symmetry applied as local symmetry operators.  

Write the Name of structure : Cd-HPO_mono1 (Step 2)   
Next; Finish;  
Next; OK; OK;  

Next; OK 
The program reports Rint 2.58% for 1385 observed reflections merged from 1706 
reflections. 
Finish; Yes “I want to apply this transformation”  
Yes “ I want to continue with the new structure”  
Refine 

Notes  
R factors [1706=1385+321/24] 
GoF(obs) ≈ 1.73; R(obs) ≈ 2.58; wR(obs) ≈ 3.38; R(all) ≈ 3.64; wR(all) ≈ 3.70 
 
The applied local symmetry operations are listed in Refinement options → Various → 
Restrictions. They keep coordinates and ADP in the former trigonal positions but allow to 
distinguish carbon and oxygen of methanol because occupancy is not restricted. 

Start Edit atoms; 
Select C1_1/C1_2/C1_3 → Action → Edit/Define atoms  
In page Edit check ai refinement  



277 Jana2006 Cookbook, version September 2019 
 
 

OK;OK:YES 
Run Refine (skip warning if necessary) 

Notes  
R factors [1706=1385+321/27] 
GoF(obs) ≈ 1.55; R(obs) ≈ 2.38; wR(obs) ≈ 3.03; R(all) ≈ 3.30; wR(all) ≈ 3.21 

Start Edit atoms; 
Check resulting occupancy (“ai”) od C1_1, C1_2 and C1_3. The ai > 0.5 means the atoms is 
oxygen; ai ~ 0 means the atoms should be deleted.  
Change chemical type of the carbon with ai > 0.5 to oxygen; change its occupancy to 0.5; 
disable refinement of ai 
Delete the carbon with occupancy close to zero 
Change the occupancy of the remaining carbon to 0.5; disable refinement of ai 
Select all→ Action → Rename selected atoms to “atom_type + number 
Ok; Yes 
Run Refine 

Notes  
R factors [1706=1385+321/24] 
GoF(obs) ≈ 1.68; R(obs) ≈ 2.42; wR(obs) ≈ 3.27; R(all) ≈ 3.39; wR(all) ≈ 3.49 

2. Add hydrogen atoms 

Start Edit atoms;  
Select C1 → Action → Adding of hydrogen atoms  
Uncheck “try automatic run for carbon atoms”; OK 
Select Tetrahedral configuration with 1 Neighbour(s) 
Press select neighbours and chose O4 with distance 1.425 Å; OK  
Press Locate position in map;  
Press Optimal and Apply; Apply 
Run Refine 

Notes  
R factors [1706=1385+321/24] 
GoF(obs) ≈ 1.54; R(obs) ≈ 2.35; wR(obs) ≈ 3.00; R(all) ≈ 3.34; wR(all) ≈ 3.29 

Select O4 → Action → Adding of hydrogen atoms  
Select Apical configuration with 1 Neighbour(s) 
Press select neighbours C1 with distance 1.425; OK  
Apply 
Select P1 → Action → Adding of hydrogen atoms  
Select Tetrahedral configuration with 3 Neighbour(s), distance to H 1.2 Å 
Press select neighbours and chose O1,O2,O3 with distance 1.521 Å; OK  
Apply; Ok; Yes 
Run Refine 

Notes  
R factors [1706=1385+321/24] 
GoF(obs) ≈ 1.57; R(obs) ≈ 2.33; wR(obs) ≈ 3.07; R(all) ≈ 3.33; wR(all) ≈ 3.35 
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Right Click on Refine  
In page various select Keep commands  
Disable “Keep hydro tetrahed” for P1 and “Keep hydro apical” for O4; OK 
In page various select Distance restrains 
“Fix to the specified” value 0.82 for O4 H1o4 distance; Add 
“Fix to the specified” value 1. 2 for P1 H1p1 distance; Add 
OK;OK; Yes +start 

Notes  
R factors [1706=1385+321/24] 
GoF(obs) ≈ 1.52; R(obs) ≈ 2.25; wR(obs) ≈ 2.96; R(all) ≈ 3.24; wR(all) ≈ 3.22 
The final structure is composed by two methanol molecules: 

  
 

References  
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Example 4.1: PtCu 

Disordered structure. 
Revised 26 September 2017 
 
[Cu(CH3-NH-CH2-CH2-NH2)2] [Pt(CN)4] 
 
Polyhedron 2011, 30, 269-278. 
 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: PtCu.hkl, PtCu_red.sum 
Frame scaling, absorption correction: done with software of diffractometer 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click PtCu 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction-CCD”; NEXT 
[On the screen: “Define basic input file”] 
Use "input from sum file"; OK  
[On the screen: “Your sum file consists of 6 appended data reduction runs”] 
OK;  
[On the screen: “Complete/correct experimental parameters”] 
Leave all settings unchanged; NEXT 
[On the screen: “Define the reference cell/split by twinning”] 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”] 
Leave all settings default; NEXT 
[On the screen: Select Laue symmetry] 
Select Tetragonal Laue symmetry 4/m; NEXT 
Select primitive unit cell; NEXT 
[On the screen: Select space group] 
Using the criteria described in the first example Select P42/m; NEXT 
Select "Accept the space group transformed into the original cell" 
Clear “Accept twinning matrices induced by the space group test” 
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The highest Laue symmetry consistent with the unit cell parameters is 4/mmm while the 
selected Lause symmetry is lower – 4/m. This opens possibility for twinning, but in this case 
twinning does not occur (as one would find during refinement of twin volume fractions). 
FINISH 
The original cell is used because the suggested transformation does not change the unit cell 
and the space group symbol 
YES to create refinement reflection file M90 

5. Creating refinement reflection file 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Accept the data block; FINISH 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type chemical composition C10 H20 Cu Pt N6, two formula units 
Select "Use Superflip" 
Check “Repeat Superflip”, number of runs 10 
Leave other settings default; “Run Solution” 
[On the screen: listing of Superflip] 
Superflip converges rapidly with R~14% and very good (i.e. low) fit  for the symmetry 
elements of 42/m 
The suggested centering vector (0,0,1/2) is in contradiction with found systematic absences, 
it cannot be used. It is a pseudosymmetry caused by positions of platinum (heavy atom).  
Close listing of Superflip 
Press “Accept last solution” to leave the Structure solution wizard 

7. Completing the structure model 
Plot the structure found by Superflip 
There should be a chain Pt – C – N – Cu visible in the plot.  

 
Open Refinement options, change number if refinement cycles to 100 
Run Refine 
Refinement converges with R value about 12% 
Start “Edit atoms” and define harmonic ADP for Pt1 and Cu1 
Delete rejected atoms (in case the button "Select rejected" is active) 
Run Refine 
Refinement converges with R value about 9% 
Open Fourier options (right button on Fourier icon) and select “F(obs)-F(calc) - difference 
Fourier”, OK, YES+Start to execute Fourier calculation 
YES to start the procedure for including of the new atoms 
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The same tool could be started separately by “Parameters → Atoms → New” 
[On the screen: Inserting/replacing of atoms] 
For “Show distances up to” type 4 Å 
 
 
OK 
[On the screen: list of peaks] 

 
In the left panel, Max1 is focused. Its integrated charge is displayed at the bottom. In the 
right panel, we can see distances of symmetry equivalent positions of Max1 to already 
existing atoms of the structure model, up to the previously defined limit 4Å. We can expect 
distances ~2 Å for Pt-C, ~1.5 Å for C-C, ~1 Å  for C-N of cyano group and ~3 Å for Pt-N. 
Therefore, the maximum Max1 is probably nitrogen. 
In the left panel, focus Max1 (or other peak if in your case Max1 has no good distance) 
In the right panel, focus its reasonable position having good distance to some existing atom 
Press “Include selected peak” 
[On the screen: Complete information for the new atom] 
For “Name of atom” type C* (even for nitrogen); TAB; OK 
We will intentionally add all atoms like carbon, it will help later on to analyse disorder. 
The chemical type was assigned to carbon, the name will be C+sequence number. 
Repeat the procedure for other maxima. Skip distances below 1 Å as well as maxima with 
too small charge or strange distances. At this point, all atoms should be added as carbon, 
we will distinguish between C and N later on.  
FINISH; YES to include the new atoms 
Finally the structure model should contain 9 symmetry-independent atoms. In case some 
improper maxima have been added, they will be probably discarded during refinement 
based on large isotropic ADP. 
Run Refine 
Refinement converges with R value about 4% 
Start “Edit atoms” and check if the button “Select rejected” is enabled. 
If “Select rejected” is enabled some atoms have zero occupancy. It was set by Refine because 
their Uiso was refined above the limit defined in the Refinement options (default limit is 0.2). 
Delete rejected atoms. 
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Check with “Select all” that the structure contains 9 atoms 
If the structure model does not contain all 9 atoms, repeat calculation of difference Fourier 
Leave “Edit atoms” 
Plot structure in Diamond 

 
Note names of atoms (C1, C5 in our example) which should be nitrogen of cyano groups 
Leave Diamond and change chemical type and names of C1, C5 
Run Refine 

8. Solution of disorder 
Open “Edit atoms” and define harmonic ADP for all atoms 
Double-click is necessary in the locked yellow-indicated options 
Run Refine 
Refinement converges with R value ~3% for 60 parameters 
Plot the disordered part of the structure: press ; click on Pt; Ctrl-M selects the Pt 
“molecule”; Delete deletes it – remaining atoms are coodinated to Cu 
 

 
Using “Action → Rename selected atoms manually”, rename atoms according to this plot 
This is not necessary but will help to follow easily the cookbook 
Start “File → Structure → Save As” and create a backup copy, for instance PtCu_completed 
Open “Edit atoms”, select C6  
“Action” → “Split atomic position” 
[On the screen: split atomic position window] 
Leave all settings default; Apply 
[On the screen: list of atoms in “Edit atoms”] 
Select C6, go to “Edit/define atoms”, switch to the page “Edit”, activate refinement of 
occupancy (the parameter ai) 
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Close "Edit atoms", YES to save changes 
The next steps show automatically created restriction for C6, C6’ 
Open Refinement options, go to the page “Various”, press “Restrictions” 
Focus the line “restric C6 2 C6’ 
Press Load 
In the lower part of the window there are listed properties of the restriction. The atom C6 
was split to two positions, C6 and C6’. Both atoms will have the same ADP and their 
occupancy will be complementary. 
Leave Refinement options 
Run Refine 
Refinement converges with R=~2% for 59 parameters 
Plot the same part of the structure 
 

 
Open “Edit atoms” 
Using “Action → Rename selected atoms manually”, rename atoms according to this plot 
This is not necessary but will help to follow easily the cookbook 
Enable refinement of occupancy for C2 and C4 
Run Refine 
Refinement converges with R=1.8% for 61 parameters 
Note refined occupancies 
Plot the same part of the structure and compare occupancies of carbons 
(Diamond shows occupancies when hovering the mouse on the atom) 
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We are looking for two symmetry-related half-occupied methyl-ethylenediamine chains. 
Atoms with occupancy above 0.5 will be half-occupied atoms of nitrogen. In positions with 
occupancy above 1 atoms of two disordered chains coincide. Occupancy of C2 and C4 
positions also reflects the missing hydrogen atoms while occupancy C6, C6’ keeps the sum 
1.0. Based on these considerations, we can speculate that the methyl-ethylenediamine 
chains will be oriented like in the next figure: 

 
Open “Edit atoms” and change chemical type of C4 and C6 to nitrogen. 
Using “Action → Rename selected atoms manually”, rename C4 to N4 and C6 to N6 and C6’ 
to C6. 
The atom names in the restrictions (page Various of the refinement commands) are 
renamed automatically 
Run Refine 
Open “Edit atoms” 
Change occupancy of C2 to 1 
Split the position of C2 (using the same procedure like previously for C6) 
Enable refinement of occupancy for C2 
The reason for changing the occupancy to 1 is that the generated restriction will keep the 
sum of actual occupancies. 
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Run Refine 
A slight increase of R value is due to change of ADP to isotropic during splitting. 
Open “Edit atoms” and change ADP of C6 and N6 from isotropic to harmonic 
Open Refinement options, go to the page "Various", press "Restrictions" 
Load the restriction C6-N6 and uncheck “ADP parameters”; press “Rewrite” 
The atoms C6 and N6 are so far from each other that their ADP can be refined independently 
OK; OK; YES+Start to save changes and run refinement 
Refinement converges with R=1.7% for 70 parameters 
Plot the structure 
Atom N4 represents through its symmetry equivalent positions the terminal nitrogen of both 
methyl-ethylenediamine groups. From this follows that the chains are symmetry-equivalent 
and must have the same occupation 0.5 
Open “Edit atoms” and select all atoms of both methyl-ethylenediamine groups 
(N4,C2,C2’,C6,N6 in our example) 
Rewrite their occupancy to 0.5 and disable its refinement 
Double-click will be necessary for the locked yellow-indicated fields 
Run Refine 
Refinement converges with R=1.7% for 67 parameters 
Create backup copy, for instance PtCu_beforeH 
Plot the result 

9. Adding hydrogen atoms 
For adding hydrogen atoms the automatic procedure cannot be used because of the 
disorder. In the following plot, we can find how many hydrogen atoms we need for carbons 
and nitrogens. Warning: In your structure model, the distances may slightly differ because of 
missing hydrogen atoms. It may also happen that C2 and C2’ are swapped (in such case it is 
better to rename them).  

 
C2 belongs to methyl 
C2’ and C6 belong to CH2 
N4 belongs to NH2 
N6 belongs to NH 
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Open “Edit atoms” 
Select C2, C2’, C6, N4 and N6 
Start “Action → Adding of hydrogen atoms” 
Clear “Try automatic run”; OK 
[On the screen: Adding hydrogen atoms for C2] 
C2 belongs to methyl, therefore it has one neighbor and three hydrogen atoms 
Select “Tetrahedral” 
Change number of neighbors to 1 
Click in the textbox for the neighbor: this activates the button “Select neighbors” in the 
lower right corner 
Press “Select neighbors” 
Select N6; OK 
In the textboxes for hydrogens type H1C2, H2C2 and H3C2 
Press “Apply → Go to next” 
[On the screen: Adding hydrogen atoms for C2’] 
C2’ belongs to CH2, therefore it has two neighbors and two hydrogen atoms 
Select “Tetrahedral” 
Change number of neighbors to 2 
Click in the textbox of the first neighbor; button “Select neighbors” will be activated 
Press “Select neighbors” 
Select N4 and C6; OK 
In the textboxes for hydrogens type H1C2’ and H2C2’ 
Press “Apply → Go to next” 
Similarly, continue for C6. For C6 two atoms N6 will be shown as neighbors but the one with 
too short distance belongs to the second chain 
Similarly, continue for N4 belonging to NH2. Here one of the neighbors will be copper.  
Similarly, continue for N6 belonging to NH. Geometry for N6 is trigonal, not tetrahedral.  
Leave “Edit atoms” 
Check in Diamond geometry of hydrogens (needs manually deleting of unwanted distances 
using Table of created bonds) 
Run Refine 
Refinement converges with R value 1.6% for 67 parameters 
 
At this structure model, hydrogen atoms attached to nitrogen are strictly kept in idealized 
geometry. This is correct for carbon but not for nitrogen. In the next step, we will redefine 
constraints (keep commands) to restraints. 
Start refinement commands; select the page Various; open “Keep commands” 
Disable the command “keep hydro tetrahed N4” 
Disable the command “keep hydro triang N6” 
The commands “keep ADP riding N4” and “keep ADP riding N6” will be retained 
OK; open “distance restraints” 
Select “Fix to the specified value” and for the “Value” type 0.87 
In the textbox “Atoms”, type: N4 H1N4; N4 H2N4; N6 H1N6 
Press “Add”; OK; OK; “YES+START” 
In case of bad convergence, change the dampling factor to 0.5.  
Refinement converges with R value ~1.5% for 76 parameters 
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This plot in Diamond requires a lot of manual work 
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Example 4.2: NaNiFe 
Revised: 07 March 2018 
 

Data Topic  Level 

X-ray single crystal data Structure with mixed sites. Intermediate 

Tasks 
Solving simple structure with mixed sites  

- Split atoms  

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
NaNiFe.hkl, NaNiFe.cif_od.sum 
Additional information: 
Frame scaling, absorption correction: done by the diffractometer software  
Chemical Formula : NaNiFe 
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Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step1) 
Left pane: locate directory with input files; Right pane: double-click NaNiFe (Step2) 

Step 1 Step 2 

  

2. Import wizard  

Select “Known diffractometer formats”; NEXT (Step1) 
Select “Oxford Diffraction → CCD”; NEXT (Step2) 
Select “Input from “sum” file”; OK (Step3) 

Step 1 Step 2&3 

  

Leave all settings unchanged; NEXT (Step4) 
Leave all settings unchanged; NEXT; OK; (Step5)  
The program reads 7999 reflections from hkl file 
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Step 4 Step 5 

  

For absorption correction select “None or done before importing”; NEXT (Step6) 
FINISH (Step7)   

Step 6 Step 7 

  

3. Data Repository 

OK; YES to accept the data set (Step1) 
Nest; (Step2) 

Step 1 Step 2 
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II. Symmetry and data merging  

Go through the steps of the Symmetry wizard,  
Select Laue symmetry 2/m, (Step1) 
C centering and space group C2/c (Step2) 
Accept the space group transformed into the original cell; FINISH 
Go through the steps of the Merging wizard leaving all settings default 
Rint will be 2.57% 

III. Structure solution  

[On the screen: window of Structure solution] 
In “Formula” textbox type chemical composition Na Ni Fe P O, 4 formula units 
Select “Use Superflip” 
Leave other settings default; OK (Step1) 
[On the screen: listing of Superflip] 
Superflip converges rapidly with R~18% and very good (i.e. low) agreement factors for the 
symmetry C2/m  
Close listing of Superflip and accept the results 

Step 1  

 

 

Step 1 Step 2 
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IV. Refinements and model improvement   

1. Checking the structure model 

Start EditM50, page Composition, (Step1) 
press “Formula from M40” (Step2) 

Notes  
It shows the formula “Na Ni3 Fe0 P3 O13” (for Z=4). However, the expected disphosphate 
unit is P2O12 with negative charge -9. The positive charge NaNi3 is only 7. Why do we have 
13 oxygens? Where is Iron? 

Leave to the basic window of Jana2006 
Step 1 Step 2 

  
Start refinement 
Refinement converges with R~5.7%.  
Using “Edit atoms” (Step3) 
Select all → Action → Edit/Define atoms  
Change all ADP to harmonic and repeat the refinement (Step4) 
Refinement converges with R~4.4% 

Step 3 Step 4 
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Open Fourier options and select Difference Fourier (Step5) 
“Yes+Start” to save changes and start Fourier 
YES to include new atoms (Step6) 

Step 5 Step 6 

 

 

 
Notes  
The list of Fourier maxima does not display any useful maximum. The structure is 
complete. 

Return to the basic window of Jana2006 without adding new atoms 
Open refinement listing (Step7) 
Go To → list of serious warnings (Step8) 
The listing says that ADP of Na1 and O1 are not positive definite 

Step 7 Step 8 

  

Return to the basic window of Jana2006 
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2. Calculation of distances and bond valences 

Open Distances options (right-click the icon Dist) (Step1) 
Uncheck “d(max) derived from…” 
For “d(max)” type 3.5 (Step2) 

Step 1 Step 2 

  

Press the button “Define coefficients for bond valences” 
Select “1st atom type” Na; “2nd atom type” O (Step3) 
Press the button “From file” and select the first line for bond valences coefficients  
 

Notes  
The list shows the coefficients like published in various sources. We are interested only in 
differences in coordinations and not in absolute values of bond valences sums. Therefore, 
we can use the first line for all cases. 

Press Add 
Do the same for the pairs Ni-O, P-O and Fe-O (Step4) 

Step 3 Step 4 
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OK; OK; Yes+Start 
Yes to open listing 
Go To → List of distances (Step5) 
Go To → List of bond valences (Step6) 

Step 5 Step 6 

  

 
Notes  
Summary (“BVS=bond valence sum”): 
Ni1 is coordinated by six oxygens, Ni-O between 2.10 and 2.13 Å, BVS 1.83 
Ni2 is coordinated by six oxygens, Ni-O between 1.95 and 2.12 Å, BVS 2.31 
P1 and P2 have the usual tetrahedral coordination with BVS about 5 
Na1 is coordinated by eight oxygens, Na-O between 2.27 and 2.83 Å, BVS 1.35 
O1 is coordinated by eight oxygens, O1-O between 2.38 and 2.87 Å 
From refinement we know that ADP of Na1 and O1 are negative 
In plotting software we can get following picture with O1 in the central void: 
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3. Refinement of occupancy Na1, O1 
 

Using “Edit atoms” select that occupancy of Na1 and O1 will be refined (Step1) 
Step 1  

 

 

Start refinement 
Refinement converges with R=3.4% 
Occupancy of Na1 refines to 0.62 
Occupancy of O1 refines to 0.69 

Notes  
From refinement listing we can see there are no warnings about negative ADP 
Na1 must be mixed with Ni or Fe because the refined occupancy exceeds the site 
occupancy. The BVS larger than 1 support this idea. 
For oxygen 0.69*2*8=11; 2 is the site multiplicity, 8 is number of electrons. The result is not 
too far of 10, which is sum of electrons for water. Therefore, O1 could be a water molecule. 

Using “Edit atoms” change chemical type of O1 to Na without renaming 
Run refinement 
Calculate distances 
 

Notes  
R value is the same. Occupancy of O1 (now chemical type Na) refines to 0.46. BVS of O1 is 
1.0. Therefore O1 could be also sodium, but partially occupied because there is no lighter 
element available for mixing. 
In the next part, we shall consider O1 to be oxygen of a water molecule. 

4. Mixed site Na1-Ni3 

Start  “Edit Atoms”  
Change chemical type of O1 back to oxygen 
Change occupancy of Na1 back to 0.5 
Close “Edit Atoms”, save changes 
Using “File → Structure → Save As”  (Step1) 
Create a backup copy of the structure but continue with the original one (Step2) 

Step 1 Step 2 
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Start  “Edit Atoms” 
Right-click Na1 and select “Split atomic position” (Step3) 
For name of the split atom, type Ni3 
For its atomic type, select Ni 
For Shift of the split atom, select “defined manually” and use the pre-defined translation “0 
0 0” 
Uncheck “Reset ADP to isotropic” (Step4) 
Press Apply 

Step 3 Step 4 

 

 

 
Notes  
We have splitted the Na1 position to two identical positions, Na1 and Ni3. The initial 
occupancy of these positions is ¼, because the original occupancy was ½. The tool 
generated a refinement restriction keeping for both atoms the same position and 
occupancy and constant sum of occupancies (i.e. ½). 

Close “Edit Atoms” and open Refinement options (Step5) 
Switch to page “Various” and press “Restrictions” 
Load the previously defined restriction to check it (Step6) 

 
Step 5 Step 6 
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Close refinement options, run refinement 
Refinement converges with R value still around 3.4% 
Site occupancies refined to 0.43 for Na1 and 0.07 for Ni3 
Similar results could be achieved with iron so at this point the chemical type of the metal is 
either nickel or iron 

5. Mixed sites Ni1-Fe1 and Ni2-Fe2 

Using “Edit atoms” and the same tools like before, split Ni1 to Ni1-Fe1, (Step1) 
and Ni2 to Ni2-Fe2. (Step2) 

Step 1 Step 2 

  

Activate refinement of site occupancies for Ni1, Ni2 
Run refinement 
Refinement converges with R~3.2% (slight improvement) 
Occupancy of the pair Ni1-Fe1 refines to 0.24, 0.26 
Occupancy of the pair Ni2-Fe2 refines to 0.36, 0.64 
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6. Calculation of the charge 

Start “EditM50”, page “Composition” 
Press “Formula from M40” 
It prints Na0.878 Ni1.306 Fe1.817 P3 O13.332 
In order to subtract easily water, we should define a separate chemical type for water 
In the “Formula” textbox, add “O” (another oxygen) at the end of the formula (Step1) 
Using “Edit atoms”, redefine chemical type of O1 to be “O#2” (Step2) 

Step 1 Step 2 

  
Start “EditM50”, page “Composition”; Press “Formula from M40” 

Notes  
It prints “Na0.878 Ni1.306 Fe1.817 P3 O12 O1.332”, where )1.332 is water with hydrogen 
atoms omitted, causing the increased occupancy of oxygen 
Assuming that the valence of iron is three, we can calculate:  
1.82*3+1.31*2+0.88+3*5-12*2=-0.04. This is very close to the charge balace.  
 
By this way, we have established one possible structure model. However, there are other 
possibilities which should also be checked, for instance: 
 
The water could be partially occupied sodium (it slightly decreases R value to 3.07%) and 
the valence of the iron mixed with Ni could be 2+. The composition would be Na1.769 
Ni1.27 Fe1.844 P3 O12. 
1.844*3+1.27*2+1.769+3*5-12*2=0.84, i.e. an exceed of positive charge 
 
Unfortunately, data quality does not allow for confirming the lack or presence of 
hydrogens bonded to O1. Moreover, microprobe analysis was not sufficiently accurate and 
no additional information was supplied by the chemist. Therefore, we finished with 
structure model, which cannot be reliably confirmed. 

 

References  
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Example 5.1: YPO 

Simple modulated structure with crenel 
Revised 3 December 2018 
 

Y(PO3)3 
 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: YPO.hkl, YPO_red.sum 
Frame scaling, absorption correction: done 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click YPO 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction → CCD”; NEXT 
[On the screen: “Define basic input file:”] 
Select “Input from sum file”; file name “ypo_red.sum”; OK 
[On the screen: “Warning about appended data reduction runs”] 
OK 
[On the screen: “Complete/Correct experimental parameters”] 
Leave all settings unchanged; NEXT 
[On the screen: “Define the reference cell/split by twinning”] 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 
[On the screen: “Information about starting symmetry wizard”] 
NEXT 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Symmetry wizard can be started separately by “File → Reflection file → Make space group 
test”. 
Leave all settings default; NEXT 
[On the screen: Select supercell] 
Select "Continue with the basic cell"; NEXT 
[On the screen: Select Laue symmetry] 
Select Monoclinic Laue symmetry; NEXT 
[On the screen: Select cell centering] 
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Select I centered unit cell; NEXT 
[On the screen: Select space group] 
Select C2/c; NEXT 
[On the screen: Select superspace group] 
C2/c(0b0)s0 
[On the screen: Final step of the superspace test] 
Accept the superspace group in the standard setting: C2/c(0b0)s0; FINISH 
 

5. Creating refinement reflection file 
We have finished creation of the file M95 (reflections converted from diffractometer format 
to Jana format) and M50 (cell parameters, symmetry). At this step we shall create the file 
M90 containing data set merged by symmetry, with extinct reflections omitted. 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Accept the data block and calculate coverage; FINISH 
[On the screen: Information that structure solution will start] 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for Y(PO3)3: Y P O 
Select “use Superflip”; “Peaks from Jana2006” 
Select "Use a specific random seed" and type value 5555 
“Run solution” 
Superflip converges (after noise suppression) with R value 21%. It confirms the symmetry 
C2/c(0b0)s0. 
Fixing the random seed to 5555 guarantees for most processors that the Superflip returns 
the same results like described in this cookbook. Otherwise, each run of Superflip would 
return slightly different electron density. For normal work, random seed should be automatic 
because the convergence of charge flipping is not guaranteed for every value of random 
seed. 
Close the listing and press “Accept last solution” to leave the structure solution wizard 

7. Verification of the structure solution 
Start “Edit/View → editing of M40 file”. It shows the structure parameter file 
Start “Edit atoms”. It shows the same in a graphical interface; parameters of atoms can be 
accessed by double clicking on atom or by “Action → Edit/Define atoms”; 
OK 
Start EditM50, go to page Composition, change “Formula units” to 4 
Press “Formula from M40” 
[On the screen: Information about formula] 
With previously used “randomseed 5555” the formula should be Y P3 O8 (for Z=4). 
OK; YES for updating the formula 
Modify the formula to Y P3 O9; OK, YES to rewrite M50 file 
Correct numbers of elements helps to find correct number of atoms in Fourier maps. It is also 
important for the final CIF generation. 
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Run Contour; start “New plot”; select “Show de Wolff’s sections”; 
New map to draw “F(obs) – Fourier”; 
Press “Define atoms for de Wolff’s sections”; 
Select atom Y1 and section x2-x4: 
 

                                  
 
Press “Add”; OK 
Leave rest stting default; 
   

                               
 
OK; 
Then the modulation density will appear. With “Atoms edit” define the Y1 atom to be 
visualized. 
 
                                                 



306 Jana2006 Cookbook, version September 2019 
 
 

 
 
The plot illustrates that the electron density from Superflip contains reliable information 
about position modulation. The modulation curve results by interpretation of the electron 
density map by Jana. 
Quit Contour 
 

8. Origin shift to the position of Y 
The atom Y should be localized at the inversion center in one of the following Wyckoff 
positions: 
4d (1/4,1/4,1/2); (3/4,1/4,0) + (1/2,1/2,0) 
4c (1/4,1/4,0); (3/4,1/4,1/2) + (1/2,1/2,0) 
4b (0,1/2,0); (0,1/2,1/2) + (1/2,1/2,0) 
4a (0,0,0); (0,0,1/2) + (1/2,1/2,0) 
In the next step we shall shift the origin to the position of the Y atom. This step is not 
necessary for the structure solution and refinement but it assures that the coordinates and 
plots will look as described in this cookbook 
Start “Tools → Transformations → Origin shift” 
[On the screen: Move the origin to:] 
Select Atom Y1 and press OK. 
Run “Edit atoms”; Select P and O atoms;  
Press “Action” and choose “Make symmetrically contiguous motifs; 
This will not only make an contiguous motif from PO, but also it will move motifs to the basic 
cell.     
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9. Verification of modulated functions found by Superflip 
Right-click the icon of Refine and select thumbnail “Various”. Use the button “Fixed 
commands”, select “Modulation parameters” and type * to the Atoms/parameters textbox. 
This fixes modulation parameters for all atoms. 
Press the button “Add”; OK; OK 
Start Refinement. 
The refinement should finish with R(obs) factors about 13%, 11%, 15% and 22% for all, main, 
1st order satellite and 2nd order satellite reflections. This means that we have reasonably 
good starting point to continue the solution. 
The screen output of Refine is closed after a delay. It is saved in refinement listing 
(“Edit/View → View of Refine → Go to → R-factors overview”) 

10. Refinement of the modulated structure 
Right-click the icon of Refine and select thumbnail “Various”. Use the button “Fixed 
commands” and disable or delete the previously used “Fixed command” 
Run refinement. 
You should get R values about 13%, 10%, 14% and 20%. 
Start “Edit atoms” 
Press “Select all” and “Action → Edit/define” 
Choose “harmonic” for ADP parameters. 
OK; OK; Yes to rewrite changes 
Start Refinement. 
Refinement converges with R value about 11%, 8%, 12% and 20% for 94 parameters. 

11. Localization of the missing oxygen atom 
Right-click the icon of Fourier and select thumbnail “Basic” – select “Map type” 
“F(obs)-F(calc) – difference Fourier” 
In the thumbnail “Scope” select: “Automatically” and “Use default map orientation” 
OK 
Run Fourier 
The modulation curve of this additional atom is rather complicated and therefore we have 
to look at the density maps to see more details. First, we should check if the peak, 
representing possible position of the new oxygen atom, has been really localized in the 
difference Fourier map. 
[On the screen: Do you want to start the procedure for including of new atoms?] 
Answer yes. 
[On the screen: Inserting/replacing of atoms – setting of distance limits] 
Use default 3 Å; OK 
(The dialogue for adding maxima is also available through “Parameters → Atoms → New”) 
The dominating maximum (with the largest charge) should be close to the special position at 
(3/4,3/4,1/2) or to some of its equivalents, with reasonable distances to the atom P1 (about 
1.5 Å). 
Note the coordinates of the dominating maximum in equivalent position close to P1 
For the current structure model (random seed 5555) it should be 0.749, 0.725, 0.495 
Round the coordinates to the closest special position and note them 
For the current structure model (random seed 5555) it should be: 0.75, 0.75, 0.5 
Leave the form without adding the new atom. 
Adding new atoms would add oxygen to a general position because its special position is not 
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properly recognized. 
Use Contour to see difference Fourier sections through the point (3/4, 3/4, 1/2). 
Start Contour, press “New plot”; Select “General contour procedure”  
Select “Calculate new ones” and “Draw maps as calculated”; OK 
In Basic thumbnail select “F(obs)-F(calc) – difference Fourier” and in the thumbnail “Scope” 
define the vicinity of the point (3/4, 3/4, 1/2): 
 

                                               
OK starts Fourier calculation 
The first section is immediately plotted: 
 

                  
 
The resulting map must be summed over x2, x3 direction to see the correct modulation curve 
Press “Sum ON”; select “x2” and “x3” leaving the intervals defaults; OK 
The resulting map shows the shape of modulation: 
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Analogously (starting with button “New plot” followed by “Calculate new ones”), calculate 
and plot the section x2-x4 and the section x3-x4: 
 

     

 

The modulation has a discontinuity at the point with x4=0.5. This is clearly visible from the 
map showing evolution of the x2 atomic coordinate (the x2-x4 section). 
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As the difference Fourier is more sensitive to light oxygen atom we should save the 
temporary result for a final check of the refined modulation of that oxygen atom. 

Close “Contour” 
“File → Structure → Save as” and use a new name for example “YPO-for-maps” but do not 
continue with the new structure. 

12. Inserting the missing oxygen atom 
From the previous we know that the modulation function of the new atom at 
(-1/4, -1/4, -1/2) has a discontinuity and therefore a crenel function will be used. In the x2-x4 
difference section we found that the length (delta) of crenel is one and its center (x40) is 
located at 0. 
“Parameters → Atoms → New”, select “Coordinates from keyboard”; OK 
Type the coordinates 3/4 3/4 1/2, press “Use new coordinates” 
Select the symmetrical position making the shortest distance to P1 and press “Include 
selected peaks”. 
[On the screen: Complete information for the new atom] 
For “Name of atom” type “O*” followed by TAB 
This selects the chemical type oxygen and the label with the first available sequence 
number. 
OK; Finish; YES to include new atom 
 
Now we have to define the crenel function 
 
Run “Edit atoms” and select the new atom (probably O5). 
“Action → Edit/define” check “crenel” and add also one position modulation wave in the 
textbox “Position” 
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define “1” for “delta” and “0” for “x40”; OK 
This is width and centre of the crenel function 
Select "Legendre polynomials in crenel interval" 
OK; OK; Yes to rewrite 
 
Draw Contour section x4-x2 for (3/4 3/4 1/2) - like previously 
Press "Atoms edit" and add O5; OK 
The Contour plot shows the initial modulation function for O5 

 

13. Refinement of the complete structure 
Right click on the Refine icon, switch to “Basic” 
Define there number of cycles 100 and damping factor 0.2. 
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Damping factor multiplies the parameters changes 
Start refinement 
 

→ R about 9%, 6%, 10%, 20% 
 

Draw Contour section (without Fourier calculation!) x4-x2 for (3/4 3/4 1/2) - like previously 
Press "Atoms edit" and add O5; OK 
The Contour plot shows the crenel modulation function for O5 combined with one 
modulation wave 

      
Run “Edit atoms”, select all atoms, press “Action” and select “Edit/Define atoms” 
Modify all ADP parameters to harmonic ones by double-clicking the corresponding radio 
button 
Yellow indicates locked objects. Locking occurs when the corresponding parameters are not 
the same (or of the same type) for the selected atoms. In our case ADP is harmonic for most 
of atoms but isotropic for the newly added O5, this is the reason for locking of radio buttons. 
The text box for site occupancy is also locked because some atoms are in special positions. 
A locked object can be unlocked by double-click. 
Add another one positional modulation wave for all atoms using the textbox “Position”. 
Save changes and start refinement 
 

→ R about 5.6%, 3.4%, 6%, 18% 
 

Run “Edit atoms”, select all atoms and (using the button “ADP 2nd”) define two ADP 
modulation waves for all atoms. 
Start refinement 
 

→ R about 3.4%, 2.5%, 3.5%, 9.0% for 297 refined parameters 
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“File → Structure → Save as” make a backup copy with name e.g. ypo-final 

14. Check modulation curves with maps for O5 
In this part we will check whether the refined modulation function for oxygen O5 
corresponds to the electron density map found previously by Superflip. We are making this 
check because refinement of sawtooth function for oxygen in the structure containing the 
heavy yttrium could be unreliable 
 
Return to the result saved previously (YPO-for-maps): 
“File → Structure → Open”: select the name of the previously saved structure (“YPO-for-
maps”) 
Run Refine to re-generate phases 
(R factors 11%, 8%, 12% and 20%.) 
“File → Structure → Copy in” copy only (!!!) m40 from the final structure 
(From this point Refine must not be started) 
Run “Contour”; Choose “Show de Wollf’s sections” and difference Fourier; 
Define primary and secondary scope, 3 and 2 respectively; 
Activate summation of the maps over secondary directions:  
 

                          
 
Press the button “Define atoms for de Wolff’s section: 
Select atom O5 and activate calculations for all three sections x1-x4, x2-x4 and x3-x4: 
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The following maps will be obtained: 
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By this procedure, we plot the final refined modulation curve of O5 together with the 
previously calculated Fourier map. The technical trick consists in the fact that Fourier 
calculation does not use M40; it uses M80 created by Refine. Only the modulation curve 
displayed by Contour is based on parameters from M40. 

15. Drawing of refined modulated structure 
Return back to the refinement result using “File → Structure → History” 
 
Drawing programs such as Diamond cannot draw a modulated structure directly. Jana2006 
creates an approximant based on the refined modulated functions. During this process, the 
superspace symmetry is used to generate all atomic positions and the symmetry is reduced 
to P1. The size of approximant and the starting t value are to chosen to visualize different 
portions of the non-periodic matter. In our case the most convenient supercell is 1x8x1 as 
follows from the modulation vector being close to (0,3/8,0). 
 
“Plot structure” 
In Diamond, symmetry operations cannot be used for the approximant (no automatic 
structure, no supercell, no coordinations …. ). This is because Diamond does not know 
modulation displacements of newly created positions.  

Checking of refinement listing 
Start “Edit/View → View of Refine” 
Press “GoTo → List of serious warnings” 
The listing contains information that modulation of ADP leads to non-positive values for some 
values of t coordinate: 
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Start “Grapht” 
Press New/Edit 
For “Parameter to draw” select “ADP parameter” 
For “Central atom” use “O1” (the label may differ) 
For “Principal” select “U(min)”; OK 
 
The following plot shows that U(min) is negative for a small region of t 

 
 
Create the same graphs for O4 and O5 
 

 
 
Decreasing of number of ADP modulation waves often solves such situation: 
In Atoms/Edit select all oxygen atoms and decrease number of ADP modulation waves to 1 
Check refinement listing and Grapht graphs 
In our case it only helps for O4. The reason for bad ADP modulation of some oxygen atoms is 
probably caused by the fact the sample is more complicated than presented here. High 
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exposition reveals another set of weak satellites, which needs another q-vector for their 
indexing. The five-dimensional structure remains unsolved.  
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Example 5.2: Na2CO3 
Revised: 10 March 2019 
 

Data Topic  Level 

X-ray single crystal data Simple modulated structure 
from single crystal data 

Intermediate 

Tasks 
Solving a modulated structure from single crystal data  

- Structure solution and refinement  

- De Wolff sections 

- Interpretation of results using Grapht  

Initial data 
Data 
Single crystal data measured with KUMA four-circle diffractometer (KUMA has changed to 
Oxford Diffraction, later on Varian, later on Agilent, now Rigaku Oxford Diffraction) 
Input files:  
naco.hkl, naco.cif_od  
Additional information: 
Frame scaling, absorption correction: done by the diffractometer software  
Chemical Formula : Na2CO3 
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Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files; Right pane: double-click naco 

2. Import wizard  

Select “Known diffractometer formats”; NEXT (Step 1) 
Select “Oxford Diffraction → CCD”; NEXT (Step 2) 
Select “Input from “cif_od” file”; OK (Step 3) 

Step 1 Step 2&3 

  

Leave all settings unchanged; NEXT (Step 4) 
q-vector read from the cif_od file should be: 0.1776  0  0.3252 
Leave all settings unchanged; NEXT; OK; (Step 5)  
The program reads 555555 reflections from hkl file 
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Step 4 Step 5 

  

For absorption correction select “None or done before importing”; NEXT 
FINISH  

3. Data Repository 

OK; YES to accept the data set 
NEXT; 

II. Symmetry and data merging  

1. Symmetry Wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
 

Notes  
Symmetry wizard can be started separately by “File  Reflection file  Make space group 
test”. 

Change “Maximal deviation for cell angles” to 0.3 (Step 1) 
Without this change unit cell angles will not be recognized as monoclinic 
Leave all other settings default; NEXT 
[On the screen: “Select supercell”.] 
Leave all settings default; NEXT  
[On the screen: Select Laue symmetry] 
Select Monoclinic Laue symmetry; NEXT (Step 2) 
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Step 1 Step 2 

  

 
[On the screen: Select cell centering] 
Select C centered unit cell; NEXT (Step 3) 
[On the screen: Select space group] 
Select C2/m; NEXT (Step 4) 

Step 3 Step 4 

  

[On the screen: Select superspace group] 
C2/m(a0g)0s (Step 5) 
[On the screen: Final step of the superspace test] 
Accept the superspace group transformed into the original cell: C2/m(a0g)0s; FINISH 
(Step 6) 

Step 5 Step 6 
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2. Creating refinement reflection file 

Notes  
We have finished creation of the file M95 (reflections converted from diffractometer 
format to Jana format) and M50 (cell parameters, symmetry). At this step, we will create 
the file M90 containing data set merged by symmetry, with forbidden reflections omitted. 

NEXT to confirm threshold 3sigma (Step1) 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT (Step2) 
The Rint for observed reflections will be 4.18% 

Step 1 Step 2 

  

Accept the data block and calculate coverage; FINISH 
[On the screen: Information that structure solution will start] 

III. Structure solution  

1. Structure Solution Wizard 

[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements: Na C O 
Select “use Superflip”; “Peaks from Jana2006 but first run Fourier” (Step 1) 
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Step 1  

 

 

Notes  
Superflip converges (after noise suppression) with R value 21%. It confirms the symmetry 
C2/m(a0g)0s. 
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Close the listing and press “Accept last solution” 

2. Reflection report 

Start “Edit/View → View of Reflection report” (Step1) 
 

Notes  
Reflection report shows which symmetry operations were used for merging of reflections 
and which extinction rules were applied 

Step 1 

 

3. Verification of the structure solution 

Start “Edit/View → editing of M40 file”. 
 

Notes  
This is the file of structure parameters. Each atom has one modulation wave (number of 
waves and six parameters are indicated in red) found by Jana2006 in the electron density 
map from Superflip. 
 
Na1       1  1     0.500000 0.670666 0.000000 0.246168      000  0  1  0 
 0.037995 0.000000 0.000000 0.000000 0.000000 0.000000      0000000000 
 0.000000 0.066260 0.000000 0.000000-0.004772 0.000000      000000 
 0.000000 
 
Note that there is no oxygen in M40 – later on some carbon atoms will be changed to 
oxygen. The coordinates may differ from the ones shown here dependent on which 
equivalent origin position was used by Superflip. 
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Close the editor 
Start “Edit atoms”. 

 
Notes  
It shows the same information in a graphical interface; parameters of atoms can be 
accessed by double clicking on atom or by “Action → Edit/Define atoms”; 

OK 
Start "Plot structure" 
Select “Draw average structure” 
Start "Draw+continue" 
With this option the basic 3d structure will be plotted 

[On the screen: window of Diamond] 
In Diamond use Ctrl-A and Delete to remove an automatically created plot (if present) 

In Diamond use  to include all symmetry independent atoms from M40 
Delete Na atoms 

In Diamond use  to add coordinated atoms 

Using mouse cursor and rotations  identify atoms which should be oxygens of CO3 
group: C1 and C2 
Quit Diamond (without saving the plot) 
Start "Edit atoms" 
Change chemical type of C1, C2 to oxygen 
Use “Action → Rename selected atoms to atom type + number” for oxygens and carbon 
The structure now contains: Na1, Na2, Na3, O1, O2, C1 
Return to the basic window 
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IV. Refinements and model improvement   

1. Refinement of modulated structure with modulations of positions 

In Refinement commands set 100 refinement cycles 
Run refinement. 
 

Notes  
Modulation waves are refined from the starting values found by charge flipping. 
Refinement converges with Robs factors 17%, 13%, 14%, 24%, 30% and 49% for all 
reflections, main reflections, 1st, 2nd, 3rd and 4th order satellites, respectively. 

 

Start “Edit atoms” and change ADP of all atoms to harmonic  
Repeat refinement 
Robs factors: 13%, 8%, 11%, 21%, 26% and 49% 
Start “Edit atoms” and add another position modulation wave for all atoms (Step1) 

Step 1  

 

 

Repeat refinement 
Robs factors: 12%, 7%, 10%, 16%, 23%, 48% 
Start “Edit atoms” and add a 3rd position modulation wave for all atoms 
Repeat refinement 
Robs factors: 8%, 8%, 7%, 9%, 15%, 25% 
Start “Edit atoms” and add a 4th position modulation wave for all atoms 
Repeat refinement 
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Robs factors: 8%, 6%, 7%, 9%, 14%, 21% 
 

Notes  
Refinement with four position modulation waves is reasonable because there are satellites 
up to the 4th order in data. However, it is not sure at this point that all atoms really need so 
many waves. 

Use “File → Structure → Save As” and create backup copy “naco_posmod” 
(Continue with the original structure) 

2. De Wolff sections – manual setup 

Notes  
In the next step, modulation functions will be checked against observed and difference 
Fourier map. 

 
Start Fourier commands 
For “Map type” select “F(obs) – Fourier” (Step 1) 
Switch to the page “Scope” 
Select “by a central point”; For “Map axes” select x1 for “1st” column and x4 for “2nd” 
For “Center” type Na1 
For “Scope [A]” type 2 1 1 
Change “Step [A]” from 0.02 to 0.05 to speed-up the calculation (Step2) 

Step 1 Step 2 

  
OK; Yes+start 
 

Notes  
Fourier calculates a four-dimensional parallelepiped x1–x4–x2–x3 with dimensions 2-?-1-1 
Å. In x4, the calculation will run over two periods: from 0 to 2 with step 0.02. The step in 
the other directions will be 0.05 Å. The two-dimensional sections x1-x4 will be stacked 
along x2; the three-dimensional "sections" x1-x4-x2 will be stacked along x3. 

Start Contour 
Press “New plot” 
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Select “General Contour procedure”, “Use old maps” and “Draw maps as calculated”; OK 
(Step 3) 
[On the screen: the first x1-x4 section] 
Press “Sum on” and select summation over x2 and x3 
This merges all x1-x4 sections stacked along x2 and x3 
[On the screen: merged section] 
Press “Atom edit” 
For “Atom name” type Na1; Add; OK 
[On the screen: merged section with refined modulation function of Na1] (Step 4] 
 

Step 3 Step 4 

 

 
 

Notes  
In your calculation, positions of atoms may be shifted (for instance y of Na2 from 0.5 to 
0). 

 
Press “New plot” 
In the next dialogue select “General Contour procedure”, “Calculate new ones” and “Draw 
maps as calculated” 
[On the screen: Fourier commands, page Scope] 
Change “Map axes” to plot sections x2-x4 instead of x1-x4: (Step 5) 
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Step 5 

 
Notes  
“Scope” has been refreshed automatically. 
Fourier will calculate a four-dimensional parallelepiped x2–x4–x1–x3 with dimensions 
2-?-1-1 Å. In x4, the calculation will run over two periods: from 0 to 2 with step 0.02. The 
step in other directions will be 0.05 Å. The two-dimensional sections x2-x4 will be stacked 
along x1; the three-dimensional “sections” x2-x4-x1 will be stacked along x3. 

OK 
[On the screen: the first x2-x4 section] 
Press “Sum on” to merge the sections (select summation over x1 and x3)  (Step 6) 
[On the screen: merged sections x2-x4 with modulation curve of Na1] 
Press “New plot” 
In the next dialogue select “General Contour procedure”, “Calculate new ones” and “Draw 
maps as calculated” 
[On the screen: Fourier commands, page Scope] 
Switch to page “Basic” 
For “Map type” select “F(obs)-F(calc) – difference Fourier” (Step 7) 
OK 

Step 6 Step 7 

 

 

Press “Sum on” and merge the sections (Step 8) 
Press “Contours” and define step 0.1 for both positive and negative contours (Step 9) 
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Step 12 Step 13 

 

 

 
 
[On the screen: merged difference section x2-x4] 

 
Notes  
The difference peaks about 0.5 e-/A3  indicate modulation of ADP 

 

3. De Wolff sections – automatic generation 

The process described above could be repeated for other atoms of the structure but usually 
we can use the automatic procedure described here. Limitation of this automatic procedure 
is that all calculated sections have the same parameters (scope, width, summation …) 
 
Start Contour and press “New plot” 
Select “Show de Wolff’s sections” 
For “New map to draw” select “F(obs) – Fourier” 
Define limits of x4, primary and secondary scope, and  interpolation step (Step 1) 
Primary scope means the scope of the coordinate displayed in the plot; secondary scope 
means the scope of the other two coordinates. Sections will be automatically summed.  
Press “Define atoms for de Wolff’s sections” 
Using the List button, select all toms, press “Select section for all three coordinates”, and 
press “Add”. (Step 2) 
OK; OK 
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Step 1 Step 2 

 

 
 

Notes  
Contour calculates the de Wolff section as defined: for each atom, sections x1-x4, x2-x4 
and x3-x4 will be calculated, with scope 2 1 1, 1 2 1 and 1 1 2, respectively, with step 0.02. 
The coordinate x4 will be calculated for two periods with step 0.02. 

 
In Contour, press “W+” “W-“ for displaying the sections.  
Repeat the same procedure for “F(obs)-F(calc) – difference Fourier” sections 
 

Notes 
Selected sections are displayed here with the contour step 0.1): 

  
x2-x4 for Na2: observed and difference Fourier map 
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x2-x4 for Na3: observed and difference Fourier map 

  
x2-x4 for O1: observed and difference Fourier map 
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x2-x4 for O2: observed and difference Fourier map 

  
x2-x4 for C1: observed and difference Fourier map 

For C1 no ADP modulation is indicated in the difference Fourier sections 

4. Refinement of ADP modulations 

Start “Edit Atoms” 
Select all atoms except carbon and add one ADP modulation wave (Step 1) 
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Step 1 

 
Notes  
The corresponding textbox has the label “ADP 2nd” which means we will setup modulation 
for the second order harmonic tensor ADP (ellipsoid)  

Run refinement 
Robs factors: 6%, 5%, 5%, 7%, 12%, 20% 
Start “Edit/View → editing of M40 file”. 
 

Notes  
This is the structure parameters file M40. Each atom has four modulation waves (number 
of waves and 24 parameters indicated in red) and – except carbon – one ADP modulation 
wave (number of ADP modulation waves and 12 parameters indicated in blue) 
 
Na1       1  2     0.500000 0.670641 0.000000 0.247961      000  0  4  1 
 0.019755 0.023192 0.028421 0.000000 0.008258 0.000000      0101111010 
 0.000000 0.065455 0.000000 0.000000-0.005129 0.000000      010010 
-0.001028 0.000000-0.001123 0.001502 0.000000 0.004475      101101 
 0.000000 0.001068 0.000000 0.000000-0.003381 0.000000      010010 
 0.001307 0.000000 0.000797 0.000771 0.000000 0.000106      101101 
 0.000000 0.000000 0.000000 0.000228 0.000000-0.001917      000101 
 0.000000 0.000000 0.000000 0.004284 0.000000 0.001486      000101 
 0.000000 

Close the editor 
Start “Edit Atoms” 
Select all atoms except C1 and add another ADP modulation wave (Step 1) 

Step 1  
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Repeat refinement 
Robs factors: 5%, 4%, 4%, 5%, 9%, 14% 
 

Notes  
According to de Wolff sections, O1 has the second smallest position modulations. Because 
ADP modulation usually corresponds to changes in environment of an atom due to position 
modulation, we should check whether ADP modulation of O1 is reasonable. 

Remove ADP modulation of O1 
Run refinement 
Add one ADP modulation wave for O1 
Run refinement 
Add another ADP modulation wave for O1 
Run refinement 
 

Notes  
The first ADP modulation wave of O1 has improved fit significantly. For the second ADP 
wave the improvement was not so evident. Therefore, for O1 we shall use maximally two 
ADP waves. 
For the remaining atoms we shall add ADP waves one-by-one to see where to stop. 

Add the 3rd ADP modulation wave for Na1 
Run Refinement 
Robs factors: 4.5%, 3.8%, 3.5%, 5.3%, 8.8%, 14.2% 
Add the 4th ADP modulation wave for Na1 
Run Refinement 
Robs factors: 4.5%, 3.8%, 3.5%, 5.2%, 8.6%, 14.3% 
Remove the 4th ADP modulation wave for Na1 
Run Refinement 
 
Add the 3rd ADP modulation wave for Na2 
Run Refinement 
Robs factors: 4.5%, 3.8%, 3.5%, 5.3%, 8.8%, 14.2% 
Remove the 3rd ADP modulation wave for Na2 
Run Refinement 
 

Add the 3rd ADP modulation wave for Na3 
Run Refinement 
Robs factors: 4.5%, 3.8%, 3.5%, 5.3%, 8.8%, 14.2% 
Remove the 3rd ADP modulation wave for Na3 
Run Refinement 
 
Add the 3rd ADP modulation wave for O2 
Run Refinement 
Robs factors: 4.3%, 3.7%, 3.3%, 5.0%, 8.0%, 13.6% 
Add the 4th ADP modulation wave for O2 
Run Refinement 
Robs factors: 4.2%, 3.8%, 3.2%, 4.6%, 8.0%, 12.0% (for 196 parameters) 
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Finally, we shall optimize position modulation of carbon: 
Remove the 4th position modulation wave for C1 
Run Refinement 
Robs factors: 4.2%, 3.8%, 3.2%, 4.7%, 8.1%, 12.0% 
Remove the 3rd position modulation wave for C1 
Run Refinement 
Robs factors: 4.9%, 3.8%, 4.0%, 6.0%, 9.9%, 16.0% 
Return the 3rd position modulation wave for C1 
Run Refinement 
Robs factors: 4.2%, 3.8%, 3.2%, 4.7%, 8.1%, 12.0% (for 192 parameters) 
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Notes  

This is the final selection of modulation waves: 
 

Atom Position waves ADP waves 

Na1 4 3 

Na2 4 2 

Na3 4 2 

O1 4 2 

O2 4 4 

C1 3 0 
 

5. Extinction correction 

Start “Edit/View → View of Refine” 
Press “GoTo” and select "Statistics Fo, sin(th)/lamba after refinement" 

Notes  

 
The shell of the strongest reflections has R factor 2.66% while the next strongest shell has 
2.32%. 

Close the refinement listing 
Start “Parameters → Extinction” 
Select Isotropic, Type1, Gaussian; OK; Yes to rewrite changes 
Run refinement 
Robs factors: 4.1%, 3.6%, 3.2%, 4.7%, 8.1%, 12.0% (for 193 parameters) 
Check refinement listing 

Notes  

The partial R factor for the strongest reflections is better (2.48%) but still slightly worse 
than the neighboring shell. 



340 Jana2006 Cookbook, version September 2019 
 
 

6. Final check of Fourier sections 

Using the same tool like before, plot de Wolff sections x2-x4 through the difference Fourier 
map for all atoms of the final structure model. The checkbox “update existing sections” 
must be selected. 
 

Notes 
The following sections are displayed for the contour step 0.1. This must be set manually for 
each displayed section, otherwise Contour selects the contour step automatically. 

   
Na1 Na2 Na3 

   
O1 O2 C1 

 



341 Jana2006 Cookbook, version September 2019 
 
 

Use “File → Structure → Save As” and create backup copy “naco_final” 

V. Interpretation of results 

1. Plotting of sodium carbonate with Diamond 

Notes  
In this part names of atoms and position of the origin may differ from your results 

Start “Plot structure” 
Notes  
In the following dialogue, we can plot either the average structure or the approximant 
structure. Average structure plot uses the reference positions of the basic structure and 3d 
symmetry. For approximant structure, Jana2006 expands the modulated structure to a 
user-defined area. Then the expanded structure is exported to the plotting software with 
P1 symmetry. In the plotting software (here Diamond), no symmetry operations are 
allowed including translations! The reason is that the plotting software cannot calculate 
corresponding modulation displacements. 

Select “Draw average structure”; start "Draw+continue" 
[On the screen: Diamond] 
Use Ctrl-A and Delete to remove an automatically created plot (if present) 
Go to “Build → Fill → Super cell” and select “3x3x3” supercell 
“Picture → Viewing direction → c” 

 to plot unit cells 
Go to "Build → Add cell edges" to define how many unit cells should be visible 
“Objects → Coordinate system” to see axes 

By selecting column of atoms and pressing  you can create the following figure: 

 
This plot allows for estimation which supercell we shall need for plotting of approximant 
structure. We shall use supercell 2 x 3 x 10 
Close Diamond without saving 
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 [On the screen: basic window of Jana2006] 
Start “Plot structure” 
Select “Draw approximant structure” and define supercell 2 x 3 x 10 (Step 1) 

Step 1  

 

 

 
Notes  
“Keep atom names” means that labels in Diamond will contain the original names from 
M40 followed by a sequence number”. 

 
Start "Draw + continue" 
 

[On the screen: Diamond] 

Use  to add all atoms of the approximant to the plot. No operation creating new 
atomic positions is allowed 
“Picture → Viewing direction → c” 

 to connect atoms 
On the right sidebar switch to “Table of atom groups” 
Right-click Na, press “Select atoms by group” 
In the plot hit the right mouse button on some of the selected sodium atoms 
From the context menu Select “Edit → Atom design” 
Switch to the page “Radius” and define radius 0.2 Å 
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Using mouse and Delete (on the keyboard) and Ctrl-I (inverts selection) separate the 
following motif (three columns of sodium around the column of CO3): 

 
 
(In case bonds obscure atoms too much, use Ctrl-A + Right click on a selected object  + Edit 
→ Atom design and change bond style from “thick” to “thin”) 
Note starting letters (Na1, Na2 or Na3) of labels of sodium atoms which are not in the 
middle of the plot 
On the right sidebar switch to the table “Table of created atoms” 
Order atoms by name and select the noted sodium atoms 
“Build → Polyhedra → Add coordination polyhedra” 
Select oxygen for “Ligand atom groups” 
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OK 
With  make sure that Rendering and Lightning is activated 
The resulting plot will be: 

 
 
Press Ctrl-A to select all atoms 
Hit some of the selected objects with the right mouse button 
From the context menu select “Edit → Polyhedron design” 
Define transparency 0.4; OK 
 

Using rotations  and zooming tool  create the following figure: 
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Select some sodium and carbon atoms 
Hit one of them with the right mouse button 
From the context menu select “Add → Atom labels” 
For “Relative position” type “0 0 10”. The last number will move the labels above the 
polyhedra 
Correct positions of labels with mouse 
This is the final plot (labels may differ in your result): 

 
In the middle column the CO3 groups alternate with Na atoms. 

2. Properties of CO3 anion 

Start commands for Dist (click right mouse button on Dist icon) 
In “Basic” page select “d(max) derived from atomic radii and typical distances”  
 

Notes  
Jana uses typical distances from International Tables. When a typical distance is not 
available, atomic radius is used instead. The d(max) value is expanded by user defined %. 
Both typical distances and atomic radii can be changed in EditM50-Page Composition 

For “Listing form”, select “Without symmetry codes” 
Press “Define coefficients for bond valences” 
[On the screen: dialogue for definition of bond valence constants] 
Select “1st atom type” carbon, “2nd atom type” oxygen 
Press “From file” and select constants given in the second line (Step 1) 

Notes  
The list displays bond valence constants from various literature sources 

Add; OK 
[On the screen: Distance commands] 
Switch to the page “Select atoms” 
Press "Refresh"; for central atom select (with ctrl-left mouse button) C1 
For neighbor atoms select O1, O2 (Step 2) 
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Step 1 Step 2 

  

Switch to the page “Modulation” 
Activate “Make coordination t- tables” (Step 3) 
 

Notes  
The default parameters for t have the following meaning: distances will be calculated for t 
between 0 and 1 with step 0.01, i.e. for 100 values of t. The 100 calculated distances will 
be used for calculation of d(min), d(max) and d(ave) printed in the listing. These values will 
be followed by list of distances printed for each 10th value of t, i.e. for t between 0 and 1 
with step 0.1 
 

 
Step 3 

 

OK; YES+Start; YES to open listing 
[On the screen: listing of Dist] 
Use “Goto → List of distances” 
 

Notes  
Here the distances are shown as explained previously. The first distance (introduced with 
dotted line) is the distance between reference positions of the basic structure, which does 
not occur in the real modulated structure 
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Use “Goto → List of bond valences” 
 

Notes  
Here minimum, maximum and average BVS for carbon is printed 
At the bottom of the listing there is a Coordination table for carbon showing the three C-O 
distances for each step in t 

Close listing of Dist 
Notes  
Similar information can be obtained from Grapht tool 

Start Grapht (Step 4) 
Press “New/Edit” (Step 5) 

Step 4 Step 5 

  

For “Parameter to draw” select “Distances” (Step 6) 
For “p” type lower limit 1 and upper limit 1.4 
“p” stands for “parameter” to be drawn  
For “Central atom” type C1 

Step 6 [On the screen: Plot of three C-O distances 
as a function of t] 

 

 

Press “Define neighbor atoms” and select O1, O2 
OK; OK 
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Notes  
As we have already seen in Dist listing, C-O distances are almost constant over the whole 
interval of t 

Press “New/Edit” 
Change “Parameter to draw” to “Bond valence sum” (Step 7) 
For “p” change lower limit to 3.5 and upper limit to 4.2 
Press “Define bond valence coefficients” 
OK; OK 
 

Step 7 [On the screen: Plot C1 Bond valence sum as 
a function of t] 

 

 
 

Notes  
Using the mouse cursor, we can find the fluctuation of BVS is between 3.94 and 4.04 
Both Grapht and Dist confirm the C-O bonds are constant. Now we shall check planarity of 
the CO3 group: 

Start "Edit Atoms" 
Select atoms only O1, O2 and C1 
Choose Action "Make symmetrically contiguous motif" 
OK; YES to save changes 

Notes  
With this procedure we transformed positions of C1, O1 and O2 to be connected without 
need of symmetry transformation 

Start commands for Dist 
In page “Basic” for “Listing form” check “With symmetry code” (Step 8) 
In Page “Select atoms” make sure the central atoms is still carbon and the neighbor atoms 
are oxygens 
OK; YES+Start; YES to open  the listing 
“Goto → List of distances” 
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Step 9 [On the screen: List of distances] 

 

 

Notes  
There are three distances: C1-O1, C1-O2 and C1-O2. For the third distance, C1-O2, oxygen 
O2 must be transformed from the position given in M40 by the symmetry operation x,-y, z, 
which is encoded to the Jana symmetry code #s4 (i.e. the fourth symmetry operation). 
Other distances do not need a transformation because "Symmetry contiguous motif" has 
been created in the previous step 
Symmetry codes of may differ for various Superflip runs! (for example #s4t0,1,0) 

Close the listing of Dist 
Start commands for Dist 
In page “Basic” press the button “Best Planes” 
For “Atoms defining the best plane” type “O1   O2   O2#s4” (Use your symmetry code for O2) 
For “Additional atoms” type C1 (Step 9) 
Add; OK; OK; YES+Start; YES to open listing 
“Goto → List of best planes”  
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Step 9 [On the screen: List of best planes] 

 

 

 
Notes  
The listing shows that the distance of C1 from the plane of oxygens does not change with 
the t coordinate which means the planarity of CO3 is not influenced by modulation. 
At the next step, we will visualize how atoms of CO3 group move during modulation. 

Run refinement (at least zero cycles) to get input M80 for Fourier calculation 
Start Fourier commands, select “Map type” “F(obs) – Fourier” 
In the page “Scope” select “automatically”, “Use default map orientation” 
OK; YES+Start; do not include new atoms; do not open listing 
Start Contour; New Plot 
Select “General Contour procedure”, “Use old map”, “Draw a general section”; OK (Step 10) 
[On the screen: form for definition of the general section] 
For the first atom type O1 
For the second atom type O2 
For the third atom type O2#s4 (Use your symmetry code for O2) 

Notes  
The three atoms define the plane of the section through the electron density map. The 
dimensions of the plot are defined in Scope 

For “Scope” type “4 4 0” 
For “Interpolation step” type “0.02” 

Notes  
This means the plot will be 4x4 Å. Number of parallel sections calculated by the program is 
1+s3/is, where “s3” is the width of the section and “is” is the interpolation step. Here it 
means one section, because the third parameter is zero. 

For “First point put to” type “1 1 0” (Step 11) 
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Step 10 Step 11 

 

 
 

Notes  
The first point of the plot is O1. The horizontal axis of the plot will be O1-O2. The last atom 
O2#s4 will be above the horizontal axis. 

OK (Step 12) 
Click the middle maximum and select all close atoms; OK (Step 13) 

Step 12 Step 13 

  

 
Press “Movie”; keep default parameters; OK 
 

Notes  
The tool plots the successive sections calculated previously by Fourier for sequence of x4 
values. Sampling in x4 can be changed in Fourier options, Page Scope. 

ESC to break the movie 
Press “t-map ON” and do the same animation for t-map. 
 

Notes  
For this case geometry of A3-A3 map is similar to that in R3-R3 map. Atoms of CO3 are 
moving in phase and probably they could be described by rigid body. The position of one of 
oxygens is very stable comparing to the other atoms. This is the oxygen described with less 
ADP waves. 
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3. Sodium atoms 

Using Grapht, plot Na-O distances for Na1, Na2 and Na3. In the Grapht dialogue select 
“Draw non-modulated curves” – they will appear in the plots like dashed lines indicating 
distances in the basic structure. 

Notes 

  
Distances Na3-O Distances Na2-O 

 

 

Distances Na1-O  
As it has been previously indicated by plot of the structure, Na1 which alternates with 
carbon in a column along c, has different coordination comparing with octahedrally 
coordinated Na2, Na3. Na1 has more neighbors with strongly varying distances which are 
all longer comparing with Na2 and Na3. Good test if this complicated model is reasonable 
provides plot of the bond valence sum. 
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Using Grapht plot graphs of bond valence sums for Na1, Na2 and Na3 (do not forget to define 
coefficients for Na-O bond) 

 
Notes 

  
BVS for Na3 BVS for Na2 

 

 

BVS for Na1  
Graphs of BVS show that Na1, Na2 are oversaturated while Na3 is slightly undersaturated. 
However, the fluctuation of BVS is in all cases small and similar. This means the modulation 
of Na3 and its coordination is properly described with approaching and departing oxygen 
atoms in balance. 

 

References  
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Example 5.3.1: CrPO data 
CrysAlis data processing for the room temperature incommensurate phase of 
Cr2P2O7 measured with Nonius Kappa CCD diffractometer. 
Revised: 07 September 2019 
 
Cr2P2O7  
Single crystal data measured with Nonius Kappa CCD four-cycle diffractometer 
This example is based on the Crysalis 171.40.53. Crysalis is a program for controll and data 
processing of Rigaku Oxford Diffraction (ROD) diffractometers. However, it can also read data 
from many other formats. 
Data can be downloaded at http://crysa.fzu.cz/jana/workshops/RT_data_Nonius.zip (for 
workshops, data should usually be available at flash disks) 
 
Note: In the Example 5.3.2. (structure solution), we used different data set because of more 
pronounced disorder. This data set can be downloade at 
http://crysa.fzu.cz/jana/workshops/CrPO_RT.zip 
 

1. Starting Crysalis 
For reading not-native data formats, Crysalis first needs to open some existing structure just 
to show the CMD window. For this reason, we have created a folder “Crysalis_start” with a 
par file of some structure measured with ROD instrument.  
Start Crysalis 
In the dialogue that follows, use the button “Browse experiment”, locate the folder 
“Crysalis_start” and select the file 2013_E1_2.par. 
“Open selected” 
For “Basic settings”, select “Small molecule”; OK 
OK for warning about par file 
In the left toolbar, press button CMD 
[On the screen: command shell] 
Type the following command (case-independent): SAXI CREATERUNLIST 
Press Enter 
[On the screen: Run list and aliases generator for SAXI data collections] 

http://crysa.fzu.cz/jana/workshops/RT_data_Nonius.zip
http://crysa.fzu.cz/jana/workshops/CrPO_RT.zip
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Browse for the first frame of the first run, i.e. CrPO_RT_01_0001 in the folder 
RT_data_Nonius 
Browse for the last frame of the last run, i.e. CrPO_RT_08_0127 
“Save run file” 
OK to accept the suggested parameters of the experiment 

 
 
[On the screen: Select experiment] 
Highlight “CrPO_RT”; Open selected 
For “Basic settings”, select “Small molecule”; OK 
 
At this point, Crysalis opens the Nonius Kappa CCD experiment and displays the first frame 
Use  at the bottom toolbar to decrease the image size 
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[On the screen: the basic window of Crysalis with the first frame loaded] 
 

 
 

2. Determination of the unit cell 

Start Lattice wizard using the button  
[On the screen: the window of Lattice Wizard] 

 
In this wizard, each button has a default function started by pressing the centre of the 
button and various optional functionalities, which are offered after pressing “>” part of the 
button 
Start “Peak hunting” with default options 
About 14000 peaks is found 
Start “Unit cell finding” with default options 
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The program finds some unit cell and indexes about 35% of peaks 

 
Start “Ewald Explorer” with default options 

Use the  buttons  to see projections of the found peaks along the unit cell 
axes.  
Set projection along a* 
[On the screen: Ewald – projection along a*] 

 
Peak positions are located to clouds; this is typical for inexact instrument parameters. 
Close “Ewald Explorer” and return to the Lattice wizard 

Press  to refine instrument parameters 
Repeat Unit cell finding 
Repeat refinement of instrument parameters 
Repeat Unit cell finding 
Repeat refinement of instrument parameters 
The purpose of these steps is to include more indexed reflections to the refinement of 
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instrument parameters. With native ROD experiment, the parameters would be correct from 
the very beginning, but here we work with a not-native experiment and start from a rough 
estimation of the initial parameters as saved in the frame headers. 
At this step, the unit cell is not changing. Its size suggests this is a supercell trying to index 
main reflections as well as satellites 

 
Start “Ewald Explorer”; select projection along b* 
[On the screen: Ewald – projection along b*] 

 
We can see set of strong points, which are probably main reflections, while the other points 
are satellites 
In the right part of the Ewald explorer, switch to the page Filters 
Activate the intensity filter and left only the strongest reflections. 
[On the screen: Intensity filter] 
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[On the screen: Ewald – projection along b* – filtered peaks] 

 
In the right part of the Ewald explorer, switch to the page Crystal 
Click on “LATTICE” and select “Auto unit cell finding in shown peaks” 
The resulting unit cell: 

 
Ewald view: 
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In the right part of the Ewald explorer, switch to the page Filters 
Disable the intensity filter 
Select view along b* 
[On the screen: Ewald – projection along b*] 

 
From this projection, it is clear that the additional spots cannot be indexed by any 
reasonable supercell because they are satellites. 
Set projection along a* 
The peaks between the equidistant planes are evidently some spurious peaks arising e.g. 
from a small crystal attached on the main sample. We will now remove these peaks to get a 
clearer view 
In the right panel, switch to the page “Selection/Lattice-It” 
Activate the radio button “Lattice-It” 
[On the screen: Ewald Explorer with activated function “Lattice-it”] 

 
The cursor changes to a pair of white lines.  
Orient these lines parallel with the horizontal rows of the peaks.  
After some delay, the program automatically recognizes the periodicity. 
Click the left mouse button to fix the selection. The spurious peaks now become green. 
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[On the screen: Ewald Explorer with activated function “Lattice-it” and recognized 
periodicity] 

  
  
In the right pane, press “Move selected to:” 
This will move the selected (green) peaks to the Group2 

 
At the bottom of the right panel, clear the checkbox of the group 2.  
The spurious peaks now become invisible 
At the right panel, switch to the page “Crystal”  
Select view along b* 
Now we have a clear figure suitable for determination of the q-vector 

3. Determination of the q-vector 
For selection of the q-vector, we should consider the following: 
- All satellites must have the same direction with respect to their parent main reflection, and 
this direction is defined by the q-vector 
- First order satellites are usually stronger  than the higher order ones 
- The projection of peaks onto a*, b* and c* in the right panel suggests that the q-vector has 
zero beta component  
- in order to be consistent with the workshop example 5.3.2, we would like the alpha 
component positive (towards the label a*) and the gamma component negative (opposite to 
the label c*). The labels a* (red) and b* (blue) are rather small, located at the end of the 
lattice vectors going through the origin.  
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From these considerations we can suggest a q-vector like this:  
(the yellow arrow cannot has not been done by Crysalis) 

 
In the right panel, press “Activate incommensurate peaks” and select “Add 1d modulation 
vector (hklm)” 
Activate the checkbox close to the q-vector and in the textbox that appears type estimated 
components of the q-vector and the maximal satellite index: 
0.33 0 -0.5 2 

 
 
Play with the arrows close to “Modify” button until the satellite positions fit with the 
projected peaks 
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Toggle the checkbox close to the q-vector  and check if the 
peak positions are properly described.  
In some areas, we can see that there are also the 3rd order satellites: 

 
Using the button “Modify” at the right panel, increase the satellite index to four.  
The reason for using the satellite index 4 is that when we can see the third order satellites by 
an eye there might be the forth order satellites not found by the default peak search 

 
Check views along a* and c* to be sure that the satellites are described 
Close the window of the Ewald explorer 

4. Refinement of the q-vector 
[On the screen: Lattice wizard] 
Press the button “Incommensurates/Quasi-crystals” 
In the displayed text box, define maximal satellite index (4) and the accuracy (0.05) defining 
the maximal tolerancy for an integer (for instance, 1.04 will be rounded to 1) 
 



365 Jana2006 Cookbook, version September 2019 
 
 

 
OK 
The program refines the unit cell and q-vector an indexes 84% of the peaks. This is 
acceptable number because the indexing included also the previously suppressed spurious 
peaks.  

 
Press the “>” part of the button “Save information” and select “Save specific peak table 
only”. Make backup copy of the peak table under some name which cannot be overwritten 
by Crysalis, e.g. “incommensurate” 
 

 
Close the window of the Lattice Wizard 

5. Data reduction 
[On the screen: Basic window of Crysalis] 
In the right panel, press the button “Start-Stop” 
In the next window, select “Data reduction with options” 
[On the screen: Step 1: Orientation matrix for data reduction] 
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Check the modulation vector (button “Edit q”) and maximal satellite index (button ”m=”) 
The unit cell found previously is C-centered. Now we are having two options: “Use filter for 
C-lattice” or “Don’t use filter (P-lattice)”. Using the filter is good for cases with close 
diffraction spots because during the data processing, Crysalis finds optimal positions for 
diffraction spots and it could skip from a systematically absent satellite position to an 
existing position. On the other hand, with less dense diffraction pattern, not using the filter 
gives us the complete information and we can verify the C centering. In our case, the filter 
for C-centering is not necessary.   
NEXT; NEXT 
[On the screen: Step 3: Basic algorithm parameters] 

 
 
Uncheck “Follow significant sample wobbling” (we know that the sample was not wobbling) 
Note: In this case, no special parameters are necessary. For more complicated modulated 
structures, e.g. with short modulation vector, there are two typical parameters one should 
consider: (1) Disabling the option “Refine q-vectors(s)”; (2) “Overriding integration mask 
size” available through the button “Edit special parameters”; (2) “Skiping model refinement” 
available through the button “Edit special parameters” followed by Alt-E keyboard shortcut.  
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NEXT;  
[On the screen: Step4: Background evaluation] 
Keep all settings default; NEXT 
The method “Average background” is faster and usually works well; the method “Smart 
background” is slower but sometimes gives better results 
[On the screen: Step5: Outlier rejection] 
Keep all settings default; NEXT 
Outlier rejection based on monoclinic Laue symmetry does not mean that the program 
would create a false monoclinic data for non-monoclinic case. Although the algorithm 
behind is undescribed, we know from our experience that the process rejects only few 
reflections. The resulting data are unmerged.  
[On the screen: Step6: Output] 
Keep all settings default; FINISH 
Data processing follows. At the first step, the program goes to the peaks positions predicted 
by the orientation matrix and makes profile analysis to get accurate peak positions and 
some other hidden information. The profile analysis is accompanied by the background 
subtraction. In the second step, the program makes data integration.  

6. Output 
1) The resulting data are placed to the directory struct\tmp. For Jana2006 we need the files 
CrPO_RT.cif_od and CrPO_RT.hkl 
 
2) In the left toolbar of Crysalis, there is a button Jana. The button triggers the following 
actions: directory struct\ jana_CrPO_RT is created; files CrPO_RT.cif_od and CrPO_RT.hkl are 
copied to this directory; Jana2006 is launched 
 

3) In the left toolbar of Crysalis, press the button  
[On the screen: Inspect data reduction results] 
Go to the page “Data reduction output” 

  
This page shows the merging R values (Rint) sorted by intensity shells. When scrolled up, it 
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also shows the same information separately for satellites: 

 
 
The Rint is calculated together for observed and unobserved reflections. After reading data 
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into Jana2006, Rint can be seen separately for observed and unobserved reflections. 
 
Go to the page “Graphs” 
The most important is the graph from the frame scaling. Too large fluctuation of this graph 
may indicate need of better absorption correction or other problems.  

  
 
4) Note about the absorption correction 
The data were automatically corrected using the empirical absorption correction, in Crysalis 
called ABSPACK. At the bottom of the “Inspect data reduction results”, there is the button 
“Abs display” for indexing of the crystal shape for better absorption correction. However, 
photos of the crystal shape are only available for native ROD experiments. For our case, the 
absorption correction of ABSPACK using the spherical harmonic functions is sufficient. 
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Example 5.3.2: CrPO 
Solution of the room temperature incommensurate phase of Cr2P2O7. 
Revised: 08 March 2019 
 
Cr2P2O7  
Single crystal data measured with Nonius Kappa CCD diffractometer 
Input folders:  
1) APEX data from Nonius (small disorder) 
2) CrysAlis data from Nonius (small disorder) 
3) CrysAlis data from Kuma (large disorder) 
 
The sample measured with Nonius has been processed with both APEX and Crysalis. For Crysalis 
data reduction, see Example 5.3.1. This sample has small disorder and its data are not suitable 
for those wanting to solve the advanced part of this example (disorder of crenel functions) 
 
The sample measured with KUMA has more pronounced disorder, and the workshop example 
is based on it.  
 
For this example, we recommend using data in the folder “CrysAlis data from Kuma (large 
disorder)” 
 
Frame scaling, absorption correction: done with software of the diffractometer 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: for jobname type crpo 

2. Import Wizard for data processed by CrysAlis 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; use “Browse” to locate hkl file; NEXT 
In “Define basic input file“ select “Input from cif_od file“; OK 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
[On the screen: Data repository] 
OK; YES to accept the data set 

3. Import Wizard for data processed by APEX 
Select “Known diffractometer formats”; NEXT 
Select “Bruker – CCD”; use “Browse” to locate hkl file 
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[On the screen: selection of the diffractometer fomat and hkl file] 

 
NEXT 
[On the screen: information from the p4p file] 
The hkl file in this format always has six indexes (two of them not used in our example) 

 
NEXT 
Change “Target dimension” to 4 
To have the same q-vector as expected in this manual, we need to invert its components 
Press “Define transformation matrix” 
In the row M, change “1” for “-1”; OK 

 
NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
[On the screen: Data repository] 
OK; YES to accept the data set 
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4. Symmetry Wizard 
Use default tolerances for crystal system recognition 
Select monoclinic Laue symmetry 
Select C centering 
Select space group C2/m 
Select superspace group C2/m(a0g)0s 
Accept the superspace group in the original cell 

5. Creating refinement reflection file 
Follow default steps of the wizard 

6. Structure solution wizard 
Type the formula Cr2 P2 O7, two formula units 
Select “Superflip” and “Peaks from Jana2006 but first run Fourier” 
“Run solution” 
Superflip converges with R around 19% and confirms the selected superspace group 
Close the listing of Superflip 
Press “Accept last solution” 

7. Investigation of charge flipping results 
Start EditM50, page Composition; press “Formula from M40” 
The formula based on structure model for Z=2 is Cr2P2O8, i.e. one oxygen more 
Start Options for Dist; for “Listing form” select “With symmetry codes”; In “expanded by” 
textbox, type 15%; 
Run Dist and open listing 
In the listing make sure that the atoms P1, O1, O2 and O3 make symmetrically contiguous 
motif, i.e. that O1, O2 and O3 listed in coordination of P1 have one of their symmetry codes 
equal to “x,y,z”.  
In this example, oxygens are NOT in correct symmetry positions and transformation is 
necessary. This will facilitate making connections between modulation function of the PO4 
anion later in this cookbook.   
Start "Edit atoms" 
Select P1, O1, O2, O3 
 "Action →  Make symmetrically contiguous motifs" 
Repeat calculation of distances with symmetry codes.  
The listing of Dist should look as follows: 

 
The symmetry codes of transformed atoms may be different because Superflip solutions 
are never exactly the same! 
In the next step, we will visualize electron density prepared by Superflip 
Start Contour and New plot 
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Select “General Contour procedure” 
Select “Calculate new ones”; OK (if the option is not active, Contour has no old map and it 
will calculate a new map by default) 
In Fourier option, page Basic, select “Map type” = “F(obs) – Fourier” 
In page Scope, select “by central point”, set calculation of the x1-x4 section with the central 
point Cr1 

 
OK; 
[On the screen: Contour window with plot of x1-x4 section through position of Cr1] 
Press “Atoms edit” and add Cr1 to the list of atoms to be plotted 
This was example how to setup de Wolff section manually. For making more de Wolff 
sections, we can use an automatic tool: 
Start Contour, “New plot” 
Select “Show de Wolff‘s sections”; change Step[A] to 0.05; change  primary and secondary 
scope to 3 and 1 
Primary scope defines length in Å of the visible axis of the plot (x1, x2 or x4) 
Secondary scope defines length in Å of the other axes of the plot (x2,x3; x1,x3 or x1,x2) 
“Sum maps over secondary sections” means that all sections will be merged to one section.  

 
 
Press “Define atoms for de Wollf’s sections” 
Check x1-x4,x2-x4 and x3-x4 boxes; For Atoms type “*”; Add 
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OK; OK to run the tool 
Use “W+” and “W-“ to see the resulting plots 
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 Cr1: section x1-x4  P1: section x2-x4          O1: section x2-x4 

   
 O1: section x1-x4       O2: section x1-x4         O3: section x2-x4 
 
From the plots we can conclude: 
(Positions of the centers depend on the Superflip solution and may be different, note your 
values! For instance, Cr may have the centre of its modulation function at 0.25) 
Cr1 needs a saw-tooth function with center at 0.75 and width 1 
P1 needs more modulation waves 
O1 seems to be properly described in x2-x4 section but not in x1-x4 
O2 needs saw-tooth function with center 0.75 and width 1 
O3 needs a crenel function with centre 0.75 and width 0.5;. the remaining maxima could be 
described with modulation function related by symmetry operation -x, -y+1, -z+3, i.e. 
#s3t1,0,2 in Jana encoding (This can be found from the Dist listing. Again – this operation 
depends on the Superflip solution!) 
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For making your results similar to the results presented here, rename (if necessary) oxygen 
atoms to be O2 with saw-tooth and O3 with crenel (Edit atoms – rename selected atoms 
manually) 
 
The saw-tooth shape of modulation function van be modeled by three ways:  
1) As a discontinuous positional modulation named in Jana2006 saw-tooth positional 
modulation 
2) As a discontinuous occupational function called crenel function combined with 
modulation described with Legendre polynomials 
3) As a discontinuous occupational function called crenel function combined with 
modulation described with so-called x-harmonics.  
The first method is obsolete. Here we will use the second method, i.e. crenel function (a 
straight line along x4) rotated to the saw-tooth direction by Legendre position modulation. 
 
(For more details, see Z.Kristallogr. 2016, 231(5), 301-312) 

8. Setting crenel functions 
Use “File → Structure → Save As” and create backup copy “crpo_superflip” 
Do not continue with the new structure 
Start “Edit atoms” 
Double-click Cr1 
[On the screen: Atom Edit tool] 
In page “Define” activate “crenel” and define delta=1 and x40=0.75; 
Leave refinement boxes clear (we don’t want refinement of x40 or delta, as x40 is fixed to 
0.75 by symmetry and the atom seems to be present for all x4 values); OK 
Refinement keys of delta and x40 are not automatic 
Select “Legendre polynomials in crenel interval”;  
OK 
Repeat the process for O2 (here delta=1, x40=0.75) 
Repeat the process for O3 (here delta=0.5 and x40=0.75) 
your value of x40 may be 0.25, depending on the Superflip solution 
Leave “Edit atoms”, YES to save changes 
After activation of Legendre polynomials, the keys “Legendre” will appear in  M40 file.  
 
Start EditM50, page Composition; press “Formula from M40” 
The program now prints correct composition for Z=2: Cr2P2O7. Number of oxygens has been 
reduced from 8 to 7 by using crenel function with delta=0.5 for O3 
Start Contour, “New plot” 
Select “Show de Wolff‘s sections” 
Keep clear “Update existing sections” because we want to see the previous Fourier maps 
with new modulation functions 
Plot again the de Wolff sections for all atoms 
The electron density will be still the one from Superflip because we did not refine the 
structure. The displayed modulation functions will have a shape calculated from the centre, 
width and previous harmonic waves found in the Superflip electron density. In case some 
crenel modulation function would not fit with the corresponding maximum, check its centre. 
The most probable reason is that the actual position of the centre differs of the value given 
in this cookbook, because Superflip put the origin to a different equivalent point.  In such 
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case, read the backup (File – Structure – Copy in) and repeat the process with correct origin 
position. 
 
The coefficients of Legendre polynomials are calculated such that the resulting modulation 
function fits best with the original modulation function. However, the first modulation wave 
expressed by Legendre polynomials has only the linear (coefficients 1-3) and quadratic 
(coefficients 4-6) part so the shape cannot fit exactly. 
 
 

     
 
      Cr1  O2  O3 
 
For O3 we can also display the modulation function related by symmetry operation  
O3#s3t1,0,2 (or your actual symmetry operation available from the list of Dist). To display 
such plot, use the following steps:  
Press the Contour button “From list” 
Select the section O3_x2-x4; OK 
Press Atom edit and add O3#s3t1,0,2; OK 
Run refinement 
Refinement converges with Robs factors 23%, 14%, 22%, 53%, 61% and 116% 
Run Contour and plot again the three sections: 
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  Cr1 O2  O3 
 
 
Start Edit atoms and change ADP of all atoms to “harmonic” 
Repeat refinement 
Refinement converges with Robs factors 21%, 9%, 24%, 52%, 61% and 109% 
 
Start Edit atoms and add one position modulation wave for each atom 
Repeat refinement 
Refinement converges with Robs factors 12%, 5%, 14%, 21%, 54% and 92% for 68 
parameters  
Make backup copy “crpo_initial_crenel” 

9. Setting up a constraint for discontinuity points of O2 and O3 
The shape of the PO4 tetrahedron cannot be changed too much by modulation because it 
would contradict the chemistry. Thus the discontinuity points of crenel functions of oxygen 
atoms O2 and O3 must have the same t coordinate. 
Start “Grapht” 
Press “New/Edit” 
For “Parameter to draw” select “Distances” 
For “Central atom” type P1 
Step in t 0.001; For “p” type “1.2” and “1.8”;   
“p” determines the lower and upper limits of the visualized parameter 
Press “Define neighbor atoms” and select only O2 and O3 
OK 
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The plot shows distances P1-O2, P1-O2#s4t0,1,0, P1-O3 and P1-O3#s3t0,1,3 as a function of 
t and it is obvious that discontinuities occur for slightly different values of t. However, the 
discontinuous changes of oxygen positions must occur at the same t value, because PO4 
cannot be so much distorted. 
 
The centre x40 of the crenel function of O3 must be fixed at 0.75 (or equivalent value 
following from your structure solution), because this atom is in a special position; for 
different center, there would be an overlap with symmetry related O3 leading to a 
disordered structure. The t-coordinate of this centre is t40[O3].  
For O3 delta=0.5, therefore one of the two discontinuity points is t40[O3]+0.25 
For O2 delta=1.0 and one of the two discontinuity points is t40[O2]-0.50 
The following equation will align the two discontinuity points: 
t40[O3]+0.25 = t40[O2]-0.50 => t40[O2]= t40[O3]+0.75 => t40[O2]= t40[O3]-0.25 
(The symbol t40 means x40 transformed to t coordinate.) In the last step the equivalent 
translation has been applied to get t40[O2] from the interval (0,1).  
 
Start Refinement options, page “Various” 
Press “Equations” and add equation t40[O2]=t40[O3]-0.25 
Add; OK; OK; YES+Start 
Refinement converges with similar Robs factors like in the previous refinement. If large 
changes occur, this is probably due to mistake in sign. In such case, recover the files (Tools – 
Recover), edit the equation and try again.  
Start “Grapht” and repeat the same plot like before 
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The discontinuity points for O2 and O3 now occur at exactly the same value of t 
Make backup copy “crpo_aligned” 

10. Crenel function for phosphorus 
Start Contour and plot the observed Fourier section x2-x4 for P1 using the scope 0 2 0. Plot 
similar section for the difference Fourier map.  
 

 
Although P1 seems to be correctly described with harmonic functions, the difference Fourier 
reveals fluctuation of density along the modulation function. For this reason, we shall 
describe P1 similarly like in case of O3: with two symmetry equivalent crenel functions of the 
width 0.5 
Quit Contour 
Start “Edit atoms” 
For P1 activate crenel; define x40=0.86 (replace with your value as follows from the Fourier 
map) and delta=0.5; activate Legendre polynomials;  
Return to Edit page 
Note that y has been shifted slightly from the specil position (this has been done 
automatically by activation of Legendre); change site occupancy from 0.5 to 1 (we are now 
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out of the special position, and the occupancy is reduced by the crenel function) 
Close “Edit atoms”; check formula in EditM50 (should be still Cr2 P2 O7 for Z=2) 
Start Contour; use old maps 
In “Atoms edit” of Contour add P1 and the symmetry equivalent P1#s4 
In this case, the proper symmetry code does not appear in the Dist listing because the crenel 
width 0.5 makes both P1 positions exclusive. To see the code, the crenel with must be edited 
to be above 0.5. This generates a disorder fro t values where both crenel functions co-exist, 
and the corresponding distance with symmetry code will appear in the Dist listing. After 
notong the code, do not forget to return the crenel width back to 0.5.  
 

  or    
The left image occurs when we shift y[P1] from the special position more then necessary. 
The right image shows the situation when y[P1] was adjusted automatically during the 
conversion of the harmonic modulation function to Legendre polynomials. Both starting 
points are sufficient for successful refinement.  
 
Quit Contour 
Start Refinement option, page “Various”, button “Equations” 
Define equation t40[P1] = t40[O3] 
This bounds discontinuity points of P1 with O3. ½ shift may be needed depending on the 
Superflip solution. 
Run refinement 
Refinement converges with Robs factors 11%, 5%, 11%, 15%, 54% and 106% (77 
parameters), i.e. better fit for 1st and 2nd order satellites 
If the initial changes of parameters are large, the previously defined equation is probably 
incorrect. In such case, recover files (Tools – Recover files), edit the equation and try again.  
Make backup copy (rewrite crpo_aligned) 

11. More modulation waves 
At this point all atoms have two position modulation waves and no modulation of ADP. We 
will add position and ADP modulation waves until they improve R factors. Normally this 
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would be result of trials and errors, here the process will be simplified. 
 
Oxygen O1 is only slightly modulated and does not need more waves. 
 
Set three position modulation waves for Cr1, P1, O2 and O3 
Refine 
Refinement converges with Robs factors 9%, 5%, 11%, 8%, 56% and 76% 
Add the first ADP modulation wave for Cr1, P1, O2 and O3 
Start Refinement options, change number of refinement cycles to 100 and set damping 
factor 0.4 
Refine 
Refinement converges with Robs factors 7%, 4%, 7%, 13%, 37% and 56%  
Set two ADP modulation waves for Cr1, P1, O2 and O3 
Refine 
Refinement converges with Robs factors 6%, 3%, 6%, 11%, 23% and 39% 
Add another position modulation wave only for Cr1 
Refine 
Refinement converges with Robs factors 5%, 3%, 4%, 5%, 13% and 31% 
Add another ADP modulation wave only for Cr1 
Refine 
Refinement converges with Robs factors 5%, 3%, 4%, 7%, 18% and 38% 
Refine isotropic extinction (Parameters → Extinction) 
Refinement converges with Robs factors 4%, 3%, 4%, 6%, 18% and 36% with 177 refined 
parameters. 
Make backup copy: crpo_simple 
 

 
 
The result is looking well except the poor fit of the 3rd and 4th order satellites: is it caused by 
structure model or weak satellite intensity? For 3rd order satellites there is still 50 % of 
reflections above the observability limit. GOF > 4 also suggests the model could be improved. 
Another problem are warnings about ADP of P1 and O3, which are not positive definite for 
some regions of t.  
 
Start “Edit/View → View of Reflection report” 
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Press “GoTo” and move to “Summary after averaging” 
Here we can see Rint for the 3rd order observed satellites (11%) and for the 4th order 
observed satellites (19%). This also suggests the quality of high order satellites is sufficient 
for a model improvement. 
 
Start Contour and plot the following difference Fourier sections: x1-x4 for Cr1, x2-x4 for P1, 
x1-x4 for O2 and x2-x4 for O3. For plotting use always the contour step 0.2. You can also 
plot the section automatically by the “Show de Wolff’s section”, in such case contour step is 
set automatically but size of difference maxima is shown under the mouse cursor. 
 

 
 

 
Cr1: x1-x4 P1: x2-x4 O2: x1-x4 

   
   



385 Jana2006 Cookbook, version September 2019 
 
 

  
 

O3: x1-x4 O3: x2-x4 O3: x3-x4 

12. Disordered structure 
The difference Fourier sections for Cr1, O2 and O3 indicate a disorder close to the 
discontinuity points of crenel function. At this part, we shall create a structure model with 
initial modulation functions describing the disorder. 
 
For each of the atoms delta will be shortened and additional atoms with small 
complementary delta will be placed to the difference maxima found in the Contour sections. 
The resulting structure model must keep formula unchanged. The delta of all disordered 
atoms will be kept the same. 
 
The atoms Cr1 and O3 have to be duplicated and the atoms O2 triplicated (because of lower 
symmetry). Then the atomic parameters of the original and split atoms must be modified to 
account for the disordered model as found from difference Fourier maps. 
Start “Edit atoms” 
Select Cr1, O2 and O3; Press “Action” → Select “Split atom”; 
Choose 0 for relative occupancy of split atom;  
Check the manually defined shift of atoms equal 0 0 0; 
Uncheck “Reset ADP to isotropic”; 
Uncheck “Generate restrict command for refine; 
Press “Apply->Go to next”; 
Repeat this procedure for O2 and O3; 
Select the atoms O2’ and repeat the split procedure once more to create O2’’; 
OK; Yes to the question about rewriting; 
 
The new positions will describe disorder at the discontinuity area. For Cr1’ and O3’ two 
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positions are generated by symmetry; for O2 we have introduced both positions. 
 
Start “Edit atoms” 
Select Cr1’, O2’, O2’’, O3’ 
Change number of their position and ADP modulation waves to zero 
Change ADP to isotropic 
OK; Refresh 
In the following, the suggested coordinate changes may not be applicable to your solution. 
In such case, plot again the Contour sections and note proper values.  
For Cr1’ change x to 0.06 and site occupancy to 0.5 
For O2’ change x to 0.12 and site occupancy to 0.5 
For O2’’ change x to 0.26 and site occupancy to 0.5 
For O3’ change z to 1.44 and site occupancy to 0.5 
New positions can be found on the above shown difference sections. 
 
Start Refinement option, page “Various” 
Press “Equations” and define the following equations: 
t40[Cr1’]=t40[Cr1]+0.5 
This puts the additional atom Cr1’ to proper position along x4 related to Cr1 
delta[Cr1’]=1-delta[Cr1] 
This defines delta of the additional atom like complementary to the original atom 
t40[O2’]=t40[O3]+0.25 
This puts the additional atom O2’ to proper position along x4 related to O3. 
t40[O2’] = t40[O2]-0.5 but we can substitute for t40[O2] from already defined equation 
t40[O2] = t40[O3]+0.75 
delta[O2’]=delta[Cr1’] 
We want delta the same for all additional atoms 
t40[O2’’]=t40[O3]+0.25 
delta[O2’’]=delta[Cr1’] 
delta[O2]=1-delta[Cr1’] 
t40[O3’]=t40[O3]+0.25 
delta[O3’]=delta[Cr1’] 
delta[O3]=0.5-delta[Cr1’] 
After applying these equations all delta intervals will depend on delta of Cr1 and the total 
occupation of atoms will be the same like in the simple model. 
In page Basic set zero refinement cycles 
Run refinement 
The refinement applies the equations and calculates structure factors 
Because delta[Cr1] is one all delta parameters of additional atoms are zero and R values are 
as before: 4%, 3%, 4%, 5%, 14% and 23% for 177 refined parameters 
Start EditM50, page “Composition”, and press “Formula from M40” 
This shows correctly Cr2 P2 O7 
 
We want to assign some non-zero delta for additional atoms and view modulation functions 
but with the original electron density 
Start “Edit atoms” and change delta of Cr1 from 1 to 0.9 
In refinement we have still zero cycles 
Run refinement 
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This recalculates delta based on equations and creates new (unwanted) input for Fourier 
Start “File → Structure → Save As” and create copy “tmp” 
Do not continue with the new structure 
Change delta of Cr1 back to 1 
Run refinement (with zero cycles) 
This creates good input for Fourier 
Start “File → Structure → Copy in” and copy to the current structure only M40 from the 
previously created backup copy “tmp” 
Now we have old input for Fourier and new input for plotting modulation functions 
Start Contour 
For Cr1 plot x1-x4 difference section and visualize Cr1, Cr1’, Cr1’#s2t0,0,2 
Your symmetry codes may be different 
For O2 plot x1-x4 difference section and visualize O2, O2’ and O2’’ 
For O3 plot x3-x4 difference section and visualize O3, O3’ and O3’#s2t0,1,3 
 

   
Cr1: x1-x4 O2: x1-x4 O3: x3-x4 

 
Make backup copy: crpo_disorder_initial 

13. Refinement of disordered model 
Refinement of the disordered model must be started from very small delta for additional 
disordered atoms. The purpose of this refinement is not to obtain proper geometry of the 
disordered atoms because the corresponding scattering power is very small: for O3 and 
delta=0.1 the disordered atom would have 0.1*0.5*8 electrons, which is less than 0.5 of 
hydrogen. 
 
Start “Edit Atoms” 
Change delta of Cr1 to 0.98 and leave it fixed 
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Run zero refinement cycles 
This will create delta=0.02 for additional atoms 
Test Formula (EditM50 – must be Cr2 P2 O7) 
Start Refinement options, set 100 refinement cycles with damping 0.4 
Uncheck “Disable atoms having too large isotropic ADP” 
Run refinement until convergence 
The simple model without disorder converged with Robs factors 4%, 3%, 4%, 6%, 18% and 
36% for 177 refined parameters. 
Now we have obtained Robs factors 3%, 2%, 2%, 4%, 9% and 18% for 193 refined 
parameters. This means the fit has been considerably improved for higher satellites, and we 
can try to refine delta. 
Start “Edit atoms” and activate refinement of delta for Cr1 
Run refinement 
Refinement converges with Robs factors 3%, 2%, 2%, 4%, 9% and 18% for 194 refined 
parameters. Delta of additional atoms refines to 0.093. 
 
Start “Edit atoms” and add one position modulation wave to all additional atoms (Cr1’, O2’, 
O2’’ and O3’). 
Run refinement 
If refinement is unstable, press “Parameters” and swith on the Marquart technique. 
Refinement converges with Robs factors 2.4%, 1.9%, 2.0%, 3.5%, 7.3% and 12.1% for 218 
refined parameters. GOF = 2.0. Delta of additional atoms refines to 0.11. 
 
Make backup copy: crpo_disorder_final 
 
Conclusions 
The disordered model does not provide proper geometry of disordered atoms. However, we 
can draw an approximant structure in large area and try to determine in which places of the 
real space the structure becomes disordered. 
 
Plot the structure expanded to 3x3x3 cells 
Indicate the atoms with ‘ and ‘‘ in yellow 
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In view along c we can distinguish columns without disorder and columns with disorder 
 
Using Grapht, we can visualize U(min) to see for which t values it becomes negative (leading 
to the serious warning during refinement) 
 

We can see this occurs close to the disordered area 



390 Jana2006 Cookbook, version September 2019 
 
 

  



391 Jana2006 Cookbook, version September 2019 
 
 

 

Example 5.4: Fresnoite 
Solution of (3+2)-dimensional incommensurately modulated structure. 
 
Ba2TiSi2O8  
 
Single crystal data measured with Oxford Diffraction four-cycle diffractometer 
Input files: fresnoite.hkl, fresnoite.cif_od 
Frame scaling, absorption correction: done with software of the diffractometer 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click fresnoite 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
In “Define basic input file“ select “Input from cif_od file“; OK 
Change all q-vector components to 0.302 keeping the original sign; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
[On the screen: Data repository] 
OK; YES to accept the data set 

3. Symmetry Wizard 
Use default tolerances for crystal system recognition 
Select tetragonal Laue symmetry 4/mmm 
Press Show/modify X centering 
[On the screen: select individual centering vectors] 
Select centering vectors: (0 0 0 0 0) and (0 0 1/2 1/2 1/2); OK; Next 
Select space group X4/mbm and note the non-centrosymmetric possibilities 
Accept the superspace group in the original cell 
For five-dimensional structures the wizard does not offer selection of superspace group. It 
will be done later manually. 

4. Creating refinement reflection file 
Follow default steps of the reflection wizard 
The program discards 54372 reflections, 455 observed, Rint=3.28% 

5. Structure solution wizard 
ESC 
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6. Solution of average structure – centrosymmetric solution 
Superflip for five-dimensional structure returns five-dimensional electron density map. 
However, Jana2006 would not evaluate initial modulation functions from this map and we 
would get average structure. For this reason solution will be done separately for average 
structure 
Start “Tools → Transformation → Go to average 3d structure” 
For name use “ave_centro” 
Follow steps of the Reflection wizard 
Continue with the new structure 
Start “Run → Solution” 
For Formula type “Ba Ti Si O” 
Select “Superflip” and “Peaks from Jana2006” 
Select “Use a specific random seed” and type “111” for random seed 
With this option result of charge flipping will be the same in most computers and origin 
position and special atomic position will be equivalent with this cookbook. For normal work 
Random seed should not be fixed. 
OK 
Superflip converges with R around 18% and confirms the selected space group 
Accept the result 
Start EditM50 and check formula for Z=4: Ba2 Ti Si2 O4 (should be Ba2 Ti Si2 O8) 
Run Refinement 
Refinement converges with Robs=14% 
Using “Edit Atoms”: check Uiso of O1 is it rather high ~ 0.13 Å2; Esc 
Plot the average structure; Check that the O1 atom is in a close contact with Ba1 ~ 1.16 Å 
Run “Edit atom” and delete the atom O1 

Run refinement 
Refinement converges with Robs=13% 
Run difference Fourier 
Add difference maxima Max1, Max2, Max3 as oxygens 
Run refinement 
Refinement converges with Robs=12% 
In EditM50 check formula: Ba2 Ti Si2 O8 
Run difference Fourier; Add difference maxima Max1 as a new oxygen atom 
Run refinement 
Check formula: Ba2 Ti Si2 O16 
In EditM40 allow refinement of atomic occupancies – “ai” parameter – of all oxygen atoms; 
Refinement converges with Robs=9.1% 
Check formula: Ba2 Ti Si2 O9.2 
Using “Edit atoms” change all ADP to harmonic 
Run refinement 
Refinement converges with Robs=5.9% 
Check formula: Ba2 Ti Si2 O10.1 
Plot average structure; make Si-O coordination; draw the projection along [0,0,1]and along 
[1,-1,0]  
 
 
Jana2006 sends to Diamond expanded structure in P1 symmetry. This is because of 
centering X which Diamond cannot use. In the plot the silicon atom is surrounded by eight 
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partially occupied oxygen atoms. This can be either reality which would be described by 
crenel functions or wrong symmetry for average structure. 
 

  
The figures indicate a disorder of SiO4 groups by the mirror perpendicular to the c axis. The 
disorder can be described alternatively by the two fold axis perpendicular to c and a+c. 
The disorder in the average structure can be produced either by the fact the structure is not 
centrosymmetric or by modulation. First we shall test non-centrosymmetric description. 
 

7. Solution of average structure – non-centrosymmetric solution 
In order to see all highest non-isomorphic subgroups we shall create a testing structure: 
Start “File → Structure → save as” and create a testing structure named “ave-test”. 
EditM50: change symmetry from X4/mbm to P4/mbm; Accept changes without re-creation 
of the diffraction file; 
Start “Tools → Transformations → Go to subgroup structure”; Press the button “Select non-
isomorphic subgroup:” 

 

 
 

The highest subgroups not giving a split model for SiO4 group are P-421m and P4bm. 
Now we have to check if basic positions (x,y,z) of atoms Si1, O1, O2 and O4 belong to a 
unique tetrahedron. 
Return to the structure “ave-centro”; Set distance commands: in the “Basic” define 
calculation of angles and the listing form “with symmetry codes”. 
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Run dist; Open the listing: 
 

 
 
The blue lines indicate the bond distances and red lines bond angles of the basic SiO4 group. 
From the symmetric codes we can see that only the atom O2 should be transformed by the 
symmetry operation #s10 i.e. by x,y,-z 
Start “Edit atoms”: select the atom O2 and transform it by x,y,-z 
Before testing of non-centrosymmetric space groups we have to reset the occupancies to 
their the values corresponding the SiO4 split. This means that their full values are to be 
reduced by 1/2. The atom O3 is coordinating Ti and it can also be shown that it has to 
represent a split position. 
Start “Edit atoms” set “ai” for O1, O2, O3 and O4 to 0.25, 0.5, 0.25 and 1, respectively. 
 
In the next step we shall test non-centrosymmetric space group X-421m 
Start “Tools → Transformation → Go to subgroup structure” 
[On the screen: Define subgroup] 
The button for selecting non-isomorphic subgroup is missing because of non-standard 
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centering 
Select symmetry operator for the screw axis 21 and rotation axis -4 of the space group 
X-421m 
Press “Complete subgroup” 
The subgroup should be X-421m without changing axes 
Next; Next 
[On the screen: select one representative of the 2nd coset] 
Select inversion as operator for expansion to the subgroup; Next 
Deselect “Make as twinned structure” 
Type name of the structure (for instance “ave_-421m”); Next 
Follow steps of the Reflection wizard 
Continue with the new structure 
Check formula – still Ba2 Ti Si2 O16 for Z=4 
“Edit atoms”: delete atoms O1_2, O2_2 and O4_2 and reduce the occupancy of O3 to 0.25. 
Check formula – still Ba2 Ti Si2 O8 for Z=4 
In “Refine commands” set damping factor to 0.5 
Run Refinement 
Refinement converges with Robs=8.3% 
 
In the next step we shall test non-centrosymetric space group X4bm 
Start “File → Structure → Open” and return to the centrosymmetric average structure 
(“ave_centro”) 
Start “Tools → Transformation → Go to subgroup structure” 
[On the screen: Define subgroup] 
The button for selecting subgroup is missing because of non-standard centering 
Select symmetry operator for glide plane b and rotation axis 4 of the space group X4bm 
Press “Complete subgroup” 
The subgroup should be X4bm without changing axes 
Next; Next 
[On the screen: select one representative of the 2nd coset] 
Select inversion like operator for expansion to the subgroup; Next 
Deselect “Make as twinned structure” 
Type name of the structure (for instance “ave_4bm”); Next 
Follow steps of the Reflection wizard 
Continue with the new structure 
Check formula – still Ba2 Ti Si2 O16 for Z=4 
“Edit atoms”: delete atoms O1_2, O2_2, O3_2 and O4_2. 
Check formula – still Ba2 Ti Si2 O8 for Z=4 
Run Refinement 
Refinement converges with Robs=2.27% 
“Edit atoms”: rename oxygens to O1, O2, O3, O4 using “Rename selected atoms to atom  
“File → Structure → Save As”: ave_final 
 

8. Back to the modulated structure 
“File → Structure → Open”: open “fresnoite” 
EditM50: 
In “Composition page” type formula Ba Ti Si O and formula units 4 
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In “Symmetry” page change symmetry to X4bm 
OK to confirm centering 
OK for the first translation part 
OK for the second translation part 
Close Editm50 
Re-create refinement reflection file 
“File → Structure → Copy in”: import only M40 from the average structure "ave_final" 
Run refinement 
Refinement confirms R value for the average structure: 
 

 
 

9. Superspace symmetry 
In the previous paragraph the program asked for completion of the translation part of 
superspace symmetry operators. For the present case two symmetry operators should be 
completed: 

 and  
 
Each translation part has two elements which can be either 0 or 1/2. Thus we have sixteen 
combinations: 0 0 + 0 0, 0 0 + 1/2 0, 0 0 + 0 1/2, 0 0 + 1/2 1/2 … However, the translation 
part can be combined with the X centering (0 0 1/2 1/2 1/2) which makes equivalent for 
instance the pairs 0 0 + 1/2 1/2 and 1/2 1/2 + 0 0. Moreover, some combinations are 
forbidden because they lead to inconsistent translation (0 0 0 1/2 1/2). 
Finally we have only two independent possibilities: 
0 0 + 1/2 1/2 
0 0 + 0 0 
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Start EditM50 
Go to page “Symmetry” 
Focus the textbox “Space group” and press TAB. The program offers the first symmetry 
operator needing to complete. 
At the first attempt try combination 0 0 for the first operator and 1/2 0 for the second one. 
The program will not allow it. 
Then try the combination 0 0 + 0 0. Close EditM50 and re-create refinement reflection file. 
From the screen output of the symmetry wizard note number of rejected reflections: 54372 
rejected reflections from which 455 is observed with the largest I/sigma(I) around 15 
Return to EditM50 
TAB in the textbox “Space group” 
For translation parts use combination 0 0 + 1/2 1/2 
Re-create refinement reflection file 
From the screen output of the symmetry wizard note number of rejected reflections: 55353 
rejected reflections from which 463 is observed with the largest I/sigma(I) around 15 
This means: the translation part 1/2 1/2 of the second operator leads to 1000 more forbiden 
reflections but the number and sigma level of the observed forbidden reflections remains 
almost the same like with the translation part 0 0. This confirms the presence of the 
translation part 1/2 1/2 for the second symmetry operator.  
 

10. Refinement of modulated structure – position modulation 
Make backup copy: “fresnoite_backup” 
Start “Parameters → Options” 
Press “Define wave vectors” 
For the third wave define 1 1 
This means modulation wave vector given by a sum of the q vectors 
For the fourth wave define -1 1 
This means modulation wave vector given by a difference of the q vectors 
“Edit atoms”: set two position modulation waves for all atoms 
This means one harmonic wave along the first wave vector (q1) and one harmonic wave 
along the second wave vector (q2) 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 10%, 3%, 13%, 51% 
By second order satellites are considered reflections described by combination of q1 and q2: 
q1 + q2 or –q1 + g2. 
“Edit atoms”: add another two position modulation waves for all atoms 
This mean one harmonic wave along the first wave vector combination (q1+q2) and one 
harmonic wave along the second wave vector combination (-q1+q2) 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 4%, 2%, 7%, 6% 
 

11. Contour sections and ADP modulation 
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“Start Contour → New plot → Calculate new ones” 
Select observed Fourier 
For “Scope” define Ba1 as central atom 
For map axes select x1, x4, x3, x2, x5 with limits as shown below 

 
This will plot section x1-x4 but the shape of atomic domain will be function of x5 
OK to calculate Fourier map 
In Contour press “Atoms edit” and add Ba1 

 
Press “Movie” to see the changes of this figure with x5 
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Press “New plot” and calculate difference Fourier map for the same section 

 
The difference maxima around Ba1 are very strong indicating ADP modulation 
 
“Edit atoms”: set two ADP modulation waves for Ba1 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 3%, 2%, 4%, 6% for 121 parameters 

12. Refinement of inversiontwin 
As the structure is non-centrosymmetric we cannot be sure that the proper absolute 
configuration has been reached. To prove the correct configuration we shall refine so called 
Flack’s parameter which means the volume fraction of twins related by the inversion centre. 
“Start EditM50” to the page cell, define the twinning operation by inversion centre 
Run “Parameters→ Twin fraction” and allow refinement of the twin ratio. 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 2.1%, 1.5%, 2.6%, 5.5% for 122 parameters. 
Run “Parameters→ Twin fraction” to see the refined volume fraction ~ 0.915. Which means 
the absolute configuration is opposite to that we got when going from the centrosymmetric 
to non-centrosymmetric description. 
Make backup copy: “fresnoite_final” 
 

13. Inverted barium position – false minimum 
Barium is located in a special position x, x-1/2, 1/4. Application of a two-fold axis creates a 
position -x, -x+1/2, 1/4, which becomes – after application of the three-dimensional part of 
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the X centering 0 0 1/2 1/2 1/2 – equivalent to the inverted position –x, -x+1/2, -1/4. Thus in 
average structure position of barium can be inverted. In modulated structure inversion of 
barium yields different modulation functions because of the 4th and 5th component of the 
centering vector. 
 
Refinement of fresnoite tends to be trapped in a false minimum because of very good fit of 
main reflections and relatively weak satellites. Inversion of the position of barium helps to 
leave the false minimum. 
 
Start “Edit Atoms”, select Ba1 
“Action → Transform selected atoms” and apply inversion -x1,-x2,-x3,-x4,-x5 
Save the result, leave “Edit atoms” 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 7.6%, 2.7%, 15.6%, 14.2%. This means that the structure can reach a 
false minimum but also stable minimum. 
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Example 5.5.1: Melilite data 
Data processing of a (3+2)-dimensional incommensurately modulated structure 
with overlaps of satellites, using Crysalis. 
Revised: 07 September 2019 
 
Ca2MgSi2O7  
Single crystal data measured with Oxford Diffraction four-cycle diffractometer 
Input files: directory Melilite available at http://crysa.fzu.cz/jana/workshops/Melilite.zip 
(for workshops, data should be available at flash disks) 
 
This example is based on the Crysalis 171.40.53. Crysalis is a program for controll and data 
processing of Oxford Diffraction diffractometers.  

1. Getting the input data (if not available in workshop materials) 
Start your browser 
Connect to http://crysa.fzu.cz/jana/workshops/Melilite.zip and download the archive 
Unpack the archive 
It will create directory Melilite 

2. Starting Crysalis 
Start Crysalis 
In a dialogue that follows locate the file run.par 
Crysalis opens the experiment. 
Use  to decrease the image size 

3. Determination of the unit cell 

Start Lattice wizard using the button  
[On the screen: the window of Lattice Wizard] 
Start “Peak hunting” with default options 
About 30000 peaks have been found 
Start “Unit cell finding” with default options 
The program finds a unit cell 7.84 7.84 5.02 90 90 90 and indexes about 70% of peaks 

 
 

http://crysa.fzu.cz/jana/workshops/Melilite.zip
http://crysa.fzu.cz/jana/workshops/Melilite.zip
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Start “Ewald Explorer” with default options 

Use the  buttons  to see projections of the found peaks along the unit cell 
axes.  
Set projection along c* 
 

 
The projection shows main reflections with radial distribution of spurious peaks. These peaks 
are tails of very strong reflection and their radial districution allows quick conclusion that 
these are not satellites.  
 
Enlarge the peak projection using the right mouse button 
 

 
 
Majority of satellite peaks can be described by two q-vectors: q1 = (α, α,0), q2 = (-α, α,0). The 
positive direction of a* and b* is indicated in the Ewald view by very small labels. 
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The peaks indicated by white circles are λ/2 reflections. The experiment was done with 
classical Mo x-ray tube and graphite monochromator and with this equipment, such 
reflections may exist between very strong regular reflections.  
 
The most important are weak reflections indicated by red circles. These reflection are 
described by combination of q1 and q2, and this proves that our structure is (3+2)-
dimensional. Without these reflections observed, there would also be possibility of a (4+1)-
dimensional crystal twinned by 90° rotation around c*.  
 
The combined satellites are also visible in the projections: 

 
The projections also indicate that the combined satellites may be overlapped due to short 
distance between them 
 
In the next step, we will visualize the reciprocal plane 0,k,l and 1,k,l to see better the 
combined satellites 

4. Unwarping 
Close the Ewald explorer 
In Lattice wizard, press “Unwarping – precession images” 
NEXT; NEXT 
[On the screen: Step 3: Creation of a layer list”] 
Press “Generate layers” 
Type 1 for “max order”, 1.2 for “resolution” 
Delete all layers except 1_k_l 
NEXT 
[On the screen: Step 4: Use background subtraction”] 
Check “Use background subtraction” 
NEXT 
[On the screen: Step 5: Data corrections”] 
Press “Edit user scale” 
Define a user scale 40 (to see weak features) 
Check “Don’t apply final convolution filter” (to see better separation of spots) 
FINISH 
Check the radio button “Layer” to see the progress of the unwarp procedure.  
Wait until the layer is finished 
Open the menu in the lower right cornes of Crysalis and select “Unwarp reciprocal lattice 
grid” 



404 Jana2006 Cookbook, version September 2019 
 
 

  
 
This is the resulting unwarped reciprocal plane (precession-like image): 

 
The weak spots indicated by yellow rectangle are the λ/2 reflections. The ones indicated by 
red circles are the combined satellites. Again, the possibility of overlaps between the 
combined satellites is evident.  
 

5. Setting up the (3+2)d structure, refinement of q-vectors 
Start Lattice wizard and Ewald explorer 
Press “Activate incommensurate peaks” and select “Add 2d modulation vectors (hklmn)” 
Define two q-vectors: (0.3, 0.3, 0) and (-0.3, 0.3, 0) with maximum satellite index 1 
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Using the sliders, modify the componets to fit with the projected peaks 
 

 
Close Ewald explorer 
In Lattice wizard, press “Incommensurates/Quasi--crystals” 
Use default settings (with mmax = 1); OK 
The refined unit cell + q-vectors index 92% of peaks. The procedure could index about 1800 
combined satellites.  

 

6. Combined satellites in Jana2006 indexing tool 
Using Jana2006 indexing tool is not necessary for getting results in this example. 
Open options of “Save information” and select “Save specific peak table only” 
Save peak table as, e.g., forjana.tabbin 
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Quit Lattice wizard 
Start Jana2006 and open any structure (File → Structure → Open) 
It might be the structure in “some_jana2006_structure” subfolder of the melilite example 
Start Tools → Graphic → Indexing 
In the file manager of Jana2006, locate forjana.tabbin; double click it; OK 
Select Mo KAlpha radiation; OK 
[On the screen: Jana2006 indexing tool] 
 

 
Press “View direction” and select c*; OK 
Press “All to cell ON” 

 
The resulting image projects all peaks positions into one unit cell. We can recognize q1 and 
q2 satellites, combined satellites (the double-points in the middle of the unit cell axes) and 
the λ/2 reflections in the middle of the plot. 

Use  to determine satellites coordinates 
Use Refine cell to obtain refined q-vectors  
Quit Jana2006 
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7. Data reduction 
In the right panel of Crysalis, press “Start/Stop” and select “Data reduction with options” 
[On the screen: Step1: Orientation matrix for data reduction] 
Select “Other (reduction list)” 
OK to confirm a message about non-existing reduction list 
Press “Generate” 
[On the screen: Proffit reduction list generation] 
This tool generates list of reflections, which will be used for the data reduction. 
Crysalis could also read an existing list of reflections (the “Load” button). This list could also 
be produced by Jana2006 and it is very useful for cases when the list cannot be generated by 
Crysalis, e.g. for composite structures or for structures with X centering vectors. In this case, 
however, we can generate the list by Crysalis.  

 
Activate (3+2)d type of the list 

 
Check “use cross q-vector reflections” 
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In the case of a structure with well separated spots, the generated list could be used for all 
data.  
 
In the case of Melilite, the combined (cross) satellites need a special treatment. The previous 
attempts showed that these satellites are partially overlapped and that the best way to 
process them is making the data reduction with a large integration mask. With such mask, 
the pairs of close combined satellites are integrated as a one spot and this can be taken into 
the account in the Jana2006 refinement. However, this large mask is not suitable for main 
reflections and for the q1/q2 satellites. For this reason, the combined satellites must be 
processed separately.  
 
Step 1 - data reduction for q1 and q2 satellites 
 
Clear “use cross q-vector reflections” 

 
OK; NEXT; NEXT 
In the Step 3, clear “Follow significant sample wobbling”; NEXT; NEXT 
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In the Step 5, use outlier rejection for 4/m; NEXT 
In the Step 6, press “Change output name” and define “q1_xor_q2” as an output file name 
OK; FINISH 
The program makes data reduction for main reflections, q1 satellites and q2 satellites, using 
the default integration mask 

In the left toolbar of Crysalis, press  
Select the page “Data reduction output” and look at Rint of main reflections and satellites 

 
The Rint of satellites is poor but we should consider that the program does not show 
separately the observed satellites. Rint of observed satellites will be shown in the Reflection 
report of Jana2006.  
Select the page Graphs 

 
The graph of frame scaling is almost flat, indicating sufficient absorption correction 
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Step 2 - data reduction for combined (cross) satellites 
 
In the next step, we will process the combined satellites. We want to ignore the real position 
of the cross satellites, use instead the position between the pairs of close satellites and large 
integration mask to cover the complete pairs. For this, we have to disable refinement of 
instrument parameters and profile analysis.  
Quit the tool “Inspect data reduction results” 
Start Lattice wizard 
Use the “>” button at “Incommensurate/qusicrystal” and set q-vectors 
q1 = ¼ ¼ 0 
q2 = -¼ ¼ 0  

 
Close Lattice wizard 
In the right panel of Crysalis, press “Start/Stop” and select “Data reduction with options” 
[On the screen: Step1: Orientation matrix for data reduction] 
Select “Other (reduction list)” 
Press “Generate” 
In the line for q1, press “Edit mmax” and define mmax=0 
In the line for q1, press “Edit mmax” and define mmax=0 
Check “Use cross q-vector reflections” 
Press “Edit max index” for the cross q-vector reflections and define mmax=1 

 
OK; YES to confirm that we really want such a list 
Ignore two warnings 
Out of Crysalis, go to the experimental directory and open in a text editor the file 
run.dcredhklmn 
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The file only contains main reflections. This means the current version of Crysalis cannot 
generate simply the list we need. However, we can use the full list + a custom extinction rule 
 
CANCEL; CANCEL 
In the main window of Crysalis - the left toolbar, press the button CMD 
Type command “dc extinct hklmn 0 0 0 1 1 2 1”; ENTER 
This defines that reflections with m+n odd will be skipped 
In the right panel of Crysalis, press “Start/Stop” and select “Data reduction with options” 
[On the screen: Step1: Orientation matrix for data reduction] 
Select “Other (reduction list)” 
Press “Generate” 
In the line for q1, press “Edit mmax” and define mmax=1 
In the line for q1, press “Edit mmax” and define mmax=1 
Check “Use cross q-vector reflections” 
Press “Edit max index” for the cross q-vector reflections and define mmax=1 

 
At the bottom of the “Generate hkl list” window we can see that our custom extinction rule 
is active. It can be checked by “Show rules” button 
OK;  
Crysalis displays warning about missing “nada/um q-vector refinement” but this is OK 
because we do not want to refine q-vectors 
Out of Crysalis, go to the experimental directory and open in a text editor the file 
run.dcredhklmn 
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Now the file contains the combined satellites and main reflections. Main reflections can be 
used for verification of the same scale for both data sets during their combining in 
Jana2006, and then discarded 
(Back in Crysalis) 
NEXT; NEXT 
[On the screen: Step3: Basic algorithm parameters] 
Press “Edit special pars” 
Check “Override integration mask size” 
Define size 1.75 (this number was found by trials and errors) 
Press Alt-E to display hidden options 
Select “Skip model refinement” and “Skip profile fitting” 

 
OK; OK; NEXT; NEXT;  
For outlier rejection, select Lause symmetry “1”, Friedel pairs equivalent 
NEXT;  
OK; “Change output name” -> q1_and_q2 
FINISH 
 

8. Results of data reduction 

After finishing the data reduction, start “Inspect data reduction” by pressing  
The results for combined satellites are poor but this might be caused by their weakness. We 
cannot make any conclusion without refinement of a structure model.  
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The input files for Jana2006 are in the directory /struct/tmp: 
q1_xor_q2.hkl; q1_xor_q2.cif_od 
q1_and_q2.hkl; q1_and_q2.cif_od 
 
The example 5.5.2. where structure of melilite is solved uses different input files: 4d data for 
q1, 4d data for q2 and 5d data for combined satellites. The reason is that we need to have 
the user-independent results. Data created in this example are tested at the end of the 
Example 5.5.2. 
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Example 5.5.2: Melilite 
Solution of a (3+2)-dimensional incommensurately modulated structure with 
overlaps of satellites. 
 
Ca2MgSi2O7  
Revised: 4 September 2019 
Single crystal data measured with Oxford Diffraction four-cycle diffractometer 
 
The structure has two q-vectors: q1=(α,α,0) and q2=(-α,α,0). Satellite reflections h,k,l,m,0 and 
h,k,l,0,n are always well separated in the CCD frames. Combined satellites hklmn, m≠0, n≠0, are 
sometimes separated and sometimes overlapped, depending on their geometry in particular 
CDD frame (i.e. angle ψ). The combined satellites needed different data processing strategy 
using large integration mask because we want to treat them like “always fully overlapped“. 
 

 
Schematic view of the diffraction pattern in melilite. Main reflections are indicated by large 
dark circles, small circles symbolize first-order satellites (grey for m x n = 0 and white for m x n = 
±1 satellites, respectively). 
 
Input files: 
q1.hkl, q1.cif_od (main reflections + satellites described by q1) 
q2.hkl, q2.cif_od (main reflections + satellites described by q2) 
q1q2.hkl, q1q2.cif_od (main reflections + combined overlapped satellites) 
Frame scaling, absorption correction: done with software of the diffractometer 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane – textbox: type “melilite” 
OK 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
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Select “Oxford Diffraction – CCD”; 
For “File name” select q1.hkl; NEXT 
In “Define basic input file“ select “Input from cif_od file“; OK 
Change the modulation vector to 0.278 0.278 0; NEXT 
The used q-vector refinement software (CrysAlis) does not allow restriction that would keep 
all components of the two q-vectors the same 
[On the screen: Define the reference cell / split by twinning] 
Change target dimension to 5 
For 2nd modulation vector type -0.278 0.278 0; NEXT 
The program reads 92323 reflections 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
[On the screen: Data repository] 
Import new 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; 
For File name choose q2.hkl; NEXT 
In “Define basic input file“ select “Input from cif_od file“; OK 
Change the 1st modulation vector to -0.278 0.278 0; NEXT 
Check “Import only satellites”;  
New import of the same main reflections would bias their weighting scheme 
Define transformation matrix (1 0 0 0 0 | 0 1 0 0 0 | 0 0 1 0 0 | 0 0 0 0 1 | 0 0 0 1 0); OK 
This will convert hklm from the input file to hkl0n 
NEXT 
The program reads 92522 reflections, including discarded main reflections 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
[On the screen: Data repository] 
Import new;  
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; 
For File name choose q1q2.hkl; NEXT 
In “Define basic input file“ select “Input from cif_od file“; OK 
Change the 1st modulation vector to 0.278 0.278 0 
Change the 2nd modulation vector to -0.278 0.278 0; NEXT 
Check “Import only satellites”; NEXT 
[On the screen: warning about changed unit cell parameters] 
“Continue with the old reference cell parameters”; OK 
The program reads 147857 reflections, including discarded main reflections 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
OK; YES to accept the data sets 
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3. Symmetry Wizard 
Use all data blocks for the space group test 

 
[On the screen: Tolerances for crystal system recognition] 
For “Maximal ave(I/sig(I)) for extinctions type “20”; NEXT 
Select tetragonal Laue symmetry 4/mmm 
Select P centering 
Select space group P-421m 
At this point there is no difference between P-421m and P4212, the decision is expected 
from the symmetry test of Superflip 
Accept the superspace group in the original cell 
For five-dimensional structures the wizard does not offer selection of superspace group. It 
will be done later on manually. 

4. Creating refinement reflection file 
Follow steps of the reflection wizard, the data sets are on the same scale 
The program discards 206 reflections, 96 observed, Rint(all)=3.31% 
In case that the same scale of the data sets would not be sure, a temporary structure should 
be created with data sets imported together with main reflections. Then we could select 
“different scales” and Jana would use main reflections for finding scaling factors. Then the 
data set would be re-imported with the found scale factors and with main reflections only in 
the first data set. 

5. Structure solution wizard 
Quit 

6. Solution of average structure 
Superflip for five-dimensional structure returns five-dimensional electron density map. 
However, Jana2006 would not evaluate initial modulation functions from this map and we 
would get only the average structure. For this reason solution will be done separately for 
average structure 
Start “Tools → Transformation → Go to average 3d structure” 
For name use “aver” 
Follow steps of the Reflection wizard 
Continue with the new structure 
Start “Run → Structure solution” 
For Formula type “Ca Mg Si O” 
Select “Superflip” and “Peaks from Jana2006” 
Select “Use a specific random seed” and type “333” for random seed 
With this option result of charge flipping will be the same in most computers and origin 
position and special atomic position will be equivalent with this cookbook. For normal work 
Random seed should not be fixed. 
“Run solution” 
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Superflip converges with R around 13% and confirms the selected space group 
“Accept last solution” 
Start EditM50; Go to the page “Composition”; for “Formula units” type “2”; press “Formula 
from M40”age 
It returns Ca2 Mg0 Si3 O7. The expected formula is Ca2 Mg Si2 O7, therefore one of silicon 
atoms is probably magnesium. 
Run Refinement 
Refinement converges with Robs around 14% 
Open “Dist” commands; clear “d(max) derived from atomic radii and typical distances”; run 
“Dist” 
Open listing of “Dist” and check Si-O distances. 
Si2-O3 distances are unusually large (around 1.921 Å), that means Si2 should be changed to 
magnesium 
Using “Edit Atoms”, change atomic type of Si2 to Mg and its name to Mg1 
Run refinement 
Refinement converges with Robs around 14% 
“Edit atoms”: change ADP of all atoms to harmonic 
Run refinement 
Refinement converges with Robs 3.7% 
“Plot structure” 

 
The structure looks normally but ADPs are unusually large 

7. Back to the modulated structure 
“File → Structure → Open”: open “melilite” 
“EditM50, Composition page”: type formula Ca2 Mg Si2 O7, Z=2 
Close Editm50, save changes 
“File → Structure → Copy in”: open “aver” and import only M40 
Run refinement to confirm R value for the average structure: 
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8. Superspace symmetry 
We will need to complete the translation part of superspace symmetry operators. 
“EditM50 → Symmetry”: focus the textbox with the space group symbol and press TAB. 
The program shows two symmetry operators where the translation part in x4 and x5 needs 
to be completed: 

 and  
 
Each translation part has two elements which can be either 0 or 1/2. Thus we have sixteen 
combinations: 0 0 + 0 0, 0 0 + 1/2 0, 0 0 + 0 1/2, 0 0 + 1/2 1/2 … However, some of them are 
forbidden because they lead to a non-consistent translation vector, which cannot be used for 
generation of the superspace group. Finally, we have only eight combinations. In the 
following table we show number of extinct reflections (observed/unobserved) which 
Jana2006 reports for each of these possibilities: 
 

Translations in x4,x5 0 0 1/2 1/2 
0 0 96/206 181/5369 
1/2 1/2 181/5369 96/206 
1/2 0 96/206 181/5369 
0 1/2  181/5369 96/206 

 
Only four possibilities lead to additional extinctions. They are all equivalent as we can judge 
from the exactly same number of extinct reflections as well as from the fact that EditM50 
does not offer creation of new refinement reflection file when we switch between them. 
Another four possibilities without additional extinctions are equivalent, too. The equivalency 
can also be confirmed by the Stokes & Campbell SSG-test which is directly accessible from 
the symmetry page at EditM50.  
 
Thus we have two possibilities for the superspace group: with and without additional 
extinctions. The choice is simple because the additional extinctions mostly concern 
unobserved reflections and therefore the symmetry leading to additional extinctions is 
confirmed by the experiment. 
 
In order to be consistent with the published structure we will choose 0 0 for the first 
symmetry operator and 1/2 1/2 for the second one. 
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Select 0 0 and 1/2 1/2 for the first and the second symmetry operator, respectively 
Close EditM50, save the result 
Create new refinement reflection file 

9. Refinement of modulated structure – position modulation 
Start “File → Structure → Save As” and make backup copy: “melilite_backup” 
Start “Parameters → Options” 
Press “Define wave vectors” 
For the third wave define 1 1 
This means modulation wave vector given by a sum of the q vectors 
For the fourth wave define 1 -1 
This means modulation wave vector given by a difference of the q vectors 
OK; OK; YES to save changes 
“Edit atoms”: set two position modulation waves for all atoms 
This means one harmonic wave with wave vector q1 and one harmonic wave with wave 
vector q2 
In Refinement commands switch to window “Modulation”; for “Overlap option” select 
“Closest reflections”; “max. satellite index” 1; “max. difference in degs” 0.5 
With this settings pair of combined satellites will be treated as fully overlapped reflections. 
Run refinement 
Refinement converges after approx. 20 cycles with the following Robs values for all 
reflections, main reflections, ±(1,0) and ±(1,1) satellites: 23%, 10%, 28%, 36% 
“Edit atoms”: add another two position modulation waves for all atoms 
This means one harmonic wave with wave vector q1+q2 and one harmonic wave with wave 
vector -q1+q2 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 
±(1,0) and ±(1,1) satellites: 9%, 6%, 13%, 11% 
 

10. Contour sections and ADP modulation 
“Start Contour → New plot → Calculate new ones” 
(If no old map exists from previous calculations this option is not active but Contour will use 
it) 
Select observed Fourier 
For “Scope” define Ca1 as a central atom 
For map axes select x1, x4, x3, x2, x5 with limits as shown below 
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This will calculate section x1-x4 through Ca1 as a function of x5 
OK to calculate Fourier map 
In Contour press “Atoms edit” and add Ca1 

                           
Press “Movie” to see the changes of this figure with x5. ESC to stop. 
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Press “New plot” and calculate difference Fourier map for the same section 

                                         
The difference maxima around Ca1 indicate ADP modulation 
Calculate and plot corresponding difference Fourier sections for the other atoms 
All atoms have strong difference maxima and minima 
“Edit atoms”: set two ADP modulation waves for all atoms 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 6.1%, 3.7%, 5.3%, 11.1% for 166 parameters 
Start Contour and repeat plotting of the difference section through Ca1 
The difference maxima are not so large but still not acceptable 
“Edit atoms”: set additional two ADP modulation waves for all atoms 
Run refinement 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 4.8%, 3.1%, 4.5%, 8.1% for 238 parameters 
 
Run Grapht and investigate distances, bond valence sums etc. All obtained graphs will 
depend on “u” coordinate, which can be changed by “Movie” button. 
 

11. Using the data prepared in Example 5.5.1 
Make backup copy of your structure 
“File → Reflection file → Import/modify the reflection file” 
[On the screen: Data repository] 
Delete all data sets 
“Import New” 
Follow steps of the import wizard to import the file “q1_xor_q2.hkl”, i.e. main reflections + 
q1/q2 satellites. The files are located in the struct/tmp directory of the CrysAlis job, input 
and target dimension is 5 



423 Jana2006 Cookbook, version September 2019 
 
 

 
As reference cell parameters, use the ones from previous refinement because they already 
have corrected q-vector components 

 
Do not close the Data repository. 
“Import New” 
Follow steps of the import wizard to import only satellites from the file “q1_and_q2.hkl”.  

 
Use the old reference parameters - this causes that 0.25 atrufucial components of q-vectors 
will not be used 
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Accept changes in data repository 
Follows steps to create refinement reflection file (both data sets are on the same scale) 
Run refinement 
 
Refinement converges with the following Robs values for all reflections, main reflections, 1st 
and 2nd order satellites: 4.4%, 2.3%, 4.1%, 7.9% for 238 parameters 
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Example 5.6: Iodomol 

A molecular modulated structure from single crystal data – molecular 
modulations and tests of positional vs occupational modulation 
Revised: 13 March 2018 
 
Single crystal data measured with a four-circle diffractometer and CCD detector. 
Input files: Iodomol.p4p, Iodomol.ram 
absorption correction: done 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click Iodomol 

2. Import Wizard 
Select “known diffractometer formats”; NEXT 
Select “Bruker-CCD”;  
Click the button “Browse” and double click “Iodomol.ram”; NEXT 
[On the screen: complete/correct experimental parameters] 
Leave all settings default; NEXT;  
[On the screen: Define the reference cell/split by twinning] 
Set target dimension to 4; NEXT; OK TO confirm the import of 52313 reflections  
In the text window, leave all settings default; NEXT; Finish 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 
[On the screen: “Information about starting symmetry wizard”] 
NEXT 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Symmetry wizard can be started separately by “File → Reflection file → Make space group 
test”. 
Leave all settings of the wizard default; NEXT 
[On the screen: “Select supercell”.] 
Confirm “continue with the basic unit cell”; NEXT 
[On the screen: Select Laue symmetry – the Rint values are quite elevated] 
Confirm monoclinic Laue symmetry; NEXT 
[On the screen: Select cell centering] 
Confirm primitive unit cell; NEXT 
[On the screen: Select space group] 
Confirm P21/m; NEXT 
[On the screen: Select superspace group] 
Select P21/m(a0g)0s – out of 1038 potentially absent reflection none is observed, this space 
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group is thus the most likely.  
[On the screen: Final step of the superspace test] 
Accept the superspace group transformed into the original cell: P21/m(a0g)0s; FINISH 

5. Creating refinement reflection file 
We have finished creation of the file M95 (reflections converted from diffractometer format 
to Jana format) and M50 (cell parameters, symmetry). At this step, we will create the file 
M90 containing data set merged by symmetry, with forbidden reflections omitted. 
NEXT to confirm threshold 3sigma;  
OK; OK to confirm information about imported reflections 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
The Rint for observed reflections will be 19.57% 
OK 
Accept the data block and calculate coverage; FINISH; OK 
[On the screen: Information that structure solution will start] 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements: C O H I P 
Check the check box “Use a specific random seed”  
This option is here only to ensure the reproducibility of the calculation. In normal practice, it 
is not necessary. 
Keep all other settings default 
Click “Run solution” 
Superflip converges within a few seconds. It confirms the symmetry P21/m(a0g)0s. 

 
 

This is symmetry found 
by Superflip in the 
electron density map 

This is fit of symmetry 
elements supplied by user 
(small numbers <10)  = good 
fit) 
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Close the viewer of the listing, wait until the structure solution is interpreted 
Click “Draw structure” 
Choose the radio button “Draw average structure” 
If you have followed this tutorial exactly, you should see a picture identical to the following 

(to obtain the picture in Diamond, click the icon “Get molecules directly” - ) 

 

 

If the structure looks slightly different (e.g. shifted by ½ along a or b), you may still continue 
with the tutorial, but the details (atom names, atom positions) may be different. 
Alternatively, you may rerun Superflip until you obtain the solution in the correct setting. 

The structure looks correctly interpreted and complete. Only atoms C1 and C2 should be 
oxygen atoms. 

Close the structure viewer and exit the solution wizard by clicking “Accept last solution” 

7. Checking the structure 
First of all, we will correct the wrong atomic types.  
Double click the icon “Edit atoms” 
Double click atom C1 
Type “O*” in the text box “Name”; Press TAB 
The name changes to the first free number for oxygen, O1 in this case 
Change the atomic type to O;  
Repeat the procedure for atom C2  
OK; Yes to confirm the changes and return to the main window. 

We will now check the modulation functions for all atoms 
Double click the icon “Contour” 
Click the button “New plot” 
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Select the radio button “Show de Wolff’s sections” 
Set the scope of the sections: primary scope to 3, secondary to 0.5 
Click the button “Define atoms for de Wolff’s sections 
In the text box “Atoms” type * (a single star) and click the button “Add”; OK 
OK 
The program calculates the Fourier maps for modulation functions of all atoms (x, y and z 
direction for each atom). It may take some time. 
Go through the de Wolff’s sections for all atoms (using the buttons “W-“ and “W+” or by 
selecting from the list and check, if the modulation functions suggested by Jana2006 follow 
the domains in the Fourier maps. This is an example of the x2-x4 section for I1: 

 

You should conclude that all atoms have been interpreted correctly and the modulation 
functions are a good starting point for the refinement. The only exception is the x1 
modulation function of the atom C11.This could be corrected manually (invert the signs, shift 
the average position), but the refinement is robust enough to correct this single problem 
automatically.  

Quit Contour and return to the main window. 

8. Initial structure refinement 

Go to “File->Structure->Save as” 
In the lower right text box type “Iodomol-solution”; OK 
No to continue with the new structure 
Right-click the icon Refine 
Set the number of refinement cycles to 100: 
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 OK; Yes + Start 
The refinement converges to the following R-values: 

 

9. Refinement of ADP 

So far the atomic displacement parameters (ADPs} are refined as isotropic. We will now set 
them for anisotropic refinement: 

Open “Edit atoms” 
Select all atoms 
Double click any of the selected atoms 
Select the radio button “harmonic (anisotropic)” 
OK; OK; Yes to quit “Edit atoms” 
Double click Refine to refine anisotropic displacement parameters. 

The refinement converges to the following R-values: 

 

Sometimes the displacement parameters themselves are modulated. This may be important 
especially for the heavy atoms. We can try to add one harmonic modulation wave for the 
iodine atoms: 

Open “Edit atoms” 
Select the atoms I1 and I2 
Double click any of the selected atoms 
increase the number of ADP harmonic waves from 0 to 1” 
OK; OK; Yes to quit “Edit atoms” 
Double click Refine. 

The refinement converges to the following R-values: 
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The R-value on the satellite reflections decreased by almost 2%, the modulation of ADPs 
seems significant.  

10. Defining phenyl rings as molecules 

Go to “File->Structure->Save as” 
In the lower right text box type “Iodomol-ref”; OK 
NO to continue with the new structure 
Draw the average structure and check the geometry. Plot the structure with thermal 
ellipsoids. The molecule looks like this: 

 

The result is not a disaster, but the displacement parameters are uneven. The data quality 
may not be sufficient to refine all atoms independently. We can define the three phenyl rings 
as three positions of the same molecule.  

Note the atom names for the free phenyl rings. Marking the phenyl rings as in the image 
above, you should get the following lists: 
Ring 1: C3, C6, C9, C13, C18, C12 
Ring 2: C5, C15, C20, C22, C10, C8 
Ring 3: C16, C17, C19, C21, C14, C11 

Ring 3 

Ring 2 

Ring 1 
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Close the structure viewer. 
Go to Parameter -> Molecules -> New molecule;  
Type “phenyl” in the text box “Name of the molecule”; Next 
Select atoms C3, C6, C9, C13, C18, C12 from the list; OK; 
Choose gravity center as the molecular reference point; Next; 
Note that the occupancy of this position is set to 0.5, because Ring 3 is located on the mirror 
plane. 
Click “Apply + Next position”. 

Add the next position by identifying the model atoms with the atoms of the next phenyl 
ring. Fill the table according to the following picture: 

 

Click “Show coinciding atoms”. You will obtain six coinciding atoms between the model 
molecule and the new position: 

 

 
Click “Apply + Next position” 

Define the third position of the molecule: 
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Check again that all six atoms of the model molecule coincide with the actual atoms in the 
atomic part of the model. 
Click “Apply + End” 

Now we defined all three phenyl rings as instances of a single molecule. The positions of 
atoms in the molecule will still be refined, but one molecule will be placed in three positions 
in the crystal. We also have to redefine the modulation parameters – remove the 
modulation from the atoms and add modulation of the molecular parameters – position and 
rotation.  

Open “Edit atoms” 
Select the six atoms shown in blue – these are the atoms belonging to the molecular part 
Set the number of positional modulation waves to 0 
Reset the displacement parameters to isotropic 
OK; OK; Yes; 
Go to Parameters -> Molecules -> Edit; 
For each position increase the number of positional modulation waves to 1: 

 

OK; Yes; 

Double click Refine to refine the new model. 
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The refinement converges to the following values: 
 

 

Note that the R-values are only marginally higher than in the previous refinement, but the 
number of parameters decreased by a factor of two, from 344 to 194. 

For future convenience, we will now rename the atoms in the molecule sequentially as 
C1…C6: 

Open “Edit atoms” 
Select all atoms 
Click Action -> Rename selected atoms manually 
Rename atom C4 to C8 (to avoid name conflict with the newly named C4) and rename the 
other atoms according to this image: 

 
OK; OK; Yes 
Go to “File->Structure->Save as” 
In the lower right text box type “Iodomol-mol”; OK 
No to continue with the new structure 
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11. Adding of hydrogen atoms 

Double click “Edit atoms” 
Select all carbon atoms 
Click “Action -> Adding of hydrogen atoms” 
Leave all settings default; OK 
Ten hydrogen atoms have been added automatically: four in the atomic parts and six in the 
molecular part. 
OK; Yes to confirm changes 
View the average structure to check, if the hydrogen atoms have been added correctly. 
Hydrogen atoms have been added on all carbons of the phenyl molecule – Jana does not 
recognize bonds between the molecular and atomic part. The atom H1C1 should be deleted. 
Close the structure viewer 
Double click “Edit atoms” 
Right-click atom H1C1; Delete selected atoms; Yes 
OK; Yes to confirm changes 
Double click Refine to refine the structure 
 

12. Viewing and interpreting the structure 

We have so far not looked at the modulated structure in detail. We will now try to interpret 
the modulation. 

Traditionally the modulation functions are interpreted with the help of plots of distances, 
angles, bond-valence sums etc. as a function of the modulation phase. This may be difficult 
for molecular crystals, where the modulation is usually quite complex. It is more useful to 
view the structure either in a supercell or as an animation of the modulation. 

Plotting the supercell 

Open the structure iodomol-mol with the harmonic modulation of the molecules. 
Double click the icon “Plot structure” 
Select “Draw approximant structure” 
Set the range of x from 0 to 5 and for z from 0 to 6 
5x1x6 supercell closely corresponds to the reciprocal values of the modulation vector 
components of (0.19,0, 0.15). We should see a good representation of various phases of the 
modulation. 
Click “Draw+continue” 
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In Diamond fill the unit cell and draw bonds (        icons  and        ). 

If Diamond is too slow, you can speed it up by switching off the rendering – icon  
The best view of the structure is along a. You can see how the rows of the hydrogen iodide 
molecule (only iodine present) form a wave, followed by the oxygen, to which the hydrogen 
iodide molecule forms a hydrogen bond. Therefore the distance iodine-oxygen remains quite 
constant. Also the large changes of the torsion angle of Ring 3 are visible throughout the 
supercell. However, it is still difficult to make sense of the interactions between the molecule 
and the overall picture of the modulation.  

Looking at the movie of the modulation 

The program MoleCoolQt can read and display modulated structure refined by Jana. 
Unfortunately, so far it cannot read modulated molecules. To see the movie, we first need to 
transform the molecular model to purely atomic model. 
First save the structure as iodomol-atomic and continue with the new structure 
Open “Edit atoms” 
Select all carbons and hydrogens from the phenyl molecule (in blue) 
Click “Action -> Atoms from molecule to atomic part 
OK; Yes 
Start the program MoleCoolQt 
Go to “File -> Open…”, locate the file iodomol-atomict.m50 and open it 
You may also drag an icon of M50 displayed in your file manager on the icon of MoleCoolQt 
Keep the selection “Load as modulated structure”; Open 

 

 

Switch off the atom labels – icon  in the top toolbar 
You should obtain this image: 
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Press the key t on the keyboard 

Modulation movie starts. It shows the molecule as a function of modulation phase. Keep in 
mind that this is NOT a movie of the actual molecular motion, although it is tempting to 
interpret it like this! These are snapshots of the unit cell configurations at various modulated 
phases, which are distributed across the whole crystal. 

You may use the options in the menu “Pack” to fill larger part of the structure to see the 
intermolecular interactions and their changes with the modulation phase. 
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Example 5.7: CaCNi 

A simple molecular modulated structure from single crystal data with crenel 
functions 
Revised: 1 October 2017 
 
Single crystal data measured with KUMA four-circle diffractometer and point detector. 
Reference: Petříček, Dušek and Černák (2005), Acta Cryst. B61, 280-286  
Input files: cacni.hkl 
absorption correction: done 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click  CaCNi 

2. Import Wizard 
Select “reflection file corrected for LP and abrorption”; NEXT 
Select “General file on I”;  
In the text box “Input format” Type “*” (single star, without quotes); NEXT 
[On the screen: complete/correct experimental parameters] 
Fill unit cell parameters:  8.4867 15.9511 7.6038 90 90.48 90  
Type the modulation vector on the “1st modulation vector” box: 0.4365 0 0.1307; NEXT;  
In the text window, leave all settings default; NEXT; OK; Finish 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 
[On the screen: “Information about starting symmetry wizard”] 
NEXT 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Symmetry wizard can be started separately by “File → Reflection file → Make space group 
test”. 
Leave all settings of the wizard default; NEXT 
[On the screen: “Select supercell”.] 
Confirm “continue with the basic unit cell”; NEXT 
[On the screen: Select Laue symmetry] 
Confirm monoclinic Laue symmetry; NEXT 
[On the screen: Select cell centering] 
The data were measured with C-centering assumed. Confirm C centered unit cell; NEXT 
[On the screen: Select space group] 
Confirm C2/c; NEXT 
[On the screen: Select superspace group] 
Confirm C2/c(a0g)0s suggested by Jana based on systematic absences 



438 Jana2006 Cookbook, version September 2019 
 
 

[On the screen: Final step of the superspace test] 
Accept the superspace group transformed into the original cell: C2/c(a0g)0s; FINISH 

5. Creating refinement reflection file 
We have finished creation of the file M95 (reflections converted from diffractometer format 
to Jana format) and M50 (cell parameters, symmetry). At this step, we will create the file 
M90 containing data set merged by symmetry, with forbidden reflections omitted. 
NEXT to confirm threshold 3sigma;  
OK; OK to confirm information about imported reflections 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
The Rint for observed reflections will be 2.82% 
OK 
Accept the data block and calculate coverage; FINISH 
[On the screen: Information that structure solution will start] 
OK 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements: Ni Cd C N H 
Check the check box “Use a specific random seed”  
This option is here only to ensure the reproducibility of the calculation. In normal practice it 
is not necessary. 
Keep all other settings default 
The default solution program in Jana is Superflip. If you have other software available (SIR, 
SHELXT), you may link it to Jana in Tools/Programs 
Click “Run solution” 
Superflip converges within a few seconds. It confirms the symmetry C2/c(a0g)0s. 
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Click “Draw structure” (select Draw average structure; Draw+continue) 
If you have followed this tutorial exactly, you should see a picture identical to the following, 
after filling the unit cell with atoms and viewing it down the c-axis: 

 

If the structure looks slightly different (e.g. shifted by ½ along a or b), you may still continue 
with the tutorial, but the details (atom names, atom positions) may be different. 
Alternatively you may rerun Superflip until you obtain the solution in the correct setting. 

This is symmetry found 
by Superflip in the 
electron density map 

This is fit of symmetry 
elements supplied by 
user (small numbers = 
good fit) 
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Close the structure viewer and exit the solution wizard by clicking “Accept last solution” 

7. Checking the structure 
All atoms in the structure are located in the planes a-b at z=0.25, or in the plane b-c, x=0.5. 
We shall view the structure in these planes to understand it better.  

Double click the icon Contour in the main window of Jana:  
Click “New plot”; OK;  
You see now the Fourier map of the structure. A few settings need to be modified to see the 
relevant features:  
Click t-map ON; OK 
Click the button “Go to” and set x3 to 0.25 
Click the button “Contours” and set positive contours to 3; OK 
Click on each atom in the view and check the check boxes to draw the position of the atoms 
(max. distance up to 1 Å) 
You should obtain an image similar to this (inverted colors)  

 

Obviously, Jana placed a single carbon atom in place of every cyano group. There is also a 
split Cd atom of which only one position is marked. However, this picture is just one of many 
unit cells in the modulated structure. To see the complete picture, we will run a movie of all 
configurations:  
Click the button “Movie”, set the start and end of x3 to 0.25, set delay time to 0.5 s and run 
the movie by clicking OK. The movie can be interrupted by pressing Esc. Watch the movie 
carefully and try to understand, what happens in the structure.  
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These are the conclusions we can make from the movie: 

- Atoms C2 and C3 should be deleted and replaced by properly placed C and N atoms of 
the cyano group 

- Atom Cd is modelled by a continuous modulation function, but in fact it is jumping 
between two positions and it is better modelled with a split position. 

We shall now make these modifications by first deleting atoms Cd1, C2 and C3 and then 
placing them in the correct positions: 

Quit Contour by clicking the button Quit 

Double click the icon “Edit atoms”  
Select Cd1, C2 and C3 (hold Ctrl while clicking the atoms), right click and select Delete 
selected atoms; Confirm deleting by “Yes to all”. OK to close the form, Yes to confirm 
changes. 

Return to Contour and make the same plot as before.  
Click t-map ON; OK 
Click the button “Go to” and set x3 to 0.25 (as before) and t to 0.2. 
Set positive contours to 3 
Click the lower of the two split positions of Cd according to the following picture: 

 

In the form that opens, click “Include the selected point as a new atoms in M40”  
Fill the next form according to this picture (i.e. atoms Cd1, atomic type Cd): 
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OK;  
Repeat the procedure with the second split Cd position and with atoms C2, C3, N2 and N3. You 
should add six atoms according to the following scheme: 

 

Please make sure to follow the scheme, so that the atomic names further in the tutorial 
correspond to your structure model. 

If you now click on the Cd atoms and let Jana show the position, you will probably see 
something like this: 

 

The Cd atom sits on the special position (two-fold axis) and the clicked position was slightly 
away. We will correct this offset later. 

Click the button Quit and confirm adding new atoms in the structure model. 

Now we will similarly check the other section of the structure, the plane b-c at x=0.5: 

Double click the icon Contour; 
Click the button “New plot” 
On the left check the radio button Calculate new ones; OK 

Cd1 

Cd2 

N2 

C2 

C3 

N3 
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In the subsequent form open the tab “Scope”, uncheck the box “Use default map orientation” 
and define the b-c plane as the primary plane of the Fourier map according to the following 
scheme: 

 

Select the radio button “Whole cell; OK 
Click the button t-map ON; OK 
Set Contour level to 3 (button Contours) 
Click the button “Go to” and set x1 to 0.5, t = 0 
Click atoms in the view and draw their position. You should obtain this result: 

 

Run movie (button movie, set x1 range to 0.5-0.5, delay time to 0.5) and investigate the 
behavior of the modulation in this plane. Do we need to modify the structure model? 

Your conclusion should be that the model is essentially OK. Atom C4 is modulated between two 
positions and is always present close to the neighboring Cd atoms. The Cd atom oscillates 
between four-fold and two-fold coordination (in this plane!). Atom C4 should be nitrogen 
(ammonium). Atom C1 should also be a nitrogen atom. We can now make the final corrections 
to the initial model: 

Click “Quit” to quit Contour 
Double click the icon “Edit atoms” 
Double click atom Cd1 
on the tab “Edit” change the x-coordinate to 0.5 
Click the button Show/reset site occupancy and update the site occupancy to 0.5; Yes; OK 
Repeat the procedure with the atom Cd2 
Double click the atom C4 
Type “N*” in the text box “Name”; Press TAB 

The name changes to the first free number for nitrogen, N1 in this case 
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Change the type to N;  
Repeat the procedure for the C1 atom. It will become N4 
OK; OK; Yes to confirm the changes and return to the main window. 

Now we have checked and updated the basic structure – atomic types and positions. Now we 
can check the modulation functions of individual atoms. Jana tries to assign harmonic 
modulation functions to each atom after the solution. 

8. Setting up modulation functions 

We will now check the modulation function for all atoms and modify them where necessary. 
Double click the icon “Contour” 
Click the button “New plot” 
Select the radio button “Show de Wolff’s sections” 
Set the scope of the sections: primary scope to 3, secondary to 0.5 
Click the button “Define atoms for de Wolff’s sections 
In the text box “Atoms” type * and click the button “Add”; OK 
OK 
The program calculates the Fourier maps for modulation functions of all atoms (x, y and z 
direction for each atom). It may take some time. 
Go through the de Wolff’s sections for all atoms (using the buttons “W-“ and “W+” or by 
selecting from the list and make notes about the type of modulation for each atom and for 
special function note their centers (denoted x40, it is the x4 coordinate of the center of the 
domain) and widths (length of the domain along x4, denoted Δ). 

You should obtain the following conclusions: 
- Ni1. Saw tooth function: x40= 0.75 (exactly, by symmetry), Δ=1 
- N4: harmonic, existing function is a good first approximation 
- N1: crenel function, x40= 0.75 (this time not fixed by symmetry, the atom is not on special 
position), Δ=0.5 
- Cd1: crenel function, x40= 0.25 (exactly, by symmetry), Δ=0.5 
- Cd2: crenel function, x40= 0.75 (exactly, by symmetry), Δ=0.5; Cd atoms have 
complementary Crenel intervals 
- N2 atom: needs to be split into two positions, N2 and N2b. N2 has a crenel function with 
x40= 0.59, Δ=0.5; for N2b x40= 0.09 Δ=0.5. Splitting is the most prominent in the x-direction. 
x(N2)=0.21, x(N2b)=0.29 
- C2 atom: needs to be split into two positions, C2 and C2b. C2 has a crenel function with 
x40= 0.57, Δ=0.5; for C2b x40= 0.07 Δ=0.5. Splitting is the most prominent in the x-direction. 
x(C2)=0.12, x(C2b)=0.19 
- C3: continuous function, can be harmonic  
- N3: continuous function, can be harmonic  
 
We will now set up these functions for individual atoms 

Quit Contour 
Double click “Edit atoms” 
Double click atom Ni1 
Click the check box “Use crenel” 
In the form that opens set delta to 1, x40 to 0.75; OK 
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Select the radio button “Legendre polynomials in crenel interval” 
Note: we defined the function as crenel, although it looks like a saw tooth. Legendre 
polynomials contain a linearly sloping term, and a crenel function can turn to a saw tooth 
during the refinement. 
Repeat the procedure for N1, Cd1, Cd2, set the parameters according to the list above 
Right click atom N2, select “Split atomic position” 
Set the atom name to N2b; Uncheck the option “Generate restrict commands for REFINE”; 
Apply 
Double click atom N2 and set its Crenel function according to the list above. On the “Edit” 
tab set its x-coordinate to 0.21. Repeat for N2b, set parameters according to the list above. 
Repeat the whole splitting procedure, setting of Crenels and change of x coordinates for the 
atom C2. 

As a last step we will release the width of the crenel domain of Cd1 for later refinement. 
Only this parameter needs to be explicitly released, other domain widths and centers will be 
restricted before the refinement – see below. 
Double click the atom Cd1 
On Card “Edit” click “Occupancy” next to the text “Edit modulation parameters” 
Check the check box next to “delta” 
OK; OK; OK; Yes to quit “Edit Atoms” 

Now we will check that the functions were correctly set: 
Double click Contour 
Calculate new de Wolff’s sections; use the option “Update existing sections” in the form 
Go through the de Wolff’s sections again and check that the functions are properly set. 
Correct the mistakes you might have done. 
These are the sections for Ni1: 

 

The difficult part of the work is over. We have set up the structure model, we have 
understood the structure in quite a detail and now we can start the refinement from a good, 
elaborated structure model. 
Quit Contour and return to the main window. 
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9. Initial structure refinement 

Important: what you have done up to now is very precious. Make sure you copy the job to 
a new job name to preserve the original and to have the chance to return to this point. 

Go to “File->Structure->Save as 
In the lower tight text box type “CaCNi-ref”; OK 
Yes to continue with the new structure 
Plot the average structure. Use “Draw and Continue”, keep the structure view open and 
return to Jana2006 
Right-click the icon Refine 
Set the number of refinement cycles to 100 and damping factor to 0.5: 

 

The last step we need to make before the refinement is setting up restrictions on the 
modulation parameters. The logic of the structure requires that the groups Cd1+N2b+C2b 
have the same “domain of existence”, i.e. are present together in the structure. The group 
Cd2+N2+C2 should also be present together and the two groups are mutually exclusive. 
Furthermore, no vacancy is expected, i.e. either Cd1 or Cd2 is always present. Thus, the 
centers of the crenel domains within each triplet should be equal and between the triplet 
shifted by 0.5. The length of the domains is equal within each triplet, and the domain 
lengths of one triplet are complementary to 1 with the domain lengths of the second triplet. 
We need to define these relationships by means of equations between the atomic 
parameters: 

Go to card “Various”; Click the button “Equations” 
In the text box “Equation” type delta[N2b]=delta[Cd1] 
Click the button Add to add the equation 
Add further equations restricting the domain lengths (parameter delta) and domain centers 
(parameter t40).  
The final list of equations will look like this 

 

Note: There is no equation on t40 of Cd2, because this parameter is fixed by symmetry. 
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OK; OK; Yes + Start 
The refinement converges to the following R-values: 

  

It is a promising start. The high R-values for the 2nd and 3rd-order satellites are not 
surprising, we have not added higher-order positional modulation yet. 

10. Add harmonic waves 

Satellites up to third order are observed. We may add up to three harmonic waves, but first 
we will add only one waves for each light atom and two waves for the heavy atoms. 
Open “Edit atoms” 
Double click Ni1  
Increase the number of positional waves to 2 
Repeat for other atoms, use 2 waves also for Cd1 and Cd2 and 1 wave for all other atoms. 
Close Edit atoms and run refinement again. 
The refinement converges to the following R-values: 

  

Recalculate de Wolff’s sections and check, if the newly refined modulation functions are still 
follow the traces in the Fourier maps. 

The sections look OK, the modulation functions are appropriately describing the electron 
density. The only exception may be the Cd1 and Cd2 atoms, where the functions are too 
curved towards the end of the occupancy domain: 
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The number of waves may thus be decreased to 1.However, testing leads to a significant 
increase of the R-values and we therefore keep two modulation waves on Cd1 and Cd2 at 
least for now.  

Checking the shapes of the modulation waves is an important check to be made after every 
significant change of the structure model to avoid divergence of the model to unrealistic 
parameters.  

11. Refinement of ADP 

So far the displacement parameters are refined as isotropic. We will now set them for 
anisotropic refinement: 

Open “Edit atoms” 
Select all atoms 
Double click any of the selected atoms 
Select the radio button “harmonic (isotropic)” 
OK; 
Set also the number of modulation waves for Cd1 and Cd2 to 1 
OK; Yes to quit “Edit atoms” 
Double click Refine to refine anisotropic displacement parameters. 

The refinement converges to the following R-values: 
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12. Setting up further harmonic waves 

Main reflections and first-order satellites now have nice R-factors, but the fit to the higher 
satellite orders is not yet good. We need to add higher harmonic positional waves to 
properly describe these parameters. There is not universal recipe on the number of harmonic 
waves to be set except that their number should almost never be larger than the number of 
satellite orders. At the same time, the refined waves should not be too wavy and 
unreasonable. 

A little bit of testing (try!) shows that an acceptable setting which lowers the R-value and 
does not lead to unphysical modulation function is this: 

Ni1: 3 waves 
Cd1, Cd2, C3, N3, N4: 2 waves 
N1, N2, N2b, C2, C2b: 1 wave 

Set the number of waves accordingly and run refinement again. 

The refinement converges to the following R-values: 

 

The fit is already quite good, but still not perfect. Further testing and checking of the 
difference Fourier maps shows that the modulation of ADPs of Cd atoms is required to 
improve the fit to the high-order satellites: 
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Open “Edit atoms” 
Select atoms Cd1 and Cd2 
Double click the atoms 
Set the number of harmonic waves for DP modulation to 1: 

 

Close “Edit atoms and run Refine 

The final refinement table looks like this: 

 

13. Plotting the structure 

To understand the structure, it can be plotted in a supercell, or various geometric 
characteristics can be drawn. 
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Example 6.1: KSm 
Revised: 15 October 2018 
 

Data Topic  Level 

X-ray Powder data Modulated structure from 
powder data 

Advance  

Tasks 
Solving a modulated structure from powder data.  

- Profile refinement and structure solution  
- Crenel modulation to describe mixed sites in 4d. 
- Stephen’ formalism for modulated structures 

Initial data 
Data 

Powder data measured with synchrotron radiation, λ = 0.7114 Å 

Input files:  

KSm.dat (powder profile data) 

KSm.txt (additional information) 

KSm.pdf (article about this compound) 

KSm-solution.m40 

KSm-solution.m50 

Additional information: 

Chemical formula: K Sm Mo2 O8 

Unit cell found: 5.5304 5.3019 11.7893 90 90 91.138 

q-vector : 0.56883 -0.12885 0 
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Instructions  

I. Data import  

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click KSm 

2. Import Wizard 

Select “Various CW formats”; NEXT  
CW stands for constant wavelength 
Type “File name” KSm.dat 
Select “Free format of 2th, I, [sig(I)]” and “Another/unknown method”; NEXT  
Fill cell parameters 5.5304 5.3019 11.7893 90 90 91.138 
The string can be copied from KSm.txt by CtrlC + CtrlV 
Change “Target dimension” to 4 and fill q vector 0.56883 -0.12885 0 
For wavelength type 0.7114 and select “Linearly polarized beam”; NEXT; FINISH  
Accept the data in Data repository (Step 1); OK 
Select “Yes, I would like to continue with the wizard”; 
OK. 

Step 1  

 

 

II. Le Bail refinement  

1. Checking data 

[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 

 

 

Notes  
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Profile viewer shows experimental powder profile 
The powder profile is stored in KSm.m95 and in KSm.m90 in analogy to single crystal data 

“QUIT” Leave profile viewer 
“Edit refinement commands”; 0 refinement cycles; OK 
“Run Refine” 
“Show powder profile” 

Notes  
Now the profile viewer shows experimental and calculated powder profile. The calculated 
profile is based on default profile parameters. Bragg positions of satellites are green. By 
default, satellites up to the order 1 are shown. 
The calculated profile is stored in KSm.prf 

Quit; Leave profile viewer 

2. Refinement of profile parameters 

“Edit profile parameters” 
[On the screen: Powder options] 

Notes  
In the initial state, all profile parameters are fixed except background parameters. In page 
“Profile”, GW has a non-zero initial value. All profile parameters are stored in KSm.M41.  

In “Profile” page activate refinement of GW 
In “Corrections” page activate refinement of shift 
Refinement of background terms is enabled by default 
OK (Leave Powder options);  
YES (save changes) 
“Edit refinement commands” 
Set 100 refinement cycles; OK 
“Run Refine” 

Notes  
Profile R factors: [8171/7+1] 
The refinement against 8171 profiles point is based on 7 profile + 1 structure parameters.   
Refinement converges with GOF ≈ 2.4, Rp ≈ 3.7, wRp ≈ 8.1 
The convergence may be slow. You can interrupt the refinement when Rp reaches 3.7% by 
button “End” pressed at the moment when LeBail decomposition is not running 

“Edit profile parameters”:  
In page “profile” activate refinement of cell parameters (a, b, c, gamma) and components 
(q1, q2) of the modulation vector; (Step 1) 
In page “Corrections” set number of Legendre terms for background to 16; OK; YES (step 6)  
“Run Refine” 

 

 

Step 1  
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Notes  
Refinement [8171/24+1] converges with GOF ≈ 1.9, Rp ≈ 3.1, wRp ≈ 6.6 

Press “Edit profile parameters”  
In Page “Profile” activate refinement of GU, GV 
“Run Refine” 

Notes  
Refinement [8171/26+1] converges with GOF ≈ 1.5, Rp ≈ 2.5, wRp ≈ 4.9.  
Waiting for the full convergence is not necessary. Although the profile viewer shows that 
profile description could be further improved, for structure solution this starting point is 
sufficient. 

FINISH;  
YES (to the question about closing the wizard)  
NEXT open a wizard for the space group test 

3. Space group determination 

[On the screen: Tolerances for crystal system recognition] 
Use default; NEXT 
[On the screen: Select Laue symmetry] 
Select the highest one – monoclinic; NEXT 
[On the screen: Select cell centering] 
Select I centering; NEXT 
[On the screen: Information about progress of space group tests. It takes some time…] 
[On the screen: Select space group]; 
Select C2/c; NEXT 
[On the screen: Final step of the space group test]; 
“Accept the superspace group transformed into the original cell”; Finish (Step 5) 
[On the screen: “Do you want to refine profile parameters one more”]; 
Answer “Yes” to refine powder parameters once more.) 
OK; 

Notes  
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The used symmetry speeds up the profile refinement because we are having less Bragg 
reflections due to systematic absences in I2/b space group. Less reflections also causes 
slightly worse Rp factor.  
Refinement [8171/26+1] converges with GOF ≈ 1.7, Rp ≈ 3.1, wRp ≈ 5.7. 

III. Rietveld refinement  

1. Structure solution 

Select “Use Superflip” 
Type formula K Mo2 Sm O8; (please use the same order it is important for the continuation 
of this example) Formula units 2  

Notes  
As in the space group I2/b the minimal site multiplicity is 4, it is clear the Sm and K are 
either alternatively occupying the same position or two positions with half occupancy. The 
first possibility would change the average density at the Sm/K position to a level similar to 
the Mo position, because the average atomic number of Sm/K 40.5 is close to 42 for Mo 
atoms. This means that then we can expect troubles to distinguish the Mo and Sm atom. 

Select “Repeat Superflip: Number of runs”, type 10 runs and 3000 cycles 
Select “Starting model” = “Patterson superposition map” 
Peak from Jana2006 but first run Fourier (Step 1) 

Step 1  

 

 

“Run solution” 
“Accept last solution” closes the structure solution wizard 
[On the screen: Basic Jana window]; 

Notes  
To unify the origin selection with the selection used in the Cookbook, we will not continue 
with the obtained structure model but we will copy the structure model from a file. The 
advanced users can continue with their own model but they should be aware that position 
of crenel functions and shape of other modulation functions may differ of the printed 
figures, because they depend on the origin position. 
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Start “File → Structure → Copy in”  
Import M40 and M50 from the structure KSm-solution. 
Start “Edit atoms” or “Edit/View → Editing of M40” and make sure the atomic positions are 
as follows:  
Sm1 0.500000 0.250000 0.147357 
Mo1 0.000000 0.750000 0.120140 

2. Completing average structure 

Notes  
Atoms in the initial structure model have already modulation functions, which were found 
in the electron density map from Superflip. However, for this example it is better to use the 
classical approach: calculating first the average structure and then refining modulation 
waves from small starting displacements. 

Press “Edit profile”,  
In page “Cell”:  
check “Use only satellites corresponding to existing modulation waves” 
 uncheck refinement of q vector components and a, b, c and gamma. (Step 1) 
In page “Profile” uncheck GU, GV and GW 
In page “Corrections” uncheck shift  
In “Edit atoms” dialogue select heavy atoms (Sm1 and Mo1), go to “Action → Edit/define” 
and set zero modulation waves for occupancy and position. (Step 2) 
OK; OK 

Step 1 Step 2 

 
 

[On the screen: Basic Jana window]; 
Right click on Refine 
In Refinement options go to page “Basic” and set Number of cycles to 100 and Damping 
factor to 0.25 
Uncheck “Make only profile matching” 
OK; YES +Start 

Notes  
R factors [174=153+21/5] 
(174 Bragg reflections, out of them 153 observed and 21 unobserved; 5 refined structure 
parameters) 
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R factors for all reflections : R(obs) ≈11.4, wR(obs) ≈15.5, R(all) ≈13.0, wR(all) ≈15.5  
R factors for main reflexions : R(obs) ≈11.4, wR(obs) ≈15.5, R(all) ≈13.0, wR(all) ≈15.5 
R factors for satellites (not listed)  
Profile R factors : [8171/16+5] 
(8171 profile points, 16 refined profile parameters, 5 refined structure parameters) 
GOF ≈8.5, Rp ≈ 21.6, wRp ≈ 29.1  
Warning: ADP of Mo1 is negative 

Press “Edit atoms” Select Sm1→ Action → Edit/Define atoms 
In page “Edit” activate refinement of occupancy (parameter “ai”) for Sm1 
OK; OK; YES 
Run “Refine” 

Notes  
Rp slightly improves, Occupancy of Sm1 changes from 0.5 to 0.4 and ADP of Mo1 becomes 
positive. The decrease in occupancy of Sm1 indicates that it could be mixed with 
potassium. 

[On the screen: Basic Jana window]; 
Right Click on “Fourier”  
In page “Basic” select in Map type “F(obs)-F(calc)-difference Fourier”, (Step 3)  
In page “Scope” and check “use default map orientation”.  
In the “Peaks” page – “Interpretation of displacement waves” change “No. of harmonics” 
to 0. (Step 4)  

Step 3 Step 4 

  
OK; Yes + Start (Run difference Fourier) 
NO (skip procedure for including new atoms) 

 

Notes  
The fact that both heavy atoms are located at special positions with interatomic vector 
about (0.5,0.5,0) leads to a false symmetry in the map. However, the true maxima should 
form a tetrahedron around Mo1. In the next steps, we will plot Mo1 and neighboring 
Fourier maxima in Diamond. 



459 Jana2006 Cookbook, version September 2019 
 
 

Run “Plot structure”; Select “Draw average structure”; (Step 5) 
Press “Add Fourier peaks”; select all maxima; OK; (Step 6) 

Step 5 Step 6 

 
 

Draw+continue” to start Diamond 

[On the screen: window of Diamond] 
 

Notes  
Jana2006 assigns to the Fourier maxima the lightest chemical element in the formula. 
For our formula, this is the oxygen. Sometimes it may be practical to append another 
light atom to the end of the formula, for instance hydrogen, but not in our case. 

Delete the automatically created structure 
With button  from the bottom toolbar select Mo1 as the only atom to be plotted 
With “Build → Connectivity” focus Mo-O distance and set the limits above 1.5 Å and 
below 2 Å; OK 

Click Mo1 and create its coordination with button  
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Rotate the plot until you recognize a tetrahedron formed by four maxima 

                             
Notes  
The reason, why we are concentrating on Mo coordination, is that Mo-O bonds are the 
strongest ones in the structure and they make usually tetrahedron around the central 
atom. From the chemical formula KMo2SmO8 and the number of 2 structural units in the 
cell, it follows that we are looking two pairs of atoms related by two-fold axis going 
through Mo1 atom. The only acceptable positions for oxygen atoms are indicated in the 
figure by cyan color. This means that only two peaks (Max1 and Max4) are to be 
included to our structure model. 

 

From the basic Jana window run “Parameters→Atom→New”; 
Select “Peaks from the last Fourier calculation”; OK 
Select the first peaks recognized in the Diamond and press “Include selected peak” write 
the name of atom O*; OK (Step 7) 
Repeat the procedure for the second maximum 
Finish; Yes (to include new atoms) 
Run “Refine” 

Step 7  

 

 

 
Notes  
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Refinement, [174=146+28/14] and [8171/16+14] converges with 
R factors for all reflections :: R(obs) ≈5.2, wR(obs) ≈7.2, R(all) ≈7.6, wR(all) ≈7.3  
R factors for main reflexion : R(obs) ≈5.2, wR(obs) ≈7.2, R(all) ≈7.6, wR(all) ≈7.3 
R factors for satellites (not listed)  
Profile R factors : GOF ≈6.9 Rp ≈ 13.9 wRp ≈ 23.5 

Start “File → Structure → Save As” and make a backup copy of the average structure, for 
instance KSm_ave 
No ( you don’t want to continue with the new structure) 

3. Refinement of modulated structure 

Start “Edit atoms” (Select Sm1→ Action → Edit define) and set 1 position modulation wave 
for Sm1 (Step 1) 
Run “Refine” 
Start “Edit atoms” (Select Mo1→ Action → Edit define) and set 1 position modulation wave 
for Mo1 (Step 2) 
Run “Refine” 

Step 1 Step 2 

  
 

Notes  
Refinement: [515/501+14/20] and [8171/16+20] converges with 
R factors for all reflections : R(obs) ≈9.6 wR(obs) ≈12.5 R(all) ≈12.7 wR(all) ≈12.8  
R factors for main reflections : R(obs) ≈5.2 wR(obs) ≈9.1 R(all) ≈5.8 wR(all) ≈9.1 
R factors for satellite reflections: R(obs) ≈15.7 wR(obs) ≈14.4 R(all) ≈17.6 wR(all) ≈14.6   
Profile R factors : GOF ≈6.2 Rp ≈ 12.9 wRp ≈ 21.1 

[On the screen: Basic Jana window] 
Press “Contour”,  
Press “New plot”,  
Select “Show de Wolff’s sections”;) 
Select “F(obs)-Fourier”; Define primary and secondary scope 2 and 1 Å, respectively; 
Check that the option “Sum maps over secondary sections” is activated; (step 3) 
Press “Define atoms for de Wolff’s sections” 
Select Sm1 and Mo1 atoms and all three sections x1-x4, x2-x4 and x3-x4; (step 4) 
OK; OK 

Step 3 Step 4 
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Notes  
With buttons “W-“, “W+” and “From list” we can see modulation curves for Sm1 and Mo1 
atoms. The x2-x4 map for Sm1 will be analyzed in more detail to find possible Sm/K 
ordering.   
The resulting modulation function of Sm1 looks continuously. However, when we follow 
the line by mouse cursor the Density window in the lower right corner displays fluctuation 
of density between 64 and 51 e/A3.  
Because position of potassium does not appear in the average structure and the 
occupation of samarium is lower than 0.5 we assume that samarium mixes with 
potassium. 
In modulated structure, classical disorder is often replaced by distribution of elements 
along x4. We can speculate that the area with lower electron density corresponds to the 
interval (in x4) where potassium exists instead of samarium. However, better background 
for this consideration will be difference Fourier map. 
  

[On the screen: Contour window] 
 Press “New plot”, select ” Show de Wolff’s sections”; OK; 
Change “New map to draw”  to “F(obs)-F(calc) - difference Fourier”; OK; (step 5) 

Step 5  
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F(obs)-Fourier F(obs)-F(calc) - difference Fourier 

  
 

Notes  
The positive maximum in the difference map indicates region with lack of electron density. 
This is the area where fully occupied samarium should be present (instead of the partially 
occupied one). From this map, we can conclude that the definition interval of potassium 
has center in x4=0 and width 0.5. Samarium would occupy a complementary interval with 
center at x4=0.5 and width 0.5. 

QUIT (Leave Contour)  
Start “Edit atoms” 
Right-click Sm1 and select “Split atomic position” (step 6) 
In the dialogue that follows: 
Type K1 for “Name of the split atom” 
Select “K” for “Atomic type” 
Type “0.5” for “Relative occupancy of the split atom” 
Type “0 0 0” for “Shift of the split atom”  
Uncheck “Generate restrict command for Refine” (step 7) 
Apply 
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Step 6 Step 7 

  
 

Notes  
By this way, we have duplicated Sm1, assigned the name K1 and chemical type K to the 
duplicated atom and reduced occupancy of both atoms by 1/2. 

[On the screen: list of atoms in “Edit atoms”] 
Select Sm1 and K1, go to “Action → Edit/define atoms” and check “crenel” (step 8) 

Step 8 Step 9 

  
Switch to the page “Edit”, ensure that “ai” = 0.5 and its refinement is disabled 
Press “Occupancy” 
Type 0.5 for “delta” and 0.5 for x40, OK, OK (step 9) 

Notes  
By this way, we have defined two identical crenel functions for both atoms Sm1 and K1. 
Note that the occupancy “ai” was recalculated back from 0.25 to 0.5 because the reduction 
of occupancy is now managed by the reduced definition interval of the crenel function. 

[On the screen: list of atoms in “Edit atoms”] 
Unselect Sm1 
Right-click K1, go to “Action → Edit/define atoms”  
Switch to page “Edit”; press “Occupancy”, change x40 from 0.5 to 0; OK; OK (step 10) 
Close “Edit atoms” and Yes (save changes) 
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Step 10  

 

 

Start “Contour”  
Press “New plot”, select “Show de Wolff’s Use old maps”; OK; (you obtain the Fourier map 
difference)  
Press Sum on x2 and x3 to make summation OK;  
Press “Atoms edit” and add K1 to the list 
Repeat the procedure for observed Fourier map 

Fourier map Difference Fourier map 

  
 

Notes  
The section shows complementary modulation functions of Sm1 and K1 

[On the screen: Basic Jana window] 
Right click on “Refine”  
In Refinement options, go to the page “Various”, press “Restrictions” 
In the textbox type Sm1 K1 
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Check “Coordinates”, “Modulations” and “ADP parameters” 
For “Occupancies” select “not restricted”; press “Add” (step 11) 

Step 11  

 

 

 
Notes  
This restriction makes the two atoms Sm1 and K1 identical except the definition interval in 
x4 

Leave Refinement options, save them without starting refinement (YES) 
File → structure → Save as (Create backup copy) KSm_crenel 
NO (you don’t want to continue with the new structure) 
Run “Refine” 

Notes  
Refinement: [515/507+8/19] and [8171/16+19] converges with 
R factors for all reflections : R(obs) ≈4.5, wR(obs) ≈ 6.1, R(all) ≈ 4.8, wR(all) ≈6.1  
R factors for main reflections : R(obs) ≈2.4, wR(obs) ≈4.4, R(all) ≈2.7, wR(all) ≈4.4 
R factors for satellite reflections: R(obs) ≈7.1, wR(obs) ≈6.9, R(all) ≈7.4, wR(all) ≈7.0   
Profile R factors : GOF ≈2.7, Rp ≈ 6.4, wRp ≈ 9.3 

“Edit atoms”; select O1 and O2  
“Edit/Define atoms”; add 1 position modulation wave for O1 and O2 
“Refine” 

Notes  
Refinement: [515/509+6/31] and [8171/16+31] converges with 
R factors for all reflections : R(obs) ≈3.8, wR(obs) ≈ 5.1, R(all) ≈ 4.1, wR(all) ≈5.1  
R factors for main reflections : R(obs) ≈2.2, wR(obs) ≈3.6, R(all) ≈2.5, wR(all) ≈3.7 
R factors for satellite reflections: R(obs) ≈5.9, wR(obs) ≈5.7, R(all) ≈6.1, wR(all) ≈5.8   
Profile R factors : GOF ≈2.6, Rp ≈ 6.2, wRp ≈ 8.7 

Using the previously described steps, plot observed and difference Fourier map for Sm1 
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x1-x4 observed x2-x4 observed X3-x4 observed 

 

   
x1-x4 difference x2-x4 difference X3-x4 difference 

 

Notes  
Contour step in the observed and difference map are 10 and 0.2 e/A3, respectively The 
residua in the difference Fourier map are smaller and in different places than before. The 
position modulation now occurs in x2-x4 section. The previously observed modulation in 
the x1-x4 section was caused by pseudosymmetry. 
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4. Better profile description 

File -> structure -> Save as (Create backup copy) KSm_mod 
NO (you don’t want to continue with the new structure) 
In page “Cell”, and check a, b c and gamma. (step 1) 
In page “Profile” check GU, GV and GW 
In page “Correction” check shift; OK; YES 
Run refine 
Press “Profile viewer” and examine the first two peaks of the profile (step 2) 

step 1 step 2 

  
Notes  
The profile width could be probably better described with anisotropic strain broadening 

[On the screen: Basic Jana window] 
Start “Edit profile”, in the page “Profile” 
Select “Tensor method”  
(This method correspond to Stephen’s formalism more description in example 2.9) 
Press “Edit tensor parameters”  
Press “Refine all” (step 3) 
Leave “Powder options” 
Right click on “Refine”  
In Refinement options go to page “Basic” and select “Use Marquart  technique” with the 
default “Fudge factor” 0.001  
OK; Yes + start 
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step 3 step 4 

  
 

Notes  
Refinement: [515=515+0/31] and [8171/45+31] converges with 
R factors for all reflections : R(obs) ≈2.4, wR(obs) ≈ 3.4, R(all) ≈ 2.4, wR(all) ≈3.4  
R factors for main reflections : R(obs) ≈1.8, wR(obs) ≈3.2, R(all) ≈1.8, wR(all) ≈3.2 
R factors for satellite reflections: R(obs) ≈3.1, wR(obs) ≈3.5, R(all) ≈3.1, wR(all) ≈3.5   
Profile R factors : GOF ≈1.6, Rp ≈ 3.8, wRp ≈ 5.5 

Press “Profile viewer”(step 4) 
The width of reflections is now described properly 
QUIT 
Press “Edit profile”, go to the page “Profile” 
Select “Pseudo-Voight” and activate refinement of “Lx” and “Ly” 
Run “Refine” 

Notes  
Refinement: [515=515+0/31] and [8171/47+31] converges with 
R factors for all reflections : R(obs) ≈1.8, wR(obs) ≈ 2.7, R(all) ≈ 1.8, wR(all) ≈2.7  
R factors for main reflections : R(obs) ≈1.4, wR(obs) ≈2.9, R(all) ≈1.4, wR(all) ≈2.9 
R factors for satellite reflections: R(obs) ≈2.3, wR(obs) ≈2.6, R(all) ≈2.3, wR(all) ≈2.6   
Profile R factors : GOF ≈1.3, Rp ≈ 3.0, wRp ≈ 4.6 
 
Some St tensor component may cause oscillations. A careful analysis would be needed to 
select the St components necessary for profile description. We can for instance fix the 
components with low parameter-to-sigma ratio (using the button “Show p/sig(p)” to see 
the ratio) 

Start “Edit profile”, in the page “Profile” 
Press “Edit tensor parameters” then press “Show p/sig(p)” 
Fix to 0 all St* parameters with p/sig(p) < 3*su and uncheck their 
OK; YES 
Run “Refine” 
Plot difference Fourier for Sm1, section x1-x4 

 

Notes  
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The section now displays very small residual density (≈ ±0.4). Depending on the fixed St 
components, the resulting section may look differently. 

  

 

[On the screen: window of Diamond] 

Start “Plot structure” and try to plot the structure in Diamond 

Notes  
For modulated structures, sufficiently large area must be selected for the plot because in 
Diamond we can only plot the supplied atoms. No symmetry transformation (rotation as 
well as translation) is allowed in Diamond because it cannot calculate modulation 
displacements of the transformed atoms. The recommended way is to add atoms 

supplied by Jana2006 using button , connect them using button  and then make 
only selections and rotations. 
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Example 7.1: Ephedrine 
Commensurately modulated structure 
Revised: 3 December 2018 
 
C10H16NOCl 

 
 
Single crystal data measured with Bruker four-circle diffractometer 
Input files: Ephedrine.hkl, Ephedrine.ins 
Frame scaling, absorption correction: done 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click Ephedrine 

2. Import Wizard 
Select “reflection file corrected for LP and absorption”; NEXT 
Select “SHELX on I”; File “Ephedrine.hkl” NEXT 
The measurement was done in a supercell using three indices 
[On the screen: complete/correct experimental parameters] 
Fill supercell parameters as used in data collection. They can be copied (Ctrl-C) from the file 
Ephedrine.ins and pasted (Ctrl-V) to the “Cell parameters” textbox; NEXT 
[On the screen: Define the reference cell/split by twinning] 
Change target dimension for 4 
Define modulation vector 0 0 1/4 
Press “Define transformation matrix” and fill the matrix array by 

1 0 0  
0 1 0  
0 0 1/4  
 
NEXT; FINISH 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 
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4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT 
[On the screen: Select Laue symmetry] 
Select Orthorhombic Laue symmetry; NEXT 
[On the screen: Select cell centering] 
Select P centered unit cell; NEXT 
[On the screen: Select space group] 
Select P212121; NEXT 
[On the screen: Select superspace group] 
P212121(00g)000 
[On the screen: Final step of the superspace test] 
Accept the superspace group transformed into the original cell: P212121(00g)000; FINISH 
[On the screen: Define superspace group] 
OK 

5. Creating refinement reflection file 
In this step we have M95 (i.e. the data from diffractometer converted to Jana format) and 
symmetry. For refinement we need M90 containing data set merged by symmetry and with 
discarded extinct reflections. 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Accept the data block; FINISH 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for C10H16NOCl: C H N O Cl 
Select “Superflip”, “Peaks from Jana2006 but first run Fourier”; Run Solution 
[On the screen: window of Superflip replaced later on by listing of Superflip] 
Superflip converges (after noise suppression) with R value between 20 and 30%. 
Note that we don’t fix random seed and the exact result of Superflip will differ between runs 
Close the listing of Superflip 
Press “Accept last solution” 

7. Verification of the structure solution 
Start EditM50; go to page “Composition”; press “Formula from M40” 
[On the screen: Information about formula] 
It should display formula C10 H0 N O Cl which means that all atoms except hydrogen atoms 
were localized. In the case that some atoms are missing they can be found from subsequent 
refinement and difference Fourier maps. In the case that the Superflip gives some additional 
false atoms they usually are detected in the refinement as atoms having non-realistic (too 
high) isotropic ADP and they will be automatically eliminated by putting their occupancy to 
zero. The atoms being eliminated can be later deleted in “Edit atoms” with help of button 
“Select rejected”. 
Start “Plot structure” to check assignment of chemical types (by comparing with the 
structure formula given at the beginning of this chapter). Use the option “Draw average 
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structure”. 
If some atom in the plot looks like a false maximum it should be deleted by “Atoms edit” 

8. Refinement of the modulated structure 
Start Refine with default parameters. 
You should get R values about 9.3%, 7.5%, 7.6% and 31.2%. 
If some atoms are missing they should be found in difference Fourier, added to the structure 
model and the refinement should be repeated 
Start “Edit atoms”, select all atoms, change ADP to harmonic (anisotropic) ones and repeat 
the refinement. 
You should get R values about 8.4%, 6.4%, 6.5% and 31.4%. 

9. Adding hydrogen atoms 
Start “Edit atoms”, select all carbon and nitrogen atoms and add hydrogen atoms 
automatically. 
For nitrogen atoms automatic procedure is not reliable, hydrogen atoms will be added 
manually 
[On the screen: Adding of hydrogen atoms for N1] 
Select “Tetrahedral”, change number of neighbors to 2 
You can verify the neighbors by focusing the textbox with the first neighbor and clicking 
“Select neighbors” 
Define names of hydrogens, for instance H1N1 and H2N1 
“Apply” 
 
Run EditM50 and go to page Composition, press Formula from M40. The found formula 
should be C10 H15 N O Cl which means that one hydrogen atom bounded to O is missing. 
This atom will be localized later from the Fourier map. 
Run refinement 
Refinement converges with R value about 6.2%, 3.4%, 4.9% and 31.6%. 

10. Localization of the remaining hydrogen atom 
Right-click the icon of Fourier 
In page “Basic” select “Map type” as  “F(obs)-F(calc) – difference Fourier” 
In page “Basic” select “Apply sin(th)/lambda limits” and set tli limits from 0 to 0.5 
This will suppress noise originated from high order reflections, to which H atoms contribute 
negligibly 
In page “Scope” select “Automatically” and use the default parameters for “Independent 
parallelepiped” 
Run Fourier. 
[On the screen: Do you want to start the procedure for including of new atoms?] 
Answer yes. 
One of the dominating maxima should have a reasonable hydrogen distance to the oxygen 
atom O1. Add it as a new hydrogen atom (named e.g. H1O1). 
Right-click the icon of Refine; select page “Various”; press the button “Keep commands” 
Restrict ADP parameter of the newly introduced hydrogen atom. 
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Add the new keep command and start the refinement procedure. 
Refinement converges with R value about 6.0%, 3.2%, 4.9% and 31.60%. 
Verify by plotting that the hydrogen in OH has a reasonable position 
Save the structure with a new name e.g. “Ephedrine-incomm” but continue with the old 
one. This structure will be used for a final comparison with two commensurate cases. 

11. Introduction of the commensurate option and twinning 
Start EditM50, go to page Cell. 
Select “Commensurate case” and “Use simple supercell” 
In text box “Supercell” type “1 1 4” 
Press button: “Select supercell group” and select Tzero = 0 + n/4 which represent 
monoclinic symmetry with two-fold screw axis along a. 
As the supercell symmetry is lower than orthorhombic we may have two twinning domains 
related either by two fold axis along b or along c direction. 
Select twinning and define the twinning matrix as a 180 degrees rotation along c axis. 
The selection of the commensurate model leads to different Laue symmetry and different 
extinctions and therefore we should generally redo the creation of the reflection file for the 
refinement. But for better comparison of tested models we shall skip this point. 
YES to the question “Do you want to rewrite M50 file ?” 

“DO you want to re-create refinement reflection file now?” NO in order to skip re-creation 
of the reflection file 
Go to “Parameters/Twin fractions” and allow refinement of twvol2 
Run Refine. 
Refinement converges with R value about 3.6%, 2.7%, 3.9% and 8.0%. 
Save the structure with a new name e.g. “Ephedrine-comm-1” but continue with the old 
one. 
This structure will be used for a final comparison with two commensurate cases. 

12. Commensurate case for t0=1/16 
Repeat the point 11 for Tzero = 1/16+n/4. 
NO in order to skip re-creation of the reflection file 
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Run Refine. 
Refinement converges with R value about 3.6%, 2.7%, 3.9% and 8.0%. 
The result is similar like in the previous commensurate model 
Save the structure with a new name e.g. “Ephedrine-comm-2” 

13. Incommensurate model with overlap option 
Go to “File → Structure → open” and select files containing the incommensurate 
refinement. 
In the incommensurate refinement, we are not taking into account the fact that main 
reflections are overlapped with satellites of fourth order and the satellites of the first order 
are overlapped with those of the third order. Even more serious are overlaps of the second 
order satellites as they have in average similar intensities. 
For the commensurate structure, the program calculates structure factors as a summation 
over really existing t sections, taking into account t0 value and with symmetry elements 
being closed in the supercell. Thus we get the same result for reflections: 
 
(h,k,l,m), (h,k,l+1,m-4), (h,k,l-1,m+4) e.t.c. 
 
On the other hand, in incommensurate structure model overlaps must be determined based 
on the proximity of reflection angles 
 
Start Refinement options 
Select page “Modulation” and activate overlap option “Closest reflections”; OK 
Run Refinement 
 
Refinement converges with R value about 3.6%, 2.7%, 3.9% and 8.0%. 
 

Conclusion: Modulations are not very strong and therefore all three models give very similar 
results 
 
Further possible steps: 
 
- for selected model second modulation wave can be added, but it has just a minor effect:             
R value about 2.9%, 2.5%, 2.9% and 6.5%. 
 
- we can deactivate twinning and verify by refinement if it was really needed (it was!) 
 
- hydrogen of OH group probably should not have individual modulation waves. They can be 
made the same like modulations of the parent atom in “Refinement options → page Various → 
Restrictions” 
 
- In the incommensurate refinement the overlaps detected by the program can be printed in the 
refinement listing if we activate the option in “Refinement options → page Select/Listing → 
Print twin/overlap details” 
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Example 7.2: CrPOcom 
Revised: 14 March 2018 
Cr2P2O7  
 
Single crystal data measured with Oxford Diffraction four-cycle diffractometer 
Input files: CrPOcom.hkl, CrPOcom_red.sum 
Frame scaling, absorption correction: done with software of the diffractometer 
 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click CrPOcom 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Define basic input file: select Input from “sum” file; OK 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 

4. Symmetry Wizard 
Use default tolerances for crystal system recognition 
Select monoclinic Laue symmetry 
Select C centering 
Select space group C2/m 
Select superspace group C2/m(a0g)0s 
Accept the superspace group in the original cell 

5. Creating refinement reflection file 
Follow default steps of the wizard 

6. Structure solution wizard 
Type the formula Cr2 P2 O7, two formula units 
Select “Superflip” and “Peaks from Jana2006”; “Run solution” 
Superflip converges with R around 25%, confirms the selected superspace group 
Close the listing of Superflip 
“Accept last solution” 
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7. Workaround to get the same atomic positions like in this cookbook 
Superflip returns arbitrary symmetry equivalent origin position. This would complicate 
reading of the cookbook because atomic positions and Fourier sections could be different 
(shifted, transformed) than it is described in the text. At this point, we shall use a saved 
Superflip solution compatible with the cookbook: 
With your file manager:  
copy superflip.m40 to jobname.m40 (“jobname” is name of your current job) 
copy superflip.m80 to jobname.m80 
copy superflip.m81 to jobname.m81 
Jana2006 can be open during copying as it always unlocks the files when going to the basic 
window 
M40 contains structure model from Superflip, M80 contains structure factors found by 
Superflip, M81 is the electron density map calculated from M80 
 
Plot the average structure with Diamond 
 

 
From the plot, it is clear that the two positions of the bridging oxygen O2 are probably 
separated in the modulated structure with a crenel function 
Click with right mouse button on the icon “Dist” and select the listing form “with symmetry 
code”; OK; “Yes+start”; “Yes” to open the listing; 
The short O2 – O2 distance (about 1.19 Å) is between O2 and the O2 related by the 
symmetry operation –x+2, -y, -z+1 – Jana code O2#s3t2,0,1 

8. Inspecting modulation functions returned by Superflip 
Start Contour and “New plot” 
Select “Show de Wolff’s sections” and set following parameters: 
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Press “Define atoms for de Wolff’s sections” 
Add all atoms, for each of them select sections x,y,x. 
OK; OK 
In Contour, plot the section using “W+”, “W-“ and “From list” 
 

 
 
Oxygen O2 has x2=-0.07, its symmetry equivalent position has x2=+0.07. Therefore we can 
define a crenel function of the width 0.5 and the center 0.75 which will be transformed by 
the symmetry to the crenel function with the same width, the center 0.25 and x2=+0.07. This 
will describe “skipping” of the bridging oxygen between two positions separated by the shift 
in x4. 
 
Similarly like in example 5.3.2 (incommensurate phase of Cr2P2O7), we will combine crenel 
functions with position modulations expressed by Legendre polynomials.  
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Leave Contour, start “Edit atoms” 
Edit O2: in “Define” page check “crenel” (it will add one occupation wave) 
Set delta=0.5 and x40=0.75; OK 
Select “legendre polynomials in crenel interval” 
Leave Edit atoms (save the results) 
Plot the same section with Contour, using the button “From list” 
In “Atoms edit” (of Contour) add atoms O2#s4 

 
 
The Contour plot now shows the two crenel functions related by symmetry operation  
–x1+2,-x2,-x3+1,-x4 
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Using the button “From list” in Contour, plot similar x2-x4 sections for P1 
 

 
P1 needs more modulation waves (will be added later) 
 
Using the button “From list” in Contour, plot x1-x4 sections for Cr1 
 
 

 
Cr1 should be described with by crenel function with center 0.25 and width 1 combined with 
positional modulation to create discontinuity at x4=0.75. 
 
Similarly like for O2 define crenel function for Cr1: x40 = 0.25, delta = 1 
Select “Legendre polynomials in crenel interval” 
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Plot the same section with Contour: 

 
 
Using the button “New plot” in Contour plot x2-x4 sections for O1 
 

 
O1 has no discontinuity and only small positional modulation 
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Using the button “New plot” in Contour plot x1-x4 sections for O3 
 

 
 
O3 should be described with sawtooth function. 
Similarly like for O2, define crenel function for O3: x40 = 0.69, delta = 1 
Select “Legendre polynomials in crenel interval” 
Plot the same section in Contour: 

 

9. Refinement 
With commensurate structures, crenel function can be used but its center and width cannot 
be refined, as their changes give zero derivations, which would lead to singularity problems 
during refinement. 
Start “Editm50”: check “Commensurate case”, “Simple supercell”, supercell 3 1 2, Tzero = 0 
Follow wizard for creating the refinement reflection file 
Start Refinement commands: 100 cycles, damping 0.5 
Refine 
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Refinement converges with 18%, 8%, 13%, 46% and 56% for all, main, 1st order, 2nd order 
and 3rd order (31 refined parameters). 
Add the second position modulation wave for all atoms except O2 
Refine 
Refinement converges with 8%, 4%, 6%, 15% and 48% for all, main, 1st order, 2nd order and 
3rd order (48 refined parameters).  
Define harmonic ADP for all atoms 
Refine 
Contour: plot relevant sections for O2, O3 and Cr1 
 

 

 

 

O2 O3 Cr1 
 
Add second position modulation wave for O2 
Refine 
At the message about singularity, choose “Skip warnings” 
Open refinement listing and use Use “Go to → Singularity report”  
For commensurate refinement, the second modulation wave for O2 cannot be used. It would 
introduce more refinement parameters than the structure would have in a supercell 
description. 
Delete the 2nd position modulation wave for O2 
Add the 3rd position modulation wave for all atoms except O2 
Refine (with skipped warnings) 
Adding the 3rd position modulation wave improved significantly the fit! 
Look at the singularity report in the refinement listing 
The list of blocked parameters contains either “cos3” terms (for harmonic modulation) or 
“ort6” terms (for Legendre modulation). This means that the second halves of the third 
modulation waves are forbidden (for the same reason given for O2).  
“Refinement commands → Various → Fixed commands”  
Use “Set individual” and set “*cos3[*]” to zero 
Use “Set individual” and set “*ort6[*]” to zero 
“?” and “*” are wildcards. 
Refine 
Refinement converges without warning messages to 2.7%, 2.5%, 2.6%, 2.8% and 4.1% for 
all, main, 1st order, 2nd order and 3rd order (72 refined parameters). 
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Add one harmonic ADP modulation wave for all atoms 
Refine 
Refinement converges without warning messages to 2.1%, 2.2%, 1.9%, 2.1% and 2.6% for 
all, main, 1st order, 2nd order and 3rd order (104 parameters). 
 
“Parameters → Extinction”: set isotropic Lorentzian extinction 
Refine 
Refinement converges without warning messages to 2.1%, 2.1%, 1.9%, 2.1% and 2.5% for 
all, main, 1st order, 2nd order and 3rd order. 
Number of refined parameters: 105 
 

10. Binding t40 of O2 and O3 
Start Grapht. 
With New/Edit: “Parameter to draw” = displacement - dy; “p” from -0.3 to 0.1; t from 0 to 
1; Central atom P1; step in t 0.001; Color Red; 
 

 
 
Press “New Item” and define the same for O2 color “Green”; 
Press “New Item” and define the same for O3 color “Blue”; 
 
OK to plot; Press the button “Option” and select “Indicate commensurate t sections”: 



488 Jana2006 Cookbook, version September 2019 
 
 

 
 
In a detailed view, it is clear that the discontinuity in O3 occurs at slightly different t then the 
discontinuity in O2. However, this small discrepancy does not make any effect in this 
commensurate case as only the t sections indicated by the dashed lines are present in the 
real supercell and the t points of discontinuity are far from the dashed lines.       
Close Grapht 

11. Transformation to supercell 
Start “Tools → Transformations → Go to supercell structure” 
Follow the wizard for creating refinement reflection file 
Continue with the new (supercell) structure 
EditM50: check cell parameters (3x1x2 supercell) and symmetry (I2/c) 
Refinement commands: set 0 cycles 
Refine 
Refinement (with zero cycles) confirms overall R value found previously in the 
commensurate model 
Number of structure parameters is 151. This means we were able to get satisfactory results 
in commensurate refinement saving 46 parameters. 
Supercell model can be used for plotting of the structure and for calculation of geometry 
 
“File → Structure → History”: return to the commensurate model 
“File → Save As”: make a backup copy 
Set three ADP modulation waves to all atoms 
Refine – skip warnings 
The number of refined parameters is now much larger but no further improvement o R 
values occurs. By adding modulation waves and fixing forbidden components to zero we 
should finally reach the same number of structural parameters in the commensurate and 
supercell model. 
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Example 7.3: PhenanTin 
Commensurate and supercell description of a five-fold superstructure. 
Revised: 15 March 2018 
 
Bis(aquachlorotriphenyltin 1,10-phenantroline), C150 H125 N10 O5 Cl5 Sn5, Z=4 
 
Single crystal data measured with four-cycle diffractometer SuperNova 
Input files:  
PhenanTin.hkl, PhenanTin.cif_od (diffraction data indexed in the supercell - see later) 
phenantroline-no-symmetry.m45 (pattern molecule phenantroline) 
phenantroline-no-symmetry.jpg 
phenyl-no-symmetry.m45 (pattern molecule phenyl) 
phenyl-no-symmetry.jpg 
supercell_keep.txt (pre-prepared keep commands for supercell refinement) 
 
Chemical diagram: 

 
 
Introduction 
Structure of this compound has been published in Journal of Science and Technology in the 
Tropics (2005), 1, 157-163, as a commensurately modulated structure. The data from Nonius 
KappaCCD diffractometer  contained strong main reflections and weak first and second order 
satellites with ratio of intensities 1000 : 0.157 : 0.075. Later on the compound was remeasured 
with much more intensive source of the Rigaku Oxford Diffraction SuperNova. In the new 
experiment, the satellites were strong and the structure could be solved in a five-fold supercell 
as a classical three-dimensional structure. This example uses data of SuperNova and compares 
possibilities of the commensurate and supercell structure refinement.    
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Reciprocal space with peak positions projected along b*. Black: unit cell for commensurate 
refinement; Red: unit cell for supercell refinement.  

Relationship between unit cells in direct space: 

Tcomm->sup = �
1 0 1
0 −1 0
3 0 −2

�;  Tsup->comm = �
2/5 0 1/5

0 −1 0
3/5 0 −1/5

� 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click PhenanTin 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Define basic input file: select Input from “cif_od” file; OK 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 

4. Symmetry Wizard 
Use default tolerances for crystal system recognition 
Select monoclinic Laue symmetry 
Select P centering 
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Select space group P21/n 
Although it is not first in the list, FOM is almost the same like for P2/n and the button 
"Details" shows that the discarded reflections are very weak  
Accept the space group transformed into the original cell; FINISH 

5. Creating refinement reflection file 
Follow default steps of the wizard 
Rint ~ 4.8% for 24879 reflections 

6. Structure solution wizard 
Type the formula C150 H125 N10 O5 Cl5 Sn5, four formula units 
Density should be 1.53 g.cm-3 
Select “Superflip” and “Peaks from Jana2006”; “Run solution”  
Superflip converges with R around 20% and confirms the selected space group 
“Accept last solution” 
Plot the structure 

 
The structure model returned by charge flipping contains most of the expected structure 
and it could be finished by adding maxima from difference Fourier and possibly by applying 
geometry constraints imposed during the refinement. However, we would like to try 
commensurate refinement in order to see its pros and cons.  

7. Data import for commensurate refinement 
 As the structure handled in the 3d supercell cannot be simply transformed to the 
superspace, we have to re-create the structure. We will use the same job name. 
 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click PhenanTin 
YES to overwrite the existing job name 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Define basic input file: select Input from “cif_od” file; OK 
[On the screen: Complete/correct experimental parameters] 
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Leave all settings unchanged; NEXT 
[On the screen: Define the reference cell/split by twinning] 
Change target dimension to 4 
For "1st modulation vector" type 0.2 0 -0.2 
The modulation vector has several possible settings. For instance, the original publication 
used (0.2,0,0.8). However, the short q-vector as defined here is the most logical selection. 
Press "Define transformation matrix" 
[On the screen: Define the transformation matrix] 
Define the following 3x3 matrix: 2/5 0 1/5; 0 -1 0; 3/5 0 -1/5 
“inp” means the input indices; “float” means the transformed indices. They can generally be 
real numbers, in such case the program tries to index them as satellites 
OK 
The transformed experimental unit cell parameters should be as follows: 

 
NEXT 
The wizard transforms indices according to the defined transformation matrix. Resulting 
integer indices are sorted as main reflections while the others as satellites defined by the q-
vector. 
For absorption correction select “None or done before importing”; NEXT 
FINISH 
OK; YES to accept the data set in the Data repository 

8. Symmetry Wizard 
Use default tolerances for crystal system recognition 
Select monoclinic Laue symmetry 
Select P centering 
Select space group P21/c 
Although it is not first in the list, FOM is almost the same like for P2/n and the button 
"Details" shows that the discarded reflections are very weak  
NEXT 
Select superspace group P21/c(a0g)0s; NEXT 
Accept the superspace group transformed into the original cell; NEXT 
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9. Creating refinement reflection file 
Follow default steps of the wizard 
Rint ~ 4.8% for 24879 reflections 

10. Structure solution wizard 
Type the formula C30 H25 N2 O Cl Sn, four formula units 
Density should be 1.53 g.cm-3 
Select “Superflip” and “Peaks from Jana2006 – but first run Fourier”;  
For “Starting model” select “Patterson superposition map” 
“Run solution”  
Superflip converges with R around 22% and confirms the selected superspace group 
“Accept last solution” to leave the structure solution wizard 
Start "Plot structure" 
Select "Draw average structure" and press "Draw+return" or "Draw+continue" 
In Diamont start "Build → Get molecules"  

 
The structure model obtained from charge flipping contains fragments of phenyls and 
phenantroline, Sn, Cl and water oxygen assigned as carbon C1. In commensurate description 
we have only one symmetry independent Sn.  

11. Initial commensurate refinement 
 As the only special position in the superspace group P21/c(a0g)0s is the inversion center, 
which is not compatible with the assumed shape of the molecule, all atoms should be 
localized in general positions.  Thus one atom in the commensurate structure represents five 
atoms in the supercell structure, i.e. 15 positional and 30 ADP parameters. Therefore, each 
atom in the commensurate structure can have maximally two positional (12 parameters) 
and two ADP (24 parameters) modulation waves (each wave of order n represents two 
periodic components – sin2πnx4 and cos2πnx4), which make together with the basic position 
and the basic ellipsoid 3+12=15 positional and 6+24=30 ADP parameters. 
At this stage all atoms from the charge flipping model already have one position modulation 
wave interpreted from the electron density map provided by Superflip. 
 
Start "Edit atoms"; change chemical type of C1 (may be also N1) to oxygen and its label to 
O1; 
OK; YES to save changes 
Start "EditM50" 
Check "Commensurate case" 
Clear "Use simple supercell" 
Press "Define supercell matrix" and type 1 0 1 ; 0 -1 0 ; 3 0 -2 
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This is transformation from commensurate to supercell parameters 
OK 
Press "Select supercell group" 
The program lists all supercell space groups, which can be obtained by changing the tzero 
value. As we know from the preliminary calculations that the symmetry in the supercell 
should be P21/n, we should select one of the two equivalent possibilities.  
Select Tzero 0+n/5; OK 
OK; YES to rewrite M50; YES to re-create refinement reflection file 
Follow steps for merging the reflections; FINISH 
Now we have set up the commensurate refinement. In our case, it means that modulation 
functions will only have 5 definition points.  
Start refinement 
The refinement converges with Rall~38%, Rmain~18% (your numbers can be different) 
Start "Edit atoms" 
Double-click Sn1 and change number of position modulation waves to 2 
OK; OK; YES to save changes 
Start Refinement options; set 100 refinement cycles; OK; YES+START 
The refinement converges with Rall~24%, Rmain~14%, Rsat1~27% and Rsat2~31% 
These numbers can be different because Superflip may have returned different number of 
carbon atoms. However, if R values at this point are significantly larger, for instance Rall > 
26% or Rsat2 ~ 50%, please do not continue and repeat structure solution (return to the 
point 10.). 
Start "Edit atoms"; Select rejected atoms if exists and delete them;  

12. Structure completing from difference Fourier 
Start "Edit atoms"; Select rejected atoms delete them (if exist) 
Start Fourier options; select the page "Basic" and "Map type" difference Fourier 
OK; YES+START 
YES to start procedure for including new atoms 
Activate “Skip peaks being too close to existing atom” and set 1.1 Å 
Include maxima with reasonable C-C distances named C* (i.e. the next free carbon label).  
FINISH; YES to include new atoms 
We don’t need a complete structure, just some atomic positions. For correct placement of 
molecules in next steps, we need to recognize phenantroline and phenyl. For recognizing N 
atoms of phenantroline, it is useful to plot “ellipsoids” although we refine isotropic ADP: 
smaller rings will indicate heavier atoms.  

13. Preparation for rigid body description 
Refinement of a commensurate structure with very strong satellites may be difficult. In this 
example, the refinement could easily finish in a false minimum with distorted geometry of 
phenyls and phenantroline. Therefore, for the initial refinement we will use fixed rigid bodies 
pre-defined in M45 files. 
Atoms used for definition of a rigid body position must belong to the same fragment without 
need of symmetry transformation. In the next step, we will manage that atoms in M40 are 
properly transformed.    
Start "Edit atoms"; select all atoms 
“Action” → “make symmetry contiguous motifs” 
OK; YES to rewrite changes 
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Start "Plot structure" 
Select "Draw average structure"; press "Draw+continue" 
In Diamond use "Build → Add all atoms" 
This adds all atoms from the structure model without applying symmetry.  
Start "Build → Connect atoms" 
The plot may differ for actual solutions but it should display all atoms important for 
introduction of rigid body of phenyl and phenantroline. In our case, the plot also includes 
some spurious maxima, but it does not matter. 
For each phenyl and for the phenantroline note labels of three atoms, which will be used 
for placing complete phenyl and phenantroline templates from m45 
In case of phenantroline note also orientation of the fragment because atoms (here) C2 and 
C3 must fit with proper N1 and N2 of the template  

  
Quit Diamond or let it open for a later reference (depends on style of work) 

14. Rigid body templates from M45 
Start "File → Structure → Save As" 
Make backup copy of the structure 
Start "Parameters → Molecule → New molecule" 
Select "Model file" 
For "Name of molecule" type "Ph" 
Press "Browse" and select "phenyl-no-symmetry.m45" 
Keep the default scaling distance 
Press the button “Show the model molecule” 
[On the screen: Windows opens jpeg plot of the template in a default viewer. Note that the 
atom labels of the template phenyl end with "p" in order not to mix with any atoms of the 
structure. Close the jpeg plot.] 
NEXT 
[On the screen: "Specify atomic types in the model molecule:" dialogue for matching 
chemical types in the template molecule and in the current structure.] 
Keep the suggested chemical types; NEXT 
[On the screen: Define the molecular reference point] 
Select "Geom. center"; NEXT 
[On the screen: Define and complete molecular position #1] 
Pair the following atoms (your labels will differ!) 
C1p with C28 
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C2p with C12 
C6p with C17 
For "Maximal coincidence distance" type 0.8 
Press "Show coinciding atoms" 
The expected coincidence ratio in our example is 6/11 (in case that all carbon atoms were 
previously localized from the difference Fourier) 

 
Press "Apply+Next position" 
[On the screen: Define and complete molecular position #2] 
Pair atoms: 
C1p with C8 
C2p with C10 
C6p with C13 
The coincidence ratio (in our example, it may differ) will be 5/11 
Press "Apply+Next position" 
[On the screen: Define and complete molecular position #3] 
Pair atoms: 
C1p with C11 
C2p with C6 
C6p with C20 
The coincidence ratio (in our example, it may differ) will be 6/11 
Press "Apply + End" 
Now we continue with phenantroline 
Start "Parameters → Molecule → New molecule" 
Select "Model file" 
For "Name of molecule" type "Trol" 
Press "Browse" and select "phenantroline-no-symmetry.m45" 
Keep the default scaling distance 
Press the button “Show the model molecule” 
[On the screen: Windows open jpeg plot of the template in a default viewer. Note that the 
atom labels of the template phenantroline end with "t" in order not to mix with any atoms 
of the structure. Close the jpeg plot.] 
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NEXT 
[On the screen: "Specify atomic types in the model molecule:" dialogue for matching 
chemical types in the template molecule and in the current structure.] 
Accept suggested chemical types; NEXT 
[On the screen: Define the molecular reference point] 
Select "Explicit"; type N1t; NEXT 
[On the screen: Define and complete molecular position #1] 
Pair the following atoms (your labels will differ!) 
N1t with C3 
N2t with C2 
C17t with C16 
Be careful with matching the correct orientation of the molecule, interchanging of N1t and 
N2t would change it 
For "Maximal coincidence distance" type 0.8 
Press "Show coinciding atoms" 
The expected coincidence ratio in our example is 14/22 (depends which carbon atoms were 
previously localized from the difference Fourier) 

      
Press "Apply+End" 
Start "Edit atoms" 
Delete all carbon atoms, which are not blue (i.e. carbons out of molecules). 
Be careful not to delete chlorine 
Press "Select all" 
For description of the structure is used 36 atoms 
Press "Refresh"; OK; YES to save changes 
Plot the structure using "Draw average structure 
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Start :File → Structure → Save As" and make a backup copy 

15. Preparing refinement with fixed rigid bodies 
Start "Edit atoms" 
Select carbons of phenyl, which have hydrogen: C2p, C3p, C4p, C5p and C6p 
Start "Action → Adding of hydrogen atoms" 
Check "generate keep command for Refine" 
Check "try automatic run ..." 
OK 
Repeat procedure for carbon atoms of phenantroline: C7t, C8t, C9t, C11t, C12t, C14t, C15t 
and C16t 
The procedure for adding hydrogen atoms, applied to already existing hydrogens, generates 
keep commands, which are necessary  for subsequent refinement.   
After this process number of atoms in the structure must be unchanged, i.e. 36 
Start Refinement options; go to the page "Various"; press "Fixed commands" 
Select "All parameters"  
For "Atoms/parameters" type "C*p C*t N*t"; Add; OK; OK; YES to save commands without 
starting Refinement 
This fixes geometry of both phenyl molecules and phenantroline 

16. Refinement with rigid bodies 
Start "File → Structure → Save As" and make a backup copy 
Start Refinement options; go to the page Basic 
Clear "Disable atoms having too large isotropic ADP parameter" 
OK; YES+START 
Rall will be ~28% for 61 parameters 
Start "Parameters → Molecules → Edit" 
Set 1 position modulation wave for the first position of Ph 
Set 1 position modulation wave for the second position of Ph 
Set 1 position modulation wave for the third position of Ph 
Set 1 position modulation wave for the first position of Trol 
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Run refinement 
Rall will be ~22% for 109 parameters 
Start "Edit atoms" 
For Sn1 set harmonic (anisotropic) ADP 
For Cl1 and O1 set 2 position modulation waves and harmonic (anisotropic) ADP 
Run refinement 
Rall will be ~20% for 136 parameters 
Start Refinement options; go to the page "Various"; press "Fixed commands" 
Disable the command "fixed all C*p C*t N*t " 
OK; OK; YES+START 
The refinement converges with Rall~19%, Rmain~11%, Rsat1~22% and Rsat2~27% for 204 
parameters 
Start "Edit atoms" 
Set harmonic (anisotropic) ADP for carbons and nitrogens of both molecules 
OK; OK, YES to save changes 
Start "Parameters → Molecules → Edit" 
Set 2 position modulation wave for the first position of Ph 
Set 2 position modulation wave for the second position of Ph 
Set 2 position modulation wave for the third position of Ph 
Set 2 position modulation wave for the first position of Trol 
Run refinement 
The refinement converges with Rall~9%, Rmain~6%, Rsat1~11% and Rsat2~10% for 352 
parameters 
Start "Edit atoms" 
Set one ADP modulation wave for Sn1, Cl1 and O1 
Start "Parameters → Molecules → Edit" 
Set one ADP modulation wave (modulation of TLS parameters) for three positions of Ph and 
one position of Trol 
Run refinement 
The refinement converges with Rall~8%, Rmain~6%, Rsat1~10% and Rsat2~10% for 548 
parameters 
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Start "Edit atoms" 
Set another one ADP modulation wave for Sn1, Cl1 and O1 
Start "Parameters → Molecules → Edit" 
Set another one ADP modulation wave for three positions of Ph and one position of Trol 
Run refinement 
The refinement converges with Rall~8%, Rmain~6%, Rsat1~10% and Rsat2~9% for 744 
parameters 
This is the final structure model with molecules 

17. Analysis of results 
Considering very good data quality, the results are still not satisfactory. Here we are looking 
for problems in the structure model 
Start "Edit/View → View of Refine" 
There are no serious warnings 
Plot the supercell structure 
The program does not use the transformation to five-fold supercell. Instead, it expands the 
structure to 5x1x5 supercell.  
Geometry seems to be correct. 
Calculate difference Fourier map 
YES to start procedure for including new atoms 
Do not include any maxima but look at their distances to atoms of our structure model. The 
largest difference maxima are close to atoms of phenantroline and phenyl, indicating some 
problem with the rigid body description.  
Start options for “Dist” 
Press "Planes" 
For "Atoms defining the best plane" type: C1pa C2pa C3pa C4pa C5pa C6pa; Add 
For "Atoms defining the best plane" type: C1pb C2pb C3pb C4pb C5pb C6pb; Add 
For "Atoms defining the best plane" type: C1pc C2pc C3pc C4pc C5pc C6pc; Add 
The second and third line can be created with help of the button "Clone" 
OK 
Go to the page "Modulation" 
Check "Make coordination t-tables" 
OK, YES+START 
Start "Edit/View → View of Dist" 
"Go to" → "List dihedral angles" 

Each "t" value indicates one of the defined commensurate sections, which is realized as one 
configuration in the five-fold superstructure. We can see that changes of angles between the 
planes #1, #2 and #2, #3 reach 30 degrees, which cannot be reliably described by rigid body 
modulation function as used in Jana2006. 
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Start “Grapht” 
Press “New/edit” 
For “Parameter to draw” set “plane” 
For “p” set limits from 0 to 90 
For “Plane #1” type “C1pa C2pa C3pa C4pa C5pa C6pa” 
For Plane #2” type “0 0 1” 
Grapht now displays angle between the plane through the first position of Ph and the axis c. 
Press “Options”; check “Indicate commensurate t sections”; OK 
Grapht now also displays the sections, for which the structure is defined. The orientation of 
the single plane changes by ~40 degrees. Again, this cannot be reliably described by rigid 
body modulation function as used in Jana2006. 

 
Actual value of t-sections is connected with the origin selection made automatically during 
solution by Superflip. Also the phenyl molecules can be placed in different order compared 
with this manual. Thus the actual plot will differ. 

18. Creating structure model without phenyl molecules 
Start "File → Structure → Save As" and make a backup copy 
Start "Edit atoms"; Select atoms *p 
Start "Action → Atoms from molecule to atomic part" 
The three molecular position have been transformed to atoms with suffixes "a", "b" and "c" 
Select H*pa, H*pb and H*pc (it can be also done with H*p?) 
Start "Action → Edit/Define" 
Set isotropic ADP 
OK; OK; YES to save changes 
Start Refinement options 
Go to the page "Various"; press "Keep commands"; press "Edit" 
Using the text editor: 
- change labels *p to *pa 
- duplicate the commands and change *pa to *pb 
- create the same commands for *pc 
OK 
Go to the page "Basic"; set Damping factor 0.5 
OK; YES+START 
Run refinement 
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The refinement converges with Rall~5%, Rmain~4%, Rsat1~6% and Rsat2~6% for 1176 
parameters.  

19. Creating structure without phenantroline molecules 
Start "Edit atoms"; Select atoms *t 
Start "Action → Atoms from molecule to atomic part" 
The molecular position have been transformed to atomic part without adding suffix "a", 
because the molecule had only one position. For this reason, keep commands are still valid 
and no editing is needed.  
Select H*t 
Start "Action → Edit/Define" 
Set isotropic ADP 
OK; OK; YES to save changes 
Run refinement 
The refinement converges with Rall~2.7%, Rmain~2.3%, Rsat1~3.2% and Rsat2~2.9% for 1576 
parameters 

20. Geometry of the atomic model 
The atomic model has excellent R factors. However, we have to ensure that the phenyls are 
planar and not distorted.  
Start "File → Structure → Save As" and make a backup copy 
Start Refinement options 
Go to the page "Various"; press "Keep commands" 
Select "Geometry" and "Plane" 
For "List of atoms" type C1pa C2pa C3pa C4pa C5pa C6pa; Add 
For "List of atoms" type C1pb C2pb C3pb C4pb C5pa C6pb; Add 
For "List of atoms" type C1pc C2pc C3pc C4pc C5pc C6pc; Add 
OK; OK; YES+START 
Change in R values should be very small 
Start Dist 
Commands for best planes prepared previously are still valid 
Start "Edit/View → View of Dist" 
"Go to" → "List of best planes" 
Here we can see that the phenyls are almost exactly planar, as expected 
Start Grapht 
Press "New/Edit" 
For "Parameter to draw" select "ADP parameter" 
For "p" define "0" as Minimum and "0.1" as Maximum 
For type of parameter to plot, select "U(max)" 
For Central atom type "N1t" 
OK 
[On the screen: plot of U(max) for N1t] 
Press "Options" 
Select "Indicate commensurate t sections"; OK 
Now the plot shows the section where the structure is defined 
Press "New/Edit" 
Press "New Item"; for "Central atom" type "N2t" 
Press "New Item"; for "Central atom" type "C7t" 
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Press "New Item"; for "Central atom" type "C8t" 
Add New items for C8t - C18t 
OK 
[On the screen: cumulative plot of U(max) for all atoms of the phenantroline] 
 

 
 
The plot indicates that for one of the sections (here for t=0; its actual value is connected with 
the origin selection made automatically during solution by Superflip) some of the 
phenantroline atoms are strongly disordered, while the other not.  
Quit Grapht 
Draw the average structure, select only the phenantroline molecule 
For this Ctrl-M keyboard shortcut of Diamond can be used, which selects molecule belonging 
to a selected atom 
Note atoms N1t, C18t, C17t and N2t.  
Phenantroline is often twisted and we will calculate torsion angle of these atoms 

 
Start Dist options 
Press "Torsion angles" 
For atoms type N1t, C18t, C17t and N2t; Add 
OK; OK; YES+START 
Open listing of Dist 
"Go to" → "List of torsion angles" 
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Here we can see that for five commensurate sections the torsion angle fluctuates between -
4 and +12 degrees. This torsion could not be described by the molecular model.  
 
The same torsion angle can be visualized in Grapht: 
(Note that only the indicated sections are defined) 

 

21. Water 
The last missing atoms in our structure model are hydrogens of the water molecule 
Start Fourier options 
For "Map type" select difference Fourier 
Check "Apply sin(th)/lambda limits 
define "max" as 0.5 
OK; YES+START 
YES to start procedure for including new atoms 
Add two difference maxima (probably the first two ones) 0.82Å close to O1 and name them 
H1O1 and H2O1 
Start "Parameters → Molecules → New molecule" 
Select "Atomic part" and "water" as a name; Next 
Select O1, H1O1 and H2O1; OK 
For the reference point select "Explicit" and use O1; NEXT 
Apply+End 
Start "Edit atoms" 
Delete all modulation waves for O1, H1O1 and H2O1; OK; YES to save changes 
Start "Parameters → Molecules → Edit" 
Set one position modulation wave for "water"; OK; YES to save changes 
Start Refinement options 
In page "Various" define  distance restraint 0.82Å for O1-H1O1 and O1-H2O2  
In page "Various" define keep command for ADP of hydrogens H1O1, H2O1, to be 1.2 
multiple of Ueq(O1).  
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Run refinement 
Add another position modulation wave for the molecule "water" 
Run refinement 
In "Edit atoms" set one ADP modulation wave for O1 
Run refinement 
The refinement converges with Rall~2.7%, Rmain~2.2%, Rsat1~3.0% and Rsat2~2.8% for 1584 
parameters 
The first ADP modulation wave improved only slightly R values. Therefore, we will not add 
the second wave - this is the principle of saving parameters in commensurate refinement 
comparing with refinement in the supercell.  
In the final step introduce isotropic extinction 
Run refinement 
The refinement converges with Rall~2.6%, Rmain~2.1%, Rsat1~3.0% and Rsat2~2.8% for 1585 
parameters 
This is the final commensurate model 

22. Transformation to supercell 
The final commensurate model can be transformed to the supercell 
Start "Tools → Transformations → Go to supercell structure" 
For Name type "sup"; OK 
OK to transform molecules 
Follow steps of the data processing wizard 
YES to continue with the new structure 
Set zero refinement cycles 
Run refinement (skip warnings) 
The R value will be 2.6%, because both descriptions are equivalent 
In order to refine the supercell structure, keep commands for hydrogens must be re-created.  
 
The supercell structure contains 15 independent phenyls: 
C1pa-1, C2pa-1, C3pa-1, C4pa-1, C5pa-1, C6pa-1 
.... 
C1pa-5, C2pa-5, C3pa-5, C4pa-5, C5pa-5, C6pa-5 
C1pb-1, C2pb-1, C3pb-1, C4pb-1, C5pb-1, C6pb-1 
.... 
C1pb-5, C2pb-5, C3pb-5, C4pb-5, C5pb-5, C6pb-5 
C1pc-1, C2pc-1, C3pc-1, C4pc-1, C5pc-1, C6pc-1 
.... 
C1pc-5, C2pc-5, C3pc-5, C4pc-5, C5pc-5, C6pc-5 
 
Five independent phenantroline molecules: 
N1t-1, N2t-1, C7t-1, C8t-1, C9t-1, C10t-1, C11t-1, C12t-1, 
C13t-1, ..., C17t-1, C18t-1 
.... 
N1t-5, N2t-5, C7t-5, C8t-5, C9t-5, C10t-5, C11t-5, C12t-5, 
C13t-5, ..., C17t-5, C18t-5 
 
Five independent water molecules: 
O1a-1; O1a-2; O1a-3; Oa-4; O1a-5 
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Keep commands can be easily expanded and edited according to the above mentioned 
labels, however, they can be also copied from the pre-prepared file supercell_keep.txt.  
Start Refinement options 
Go to the page "Various"; press "Keep commands" 
Press "Edit" 
Replace content of the file with content of the supercell_keep.txt 
Save and close the text editor 
OK 
Number of keep commands should be 235 
Press "Distance restraints" 
Restrain the following distances to 0.82Å: O1a-1 H1O1a-1; O1a-1 H2O1a-1; O1a-2 H1O1a-2; 
O1a-2 H2O1a-2; O1a-3 H1O1a-3; O1a-3 H2O1a-3; O1a-4 H1O1a-4; O1a-4 H2O1a-4; O1a-5 
H1O1a-5; O1a-5 H2O1a-5; 
Some keep commands and distance restraints may be invalid because the atomic positions 
may be transformed during the commensurate-to-supercell transformation. Such commands 
would need symmetry codes.  
Start "Edit atoms" 
Press "Select all" 
Start "Action" → "create symmetrically contiguous motifs" 
After this the keep commands can use labels without symmetry codes 
Start refinement (still with zero cycles) 
The R value will be 2.6% 
Start "File → Structure → Save As" and make a backup copy 
Set 100 refinement cycles, damping factor 0.5, and run refinement 
Refinement uses 1611 parameters, which is more than in comensurate refinement, because 
we did not use full set of parameters for water molecules. However, the resulting R value is 
still 2.58% 

23. Back to the rigid body description 
Now we can introduce phenyl molecule in 15 positions, which was not possible in the 
commensurate refinement due to too large rotations. For phenantroline, we can try to use 
rigid body description using two halves of the phenantroline as independent pattern 
molecules, in order to describe the torsion of phennatroline. Finally, we can model the 
disordered phenantroline molecule by partially occupied molecules. All this is routinne job, 
which will not be presented here.  
 

24. Conclusions 
Commensurate refinement can help to find solution of very large structures, it allows to save 
parameters by using less than the full set of modulation parameters, and it facilitates 
interpretation of a superstructure through calculation of various parameters as a function of 
t. However, commensurate refinement may be difficult when satellites are too strong, 
because strong satellites indicate large displacements, which must be described by 
modulation functions defined only in few points. Despite of this, commensurate refinement 
was possible for our structure and it helped us to understand its geometry. On the other 
hand, the phenyl rigid body could be only possible in the supercell refinement, as well as the 
full description of the disordered phenantroline molecule. 
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Example 8.1: TerBut 
 
Application of rigid body groups for disordered parts of crystal structure 
Revised: 4 March 2015 
 
N-(3-nitrobenzoyl)-N’,N’’-bis(tert-butyl)phosphoric triamide 
Chemical formula: C90H150N24O24P6 
 

 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: TerBut.hkl, TerBut.cif_od 
Frame scaling, absorption correction: done with software of the diffractometer 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click TerBut 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
Each line in data repository window corresponds to one data set. 
OK; YES to accept the data set 

4. Symmetry Wizard 
[On the screen: “Information” about symmetry wizard] 
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NEXT 
[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT 
[On the screen: Select Laue symmetry] 
Select Triclinic; NEXT 
Select primitive unit cell; NEXT 
[On the screen: Select space group] 
Select P-1; NEXT 
Accept the space group; FINISH 

5. Creating refinement reflection file 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Press "Accept the new DatBlock and calculate coverage"; FINISH 

6. Structure Solution Wizard 
[On the screen: "Information" about Structure solution tool] 
OK 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for TerBut: C15 N4 O4 P H25; 
Set "Formula units" to 2 and calculate density; 
[On the screen: Calculated density: 0.4242 g/cm3] 
 
This is unrealistic value which indicates that the structure can contain more independent 
structural motifs. As the density should be larger than 1 the most probable number of 
independent structural motifs is 6. 
Set "Formula units" to 6; 
Select “Superflip”, “Peaks from Jana2006”; leave other settings default; “Run solution” 
Close listing of Superflip 
Press Accept last solution” to leave the structure solution wizard 

7. Verification of the structure solution 
Start “Plot structure”, use either "Draw+return" or "Draw+continue" 
[On the screen: window of Diamond] 
Start “Build → Get molecules” or use  on the bottom toolbar 

Rotate the molecule (  and  on the bottom toolbar) to get an optimal view 
[On the screen: plot of the three independent, probably incomplete molecules] 
Assignment of chemical types need not be correct and some atoms may be missing. 
Chemical types will be corrected later on. 
The three iindependent molecules are combined with the inversion center. This confirms  
Z=6 as estimated previously from the density. Correct Z helps the program to offer proper 
number of maxima from difference Fourier. 
Quit Diamond; 

8. Refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
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[On the screen: Refinement commands] 
Define 100 of cycles; OK 
Choose “YES+START” 
Refinement converges with R(obs) value about 20-22% 

9. Completing the structure – difference Fourier synthesis 
[On the screen: basic window of Jana] 
Right-click the icon of Fourier. 
[On the screen: Fourier commands] 
For "Map type" select difference Fourier, make sure that “Weighting of reflections” is 
checked and “Apply sin(th)/lambda limits” unchecked 
OK; YES+START to save commands and run the difference Fourier; 
YES to start the procedure for including of new atoms; 
[On the screen: parameters for inserting/replacing of atoms] 
Use default parameters; OK 
[On the screen: the form for inserting of new atoms] 
Go through the list of maxima and include all peaks having reasonable distances (i.e. similar 
to C-C distance) to already localized atoms. Skip short distances. Do not attempt including H 
atoms. 
After pressing the button “Include selected peak” the form for completing of the new atom 
appears. For the “Name of the atom” type C*. For more information what C* means press 
the “Info” button. 
Repeat the points 8 and 9 till no new atoms are localized. The structure should have 72 non-
H atoms 
FINISH; YES to include new atoms 
Repeat refinement 
Finally R(obs) value should be between 16 and 17% 
 

10. New verification of the structure solution 
Start “Plot structure”, "Draw+continue" or "Draw+return" 
[On the screen: window of Diamond] 
Start “Build → Get molecules” or use  on the bottom toolbar 
Rotate the molecule (  and  on the bottom toolbar) to get an optimal view 
[On the screen: plot of the three independent molecules] 
Activate atom labels 
[On the screen: plot of the molecule with atom labels] 
Compare the plot with the chemical scheme at the beginning of this Cookbook chapter and 
note labels of atoms which chemical types need to be changed.  
(For Diamond started by "Draw + return" the changes can be done immediately in Jana2006 
running alongside.) 

Use  at the bottom toolbar of Diamond to see temperature ellipsoids. 
The large spheres derived from Uiso values for the terminal carbon atoms indicate positional 
disorder of some tertiary butyl groups. 

11. Assignment of correct chemical types 
[On the screen: basic Jana window] 
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Start “Edit atoms” 
[On the screen: list of atoms] 
Highlight one of the atoms you are going to modify 
Make left double-click or Start “Action → Edit/define” 
Change “Type” to the desired one 
Rename the atom. Here you can use again the wild character * which prevents duplication 
of atom names. 
Repeat this procedure till all atoms have correct chemical types. 
Note: alternatively you can select more atoms and change the chemical type of the selected 
group. After returning to the list of atoms in Atom/Edit the atoms are still selected and they 
can be automatically renamed with “Action → Rename selected atoms”.  
Check again the chemical types with Diamond 
Check number of atoms with "Edit atoms", using the textbox close to "Select advanced", 
which accepts wildcards as "C*". The structure contains 3P, 12O, 12N and 45C; 72 atoms 
altogether.  

12. Refinement 
[On the screen: basic window of Jana] 
Double-click the icon Refine. 
Refinement converges with R(obs) value about 16% 
Start “Edit atoms” 
[On the screen: list of atoms] 
Press “Select all” and “Action → Edit/define” 
Choose “harmonic” for ADP parameters. This defines anisotropic temperature parameters 
for all atoms. OK, OK, YES to save changes 
Double-click the icon Refine. 
Refinement converges with R(obs) value about 9% 

13. Formula check 
[On the screen: basic window of Jana] 
Run EditM50; 
Go to the tab “Composition” and press button “Formula from M40”. 
The derived formula should be correct for all atom types except hydrogen. 

14. Unifying atom labels 
To follow easily the cookbook we need to re-label the atoms. It would be tedious work and 
therefore we will used pre-prepared files with correct labelling.  
Start “File → Structure → Copy in”, select the structure “TerBut-simple-atomic” and in the 
next dialogue select files m40 and m50 for the copy. 
Double-click the icon Refine. 
Refinement should converge to R(obs) value about 9.4% 
The labeling of atoms of the first independent molecule is shown in the following figure: 
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The last digit in each label is the identifier of the molecule (replaced by 2 and 3 for the 
second and third independent molecule, respectively). 
 

15. Search for split atom positions 
Double-click the icon Contour; Click the button “New plot” 
[On the screen: options for defining of new maps] 
In “New map to draw” select “Fourier map”; 
Select “Calculate new ones” and “Draw a general section”; OK 
[On the screen: Fourier commands – page Basic] 
Set “Map type” to “F(obs) – Fourier”; 
Clear “Omit not-matching reflections”; 
Clear “Apply sin(th)/lamba limits”; 
Select “Use weighting of reflections”; OK 
[On the screen: Plane/Volume] 
For 1st, 2nd and 3rd atom use C91, C101 and C111; 
Keep interpolation step 0.1 Å; 
Define scope of the section: 5 5 0 and “1st point to” 1.5 1.5 0; OK 
You should see the following figure: 
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Click the button “New plot” 
(The definition of the plane has been automatically saved as Plane#1) 
[On the screen: options for defining of new maps] 
Select “Use old maps” and “Draw a general section” (i.e. default values); OK 
[On the screen: Plane/Volume] 
Select “Use old” 
Rewrite 1st, 2nd and 3rd atom by C92, C102 and C112; 
You should see similar figure like for the previous figure 
Repeat the procedure for C93, C103 and C113; 
Again no clear splitting of atomic positions 
Repeat the procedure for C131, C141 and C151. 
The last map indicates clearly splitting for two atoms: 

 
 
Locate the split positions by clicking at corresponding points of the section and save them 
for future use by “Save the selected point for future use” button. 
 
points close to C141 ~ (0.2795, 1.102,0.2494) and (0.2995,1.1158,0.1820) 
(they can be named C141a and C141b) 
points close to C151 ~ (0.2455,1.111,0.1117) and (0.1869,1.0974,0.1017) 
(they can be named C151a and C151b) 
 

Make the same for the second molecule (the section C132, C142, C152). Here the splitting 
of atoms C142 and C152 is less pronounced, however we only need some points for initial 
orientation of rigid bodies.  



513 Jana2006 Cookbook, version September 2019 
 
 

 
 

points close to C142 ~ (0.7732, 0.3731,0.4747) and (0.8239,0.4088,0.4588) 
(they can be named C142a and C142b) 
points close to C152 ~ (0.8695,0.4942,0.5074) and (0.8356,0.5156,0.5715) 
(they can be named C152a and C152b) 
 

Make the same for the third molecule (the section C133, C143, C153). Here all positions are 
clearly split but we only need two pairs of points.. 

   
 

points close to C143 ~ (-0.1854, 0.7837,0.1733) and (-0.1759,0.7836,0.1320) 
(they can be named C143a and C143b) 
points close to C153 ~ (-0.0588,0.8945,0.1860) and (-0.1022,0.8639,0.2186) 
(they can be named C153a and C153b) 
 

The split positions localized during preparation of this example were also written to the file 
“TerBut-points.txt” and can be later to pasted to Jana2006 textboxes. 
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Quit Contour 
YES to save new points in M40 (this does not change structure model) 
The points have been stored in M40 in the “Saved points” section  

16. Defining of rigid-body groups 
First we will create a model where one pattern “molecule” – tertiary butyl – is used to create 
three non-split positions related to N3i, C8i, C9i, C10i, C11i fragments and another six split 
positions related to N4i, C12i, C13i, C14i and C15i fragments (i=1,2,3). 
Start “File → Structure → Save As” and create a backup copy “before_rigid” but do not 
continue with the new structure. 
Start “Parameters → Molecules → New molecule”; 
[On the screen: Wizard for new molecule] 
Select “Atoms of the new molecule from” - "Atomic part"; 
For “Name of the molecule” type, for instance, "Tb"; NEXT; 
[On the screen: Select atoms for the molecule] 
Select atoms to be used as a pattern (elsewhere called model) molecule – N31, C81, C91, 
C101 and C111;OK 
[On the screen: Define the molecular reference point] 
Select “the molecule reference point” as “Explicit” defined by the atom C81; NEXT 
[On the screen: Form for completing of the molecular position #1]; 
The “Coincidence ratio” says that five atoms of the molecular position #1 coincide with five 
atoms in the atomic part of M40. This should be true because the pattern molecule is 
created from five atoms in M40 and the first position coincides with the pattern molecule. 
Use the default value for occupancy; Press “Apply+Next Position”; 
[On the screen: Form for completing of the molecular position #2]; 
For the position #2 and all consecutive ones we have to define where to put the pattern 
molecule to get the new actual position. This means that actual positions of three atoms of 
the pattern molecule, not lying in a line, are to be specified. 
Fill “Model atoms” column with N31, C101 and C111 and the fill the “Actual position/atom” 
column with N32, C102 and C112. Press the button “Calculate molecular parameters”. 
The coincidence ratio should be 5/5. It says that five atoms of the pattern molecule coincide 
in its actual position with five already existing atoms of the structure. After finishing the 
molecular position the coinciding atoms will be deleted from the atomic part – for this 
reason it is important that all of them are recognized by the program. The coincidence can 
be controlled by the "Maximal coincidence distance". 
Press the button “Apply+Next Position”; 
Repeat the procedure for the third non-split tertiary group (i.e. N33, C103 and C113 for 
Actual positions); press "Apply+Next position" 
[On the screen: Form for completing of the molecular position #4]; 
For actual positions use N41, % C141a and %C151a. The character "%" refers to saved 
points.      
Press the button “Calculate molecular parameters”. 
If the "Coincidence ratio" is not 5/5, change the “Maximal coincidence distance” to 0.8 and 
press again "Calculate coincidence distance" 
If the "Coincidence ratio" is still not 5/5, replace the points for the 2nd and 3rd actual 
position and press again "Calculate coincidence distance" 
The reason for this step is that the selected saved points may define by mistake 
contradicting rotations of the pattern molecule. This cannot happen when the "a" and "b" 
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labels have been used as indicated in the plots. 
Finally, the “Coincidence ratio” should be 5/5 
For “Occupancy" type 0.5. 
Press “Apply+Next position”; 
[On the screen: Form for completing of the molecular position #5]; 
For actual positions use the same atom N41 and another two split positions % C141b and 
%C151b. 
Press the button “Calculate molecular parameters” and check that the "Coincidence ratio" 
is 5/5;  
Change the occupancy to 0.5; 
Press the button “Apply+Next Position”; 
Repeat the process for the second and third split tertiary butyl: 
Position #6: N42, %C142a, %C152a 
“Apply+Next Position” 
Position #7: N42, %C142b, %C152b 
“Apply+Next Position” 
Position #8: N43, %C143a, %C153a 
“Apply+Next Position” 
Position #9: N43, %C143b, %C153b 
“Apply+End” 
The total number of molecular positions is 9. 

17. Verification 
Use Diamond for verification of proper geometry: each molecule should have one single 
and one disordered tertiary group. 
Use Parameters → Molecules → Edit for verification that positions #4 – #9 have occupancy 
(i.e. the parameter “aimol”) 0.5 
Use “EditM50”, page “Composition”, button “Formula from M40” 
If occupancy of molecular positions has been properly defined and the coincidence ratio has 
been always 5/5 the formula should be C15 N4 O4 P H0 (for Z=6) 
Use “Edit atoms” to see changes in the atomic part of M40 
Black atoms are the ones not used in molecular description 
Blue atoms are the ones defining the pattern molecule 
Start “File → Structure → Save As” and create a backup copy “rigid_ini” but do not 
continue with the new structure. 

18. Refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: Refinement commands] 
Change the damping factor to 0.5; 
OK, “YES+START” 
Refinement converges with R(obs) value about 10.4% 

19. Refinement of the molecular occupancies 
Start “Parameters → Molecules → Edit”; 
[On the screen: molecule edit] 
Allow refinement of the molecular occupancies (aimol) for the positions #4, #6 and #8; 
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OK; YES to save changes 
Right-click the icon of Refine; select tab "Various”; 
[On the screen: Refinement commands] 
Press the button “Restrictions”; 
[On the screen: The tool for defining and editing of restriction commands] 
Write into the textbox “Atoms/molecules”: “Tb#4 Tb#5” 
Deselect “Coordinates” 
Select “Occupancies: Keep overall sum” 
Select “ADP parameters” 
Press the button “Add”; 
This restriction means that the molecular positions #4 and #5 have independent coordinates, 
the same ADP and complementary occupation 
Select the line: restric Tb#4 Tb#5; 
Press the button “Clone” and then “Load” and modify the string to “Tb#6 Tb#7” 
Press the button “Rewrite”; 
Press the button “Clone” and then “Load” and modify the string to “Tb#8 Tb#9” 
Press the button “Rewrite”; 
OK; OK; Yes+Start; 
Refinement converges with R(obs) value about 10.3% with 475 parameters 

20. Refinement of the molecular TLS tensors 
Start “Edit atoms”; 
[On the screen: tool for selection of atoms] 
Select all atoms of the pattern molecule (before selection they are indicated by blue color). 
Double-click; Select “Use TLS”; 
OK; OK; Rewrite changes 
This change means that individual ADP parameters of the pattern molecule are suppressed. 
Instead, for each actual position independent TLS tensors will be refined. 
Run refinement 
Refinement converges with R(obs) value about 8.6% with 565 parameters 

21. Adding hydrogen atoms 
Start “Edit atoms”; 
[On the screen: tool for selection of atoms] 
Select all carbon atoms and nitrogen atoms N21, N22 and N23 
Press the button “Action” 
Select the procedure “Adding of hydrogen atoms” 
[On the screen: parameters for adding hydrogen atom] 
Use default options (i.e. automatic procedure for C and manual procedure for N);  
For N21, N22 and N32 select the trigonal coordination with two neighbors (P and C). Then 
only one H atom will be added.  
Total number of hydrogen atoms in Atoms edit should be 24  
OK; Save changes 
Use Diamond for verification that all hydrogen atoms have been correctly placed 
Run refinement 
Refinement converges with R(obs) value about 6% 
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22. Drawing of the refined model 
Start "Plot structure" 
In Diamond, start “Build → Get molecules” or use  on the bottom toolbar 

Use  at the bottom toolbar of Diamond to see temperature ellipsoids. For plotting H 

atoms without ellipsoids switch to “Table of atom groups”, select all H atoms and use  
again. 
The large temperature ellipsoids for the terminal carbon atoms indicate that there is 
probably some additional positional splitting of tertiary butyls N3, C8, C9, C10, C11 and also 
of some oxygen atoms. For teaching purposes, we can stop at this stage, as introducing of 
additional splitting does not bring any new. 
Quit Diamond 
Start “File → Structure → Save as” and save the result as “TerBut_final_1” but do not 
continue with the new structure. 

23. Reset the structure into the atomic model 
Start “File → Structure → Copy in”, select the structure “before_rigid” and copy in the m40 
and m50 file. 

24. Defining of rigid-body groups from a known model saved in M45 
M45 may contain coordinates of a rigid-body group. Syntax of M45 is explained in the 
example 2.3.2-MagCag, where steps how to create M45 from a template found in CSD are 
shown. Library of frequently used rigid bodies for Jana2006 is under development, see the 
directory "Molecular patterns" in Jana2006 installation path.  
Start “Parameters → Molecules → New molecule”; 
[On the screen: Wizard for new molecule] 
Select “the new molecule from a model file”; 
Define “Name of the molecule” Tb; 
Define “Model filename” TerButyl-no-symmetry.m45; 
Keep the default scaling distance 
With this number the whole object can be shrunk or expanded 
Press "Show the model molecule" 
This will display the pre-prepared figure from the file TerButyl-no-symmetry.jpg 
NEXT 
[On the screen: specify atomic types in the model molecule] 
Keep the default atomic types; NEXT 
[On the screen: Define the molecular reference point] 
Select “the molecular reference point” as explicit defined by the atom C81; NEXT 
[On the screen: Form for completing of the molecular position #1]; 
For creating molecular parameters from a model file we have to specify also the actual 
coordinates of the first position. Starting from the position #2 we can repeat instructions 
from the point 16 and 17. Because the pattern molecule contains hydrogen atoms which are 
not present in the atomic part, the coincidence ratio will be 5/14 or higher for the split 
positions. This is due to the fact that some hydrogen atoms of the split positions can be close 
to average carbon positions. This should not have any effect as this message has only 
informative character.For coincidence lower than 5 please change the "Maximal coincidence 
distance" to 0.8.  
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As follows from the point 16 and 17, the atoms N31, C101 and C111 of the pattern molecule 
will be associated with the following actual positions present in the atomic part of M40 or 
from the saved points:  
 
1. N31 C101 C111 (occupancy 1) 
2. N32 C102 C112 (occupancy 1) 
3. N33 C103 C113 (occupancy 1) 
4. N41 %C141a %C151a (occupancy 0.5) 
5. N41 %C141b %C151b (occupancy 0.5) 
6. N42 %C142a %C152a (occupancy 0.5) 
7. N42 %C142b %C152b (occupancy 0.5) 
8. N43 %C143a %C153a (occupancy 0.5)C101 
9. N43 %C143b %C153b (occupancy 0.5) 
 
Resulting number of atoms: 42 in atomic part (here hydrogens are still missing); 14 in the 
pattern molecule. 

25. Refining of the structure with fixed ideal geometry 
Start “Parameters → Molecules → Edit”; 
[On the screen: molecule edit] 
Allow refinement of the molecular occupancies (aimol) for the positions #4, #6 and #8; 
OK; YES to rewrite files; 
Right-click the icon of Refine; 
[On the screen: Refinement commands] 
Change number of cycles to 100 and the damping factor to 0.5; 
Select tab “Various”; 
[On the screen: Refinement commands] 
Press the button “Restrictions”; 
[On the screen: The tool for defining and editing of restriction commands] 
Write into the textbox “Atoms/molecules”: “Tb#4 Tb#5” 
Deselect “Make identical coordinates”; 
Select: “Occupancies: Keep overall sum” 
Select: “ADP parameters” 
Press the button “Add”; 
This restriction means that the molecular positions #4 and #5 have independent coordinates, 
the same ADP and complementary occupation 
Select the line: restric Tb#4 Tb#5; 
Press the button “Clone” and then “Load” and modify the string to “Tb#6 Tb#7” 
Press the button “Rewrite”; 
Press the button “Clone” and then “Load” and modify the string to “Tb#8 Tb#9” 
Press the button “Rewrite”; OK 
[On the screen: Refinement commands] 
Press the button “Fixed commands”; 
Select “Coordinates”; Fill textbox “Atoms/parameters” with 
N31 C81 C91 C101 C111 H?c91 H?c101 H?c111 
This fixes coordinates of the pattern molecule. For library molecule we expect correct 
geometry. 
Press the button “Add”; OK 
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[On the screen: Refinement commands] 
Select “Keep commands”; 
Select “ADP”, “Riding”; 
Central atom: C91; Number of hydrogen atom 3; 
Fill hydrogen textboxes by: H1C91, H2C91 and H3C91; 
For this button “Select hydrogens” can be used. 
Add; 
Repeat the process for C101 and C111; 
OK; OK; Yes+Start 
Refinement converges with R(obs) value about 10.2% for 441 parameters.  

26. Refining of the structure with anisotropic ADP for tertiary butyls 
Start “Edit Atoms”; 
[On the screen: tool for selection of atoms] 
Select non-hydrogen atoms of the pattern molecule. 
Double-click; Select "Harmonic ADP"; 
OK; OK; Rewrite changes 
Start refinement; 
Refinement converges with R(obs) value about 9.4% for 466 parameters 

27. Refining of the structure with TLS tensors for tertiary butyls 
Start “Edit Atoms”; 
[On the screen: tool for selection of atoms] 
Select all atoms of the pattern molecule. 
Select “Use TLS” using double-click; 
OK; OK; Rewrite changes 
Start refinement; 
Refinement converges with R(obs) value about 7.5% for 556 parameters 

28. Adding remaining hydrogen atoms 
Start “Edit Atoms”; 
[On the screen: tool for selection of atoms] 
Select all individual (black) carbon atoms and nitrogen atoms N21, N22 and N23 
It is important that carbon atoms of the molecule are not selected. Here the geometric keep 
commands would contradict with setting of the local symmetry, which will be done later on 
Press the button “Action” 
Select the procedure “Adding of hydrogen atoms” 
[On the screen: parameters for adding hydrogen atom] 
Use default (i.e. automatic run);  
For N21, N22 and N32 select the trigonal coordination with the neighbors (P1, C71), (P2 
C71) and (P3, C73), respectively.  
OK; Save changes 
Repeat refinement 
Refinement converges with R(obs) value about 6.6% for 556 parameters. This result can be 
compared with the previously obtained model TerBut_final_1, where the shape of the 
pattern molecule was refined, yielding R value 5.8 for 565 parameters.    
Start “File → Structure → Save as” and save the result as “TerBut_final_2” but do not 
continue with the new structure. 
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29. Introducing of the local symmetry 
The tertiary butyl has in an ideal case the point symmetry m31 . Application of the local 
symmetry can considerably reduce the number of independent atoms. The point group 
generated by Jana2006 has its three-fold axis directed along the z-axis and the normal of the 
mirror plane directed along x-axis. As the atoms N31 and C81 are localized at the three-fold 
axis of the molecule the vector from the central point C81 to N31 can be used to define the z 
axis. The second x-axis is to be perpendicular to the z axis and it can be located at the plane 
N31-C81-C91.  
Start “Parameters → Molecules → Edit”; 
Define the point group 31m; TAB 
A dialog window for defining the local coordinate system for the pattern molecule will 
appear.  
The model imported from the m45 file fulfills already the 31m symmetry in the setting as 
described above and therefore the local coordinate system need not be modified. 
OK to close the dialog window; OK; YES to save changes 
This process is irreversible because atoms in the pattern molecule are deleted if they become 
duplicit with respect to the introduced point group 

30. Check atoms of the model tertiary butyl 
Start “Edit Atoms”; 
The number of independent atoms is now only 5. 
Select the first atom of the model tertiary butyl and make double-click; 
Switch to Edit to see the site occupancy; 
You should get: 
N31 0.166667 
C81 0.166667 
C91 0.500000 
H1c91 0.500000 
H2C91 1.000000 

31. Refinement of the structure with local symmetry 31m – atomic positions of the tertiary 
butyl fixed 
Start the refinement; 
Refinement converges with R(obs) value about 6.6% for 556 parameters, i.e. the same value 
like before, because the shape of the pattern molecule is still fixed. 

32. Refinement of the structure with local symmetry 31m 
Right-click the icon of Refine; select tab “Various”;  
[On the screen: Refinement commands] 
Press the button “Fixed commands”; 
Disable the fixed command; OK 
Start the refinement; 
Refinement converges with R(obs) value about 6.5% for 564 parameters. 
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Example 8.2: Dinitros 
 
Application of rigid body groups for disordered parts of crystal structure 
Revised: 27 December 2017 
 
(3aRS,7aRS )-1,3-dinitrosooctahydro-1H-benzimidazole 
Chemical formula: C7H12N4O2 
 

 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: dinitros.hkl, dinitros.cif_od 
Frame scaling, absorption correction: done with software of the diffractometer 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click dinitros 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
Each line in data repository window corresponds to one data set. 
OK; YES to accept the data set 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT 
[On the screen: Select Laue symmetry] 
Select Monoclinic; NEXT 
Select primitive unit cell; NEXT 
[On the screen: Select space group] 
Select P2/c; NEXT 
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Accept the space group; FINISH 
[On the screen: define space group window] 
OK to accept the space group P2/c 

5. Creating refinement reflection filed 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Accept the data block and calculate coverage; FINISH 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for Dinitros: C7 H12 N4 O2; 
Set "Formula units" to 4 and calculate density; 
The density 1.393 g/cm3 looks reasonably so probably Z=4 is correct 
Select “use Superflip”, “Peaks from Jana2006”; leave other settings default; “Run 
solution” 
Close listing of Superflip 
Superflip converges with R value 16% and confirms symmetry P2/c 
Press “Accept last solution” to leave the Structure solution wizard 

7. Verification of the structure solution 
Start “Plot structure”; “Draw + Continue” 
[On the screen: window of Diamond] 
Start “Build → Get molecules” or use  on the bottom toolbar 

Rotate the molecule (  and  on the bottom toolbar) to get an optimal view 
[On the screen: plot of the two independent molecules] 

 
The results may be slightly different for each run of Superflip,  because it starts from 
random phases.  
Draw rectangle to select all atoms of the molecule or press Ctrl-A 
Right-click on one of the selected atoms, choose “Add → Atom labels” 
[On the screen: dialogue of Diamond for atom labeling] 
Note incorrect chemical types (using the chemical diagram above); 
Quit Diamond; 
Run “Edit atoms”; 
Correct the improper chemical types; 
Rename atoms according to chemical types; 
Make symmetry contiguous motifs; 
Quit “Edit atoms”, save the changes 
For this structure making the symmetry contiguous motifs is very important. To make sure 
the motifs have been correctly created: 
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Return to Diamond; 

Use  or “Build → Add all atoms”; 
Connect atoms with bonds 
This will plot symmetry independent atoms of the structure model without any symmetry 
transformation. They should create motifs: 

 
If these motifs are not created  the atoms must be put to the motif manually using 
symmetry transformations in "Edit atoms". Without proper motifs this example will not 
work! 
Quit Diamond 

8. Refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: Refinement commands] 
Define 100 of cycles; OK 
Choose “YES+START” 
Refinement converges with R(obs) value about 13% 
Plot the structure 
It should be the same like before 
Start “Edit atoms” and change ADP of all atoms to “harmonic” 
Repeat refinement 
Refinement converges with R(obs) value about 9.4% 
Plot the structure 
Activate ADP ellipsoids using “Picture → Model and Radii” 
One of the molecules has very large ellipsoids for carbon atoms: 

 

9. Labeling 
At this point we would need some more practical labeling of atoms.  Jana2006 doesn’t 
include tools for graphical renaming. The labels and their changes must be planned in 
Diamond, noted and realized in “Edit atoms” tool or by direct editing of M40 
The desired labeling for the molecule with large ADP’s (starts from C1) and the one with 
smaller ADP’s (starts from C5): 
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(The molecule with large ADP’s starts from C1) 
Plot the molecules in Diamond; activate atom labels;  
EITHER note the desired changes and Quit Diamond; 
OR rename atoms in Jana2006 running parallel with Diamond (Diamond started with 
“Draw+continue”) 
(You may also keep Diamond window open and type the new labels directly to Edit atoms 
tool of Jana2006) 
Start “Edit atoms”; select all atoms and choose “Rename the selected atoms manually”  
Plot the structure and verify the labels  

10. Splitting positions with large ADP 
The largest ADP have been found for atoms C2 and C4 
Start “Edit atoms” and split positions of C2 and C4, using default options for splitting 

 
The splitting procedure created pairs C2-C2’ and C4-C4’, their ADP are isotropic and the 
same for each pair, partial occupations are ½ and the sum of occupancies for each pair is 
kept by a Restriction for the case it would be refined 
Run refinement 
Refinement converges with R(obs) value about 10% 
Start “Edit atoms” and activate refinement of occupancy for C2 and C4 
Run refinement 
Refinement converges with R(obs) value about 8.4% 
The refined occupancies in both pairs are in the ratio 1:3, i.e. one of the split atoms in each 
pair is much weaker. 
Plot the structure; distinguish by colors the weakly occupied carbon atoms 
Activate plotting of ADP ellipsoids and plotting of labels 
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In the plot C4, C2 have occupancy ~0.25; C4’, C2’ have occupancy ~0.75, the other atoms 
have a full occupancy. We can distinguish two chairs: C4-C4-C3-C2-C2-C3 and C4’-C4’-C3-
C2’-C2’-C3, the latter having stronger occupation.  
 
Warning: splitting of atomic positions was automatic process. In particular solution, it 
may happen that the labels of the strongly and weakly occupied atoms (i.e. atoms with 
and without comma) will be exchanged. In such a case, we recommend relabeling the 
atoms according to this plot in order to follow easily the cookbook. 

11. Rigid body description 
Refinement of the weakly occupied positions is unreliable because ¼ of carbon is an 
electron density comparable with hydrogen. In this part, we will describe the disorder with 
a rigid body. For model molecule, we will take the more occupied version of the molecule.   
 
Start “File → Structure → Save As” and create a backup copy 
Start “Parameters → Molecules → New molecule” 
Choose the name for the molecule, e.g. “molec” 
Select “Atomic part”; NEXT 
[On the screen: Select atoms for the molecule] 
Select O1, N1, N2, C1, C2’,C3,C4’ 
OK 
The selected atoms will be removed from the atomic part of the structure model, and they 
will be used as a pattern molecule. This pattern molecule will be later on transformed to 
the actual places in the crystal structure by a translation vector and three rotations  
[On the screen: Define the molecular reference point] 
Reference point of the molecule is used for calculation of symmetry restrictions. In our 
case C1 is located in a special position while the other atoms not. Therefore C1 should be 
the reference point 
Select “Explicit”; for “Reference point” type C1; NEXT  
[On the screen: complete molecular position #1] 
For the placement of the model molecule to the first actual position the program shows 
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zero rotations and zero translation. This is because the model molecule has been taken 
from the existing atoms in the atomic part of the structure model. “Coincidence ratio 7/7” 
means that 7 atoms of the model molecule placed to the actual position #1 coincides with 
existing seven atoms in the atomic part. This is correct - the 7 atoms have been used for 
the model molecule. 

’ 
For “Occupancy” type 0.75; 
“Apply + Next position” 
[On the screen: Define and complete molecular position #2] 
In this dialogue we will define rotations and a translation vector for placing the model 
molecule to the second actual position. This is done by defining three atoms of the model 
molecule and three atoms in the atomic part of the structure model, which should 
coincide. In order to get correct placement of the second position the split atom positions 
must be used. 
Use C1, C2’, C4’ as model atoms and C1, C2 and C4 for the actual position 
Press “Show coinciding atoms” 

  
We expected that the 7 atoms in the actual position will coincide with 7 atoms in the 
atomic part. However, we obtained only 3 coinciding atoms .  
OK to quit information window 
Select “Apply inversion”; Press “Show coinciding atoms” 
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Now we have seven coinciding atoms. Thus to get the second position the rotation must be 
combined with inversion. The inversion centre is the reference point.  
For “Occupancy” type 0.25 
“Apply + End” 
Start “Edit atoms” 
The atoms of the model molecule are blue 
Rename C2’ to C2 and C4’ to C4 
Change occupancy of C2 and C4 to 1 (the model molecule has the full occupancy) 
Change ADP of C2, C4 to “harmonic” 
Quit “Edit atoms” 
Plot the structure 
Before starting Diamond Jana transforms the molecular positions back to the atomic part. 
Atoms of the first position will obtain the suffix “a”, the second position has the suffix “b” 

 
Note that all positions except C1 are now more or less split. Close positions in the rigid 
body model are not problematic because the individual atomic parameters will be refined 
only once for the model molecule. 
 
Start “Parameters → Molecules → Edit” 
Select refinement of “aimol” (this is occupancy of the molecular position) 
OK; YES to save changes 
Start Refinement options 
In page “Various” go to “Restrictions” 
Define a new restriction command between Molec#1 and Molec#2: coordinates and ADP 
parameters will not be restricted but molecular occupancies will keep the overall sum.     
OK; OK; Yes+Start 
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Refinement converges with R(obs) value about 8% 
The R value is still rather high but in a light structure missing hydrogen atoms may play an 
important role 

12. Local coordinate system 
Atoms in the atomic part are generated according to the space group symmetry. In order 
to generate atoms within a model molecule, we have to define local symmetry of the 
molecule. After the placement of the model molecule to the final position in the unit cell, 
the local symmetry and the space group symmetry are combined.  
 
In our case, if we define the local symmetry 1, still keeping only one half of atoms in the 
model molecule, the molecule would be completed after correct placement on a two-fold 
crystallographic axis. However, we could not keep hydrogens of the carbon C1 in 
geometrically expected positions because the keep command applies to the model 
molecule and hydrogen positions need to be generated by symmetry. For this reason, we 
have to define the local symmetry.  
 
In our case, the model molecule has a two-fold axis along b and its point group will be 2. 
Because the internal definition of the point group expects rotation along c we have to 
define the point group 2 and change the local coordinate system. 
 
Start “Parameters → Molecules → Edit” 
For “point group” type “2”; TAB 
Check “use local system” and define “1 0 0” for x and “0 1 0” for z 

 
OK; OK; YES to save changes 
Run refinement – the results should be the same like without the local symmetry 

13. Hydrogen atoms 
Start “Edit atoms” 
Select all carbon atoms including the ones of the model molecule 
Add hydrogen atoms in automatic mode 
Verify by plotting placement of hydrogen atoms 
For suppressing one of the disordered positions its molecular occumapcy can be 
temporarily set to zero through "Parameters → Molecules → Edit". In such case, do not 
forget to set it back after the plotting.  
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Run refinement 
R value drops to 3.9%, GOF=2.6. 
 
Start EditM50 
Go to the page “Composition” 
Press “Formula from M40” 
It should print C7 H12 N4 O2 for Z=4 
Start Refinement options, page Basic 
Change Instability factor from 0.01 to 0.02 
Run refinement 
Refinement converges with R(obs)=3.9%, GOF=2.0. 
Ideally, the instability factor should be determined for a given instrument. In the practice 
we know that it ranges between 0.01 and 0.02.  
GOF about 2.0 may indicate that disorder is not described exactly. It may also indicate that 
the data contains information about bonding effects.  
Start Fourier options 
In page Basic define “Map type” “Fobs-Fcalc difference Fourier” 
Run difference Fourier 
In the listing of Fourier check list of maxima and minima 
The residua are small like for fully solved structure 
Last step, which is skipped in this example would be comparison of the molecular model 
with a model built from split atom positions. The resulting R value would be very similar to 
that of the molecular model. 
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Example 8.3: DFerrocene 
Simple disordered structure from neutron single crystal data 
Revised: 5 April 20188 
DFerrocene 
 

Single crystal data measured with SXD ISIS diffractometer 
Input file: DFerrocene.int 

1. Creating new jobname 
Start Jana2006 
[On the screen: Basic Jana window] 
“File → Structure → New” opens a file manager 
[On the screen: New : Select name of the structure] 
Left pane: locate directory with input files 
Right pane: double-click dferrocene 

2. Import Wizard 
[On the screen: Specity type of the fie to be imported] 
Select “Single crystal: known diffractometer format”, NEXT 
[On the screen: Data reduction file from] 
Select “ISIS SXD”; NEXT 
File name is automatically set to ”hurea.int”. 
[On the screen: Complete/Correct experimental parameters] 
Modify temperature to 200; NEXT 
[On the screen: Define the reference cell/split by twinning] 
 NEXT; FINISH 
[On the screen: Data repository] 
OK; Yes, to accept changes 

3. Creation of the refinement reflection file 
Leave the form unchanged; NEXT; OK; Finish 
SXD, the single-crystal diffractometer at the ISIS spallation neutron source, uses an array of 
two-dimensional position-sensitive detectors and the neutron time-of-flight technique to 
measure diffraction data throughout very large volumes of reciprocal space for each fixed 
orientation of a single-crystal sample. [from: D.A.Keen, M.Gutmann and C.C.Wilson Journal 
of Applied Crystallography, (2006), 39, 714-722.].  
The “int” file contains all necessary information to create Jana reflection file for multi-wave 
data. As intensities of reflections are measured by TOF method with more than one detector 
the step of merging data and symmetry test in Jana is skipped.  
 

4. Structure solution 
[On the screen: Structure solution] 
Type formula C10 D10 Fe; Formula units 2 
Press “Change the space group”; 
[On the screen: Define space group] 

http://reference.iucr.org/dictionary/Reciprocal_space
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File the space group P21/a, monoclinic axis “b” (P 1 21/a 1) 
Go through the dialog for creation of the refinement of the reflection file; 
Select “Use Superflip” 
For peak interpretation select EDMA – fixed composition 
Check “Repeat Superflip: Number of runs” 
Set “Maxcycles” to 2000 and Number of runs 10; 
 

 
 
Press “Run solution” to start Superflip 
Press “Draw structure” 
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The model seems to be correct the D atoms will be localized in the next step. 
Accept last solution. 

5. Refining the structure 
[On the screen: basic window of Jana] 
Start Refine 
Refinement converge with R(obs) about 42% 

6. Completing the structure 
[On the screen: basic window of Jana] 
Start Fourier option 
In the page “Basic” define “F(obs)-F(calc) – difference Fourier) 
OK; YES+START 
OK to start procedure for including new atoms 
Go through the list of found peaks to add missing D atoms:  
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Finish; Yes to include new atoms; 
Start Editm40; Select all carbon and deuterium atoms;  
Press Action and select “Make symmetrically contiguous motifs”; 
Yes to save changes; 

7. Refinement of the structure 
[On the screen: basic window of Jana] 
Start Refine 
Refinement converge with R(obs) about .1% 
Press “Select all” and “Action → Edit/define” 
Choose “harmonic” for ADP parameters. This defines anisotropic temperature parameters 
for all atoms. OK, OK, YES to save changes 
Start Refine 



535 Jana2006 Cookbook, version September 2019 
 
 

Refinement converge with R(obs) about 25.5% 
 

8. Extinction correction 
[On the screen: basic window of Jana] 
Go to “Parameters → Extinction” 
 

                                 
Results: 
Isotropic – Becker & Coppens, Type 1, Gaussian R(obs)=18.3% 
Isotropic – Becker & Coppens, Type 1, Lorentzian R(obs)=18.5% 
Isotropic – Becker & Coppens, Type 2, R(obs)=18.4% 
Continue with the best fitting model Isotropic – Becker & Coppens, Type 1, Gaussian 

9. Disorder in the structure  
[On the screen: basic window of Jana] 
Start “Plot structure” with Diamond 
Plot the structure with  

Use  at the bottom toolbar of Diamond to see ADP ellipsoids. 
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The ellipsoids of C and D atoms are strongly prolonged in way, which clearly demonstrate a 
rigid body disorder.     
Quit Diamond 

10.  Atom split model 
[On the screen: basic window of Jana] 
Start Edit atoms 
Select all C and D atoms; Press Action and run “Split atom position” 
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The atomic position will be split into two positions with a shift which is derived from the ADP 
ellipsoid. The above choice means newly created atoms will have identical isotropic ADPs 
and their occupancies will be restricted to keep a constants sum.   
OK; Yes to save changes 
Right-Click on “Refine” 
[On the screen: Refine commands] 
Set "Number of cycles" to 30 
OK; Yes+start 
Refinement converge with R(obs) about 23.7% for 83 refined parameters 
The fit is considerably worse that we got from the simple anisotropic model. The split model 
can help us to get a starting positions for two split molecular fragments C5D5  

11. Rigid body model 
[On the screen: basic window of Jana] 
Start “Plot structure” with Diamond 
Plot the structure with  
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Two molecular fragments make the atoms: C1,D1,C4,D4,C3’,D3’,C2’,D2’,C5’,D5’ and 
C1’,D1’,C4’,D4’,C3,D3,C2,D2,C5,D5. 
“Parameters → Molecule → New molecule” starts the procedure for building a new 
molecule 
[On the screen: Atoms of the new molecule from] 
Select from Atomic part; 
Type in the name of molecule “Cp” (cyclopentadienyl) ;NEXT 
[On the screen: Select atoms for the new molecule] 
Select C1,D1,C4,D4,C3’,D3’,C2’,D2’,C5’ and D5’; OK 
[On the screen: Define the molecular reference point:] 
Check “Gravity center”; OK 
[On the screen: Complete molecular position #1:] 
Press “Apply+Next Position”; 
[On the screen: Complete molecular position #2:] 
Fill the three model atoms – C1, C2’ and C3’; 
Any three atoms can be used as in cyclopentadienyl none of three atoms lay on the line;   
Fill the three model atoms – C1’, C2 and C3; 
Change the maximal coincidence distance to 0.5; Press “Show coinciding atoms” 
The coincidence ration should be 10/10; 
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Press Apply+End; 

12. Refining the rigid bode model 
[On the screen: basic window of Jana] 
Start Refine 
Refinement converge with R(obs) about 24.52% for 59 refined parameters 
“Parameters → Molecule → Edit” 
Activate refinement of “aimol” i.e. relative occupancy of the first molecular position; 
Right-Click on “Refine” 
[On the screen: Refine commands]   
Go to "Restrictions" 
Define two molecular positions Cp#1 and Cp#2 and check “keep overall sum”; Add; Ok; Ok                      
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Yes+Start 
Refinement converge with R(obs) about 24.47% for 60 refined parameters. This means 
almost no change – two positions are equally occupied. 
Run Edit atoms 
Select all atoms of the molecule (blue ones); Double click with mouse; 
Activate “Use TLS”; Ok; Ok; Yes to rewrite changed files; 
Run Refine;   
Refinement converge with R(obs) about 10.6% for 90 refined parameters 
 

13. Corrected structure  
[On the screen: basic window of Jana] 
Multi-wave data collected with several detectors cannot be merged by a usual data 
reduction procedure and therefore all R values are considerably worse than for other 
diffraction techniques. For this reason a special option which creates so called “corrected” 
structure has been included into the Jana software. This method uses the refined scales and 
extinction parameters to correct the measured intensities. 
Go to “Tools → Special tools → Creation of “corrected” structure” 
[On the screen: Create a corrected structure] 
Define name for the corrected structure “_corrected”; OK 
After the creation of the refinement reflection file continue with the corrected structure 
[On the screen: basic window of Jana] 
Start Refine         
Refinement converge with R(obs) about 8.81% 
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Example 8.4: Boroncage 
Revised: 8 March 2019 
 

Data Topic  Level 

X-ray single crystal data Structure with disorder solved from 
a non-merohedric twin 

Intermediate  

Tasks 
Disordered structure solved with help of rigid body 

- creating new jobname 

- reading input file in the hklf5 format with twinning 

- determination of symmetry 

- solving a structure with charge flipping 

- completing the structure 

- basic refinement 

- identification of disorder 

- description of disorder with several positions of one molecule 

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
Cage_hklf5.hkl, cage_hklf5.cif_od 
Additional information: 
Chemical formula: B10C2H10IS 

 
Frame scaling, absorption correction: done by the diffractometer software  
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Instructions  

I. Data import  
Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files; Right pane: double-click cage_hklf5 (Step2) 

Import wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction → CCD”; NEXT 
Select “Input from “cif_od” file”; OK 
Leave all settings unchanged; NEXT 
In the next window, click the button “Twinning matrices” to check that the twinning was 
properly read from the cif_od file; (Step1) 
OK; Yes to accept the twinning matrix and close the window; NEXT  
The program reads 10823 reflections from the hkl file 

Step 1  

 

 

For the absorption correction select “None or done before importing”; NEXT; FINISH 

OK to accept data repository; NEXT to start symmetry wizard 

II. Symmetry and data merging  

5. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT 
“Continue with the basic cell”; NEXT 
[On the screen: Select Laue symmetry] 
Select Monoclinic Laue symmetry; NEXT 
 

Note  
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Note the high Rint for both Laue classes and low redundancy. This is the consequence of the 
twinning in the data. 

 
 [On the screen: Select cell centering] 
Select primitive unit cell; NEXT 
[On the screen: Select space group] 

Notes  
The window shows possible space groups. In this case all statistics show zeroes and all space 
groups have the same FOM (figure of merit). This is due to the twinning described with the 
hklf5 format, which prevents the detection of systematic absences from the data. No 
distinction between the space groups can thus be done and we need to guess. We select 
P21/n, because it is a very common space group. The space group will later be independently 
checked by structure solution in Superflip (see part III – Structure solution). 

Select P21/n; NEXT 
Accept the space group in the original cell setting; FINISH 
Symmetry is saved in file cage_hklf5.m50. 

Creating refinement reflection file 
Notes  
In this step the program creates file cage_hklf5.m90 containing the data set merged by 
symmetry and with discarded forbidden reflections. M90 will be used for refinement. 

NEXT to confirm threshold 3sigma; OK (to confirm Information windows); NEXT (Step1) 

Notes  
Due to the twinning described with the hklf5 format, no merging can be performed and no 
Rint is calculated. 

 
OK; Select "Accept the new DatBlock and calculate coverage"; FINISH 

Step 1  
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III. Structure solution  

6. Structure solution wizard  

[On the screen: Structure solution] 
In “Formula” textbox type list of chemical elements: C B I S H 
 

Notes  
Superflip as well as SHELXT does not need exact information about chemical elements 
because it is required only for analysis of the resulting electron density. Other solution 
methods like SIR may need the correct formula and number of formula units.  
In this example, usage of SHELXT is not possible because we would lose the twinning 
information.  

Select “Use Superflip” 
Leave other settings default; press “Run solution” 
[On the screen: window of Superflip is replaced after reaching the convergence with the 
listing of Superflip](Step2) 
 

Notes  
Superflip converges (after noise suppression) with R value ~24%. The space group suggested 
from the symmetry search in the electron density map is P21/n and it thus confirms our initial 
guess. 

 
Step 1  

 

 

Press CLOSE to leave the listing 
Verification of the structure solution from the structure solution wizard 

[On the screen: Structure solution] 
Press “Draw 3D map” 

 
Notes  
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This button starts Vesta (requires path to Vesta set in Tools Programs), which plots the 
electron density produced by Superflip together with atomic positions found by Jana2006.   

 
[On the screen: window of VESTA] 

 
 

Notes  
Look closely at the structure. Compare with the expected molecule shown at the beginning of 
the tutorial. You will see that large part of the structure is present, but some atoms are 
spurious and quite a few atoms are missing.  

 
Close VESTA; Do not save the changes in VESTA; 
Click “Accept last solution” 

Completing and correcting the structure 
[On the screen: basic Jana window] 
Start Refine  
Refinement converges with R value ~13% 
Start Edit Atoms; Press Select rejected; Action → Delete selected atoms 
Start Refine 
Refinement converges with R value ~13% 
Right click on Fourier; select “F(obs)-F(calc) – difference Fourier”; OK; Yes+Start 
Yes to start adding new atoms; OK 
[On the screen: dialog for adding new atoms] 
Add all maxima with reasonable (~1.7 Å) distance of some existing carbon or boron: 
In the left pane, select the maximum to be added 
In the right pane, check the distances and press “Include selected peak” 
Name of atom: B*; OK 
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Repeat the process for other maxima 
FINISH; YES to include new atoms 
Start Refine 
Refinement converges with R value ~9.5% with 113 refined parameters 
In case of less parameters, something is missing and difference Fourier must be repeated. 
The resulting number of atoms is 28.  
[On the screen: basic Jana window] 
Double click the icon “Plot Structure”; “Draw + Continue” 
In Diamond, press “Get Molecules directly” and activate plotting of ellipsoids 

 
 

Notes  
We can see two complete cages, and the only issue is assignment of carbons. From 
chemistry, it follows that in each cage carbons are the two atoms opposite the boron atoms 
with I and S. These atoms are highlighted it the figure. 
Another remarkable feature is rather small Uiso of Sulphur and rather large Uiso of iodine in 
one of the cages.   

 
In Jana2006, Edit Atoms, change the highlighted atoms to carbon and all other atoms of the 
cage to boron 
Still in Edit atoms, select all atoms and press Action → ”Rename atoms to atom type + 
number” 
Select I1, I2, S1, S2; Action → Edit/define atoms 
Select harmonic (anisotropic) ADP; OK; OK; YES to save changes 
Run Refine 
Refinement converges with R value ~7% and 133 refined parameters 
Some ADP are negative 
YES to open the refinement listing 
Press Go to; select “List of serious warnings” 
We can see that one of S atoms has non-positive ADP. Together with the fact of strange Uiso 



548 Jana2006 Cookbook, version September 2019 
 
 

if Sulphur and iodine, this is clear we should try refinement of their occupancy 
Close the refinement listing 
Start Edit Atoms 
Select I1, I2, S1, S2; Action → Edit/define atoms → Page Edit 
Activate refinement of “ai”; OK; OK; YES to save changes 
Run Refine 
Refinement converges with R value ~5% and 137 refined parameters 
No serious warning are present 
Start Edit Atoms 
Select I1; Action → Edit/define atoms → Page Edit 
Look at “ai” (site occupancy) of I1 
Using arrows close the List button, look at “ai” of I2, S1 and S2 
Quit Edit atoms 
 

Notes  
We can see “ai” (site occupancy) of I1 and I2 is decreased while occupancy of sulphur is 
significantly increased in one case and slightly increased in the second case. This can be 
explained by assuming the disorder of the molecule between the two positions, in which 
all the boron and carbon atoms are essentially in the same position, but iodine and 
sulphur are exchanged. In the following, we will describe this disorder using the rigid body 
approach.  

 
 

IV. Setting up molecules and molecular positions 
1. Preliminary work 
Start File  → Structure → Save As and create a backup copy 
Start Edit atoms; Select all; Action → Make symmetrically contiguous motifs 
Still in Edit atoms: Select I1, I2, S1, S2; 
Action → Edit/define → Edit; double-click “ai” textbox and change its value to 1, and 
disable its refinement 
Change ADP of I1, I2, S1, S2 to isotropic 
OK; OK; YES to save changes 
Plot structure: in Diamond, use the button  (Add all atoms and bonds), which adds 
atoms like they are in M40 (i.e., without symmetry transformation). Connect atoms with 
bonds.  

Notes  
If you see two complete cages that means the previously used command “Make 
symmetrically contiguous motifs” has been working correctly. The properly connected sets 
are necessary for work with rigid body. 

 
Still in Diamond, plot labels of atoms 
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Note labels of three atoms from the first cage and three corresponding atoms from the 
second cage.  
 

Notes  
In our example, the possible three pairs of atoms are I2-I1, S1-S2, C4-C1 (in your solution, 
labels might be different). In next steps, the procedure for transforming the first cage to the 
second one will use atoms I2, S1 and C4 of the first cage and create a transformation matrix + 
translation vector for transforming these three atoms to positions of I1, S2 and C1.  

 
Note labels of all atoms of the first cage (in our case, I2, S1, C3, C4, B1, B11, B3, B8, B4, B17, 
B18, B5, B15, B9, 14 atoms) 
2. Defining the molecule from atomic part 
[On the screen: basic window of Jana] 
Go to “Parameters → Molecules → New molecule” 
Name the molecule “cage”; NEXT 
Select the previously noted 14 atoms belonging to the first molecule; OK 
Select gravity center as the molecular reference point; NEXT 
Leave all setting default, click “Apply + Next position” 
 
To define the second position, identify three pairs of corresponding atoms between the first 
and second instance of the molecule in the structure. In our example, the pairs are I2-I1, S1-
S2, and C4-C1. In your case, labels might differ. 
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Click “Show coinciding atoms” to convince yourself that all atoms of the second molecule 
were correctly identified with the atoms in the reference molecule. 
Click “Apply+End” to apply the changes. 
 
Start Edit Atoms 
Atoms which are part of a rigid body are blue. No black atoms should be present 
Select all; Action → Rename selected atoms to “atom type”+number 
OK; YES to rewrite changes 
 

Notes  
With this procedure, we generated one reference molecule from the first of the two 
independent molecules, and placed this molecule in two positions, corresponding to the two 
molecules in the structure. We will now run a check refinement to see if we did not make any 
serious mistake with this modification of the structure model. 

Checking refinement 

[On the screen: basic window of Jana] 
Make a backup copy of the structure through “File – Structure – Save as” 
Start Parameters  → Twin fractions and activate refinement of twvol2 
The initial value was determined by the diffractometer software. This step could have been 
done sooner but the initial value is correct.  
Double click the icon “Refine” 
The refinement converges to an R-value of about 11.7% 
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Notes  
11.7% is a larger value than 9.5% from the previous refinement. However, the number of 
parameters is also much lower (64 instead of 114 of the free-atomic isotropic model with 
refined twvol2). The reason for the increased R-value is the fact that now atoms in both 
molecules have identical displacement parameters and identical mutual positions, while 
before the two molecules were refined independently. Given this strong restriction, the 
increase in R-value is not so large and we may proceed with the current model. 

 
Set up the disordered positions of the molecules 

Notes  
To place second position of the molecule that describes the disorder of Sulphur and iodine, we 
may either use some of the available transformation tools, or we need a set of atoms to align 
the new position with. In the current case the transformation between the positions is 
difficult to express in crystallographic coordinates, and we will therefore use the second 
option. In Jana, new molecular position can be aligned only to atoms in atomic part. We will 
thus first create duplicates of three atoms in each molecule, move it to atomic part and then 
use them to define the new position. 

 
[On the screen: basic window of Jana] 
Click “Edit Atoms” 
Select atoms I1, S1, C1 
Click “Action -> Split atomic position” (Step1) 
Uncheck “Generate restrict commands for REFINE”;  
Set Relative occupancy of the split atom to 0 (we are making a dummy atom) (Step2) 
“Apply-> Go to next”; 
Repeat with the remaining two atoms 
Select the newly created atoms I1’, S1’, C1’ 
Click “Action -> Atoms from molecule to atomic part” (Step3) 
“OK+Yes” to apply changes 
 
 

Step 1 Step 2 
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Step 3 Step 4 

  
 

Notes  
We now generated six new atoms I1’a, I1’b, S1’a, S1’b, C1’a, C1’b. To place a molecular 
position with I1 and S1 exchanged, we will identify the model atom I1 with S1’a, S1 with I1’a 
and C2 with C1’a, and similarly for the second molecule. 

 
[On the screen: basic window of Jana] 
Go to “Parameters → Molecules → New position” 
Type in model atoms I1, S1, C2 and actual position/atom S1’a, I1’a, C1’a Increase “maximum 
coincidence distance” to 0.6 (Step4) 
Click “show coinciding atoms” to ensure that all three pairs have been correctly matched 
“Apply+Next position” 
Repeat with model atoms I1, S1, C2 and actual position/atom S1’b, I1’b, C1’b 
“Apply+End”; “Yes” to confirm changes and rewrite files 
 
[On the screen: basic window of Jana] 
Go to “Parameters → Molecules → Edit” 
Set the molecular occupancy aimol of the first position to 0.5; check the check box next to it 
to refine it (Step5) 
Repeat for the remaining three positions 
OK; “Yes” to confirm the changes 
Right-click the icon Refine 
 
[On the screen: basic window of Jana] 
Go to tab Various click on  ”Equations” (Step6) 
In the Equation line type “aimol[cage#3]=1-aimol[cage#1] 
Click the arrow “Add” (Step7) 
In the same manner define the second equation aimol[cage#4]=1-aimol[cage#2] 
OK+OK+Yes to confirm and save new commands. 
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Step 5 Step 6 

 

 
Step 7  

 

 

 
Notes  
Let us summarize what we did in this long series of commands. We have 

1) Placed two new positions of the molecule that almost superimpose with the original 
positions except for a rotation by 180 degrees, which exchanges iodine with sulphur. 

2) Reset the occupancies to 0.5, so that the occupancies of the superimposed molecular 
positions sum up to 1. 

3) Asked Jana to refine the occupancies. 
4) Defined equations that ensure that the sum of the occupancies of overlapping 

positions will remain 1. 
Now we are ready to start refinement. You may first plot the structure to better understand 
the changes and appreciate the complexity of the created structure model. 

 
Refine the disordered model 

[On the screen: basic window of Jana] 
Double click the icon “Refine” 
The refinement first converges quickly to relatively low R-values, but then oscillates. We 
need to damp the refinement 
Click the button “Parameters” in the refinement window during the refinement 
Set the Damping factor to 0.3; check the checkbox “Make these settings permanent; OK 
(Step1) 
The refinement stabilizes and converges to an R-value of about 6.9% 
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This is an important improvement showing that the disordered model was a good direction 
(The iodine and sulfur atoms are still isotropic) 
  

Step 1  

 

 

 
[On the screen: basic window of Jana]  
Go to “Parameters → Molecules → Edit” 
Check the refined occupancies of the molecular positions. 
 

Notes  
The occupancy of position 1 refines to 77% and position 2 to 95%. Thus, the occupancy of the 
minor orientation of molecule 2 is only 5%. However, the esd of this value is 0.2% (this can be 
found in the refinement listing), i.e. the occupancy is small, but strongly significant. 
At this point it is good to check the difference Fourier map to see if the problem with the large 
maxima on iodine and sulphur atoms disappeared. 

 
Add hydrogen atoms 

[On the screen: basic window of Jana] 
Double click the icon “Edit atoms“ 
Select all atoms except I1, S1 and the two boron atoms bonded to I and S 
Go to “Action → Adding of hydrogen atoms” (Step1) 
Uncheck the check box “try automatic run for carbon atoms”; OK (Step2) 
Set the hydrogen distance to 0.96Å if the title atoms is carbon, and 1.06 for boron (Step3ab) 
Leave other settings default; “Apply -> Go to next” 
Repeat for all atoms 
OK; “Yes” to confirm changes 
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Step 1 Step 2 

 

 

Step 3a  

  
 
[On the screen: basic window of Jana] 
Double click the icon “Refine” to refine the model with hydrogen atoms 
The refinement converges to an R-value of about 6.6%. Thus, the improvement by adding 
hydrogen atoms is only minor, which is not surprising given the presence of iodine and 
sulphur in the structure. 
 

Apply TLS tensors 
Notes  
So far all corresponding atoms in the four positions of the molecules had the same (isotropic) 
displacement parameters. This is quite a coarse approximation. If we change ADP of all non-
hydrogen atoms to anisotropic, we will increase number of parameters from 78 to 148 but 
the decrease in R value will be only 0.6 %. More logical seems to be refinement of the 
displacement parameters of each position separately using the concept of TLS tensors. TLS 
tensors are a generalization of displacement parameters to groups of atoms which are 
assumed to undergo collective displacement. 

 
[On the screen: basic window of Jana] 
Create backup copy of your structure 
Double click the icon “Edit atoms” 
Select all atoms and double click any of them 
Choose “Use TLS” (Step1) 
OK+OK+Yes 
Double click the icon “Refine” to refine the new model 
The refinement converges to an R-value of about 4.5% (Step2)    
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Step 1 Step 2 

 

 

 
Notes  
The improvement of the fit with the TLS tensors is dramatic, despite of the increase of the 
number of refined parameters to 144. Unfortunately, TLS tensors tend to generate physically 
meaningless displacements on some atoms, especially on those at the periphery of the 
molecules. This can be checked in the refinement listing (check for negative eigenvalues of the 
ADP parameters in the list towards the end of the file) or by visual inspection of the structure 
with ADP ellipsoids. In the current case the main molecular positions (position a and b) refine 
to largely acceptable displacement parameters (although a few hydrogen atoms and two 
non-hydrogen atoms also have non-positive ADP), but the minority positions have some of 
the displacement tensors non-positive definite. This not surprising especially for the position 
with 5% occupancy. To solve this problem, some of the TLS parameters would have to be set 
to zero or restrained between the two positions. 
 
The most often case is that “S” tensors are the cause of the troubles. In  the next step, we will 
set “S” tensor components to zero 

 
Start refinement options → page Various → fixed commands 
Check “set individual” 
In the Atoms/parameters textbox type s??[Cage#?]; Add 
OK; OK; YES+Start 
The refinement converges to an R-value of about 4.6% with 112 parameters. This shows the 
S components could be omitted 
In the next step, we will define a constraint that TLS parameters are the same for “a” and 
“c” cage (i.e. cage#1 and cage#3), and also for “b” and “d” cage (i.e. cage#2 and cage#4) 
Start refinement options → page Various → Restrictions 
Delete three already present restrictions defined previously fro already not existing dummy 
atoms I1’, S1’ and C1’ 
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In the Atoms/molecules textbox type cage#1 cage#3; check “ADP parameters”; Add 

 
OK; OK; YES+Start 
The refinement converges to an R-value of about 4.8% with 88 parameters. 
The list of eigenvalues in the refinement listing as well as a plot with ellipsoids show that 
everything is correct.  
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Example 9.1: L9A 
Getting familiar with the output of Superflip. Some useful tricks. 
 
Revised: 15 September 2014 
 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: L9A.m40, L9A.m50, L9A.m90, L9A.m95 
 
The purpose of this exercise is to understand the log-file of Superflip, point out the most 
important information to check, and to learn some basic tricks for the case Superflip does not 
converge with default parameters. The structure used for the exercise is an organic structure 
with symmetry Pna21. 

1. Load the structure 

The structure is already prepared in Jana format for your convenience. 
Start Jana2006; 
“File → Structure → Open” opens a file manager; 
Left pane: locate directory with input files; 
Right pane: double-click L9A; 
 
Plot the structure, if you wish, check EditM50 to see the composition and symmetry. 

2. Run Superflip. 

Double click the icon Structure solution  
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[On the screen: Structure solution] 

 
Select “use Superflip”; 
Start “Run Solution”; 
Superflip starts, and after a few moments you will see the Superflip’s log-file open in the 
window of Jana. It should be very similar to the commented file below. It will not be exactly 
the same, because the iteration starts from random starting point, but the differences 
should be minor. Please take your time to go through the text below, read the comments, 
try to understand the listing both in this exercise and on your screen. Are the two listings 
different in any important manner? 
 
The first part is the header of the file, with information about the version. If you encounter 
strange behavior of Superflip, make sure in http://superflip.fzu.cz you have the newest 
version.The executable of Superflip downloaded from this web page should be copied to the 
SUPERFLIP directory of Jana2006 installation.  
 
************************************************************** 
                           Superflip 
                    Version: 12/04/13  7:57 
Palatinus, L. & Chapuis, G.(2007): J. Appl. Cryst. 40, 786-790 
              http://superspace.epfl.ch/superflip 
************************************************************** 
 

Next part is a review of input parameters and crystallographic information. Superflip 
currently writes only the matrix-vector representation of the space group, and not the space 
group symbol. 
 
----------------------------------------------- 
Start of the calculation: 28.JAN 2014, 14:29:49 
----------------------------------------------- 
 
################################################################### 
# Following data were read from the input file or set as default: # 
################################################################### 
 
Job title: L9A 
 
------------------------ 
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Information about files: 
------------------------ 
Name of the input file: L9A.inflip 
Density will be writen in following files: 
   L9A.m81, with type jana 
   L9A.m80, with type m80 
Warning: If the outputfile exists, it will be overwritten by the new density. 
Logfile will contain only basic information about the calculation. 
Logfile will contain information about the data coverage. 
 
----------------------------- 
Crystallographic information: 
----------------------------- 
Superspace dimension:             3 
Dimension of the physical space:  3 
Direct cell parameters:         15.3079   9.2915  13.8059  90.0000  90.0000  90.0000  Volume:   1963.65942 
Reciprocal cell parameters:      0.0653   0.1076   0.0724  90.0000  90.0000  90.0000  Volume:      0.00051 
Wilson plot will be based on this composition: C84H104N8O16 
4 symmetry operations found, their list follows: 
 
   1:   1  0  0   0.0000   2:  -1  0  0   0.0000   3:   1  0  0   0.5000 
        0  1  0   0.0000        0 -1  0   0.0000        0 -1  0   0.5000 
        0  0  1   0.0000        0  0  1   0.5000        0  0  1   0.0000 
 
   4:  -1  0  0   0.5000 
        0  1  0   0.5000 
        0  0  1   0.5000 
 
The structure is non-centrosymmetric. 
 
-------------------------- 
Settings of the algorithm: 
-------------------------- 
Number of voxels:                   40    24    36   Total:     34560 
Number of voxels for polishing:     80    48    72   Total:    276480 
The density modification method will be charge flipping. 
Delta will be determined automatically. 
The iteration will be stopped when the convergence is detected or after ***** cycles. 
After the regular iteration   5 cycles of "density polishing" will be applied. 
The random number generator will be initialized automatically. 
 
Random initial phases will be assigned to the structure factors. 
Isotropic Debye-Waller factor:   0.000 
Proportion of reflections to be treated as weak:   0.000 
All reflections with sin(th)/lambda < 0.400 not present in the input data set will be treated a missing. 
The amplitudes of the missing reflections will be left unconstrained. 
 
The resulting density will be shifted and averaged according to the symmetry operations given above. 
Following symmetry operations will be used to locate the origin of symmetry:   3   4 
 

Most of the information above is just diagnostic and is not important for ordinary user. 
However, the number of reflections treated as weak might be changed, if Superflip does not 
converge with default parameters. See below for more discussion on this parameter. 
 
Next part is an overview of reflection import. “Number of reflections treated as missing” is 
the number of low-resolution reflections that are not present in the input data. By default, 
Superflip lets their value vary freely during the iteration. However, if this number is large 
(say more than 10% of all reflections), the iteration may fail. In such a case a more 
sophisticated treatment of reflections (or a more complete dataset) may be necessary. See 
manual of Superflip, keyword missing for more information. 
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################################## 
# Information about reflections: # 
################################## 
 
Number of reflections in the input file:   1624 
 
------------------------- 
Averaging of reflections: 
------------------------- 
Redundancy   : 1.000 
Rint         : ----- 
 
Maximum indices in expanded reflection set:  17  10  15 
 
Number of reflections treated as missing:      6 
 

Wilson plot is always a useful indicator of the data quality and consistency. If you encounter 
problems with your structure, do not forget to check the Wilson plot and make sure it does 
not show anomalies. The value Biso is the Wilson-plot based estimate of the average Debye-
Waller factor. If it is larger than 2, a correction of the input data might be needed. We will 
learn how to make this correction later in this exercise. 
 
------------ 
Wilson Plot: 
------------ 
 
circles: <I>/SUM(f^2) 
dots   : linear fit y =   1.5450 +   -3.480 * [sin(theta)/lambda]^2 
 
   4.15377-|     o o 
          -|         . . o 
  Scale^2 -|   o       o . o                     o 
          -|         o       o .               o 
          -|                     .           o     o o 
   2.99073-|                   o   . .   o o 
          -|                     o     . .             o 
          -|                               . .           o 
          -|                           o       . . 
          -|                       o o             . . 
   2.15334-|                                           . . o 
          -|                                               . o 
          -|                                                   o o 
          -|                                                       . 
          -|                                                       o . . 
   1.55041-|                                                             . . 
          -|                                                         o       . . o 
          -|                                                           o o       . 
          -|                                                               o 
          -|                                                                   o 
   1.11630-|                                                                 o 
           I-------------------I-------------------I-------------------I---------- 
          0.00                0.10                0.20                0.30 
                                   [sin(theta)/lambda]^2 
 
Scale (F_obs = K * F_abs):     2.165 
Biso:                          1.740 
 
 
 

Coverage statistics shows the coverage as a function of resolution. The coverage should be 
high (optimally more than 90%) up to a reasonable resolution (dmin<1.1 or better). If one of 
these conditions is not fulfilled, Superflip may fail. Very low coverage at low resolution is 
especially dangerous. 
 
---------------------------------------------------------- 
Coverage statistics of the expanded reflections by shells: 
---------------------------------------------------------- 
Resolution (sin(th)/l):    0.050    0.100    0.150    0.200    0.250    0.300    0.350    0.400 
Resolution (d_min):       10.000    5.000    3.333    2.500    2.000    1.667    1.429    1.250 
Obs. refl. in shell:           0       25       69      139      238      349      515      655 
Total refl. in shell:          0       27       73      139      238      349      515      655 
Coverage in shell:          0.0%    92.6%    94.5%   100.0%   100.0%   100.0%   100.0%   100.0% 
Commulative coverage:       0.0%    92.6%    94.0%    97.5%    98.7%    99.3%    99.6%    99.7% 
 
Resolution (sin(th)/l):    0.450    0.500    0.550    0.575 
Resolution (d_min):        1.111    1.000    0.909    0.870 
Obs. refl. in shell:         876     1093     1323      708 
Total refl. in shell:        876     1093     1323      730 
Coverage in shell:        100.0%   100.0%   100.0%    97.0% 
Commulative coverage:      99.8%    99.8%    99.9%    99.5% 
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Iteration record shows some most important quantities during the iteration process. At the 
beginning the program tries to estimate the value of delta automatically. This procedure is 
very reliable, and only in very rare cases a manual selection of delta is necessary. The four 
quantities shown in every line are as follows: 

- R: The R-value between the observed structure-factor amplitudes, and the amplitudes 
calculated after flipping. This value usually lowers at the convergence. 

- Charge: Total charge in the current density. This value progressively lowers during the whole 
iteration, but drops down abruptly at the convergence 

- Peaks: The third central moment of the density – a measure of “peakiness” of the density. 
This value grows at the convergence. 

- Score: A combined “Figure of merit” calculated from the three quantities above as well as 
from their derivatives. If the score grows above 0.8, Superflip considers the iteration as 
converged. 
Note: An automatic detection of convergence is an extremely difficult task, because it must 
cover a wide range of cases. Therefore, despite of a substantial effort invested into the 
detection, Superflip occasionally fails to detect convergence. It is therefore always worth 
checking whether the structure is solved, even if the iteration does not seem to converge. 
 
############# 
# Iteration # 
############# 
 
Estimated delta:  2.2715 
Random seed:     131727704 
 
Searching for a proper delta: 
Current delta =    2.27153  (k_ed =   1.00000) 
Total/flipped ratio =    1.021. Increasing delta. 
 
Current delta =    2.43053  (k_ed =   1.07000) 
Total/flipped ratio =    0.856. 
Criterion for delta fulfilled, continuing iteration. 
   20  R: 49.925  Charge:    1220.10   Peaks:  1.26   Score:    --- 
   30  R: 48.103  Charge:    1149.05   Peaks:  1.36   Score:    --- 
   40  R: 49.758  Charge:    1128.06   Peaks:  1.47   Score:    --- 
   50  R: 49.224  Charge:    1120.09   Peaks:  1.53   Score:    --- 
   60  R: 49.160  Charge:    1067.55   Peaks:  1.58   Score:    --- 
   70  R: 49.279  Charge:    1092.28   Peaks:  1.62   Score:    --- 
   80  R: 48.642  Charge:    1088.73   Peaks:  1.70   Score:    --- 
   90  R: 48.457  Charge:    1063.52   Peaks:  1.74   Score:    --- 
  100  R: 48.313  Charge:    1065.67   Peaks:  1.74   Score:    --- 
  200  R: 46.931  Charge:    1057.27   Peaks:  1.89   Score:    --- 
  300  R: 38.686  Charge:     972.57   Peaks:  2.09   Score:   0.15 
 
Calculation successfully converged after   390 cycles. 
Last iteration record: 
  390  R: 23.891  Charge:     878.59   Peaks:  2.23   Score:   0.91 
 
     5 cycles of noise suppression follow: 
    5  R: 14.793  Charge:       0.00   Peaks:  2.71 
 

At this moment the calculation is converged (or the maximum number of iteration cycles 
was reached). Superflip has the capacity to check the resulting density for symmetry. It is 
advisable to always check this part of the log-file, and to make sure that the detected 
symmetry corresponds to your expectations. Derived space group P1 in cases where higher 
symmetry is expected usually indicates that the structure is not solved. 
Superflip lists all symmetry operations compatible with the lattice. Each line in the listing 
corresponds to one symmetry operation. The symbol of the operation is followed by a one-
line representation as used in International Tables for crystallography. Next is the 
“symmetry agreement factor”. This number indicates quantitatively, how well the operation 
is present in the electron density. Numbers below 10 indicate a very good match, number 
between 10 and 25 are still probable symmetry operations of the density, and numbers 
above 25 usually mean that the corresponding symmetry operation is not present. In the 
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example below the n-glide, a-glide, and two-fold screw axis have agreement factors below 
0.1, indicating an excellent agreement. All the rest of the list has a far too high value. The 
rows of XXXXXX after the symmetry agreement factor are just a graphical representation of 
the agreement factor, and serve as a quick guide for eye. 
 
##################################### 
# Checking the density for symmetry # 
##################################### 
 
Symmetry operations compatible with the lattice and centering: 
                              Symmetry operation             agreement factor 
        n(1,0,0):           -x1       1/2+x2       1/2+x3    0.022    XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX 
        a(0,1,0):        1/2+x1          -x2           x3    0.072    XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX 
      2_1(0,0,1):           -x1          -x2       1/2+x3    0.090    XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX 
        m(0,0,1):            x1           x2          -x3   74.885    XXXXXXXXXXXXX 
      2_1(0,1,0):           -x1       1/2+x2          -x3   74.894    XXXXXXXXXXXXX 
      2_1(1,0,0):        1/2+x1          -x2          -x3   74.907    XXXXXXXXXXXXX 
        m(1,0,0):           -x1           x2           x3   78.690    XXXXXXXXXXX 
        2(0,0,1):           -x1          -x2           x3   78.739    XXXXXXXXXXX 
        2(0,1,0):           -x1           x2          -x3   80.683    XXXXXXXXXX 
              -1:           -x1          -x2          -x3   80.741    XXXXXXXXXX 
        b(0,0,1):            x1       1/2+x2          -x3   84.318    XXXXXXXX 
        n(0,0,1):        1/2+x1       1/2+x2          -x3   91.302    XXXX 
        2(1,0,0):            x1          -x2          -x3   91.311    XXXX 
        a(0,0,1):        1/2+x1           x2          -x3   91.487    XXXX 
        b(1,0,0):           -x1       1/2+x2           x3   92.258    XXXX 
        c(0,1,0):            x1          -x2       1/2+x3  104.952    X 
        m(0,1,0):            x1          -x2           x3  107.481    X 
        c(1,0,0):           -x1           x2       1/2+x3  120.115    X 
        n(0,1,0):        1/2+x1          -x2       1/2+x3  135.532    X 
 

An experienced crystallographer can “see” the space group already in the list of the 
symmetry operations, but Superflip can analyze the list automatically. The default threshold 
for accepting a symmetry operation is the symmetry agreement factor below 25. All such 
operations are combined together, and a final space group is printed as Herman-Mauguin 
symbol, Hall symbol, Fingerprint, and a list of symmetry operations. The “Fingerprint” is an 
internal space-group symbol used by Superflip for a database search, and currently does not 
have any other use. 
 
------------------------------------------------- 
Space group derived from the symmetry operations: 
------------------------------------------------- 
    HM symbol:     Pna21 
    Hall symbol:   P 2c -2n 
    Fingerprint:   3300223}240qY3 (3/4,3/4,0) 
    Symmetry operations: 
               1:            x1           x2           x3 
      2_1(0,0,1):           -x1          -x2       1/2+x3 
        n(1,0,0):        1/2-x1       1/2+x2       1/2+x3 
        a(0,1,0):        1/2+x1       1/2-x2           x3 
 

As the density is reconstructed in P1, the origin is arbitrary. To allow for further processing, 
the density must be shifted to the standard origin of the space group, and averaged to have 
the desired symmetry exactly. The lines below show the record of this process. 
 
Important note: The “Check for symmetry” described above is just indicative, and does not 
have any impact on further symmetry processing (unless you force it explicitly in the input 
file of Superflip – see manual, keyword derivesymmetry for details). Thus, the output 
symmetry will be the symmetry indicated in the input file. If you call Superflip from Jana with 
default parameters, this is the symmetry recorded in m50. 
 
“Agreement factors of individual generators” show agreement factors for the generators of 
the input space groups. These generators are used to locate the origin of the space group. If 
the input space group is incorrect, or the solution did not converge, these agreement factors 
will be high (more than 25). Low values of the agreement factors are another reliable 
indicator that the structure was correctly solved. 
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############################################ 
# Search for the origin of the space group # 
############################################ 
 
 
Position of the origin in the CF map:  
  0.6641  0.6559  0.0000 
Agreement factors of individual generators: 
Number smb agreement 
   3   a        0.07 
   4   n        0.02 
 
Overall agreement factor:   0.06 
 

These are the final notes in the log file with information about the file with the output: 
 
You can obtain more information about the reconstructed reflection phases by using 'expandedlog yes'. 
 
Electron density written to file L9A.m81. 
 
 
--------------------------------------------- 
End of the calculation: 18.JAN 2010, 13:17:29 
--------------------------------------------- 
Superflip version: 07/16/09 09:12 
 

Press “Close” to close the listing and return to the Structure solution dialogue 

3. View the output of Superflip and resulting structure model 

[On the screen: Structure solution] 
After closing the listing of Superflip, Jana2006 automatically interprets the resulting density 
in terms of atomic positions and types. For chemical types, only the ones available in 
“Formula” are considered.  
Press “Draw structure” to visualize structure model interpreted by Jana2006 from the 
density provided by Superflip 
Note that the structure model has the symmetry originally det by the user. If the symmetry 
suggested by Superflip is different and you want to use it, it must be set by the “Change the 
space group” button, and the interpretation of the density map or complete charge flipping 
must be repeated.   
“Return to previous” loads the previous structure model. Note that there is only one step 
back possible. 

If everything goes well, the structure model correctly describes the density produced by 
Superflip. However, in some cases this can lead you to the wrong impression that this is 
what Superflip produces. In case of problems (typically disorder or wrong chemical types in 
the formula) viewing the density may be very helpful. 

Press “Draw 3d map” to view the 3D isosurface representation of the raw density produced 
by Superflip 
The crystallographic (not only) viewer VESTA must be installed on your computer and 
enabled it in Jana. If not, consult the installation notes and install the program first. Jana 
passes the volumetric data to VESTA along with the structure model. VESTA shows an 
overlay of both, with the density represented by isosurfaces, and atoms by spheres. In this 
case the density shows nice spherical maxima at the positions of atoms. All maxima are 
“occupied” by an atom. Thus, the structure model is likely to be complete and ready to be 
refined. 
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By default, the density from Superflip is saved in the file jobname.m81. That means that you 
can directly view it even after quitting the Structure solution dialogue as long as you do not 
overwrite it by calculating another Fourier map. M81 can be viewed with Contour program.  

By default, the structure factors from Superflip are saved in the file jobname.m80. That 
means the Fourier map can be recalculated by Jana2006 as long as m80 is not overwritten 
by refinement.  

4. Modify the default settings for Superflip 
The default settings passed to Superflip by Jana are applicable to most standard cases. 
However, under some circumstances the change is necessary. The most useful changes will 
be listed here. 
 
Hint 1: use normalized intensities:  
For more difficult structures using normalized intensities helps enormously.  

Check the checkbox next to Use local normalization:  
 
Hint 2: Run Superflip several times with a limited number of cycles: 
Check the checkbox “Repeat Superflip: number of runs” 

 
You may select a different number of repetitions than the default 10. 
If necessary, modify the maximum number of cycles per run, for example to 5000: 

 
This option may help if the solution appears unstable or if it gets trapped in a local 
minimum. Some of the repeated runs may escape from the local minimum. Superflip selects 
the best of all attempts for the output. 
 
Hint 3: Use a non-random starting model 
Select the option “Patterson superposition map” from the list named “Starting model”: 

  
With this option Superflip first calculates a Patterson superposition map and then uses this 
map as a starting model for the iteration. Very often this option speeds up the convergence, 
and sometimes it makes the difference between solved and non-solved structure. However, 
sometimes – especially for simpler structures – the convergence is so rapid that it cannot be 
detected and Superflip keeps running. This option saves time only for larger structures, 
ideally with at leas one non-light atom. 
 
Hint 4: use the AAR algorithm:  
Select the AAR iteration scheme from the list of options at the bottom of the window: 

 
The AAR algorithm appears to perform better than the standard algorithm for very 
incomplete data or for low-resolution data. However, it is less stable than the standard 
algorithm and it is more difficult to detect its convergence. AAR is the default algorithm for 
electron diffraction data.  
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Try one or more of the above hints and see how they affect the speed of convergence. You 
should come to the conclusion that for this simple structure there is hardly any difference 
between the options, but most of them speed up the convergence., However, combination 
AAR + local normalization is too aggressive and does not lead to the solution. 
 
Superflip offers a large number of other options, which are described in detail in the manual. 
If you want to use any of these advanced options, then: 
Check the checkbox “Allow manual editing of the command file before start:  

 
Click Run solution 
 
Before Superflip starts, the input file opens in a text editor and you may edit the file and 
include whatever additional options you wish. 
 
The price to pay for faster convergence is the increased noise in the result, and sometimes 
more difficult detection of convergence. Because the default parameters work usually quite 
well and yield the best densities, we recommend using them for first attempts. Only if the 
iteration does not converge, try modifying the parameters according to the hints described 
above. 
 
Press “Quit” to close the Structure solution tool  
Note that there is no “escape” option. The original M40 which might be present before 
starting this tool is being overwritten after each “Run solution” process and the only way 
how to retain it is to use in proper time the “Return to previous” button.  
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5. Integration of Superflip to Jana2006 
The following scheme shows how Superflip communicates with the rest of Jana2006. M95 
contains raw data; M90 is refinement reflection file (merged reflections without extinct 
reflections); M40 is structure model; M50 is basic crystal information; M80 are structure 
factors from refinement or charge flipping; M81 is density map 
 

 
*) Superflip expands M90 to P1 symmetry. However, its results are to some extent 
influenced by the symmetry set by the user with the Symmetry wizard, because M90 
contains merged reflection and systematically extinct reflections are omitted 

Data Import 
Output: M95 

Symmetry wizard 
Updates symmetry in M50 

Create refinement reflection file 
Output: M90 

Structure solution  
(Superflip calculates density, Jana interprets it) 

Run Solution 
Reads M90*) 

Writes M80, M81 
and M40 

 

Change 
formula 
Updates 

M50 

Change 
symmetry 

Refinement 
Reads M90,M40,M50 

Writes M40,M80 

Fourier Calculation 
Reads M80,M50 

Writes M81 

Contour 
Reads 

M40,M50,M81 

Draw structure 
Reads M50,M40 

Draw 3d map 
Reads M81,M40 
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Example 9.2: pArNO2 

Solving the centro-noncentro ambiguity with Superflip 
 
This relatively simple structure illustrates the advantages of using Superflip to determine the 
space group. 
 
Revised: 16 September 2014 
 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: pArNO2.hkl, pArNO2.cif_od 

1. Create new structure  
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click pArNO2 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Leave all settings unchanged; NEXT 
OK to confirm the name of the basic input file  
Leave all settings unchanged (note the cell parameters and thus the probable crystal 
system); NEXT 
Finish the import wizard with all settings default 

3. Symmetry Wizard 
[On screen: Information about the symmetry wizzard.] 
NEXT to start the wizard; 
Leave all settings default; NEXT; OK; 
[On screen: Select Laue symmetry] 
Jana2006 suggests orthorhombic symmetry based on Rint. In this case the choice appears 
clear. 
Keep the suggested selection; NEXT 
Select primitive unit cell; NEXT 
[On screen: Select space group] 
You are now offered a list of candidate space groups sorted by their likelihood. Note that 
the first two space groups Pnma and Pn21a differ only by the presence of inversion center 
and they have the same FOM: 
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Jana by default does not use the distribution of E-values to estimate, if the structure is 
centrosymmetric or not. The main reason is that the same information can be obtained 
from Superflip with higher reliability. At this point the space group choice can be made 
either randomly or based on chemical knowledge. The choice of one of the two space 
groups has no impact on the structure solution by Superflip. 
 
Select Pnma; NEXT 
Accept the space group; FINISH 
 

4. Creating refinement reflection file 
Proceed with the creation of refinement reflection file, leaving all settings default until 
you see the following screen:  

 

5. Consulting the intensity statistics 
At this point we will interrupt the standard flow of the solution process to check the E-
statistics and estimate the presence or absence of the inversion center. 
OK; Quit to escape the structure solution dialog.  
[On screen: Main window] 
First we have to define the chemical composition.The crystallized molecule has sum 
formula C42 H43 N1 O6 S4 (see the end of the exercise for the picture of the molecule), 
number of molecules per unit cell: 8. The solvent was acetonitrile – we do not know the 
number of solvent molecules per formula unit, but we may ignore the solvent contribution 
for now. 

Double click the icon EditM50  
Select the page “Composition” 
Enter “C42 H43 N O6 S4” in the first field; 
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Keep 8 for the number of formula units; OK; Yes;  
[On screen: Main window] 
Go to Run → Intensity statistics 
[On screen: Wilson plot] 
Check the Wilson plot. Click anywhere in the plot to continue; 
Yes to open the listing; 
[On screen: listing of intensity statistics] 
This listing contains a large number of statistics related to intensity normalization. We will 
focus only on the following table (found around the middle of the listing): 
 
                       Experimental                        Theoretical 
 
  Value    All data   hkl     0kl     h0l     hk0  Acentric Centric Hypercen. 
 
  mod(E)     0.801   0.804   0.779   0.499   0.867   0.886    0.798    0.718 
   E**2      1.000   1.003   1.086   0.473   1.095   1.000    1.000    1.000 
   E**3      1.690   1.694   2.131   0.630   1.773   1.329    1.596    1.916 
   E**4      3.556   3.570   5.127   0.997   3.433   2.000    3.000    4.500 
   E**5      8.781   8.832  13.989   1.728   7.628   3.323    6.383   12.260 
   E**6     24.409  24.611  41.363   3.164  18.939   6.000   15.000   37.500 
mod(E**2-1)  0.983   0.981   1.177   0.905   0.985   0.736    0.968    1.145 
(E**2-1)**2  2.556   2.565   3.955   1.051   2.244   1.000    2.000    3.500 
(E**2-1)**3 15.740  15.908  28.239   0.592  10.922   2.000    8.000   26.000 

 
This table shows the numbers typically used to estimate the centrosymmetry. If you 
compare the column All data with the theoretical values, you can see that all numbers 
indicate a centric or hypercentric distribution. Our guess Pnma thus appears to be strongly 
supported by the statistics 
Click the button “Close” to close the listing and return to the main window. 
 

6. Structure Solution 

Double click the icon Structure solution   
[On screen: window of Structure solution] 
Leave all settings default; 
Click the button “Run solution” to start Superflip 
Superflip converges smoothly and the listing of the solution procedure opens in Jana. 
[On screen: listing of Superflip] 
Locate the symmetry analysis in the listing. It should look very similar to this (rows of 
XXXX are omitted here to save space): 
 
##################################### 
# Checking the density for symmetry # 
##################################### 
 
Symmetry operations compatible with the lattice and centering: 
                       Symmetry operation             agreement factor 
        a(0,0,1):        1/2+x1           x2          -x3    0.229     
        n(1,0,0):           -x1       1/2+x2       1/2+x3    0.651     
      2_1(0,1,0):           -x1       1/2+x2          -x3    0.714     
      2_1(0,0,1):           -x1          -x2       1/2+x3   51.947     
              -1:           -x1          -x2          -x3   52.037     
        2(0,0,1):           -x1          -x2           x3   66.366     
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        m(0,1,0):            x1          -x2           x3   71.723     
      2_1(1,0,0):        1/2+x1          -x2          -x3   72.620     
        c(0,1,0):            x1          -x2       1/2+x3   72.643     
        2(0,1,0):           -x1           x2          -x3   78.403     
        m(1,0,0):           -x1           x2           x3   78.485     
        2(1,0,0):            x1          -x2          -x3   78.709     
        n(0,1,0):        1/2+x1          -x2       1/2+x3   78.768     
        m(0,0,1):            x1           x2          -x3   82.199     
        b(1,0,0):           -x1       1/2+x2           x3   82.308     
        a(0,1,0):        1/2+x1          -x2           x3   83.217     
        c(1,0,0):           -x1           x2       1/2+x3   89.079     
        n(0,0,1):        1/2+x1       1/2+x2          -x3  126.255     
        b(0,0,1):            x1       1/2+x2          -x3  131.166     
 
------------------------------------------------- 
Space group derived from the symmetry operations: 
------------------------------------------------- 
    HM symbol:     Pn21a 
    Hall symbol:   P -2ac -2n 
    Fingerprint:   33002241Y40qY3 (3/4,0,3/4) 
    Symmetry operations: 
               1:            x1           x2           x3 
        a(0,0,1):        1/2+x1           x2       1/2-x3 
        n(1,0,0):        1/2-x1       1/2+x2       1/2+x3 
      2_1(0,1,0):           -x1       1/2+x2          -x3 

 
 

Look at the table. You can see that the first three operators belonging to the Pn21a space 
group have very low agreement factors (less than 1%) indicating a very good match. All 
other operators have agreement factors above 50%, which is very poor. In particular the 
mirror plane perpendicular to b has agreement factor 71.7%. It is thus clearly absent in the 
structure. The space group is without doubt Pn21m. 

6. Insert the correct space group and solve the structure 
Although the solution by Superflip is correct, the space group in Jana is still wrong, and the 
solution is thus not usable. We have to set the correct space group and rerun Superflip. 
Close the view of the log file; 
Click “Change the space group” in the “Structure solution” form; 
Type “Pn21a” in the upper left box; OK; YES; 
As the symmetry changed, the refinement reflection file must be recreated. Create the new 
file with default settings. 
Press “Run solution” to start Superflip again with the correct symmetry; 
Superflip starts, and should again converge smoothly to a solution.  
Close the log-file viewer; 
Click “Draw 3D map”; 
View the resulting electron density and the interpreted model. The structure is correctly 
solved, but quite a few peaks have not been assigned an atom. We know the expected 
composition and we may thus use the alternative peak-interpretation option – use of an 
external program EDMA: 
Close VESTA; 
Select the radiobutton “EDMA – fixed composition”: 
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Check the checkbox “Use old solution and reinterpret it: 

 
 
Click “Run solution” to interpret the previous solution with the new setting. 
A new screen appers with the run-time information from EDMA: When EDMA finishes, a 
listing of Superflip opens.  
Close the listing and return to the structure solution dialog 
Double click “Draw 3D map” 
This time you sould see all maxima in the map occupied by an atom. Most atoms should 
have a correctly assigned atomic type, although carbon, nitrogen and oxygen may be 
occasionally swapped. 
Here is the correct molecule for reference (hydrogens omitted for clarity): 
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Example 9.3: flo19 

 
A challenging case of difficult symmetry and difficult convergence detection 
 
Revised: 18 February 2014 
 
Input files: flo19.cif, flo19.hkl. The structure is an organic molecule built by four aromatic 
rings bridged by one or two nitrogen atoms. 

1. Load the structure from CIF 
Start Jana2006; 
“File → Structure → New”; 
Locate the input files, and double click the name flo19 in the right pane; 
Select the radiobutton “Structure: from CIF”; NEXT; OK to confirm the file flo19.cif 
OK to the warning that the CIF does not contain symmetry information; 
At this moment you loaded the basic crystallographic information. You can check the 
composition and unit cell dimensions by double clicking the EditM50 icon and consulting the 
card Cell and Composition. 
 

2. Import the reflection file 
“File → Reflection file → Import/modify the reflection file” 
Select “Single crystal: reflection file corrected for LP and absorption”; NEXT; 
Check that the filename is flo19.hkl and that the file type is SHELX on I; NEXT; 
2x NEXT for the two following screens; OK; Finish; OK; YES to finish the import wizard 
 

3. Estimate the symmetry 
When the reflection import finishes, you are automatically offered the symmetry 
determination form1. 
NEXT to start the wizard; 
NEXT to confirm the default settings of the test; 
OK to the information about no higher metric symmetry; 
On the screen with Rint for different Laue groups make sure you understand Jana’s choice of 
the mmm Laue group. 
NEXT; 
On the screen with centering statistics make again sure that you understand the meaning of 
the numbers and the choice Jana2006 made. 
NEXT; 
At this moment you are presented with the list of possible space groups. The upper part of 
the list looks like this: 

                                                      
 
1. 1 If you accidentally close the wizard or if you want to repeat the test, you can access the 

symmetry determination procedure through the EditM50 icon, card Symmetry. 
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Select the space group P21221 and click “Details”; 
In the listing you can find basic information about the space group and the list of observed 
reflections that violate the rules for systematic absences. Check the details for several space 
groups. Which space groups would you consider possible and which would be the most 
likely? 
 
Because the solution in Superflip is not sensitive to the choice of the space group symmetry, 
we will choose just one of the space groups without any systematic absences to keep the 
solution unbiased. 
 
Select the space group Pmmm; NEXT; FINISH; OK; YES to finish the space group selection 
We selected the space group Pmmm not because it is the most likely choice, but because it 
does not induce any systematic absences. We will now process the reflections, and ask 
Superflip to estimate the space group. If we selected a space group with systematic 
absences, some reflections would be excluded from the reflection file, and the result from 
Superflip could be biased. 
 

4. Create refinement reflection file 
When the space group determination finishes, you are automatically offered the “Create 
refinement reflection file” tool. If you accidentally exit it, you can always return to it through 
“File → Reflection file → Create refinement reflection file” 
NEXT; OK; NEXT; OK; FINISH to create the refinement reflection file with all settings default 

7. Run Superflip. 
Next Jana offers you the dialog for structure solution. If you want to open this dialog later, 
just double click the icon “Structure solution” in the main window of Jana. 
Make sure Superflip is selected; 
Leave other settings default; Click Run solution; 
Superflip starts and runs for many thousand cycles. No convergence is detected. 
Press “Interrupt” to stop Superflip; 
The log file of Superflip opens. Check the symmetry determination part. You will see that no 
symmetry operation has agreement factor lower than 25% and thus the derived space group 
is P1. Because we expect higher symmery (although we do not know the exact space group), 
it is a sign that the calculation did not converge. 
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Inspection of the log file does not reveal any serious problem, but a series of hints shows 
that the structure can be difficult to solve. The potential problems are that the coverage 
starts dropping already at dmin≈1.1 Å, and that the coverage at low resolution is very low 
(only 21% at dmin≈ 5 Å). It can be assumed that quite a few strong reflections are missing in 
the dataset. The first change to try is to use normalized intensities. When using normalized 
intensities, Superflip also automatically treats the missing reflections in a special way that 
improves the performance in case of data with missing low-order reflections. 
Close the view of the log file; 
Check the checkbox “local normalization” 
Click “Run solution” 
 
Superflip starts and probably runs again for many thousand cycles without detecting 
convergence2. 
If you look at the evolution of the convergence indictors, you will most probably see behavior 
similar to this2,3: 
 
   20  R: 56.175  Charge:      20.84   Peaks:  1.11   Score:    --- 
   30  R: 57.537  Charge:      20.13   Peaks:  1.16   Score:    --- 
   40  R: 58.291  Charge:      19.03   Peaks:  1.15   Score:    --- 
   50  R: 58.075  Charge:      19.08   Peaks:  1.22   Score:    --- 
   60  R: 57.460  Charge:      18.65   Peaks:  1.22   Score:    --- 
   70  R: 59.161  Charge:      18.79   Peaks:  1.32   Score:    --- 
   80  R: 57.279  Charge:      18.88   Peaks:  1.33   Score:    --- 
   90  R: 59.624  Charge:      18.89   Peaks:  1.39   Score:    --- 
  100  R: 56.954  Charge:      18.29   Peaks:  1.41   Score:    --- 
  200  R: 55.838  Charge:      18.37   Peaks:  1.29   Score:   0.15 
  300  R: 57.292  Charge:      18.12   Peaks:  1.35   Score:   0.15 
  400  R: 55.889  Charge:      17.89   Peaks:  1.32   Score:   0.15 
  500  R: 55.456  Charge:      18.50   Peaks:  1.32   Score:   0.15 
  600  R: 55.902  Charge:      18.88   Peaks:  1.22   Score:   0.15 
  700  R: 53.192  Charge:      18.50   Peaks:  1.24   Score:   0.15 
  800  R: 53.102  Charge:      18.23   Peaks:  1.27   Score:   0.15 
  900  R: 50.902  Charge:      17.41   Peaks:  1.23   Score:   0.15 
 1000  R: 45.968  Charge:      18.16   Peaks:  1.19   Score:   0.15 
 2000  R: 43.139  Charge:      18.59   Peaks:  1.12   Score:   0.15 
 3000  R: 42.466  Charge:      18.12   Peaks:  1.11   Score:   0.15 
 4000  R: 43.158  Charge:      19.33   Peaks:  1.16   Score:   0.15 
 5000  R: 43.369  Charge:      18.80   Peaks:  1.11   Score:   0.15 
 6000  R: 44.689  Charge:      18.11   Peaks:  1.12   Score:   0.15 
 
Note the bold part. We can see a clear drop in R-value accompanied by no change in the 
charge and a small decrease (instead of expected increase) of the Peaks indicator. Although 
the change in R-value is clearly visible, together with the decrease in Peaks it is not enough 
to trigger automatic convergence detection. However, it is likely that the iteration 
converged.  
Press “Interrupt” to stop Superflip; 
In the log file locate the symmetry determination part.  
You will see a listing similar to this: 

                                                      
 
2 Occasionally it may detect convergence, but in most cases it does not. 
3 Rarely the calculation does not converge even after several thousand cycles. In that case interrupt Superflip and 
run it again. 
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Go carefully through the list, and make sure you understand, why Superflip suggests the 
space group P21221. Note also that the space group has nothing to do with the Pmmm space 
group used as input. This confirms that the symmetry derivation by Superflip is indeed 
independent from the input space group. 
 
Note also that the space group found by Superflip is the same as the most likely space group 
suggested by Jana2006 on the basis of systematic absences. Thus, in this case the two 
indications agree. However, the analysis of systematic absences was not conclusive, while 
the result of Superflip leaves no doubt about the correct space group. 
 

8. Insert the correct space group and solve the structure 
Although the solution by Superflip is correct, the space group in Jana is still wrong, and the 
solution is thus not usable. We have to set the correct space group and rerun Superflip. 
Close the view of the log file; 
Click “Change the space group” in the “Structure solution” form; 
Type “P21221” in the upper left box; OK; YES; 
As the symmetry changed, the refinement reflection file must be recreated. You will be 
guided through the process. Repeat it as you did in step 4 of this exercise. 
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Press “Run solution” to start Superflip again with the correct symmetry; 
Superflip starts, and should again converge smoothly to a solution. You may again need to 
interrupt the iteration, when you see the drop of the R-value. Check that the derived 
symmetry is again P21221. 
Close the log-file viewer; 
Double click “Plot structure”; Draw+continue 
In Diamond click the “Get molecules directly”  button in the bottom toolbar. The 
molecule should look like this, possibly with a few carbon and nitrogen atom types 
interchanged: 

 
Close Diamond; 
Double click the icon “Refine” 
The refinement will converge to an R-value around 10% or less depending on the number of 
incorrectly identified atoms. The structure is solved. Now the atoms must be correctly 
assigned to chemical types, and the structure refined in the standard manner. 
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Example 9.4: MnVPO 

A difficult case for symmetry determination 
 
Revised: 12 February 2014 
  
(Mn(H2O)4)(VO)2(PO4)2 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: MnVPO.m50, MnVPO.m95 
 

1. Opening the structure 
Start Jana2006 
“File → Structure → Open” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click MnVPO_start 

You opened a structure which contains crystal information about the compound and 
hkl-data. There is no structural information present yet. To preserve the original files, save 
the structure under another name: 

“File → Structure → Save as” opens a file manager 
Type “MnVPO” in the line under the right pane and press Enter 
“YES” to the question if you want to continue with the new structure 

2. Symmetry Wizard 
“File → Reflection file → Make space group test” 
Proceed with the space group test. Check the table of the Laue groups, and note Rint for Laue 
groups 4/m and 4/mmm. Continue until the screen with the title “Select space group”. You 
should see this output: 

 
 
In this case it is impossible to determine the space group only from systematic absences. 
Select the space group I4/m, NEXT, FINISH 

3. Creating refinement reflection file 
Answer YES to the question if you want to create refinement reflection file 
Leave all settings default; NEXT; OK; NEXT; OK; 
Accept the data block; FINISH 
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4. Structure Solution 
Click the icon “Structure solution” in the main window of Jana 

Make sure that the formula is H8 Mn O14 P2 V2 with Z=2 
Leave other settings default; Click the button “Run solution” 
[On the screen: listing of Superflip] 
Superflip converges rapidly. The symmetry determination part of the log-file looks like this: 

 
Superflip suggests the space group I4/mmm. This space group is incompatible with the 
detected Laue group (Check your notes with Rint of the Laue groups 4/m and 4/mmm). It is 
a supergroup of all three possible space groups suggested by the symmetry wizard. This is 
an indication that the structure is peculiar in some respect. 
 
Close listing of Superflip 
Quit the Structure solution dialog 
 
Note: Superflip suggests a different space group, but it does not use this space group to 
produce the final density. The final result has always the symmetry defined in EditM50. If 
you want to accept the symmetry suggested by Superflip, you have to change the symmetry 
and rerun Superflip to get new solution. 
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“Parameters → Atoms → Edit” 
Check that the list of atoms contains one Mn, V and P atom and three oxygens. The peak 
search sometimes does not assign all atoms at once. In practice the missing atom would be 
located among the Fourier peaks. For the purposes of this example, however, make sure the 
solution contains 6 atoms immediately to keep your files compatible with the rest of the 
exercise. If it does not, rerun Superflip again. 

5. View the structure 
Double click the icon “Plot structure”; Answer NO to question about Fourier peaks; 
In Diamond click the button for filling one unit cell  and for filling coordination spheres 

; 
You should get a view similar to this: 

 

The structure looks correct. To convince yourself that the cations have correct coordinations, 
rotate the structure and increase the accepted V-O bond length to 2 (“Build → 
Connectivity”). Try to understand, why Superflip suggested a wrong space group before you 
go to the next page and read the solution. 
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The reason Superlip gets confused by this structure is the strong pseudosymmetry. All atoms 
except for one oxygen (the in-plane oxygen coordinated to Mn) obey the I4/mmm symmetry. 
The contribution of the oxygen to the total density is not sufficiently strong to indicate the 
deviation from the higher symmetry. 

If you look closely at the list of symmetry operators and their agreement factors, you will see 
indeed that the symmetry operators of the space group I4/m are all at the beginning of the 
list with the lowest agreement factors. But the difference in agreement factors between the 
true opeators and the remaining operators of the I4/mmm space group is too small to be 
detected by the program. 

6. Refine the structure 

Run Refine by double clicking the icon Refine 
Refinement should immediately converge to an R-value around 5% 
“Parameters → Atoms → Edit → Select all → Action → Edit/Define atoms → harmonic” 
Change the type of displacement parameters of all atoms from isotropic to harmonic 
Run Refine again 
Refinement should converge to an R-value around 3.8% 
 
This exercise demonstrates that the best approach to determining the space group is to 
combine the information from diffraction pattern and the symmetry determination of 
Superflip. In most cases the two approaches yield the same result. If the results differ, the 
structure or data usually exhibit some non-standard features. It can be a strong 
pseudosymmetry (as in this example), problem in the evaluation of systematic absences, or 
twinning. The two approaches are complementary, and have different weaknesses. Their 
combination gives the best result. 

7. Additional exercises 

a) Try to solve and refine the structure in I4/mmm. Apart from the high Rint, would you be 
able to recognize that something is wrong with the structure model? What R-value do 
you get? 

b) For training purposes you can try to finish off the structure – check for the presence of 
hydrogen atoms, define them and refine. 
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Example 9.5: 8rings 

Very large structure – use of non-random starting point in Superflip 
 
Revised: 12 February 2014 
 
Input files: 8rings.hkl, 8rings.p4p. This is a huge organometallic structure with three eight-
membered and one three-membered ring containing chromium, nickel, iron and cobalt. Cell 
volume 67312 Å3. 
 
Refrence: G. F. S. Whitehead, F. Moro, G. A. Timco, W. Wernsdorfer, S. J. Teat and R. E. P. 
Winpenny, Angewandte Chemie International Edition, 2013, 52, 9932-9935. 

1. Load the data 
Start Jana2006; 
“File → Structure → New”; 
Locate the input files, and double click on the green name 8rings in the right pane; 
Select the radiobutton “known diffractometer formats”; NEXT;  
Select the format Bruker-CCD; OK 
OK to skip the warning about incomplete information; 
Continue with the data import wizard, leaving all setting default, until the screen with the 
information about the symmetry wizard 
At this moment you loaded the basic crystallographic information and intensity data. 
 

2. Determine the symmetry  
When the reflection import finishes, you are automatically offered the symmetry 
determination form. If you accidentally close this card, you can access the same functions 
through the EditM50 icon, card Symmetry. 
NEXT to start the wizard; 
NEXT to confirm the default settings of the test; 
OK to the information about no higher metric symmetry; 
On the screen with Rint for different Laue groups make sure you understand Jana’s choice 
for the 6/m Laue group. 
NEXT; 
On the screen with centering statistics make again sure that you understand the meaning of 
the numbers and the choice Jana2006 made. 
NEXT; 
At this moment you are presented with the list of possible space groups. Based on the 
analysis of systematic absences Jana suggests the space group P65. You may click the 
button “Details” to get a detailed listing with the absent reflections. In this case there is little 
doubt that the correct space group is indeed P61/P65. 

 
3. Create refinement reflection file  

Now you will filter and merge the raw reflection ata to produce the final reflection file ready 
for solution and then refinement. In this case all settings can be left default: 
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Answer YES to the question if you want to create refinement reflection file 
Leave all settings default; NEXT; OK; NEXT; OK; 
Accept the data block; FINISH 
 

4. Structure Solution 
As the next step the wizard suggests starting the structure solution. When you accept the 
suggestion, a form with options for structure solution opens. 
 

This is a large structure, and normalizing the intensities is most likely necessary. 
Check the checkbox “Use local normalization”. 
 
It is also necessary to give some composition. It is not used for solution but for interpretation. It 
is sufficient to enter just a list of present atoms. Iron, cobalt and nickel will most probably be 
indistinguishable in the solution, but we may enter them anyway, so that we do not have to add 
them later during the refinement process. The same holds for hydrogen. 
In the files Composition enter “Cr Fe Co Ni C H F N O” 
Leave other settings default. 
Click “Run solution” 
 
Superflip starts and tries to solve the structure with default options for the charge flipping 
algorithm. You may let the iteration run for a few hundred cycles and you will see that there are 
no signs of convergence in the three indicators (R-value, total charge and peakiness).  
There is still a chance that the structure is solved – sometimes the convergence is just not 
visible. We will interrupt the iteration and check the result.  
In the window of Jana click the button “Interrupt” 
 
Superflip finishes the calculation and the log-file opens in the main window of Jana. Check the 
symmetry analysis. The final part will look like this: 
------------------------------------------------- 
Space group derived from the symmetry operations: 
------------------------------------------------- 
    HM symbol:     P1 
    Hall symbol:   P 1 
    Fingerprint:   33001041a0 (0,0,0) 
    Symmetry operations: 
               1:            x1           x2           x3 
 
It is most unlikely that the structure really has symmetry P1. Together with the lack of indicators 
of convergence this means that the structure is not solved. 
 
The structure contains moderately heavy atoms. It is thus sensible to start the iteration with 
Patterson superposition map instead of the random map. 
Click the button “Close” in the upper row to close the viewer of the log file; 
In the selection list labeled “Starting model” select the radiobutton “Patterson superposition 
map”: 

  
Run the solution again 
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Typically the iteration converges within a few hundred cycles. The space group determination 
part of the log file looks like this: 
------------------------------------------------- 
Space group derived from the symmetry operations: 
------------------------------------------------- 
    HM symbol:     P61 
    Hall symbol:   P 61 
    Fingerprint:   3300163Xx01 (0,0,0) 
    Symmetry operations: 
               1:            x1           x2           x3 
     6+_1(0,0,1):         x1-x2           x1       1/6+x3 
     3+_1(0,0,1):           -x2        x1-x2       1/3+x3 
      2_1(0,0,1):           -x1          -x2       1/2+x3 
     3-_2(0,0,1):        -x1+x2          -x1       2/3+x3 
     6-_5(0,0,1):            x2       -x1+x2       5/6+x3 

 
This time the solution has the correct symmetry and it is a strong indication that the structure is 
solved. 
Close the log-file viewer; 
Wait until Jana performs the peak search (be patient, it is a large structure…) 
Click the button “Draw 3D map” to view the resulting electron density 
The density and the interpreted model are shown overlaid in VESTA. The structure is large and it 
is not easy to understand the density. Nevertheless, after a while it becomes clear that the 
structure is correctly solved and the main expected motifs are well visible. It is also visible that 
some of the peaks present in the electron density were not interpreted as atoms by the peak-
seaching routine. These peaks are saved as “Fourier maxima” in Jana and you may change them 
to regular atoms when you go to Parameters → Atoms → New → Peaks from the last Fourier 
calculation. To see which maxima are interesting, we will plot the strongest peaks together with 
the structure: 
 
Close VESTA; 
Click the button “Draw structure”; 
In the next dialog click “Add Fourier peaks”; 
A dialog with a long list of maxima opens. First about 100 maxima are deselected, because they 
represent existing atoms. Then a large number of maxima are selected (typed in red).  
OK to include all maxima; 
 
The structure-plotting program (typically Diamond) opens and you may view the structure.The 
added maxima are shown as the lightest element from the element list. In this case it is 
hydrogen. You can see that a large number of these maxima are just artifacts close to the heavy 
atoms, but among the added maxima you can also find most of the missing atoms. This 
illustrates the fact that often the raw solution – the electron density – is more complete and 
informative than the structure interpretation, and it is worth checking the electron density after 
the solution, if the interpreted structure appears incomplete or otherwise wrong. 
 
Here is for reference the image of the two chemically different entities found in the structure: 
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The three-ring with mixed iron-cobalt sites: 

 
 
The eight-ring with chromium and nickel: 
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Example 10.1: AgSbS 

Refinement of anharmonic ADPs in Jana2006. 
 

Chemical formula: Ag3SbS3 
Reference: F. Laufek, J. Sejkora & M. Dušek (2010). Journal of Geosciences, 55, 161–167 
 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: agsbs.hkl, agsbs.cif_od 
Frame scaling, absorption correction: done with software of diffractometer 
 
In this example we shall need installation of VESTA for visualization of electron density 
associated with anharmonic ADP. VESTA is supplied as a zip archive which can be unpacked to 
arbitrary location (with simple path – not to Desktop). Then the path to VESTA.exe must be 
defined in “Parameters → Programs”. 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate the directory with input files 
Right pane: double-click agsbs 
Right pane detects possible Jana files and shows one jobname for each group of files 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
Select “Input from “cif_od” file”; OK 
The used diffractometer software splits reflection file and another information (cell 
parameters, wavelength …). There are several output formats for both cases. 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
The program reads 11948 reflections from hkl file 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data RepositoryOK;  
Each line in data repository window corresponds to one data set converted to Jana format. 
In our case we use only one data set. 
OK; YES to accept the data set 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Symmetry wizard can be started separately by “File → Reflection file → Make space group 
test. 
Leave all settings default; NEXT 
[On the screen: Select Laue symmetry] 
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Select Trigonal -3m1 Laue symmetry; NEXT 
Select R-obverse cell; NEXT 
[On the screen: Select space group] 
Select R3c; NEXT 
Selecting the non-centrosymmetric space group is a shortcut. It will be explained at 
“Verification of structure solution”. 
Accept the space group transformed into the original cell; FINISH 
Symmetry is saved in file agsbs.M50. 

5. Creating refinement reflection file 
In this step program creates file agsbs.M90 containing the data set merged by symmetry 
and with discarded forbidden reflections. M90 will be used for refinement. 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
The program reports Rint 1.88% for 430 observed reflections merged from 3577 observed 
reflections. 
Accept the new data block and calculate coverage; FINISH 

6. Structure Solution Wizard 
[On the screen: window of Structure solution]. 
In “Formula” textbox type list of chemical elements: Ag Sb S 
Select “Use Superflip”, “Peaks from Jana2006”; 
Select “Use a specific random seed” and use “222” 
Fixing the random seed to 222 guarantees for most processors that the Superflip returns 
exactly the same results like described in this cookbook. Otherwise each run of Superflip may 
return different equivalent origin. For normal work random seed should be automatic 
because the convergence of charge flipping is not guaranteed for every value of random 
seed. 
Leave other settings default; OK 
[On the screen: window of Superflip replaced after reaching the convergence with listing of 
Superflip] 
Superflip converges (after noise suppression) with R value (after noise suppression) 16%. 
Press CLOSE to leave the listing 
Press “Accept the result” 

7. Verification of the structure solution 
Start EditM50, go to page Composition, enter 6 for “Formula units”, press “Formula from 
M40” 
It displays formula Ag3 Sb S3 (for Z=6). This is the same as expected composition. 
[On the screen: Information about formula] 
OK; YES for updating the formula. 
In next steps we shall verify with Superflip that centre of symmetry is not present. 
Start “File → Structure → Save As” 
Save the structure with jobname “testspg” 
YES to continue with the new structure 
Start “Run → Solution” 
Select “Use Superflip” and press button “Change the space group” 
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For the “Space group” type R-3c; OK; YES to rewrite M50 
Follow steps for creating the refinement reflection file 
Merging the data yields Rint 2.11% and the program returns to the structure solution wizard 
[On the screen: Structure solution wizard] 
OK to start structure solution 
[On the screen: listing of Superflip] 
At the end of the listing we can see unsatisfactory agreement factor for the symmetry 
operator “2”. This indicates the space group is probably wrong. 
Press “Accept the result” 
Start EditM50, go to page Composition, enter 6 for “Formula units”, press “Formula from 
M40” 
It displays formula Ag0 Sb S6 (for Z=6) which is also wrong 
Return to the basic window of Jana2006 
Start “File → Structure → History” and open the previous structure (with space group R3c) 

8. Refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: refinement options] 
Define 100 of cycles, damping factor 0.5; OK 
Choose “YES+START” 
Refinement converges with R value about 12% 
Start “Edit atoms” 
[On the screen: list of atoms] 
Press “Select all” and “Action → Edit/define” 
Choose “harmonic” for ADP parameters. This defines anisotropic temperature parameters 
for all atoms. OK, OK, Yes to save changes 
Double-click the icon Refine. 
Refinement converges with R value about 4%. 

9. Extinction correction 
The results seem to be OK, but: 
[On the screen: basic window of Jana2006] 
Open listing of Refine (by “Edit/View → View of Refine”) 
Press “Go to” and select “Statistics Fo, sin(th)/lambda after refinement” 
R value should decrease with increasing intensity or with lowering the diffraction angle. 
Here the R value for the strongest reflections as well as for the low angle reflections is higher 
than in the previous shell. This suggests that extinction correction is required. 
Close the refinement listing 
“Parameters → Extinction” 
Select “Isotropic”; OK 
Refinement of extinction coefficient is enabled by default 
Double-click Refine and refine the final structure 
Refinement converges with R factor 3.67 %. 
Check the extinction coefficient through “Parameters → Extinction” 
View listing of Refine; Go to “Statistics”; check improved R value for strongest reflections. 



592 Jana2006 Cookbook, version September 2019 
 
 

10. Anharmonic refinement 
Run Contour, start “New plot” – “Calculate new ones” +” Draw maps as calculated”. 
Here no previous map exists and therefore “Calculate new ones” will be disabled 
[On the screen: Fourier commands] 
In Basic thumbnail select “F(obs)-F(calc) – difference Fourier”; leave other settings default 
In Scope thumbnail define the vicinity of Ag1 according to the following screenshot; OK 

 
 
[On the screen: contour plot of the first section] 
In “Contours” define both positive and negative contours to 0.1 e-/Å3; 
In “Atoms edit” add Ag1; 
Examine the sections using "M+" and "M-" 
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We can see residua of positive density in the vicinity of the Ag atom. 
 
Quit Contour 
 
Run “Edit atoms” and select Ag1. 
“Action → Edit/define atoms”: check “Anharmonic ADP”, third order; 
Run Refine 
Refinement converges with R factor 1.14 %. 
In Contour draw the same difference Fourier section as previous (calculate new maps). Use 
the same limits for contours. 
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The residua have significantly decreased. 
 

11. Density modeling using the joint probability density function 
Run Contour, start “New plot” – select j.p.d.f. 
[On the screen: Select atoms and basic parameters for j.p.d.f] 
Select Ag1 and S1; Next 
[On the screen: Plane/Volume] 
For 1st atom use Ag1; for the 2nd and 3rd atom use difference to 1st 1 0 0 and 0 1 0, 
respectively; 
Define scope of the section: 6 6 6 and “1st point to” 3 4 2.5; 
Use cutoff distance for atoms 4 Å; NEXT 
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[On the screen: Select individual atoms for j.p.d.f] 
Select Ag1, and all symmetry related sulphur atoms close to Ag1 and note their symmetry 
codes (i.g. S1#s5c3t0,-1,-1); NEXT 
 

 
 
In “Atoms Edit” of Contour define the Ag1 atom and all four S1 atoms using their symmetry 
codes. 
Press “Run 3d maps” 
Jana2006 will call an external program for drawing isosurfaces, previously defined in 
“Tools → Programs”, in our case VESTA 
Setting drawing options: 
In “Edit → Bonds” define bond between Ag and S; maximal distance 3.15 Å, 
In “Objects → Structural model” select “Stick”, 
In “Properties” check “Do not show unit cell”. 
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The application of non-harmonic parameters led to the triangular shape of the electron 
density centered in Ag1 position. The electron density is extended in directions between of 
Ag-S bonds. 
 

12. Drawing one particle potential curve 
Sulphur and Silver form spirals defined by short Ag-S bonds. The possible exchange paths for 
silver atoms within and between the spirals can be tested with help of one particle potential 
along a proposed path. One of proposed paths is shown in the following figure where it goes 
along sides of the indicated triangle: 
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Run Contour, start “New plot” – select j.p.d.f. 
[On the screen: Select atoms and basic parameters for j.p.d.f] 
Select Ag1; Next 
[On the screen: Plane/Volume] 
Define the displayed volume according to the following screenshot; OK 
 

 
 
 
Select Ag1#s3c2, Ag1#s5c3t0,-1,0 and Ag1; NEXT 
 

 
 
 
In “Curves” “Use mouse to define polyline” and draw the line Ag1(a)—P—Ag1(b)—P—Ag1(c)—
P—Ag1(a) by mouse (2nd mouse button quits the selection). You can also fill in these points 
directly in the textboxes of the “Curves” dialogue. Fractional coordinates of the point P are 
approximately 0.267 -0.63 0.235. Ag atoms should be written with corresponding symmetry 
codes, i.e. Ag1#s3c2. 
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In the first plot we can see an electron density curve. The maximal electron density is located in 
Ag1 atoms. 

 
Press “Continue” 
Adjust “y-Scale”: Min and Max in meV: 0 600; 

 
The resulting curve is one particle potential path. The peaks represent the potential barrier 
between Ag1 atoms when the exchange path runs through the point P. These values suggest 
that the silver transfer within and between neighboring Ag–S–Ag spirals is possible. 
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Example 10.2: Oxa 
 
multipole refinement 
 
X-ray data from an oxalic acid sample measured at 110K to a high resolution limit. The crystal 
contains also crystal water: C2O4H2.2H2O 
 
Input files: oxa.m40, oxa.m50, oxa.m90 and oxa.m95 – Jana files from a conventional 
refinement 

14. Drawing density map based on the regular refinement 
[On the screen: Basic Jana window] 
Start Jana2006 
“File → Structure → Open”: open structure “oxa” 
This is result of conventional structure refinement 
Run refinement 
Refinement converges in 1 cycle to R(obs)=2.74% 
[On the screen: Basic Jana window] 
Double-click the icon Contour; Press the button “New plot” 
Select “Draw a general section”; OK; 
[On the screen: Fourier commands] 
In “Basic” page for “Map type” select “F(obs) – Fourier” 
clear “Omit non-matching reflections” 
select “Use weighting of reflections” 
clear “Apply sin(th)/lambda limit” 
In “Scope” page select “automatically”, “Independent parallelepiped” and “Use default map 
orientation” 
Change the step to 0.05 Å 
OK 
[On the screen: Plane/Volume] 
This form defines the general section to be drawn from the calculated map. 
Define: 1st atom C1; 2nd atom C1#s3; 3rd atom O1 
#s3 encodes symmetry operation (the third one in the list in EditM50) 
Set the “Interpolation step” to 0.05 Å, “Scope of section” 6 6 0; 1st point to 2 3 0 
OK; 
After calculation the density section through oxalic acid molecule will appear: 
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Atomic positions can be included into the map by clicking the pointer at different locations 
and selecting atoms close to the given location. The following atomic position should be 
selected: C1, O1, H1, O2, C1#s3, O1#s3, H1#s3; O2#s3. 

 
 
Quit; Save it as Plane#1; OK 
[On the screen: Basic Jana window] 
Now we shall visualize the difference map. 
Double-click the icon Contour; Press the button: ”New plot” 
Select “Calculate new ones” and “Draw a general section”; OK; 
[On the screen: Fourier commands] 
In “Basic” page for “Map type” select “F(obs)-F(calc) – difference Fourier” 
Keep all remaining settings unchanged; OK; 
[On the screen: Plane/Volume] 
Select “Use old”; OK 
[On the screen: Difference Fourier map through the oxalic acid] 
Press the button “Atoms ON” 
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Press the button “Contours” to see contour interval. The value should be about 0.05 e-/Å3. 
The positive density clouds are in vicinities of possible bonds. This indicates that the 
multipole model can reflect real charge densities in this crystal. 
Quit Contour 

15. Kappa refinement 
[On the screen: Basic Jana window] 
We shall keep backup copy of the conventional refinement. Refinement will now continue 
with new job name. 
Start “File → Structure → Save As” 
Save structure as “Oxa-Kappa” 
Continue with the new structure 
[On the screen: Basic Jana window] 
Double-click the icon EditM50 
In page “Composition” define multipoles “MOLLY”; 
In page “Multipole parameters” define orbital populations; for O and C atoms keep the 
default values; for H atom select “Slater form factor” with the default values for H-N and 
H-Dzeta; 
OK; YES to rewrite M50 
[On the screen: Basic Jana window] 
Double click the icon “Edit atoms”; 
Select all atoms; Choose “Action → Edit/define” or double click on the selected atoms; 
[On the screen: Atom edit] 
In the column “Multipole parameters” select “kappa”; OK; OK; 
Yes to rewrite the changed files 
[On the screen: Basic Jana window] 
Right click on the icon “Refine”; 
In the “Various” page press “Equations” and define the following equations: 
pv[H3]=pv[H2] 
kappa[H2]=kappa[H1] 
kappa[H3]=kappa[H1] 
OK; OK; Yes+start 
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Refinement converges to R(obs)=2.69% 
The kappa refinement made only small improvement. This is in accordance with the 
difference Fourier map in which strong asphericity has been visible. 

16. Distance and angular restrains for H atom 
Way how hydrogen atoms are described is a delicate point for charge density refinement. 
Generally hydrogen electron can be related to any reference point. In order to have 
reasonable deformation maps it is worthwhile to fix the reference positions of hydrogen 
atoms close to its ideal values. For the oxalic acid we can use the distance and angular 
restrains to values refined against neutron diffraction data. For distance H1-O1 this value is 
1.07 Å with angle H1-O1-C1 113o and for O3-H2 and O3-H3 0.97 Å with angle H2-O3-H3 
about 106o. 
[On the screen: Basic Jana window] 
Right click on the icon “Refine”; 
In the page “Various” define the following “Distance restrains”: 
O1 H1; Value 1.07; s.u. 0.001; 
O3 H2; Value 0.97; s.u. 0.001; 
O3 H3; Value 0.97; s.u. 0.001; 
OK; 
In the page “Various” define the following “Angle restrains”: 
H1 O1 C1; Value 113; s.u. 0.01; 
H2 O3 H3; Value 106; s.u. 0.01; 
OK 
In the page ”Various” define the following “Keep commands”: 
ADP; Riding; Central O1; Extension 1.2; One hydrogen: H1; 
ADP; Riding; Central O3; Extension 1.2; Two hydrogens: H2, H3; 
OK; Yes+start; 
Use all to “significant discrepancies”; 
Refinement converges to R(obs)=2.74% 

17. Multipole refinement 
 
For defining of multipole parameters it is convenient to select a local coordinate systems for 
each atom. The following figure shows a recommended choice for atoms C1, O1, O2 and H1: 
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The axis x is oriented along the bond from the central atom to one of non-hydrogen atoms 
(here called "first atom"). Our choice of “first atom” for central atoms C1, O1, O2 and H1 is 
O2, C1, C1 and O1, respectively. According to the definition in Jana2006, the second axis 
(here y) is perpendicular to the axis x and it lies in the plane defined by the central, first and 
second atom in such a way that the angle between the axis y and vector from the central 
atom to the second one is smaller than 90o. Our choice of “second atom” for central atoms 
C1, O1, O2 and H1 is O1, O2, C1 and C1, respectively. Note that second atoms need not 
make bonds with the central atom. 
The similar choice can also be used for the molecule of crystal water. 
[On the screen: Basic Jana window] 
In order to save the result of the kappa refinement a new structure will be opened: 
Start “File → Structure → Save As” 
[On the screen: File manager for saving structure] 
In File manager focus the right-bottom textbox and define a new name for testing of the 
kappa refinement i.e. “Oxa-Multipole”; OK 
Yes to continue with the new structure 
[On the screen: Basic Jana window] 
Run “Edit atoms”; 
Double click the first atom – C1; switch from “kappa” to “order” 
Change multipole parameters to order 3 and define the coordinate system x → O2 and 
y → O1. 

 
Using the list box on the top left corner go to the next atom – O1. 
Change multipole parameters to order 3 and define the coordinate system x → C1 and 
y → O2. Go to the next atom – O2. 
Change multipole parameters to order 3 and define the coordinate system x → C1 and 
y → O1. Go to the next atom – O3. 
Change multipole parameters to order 3 and define the coordinate system x → H2 and 
y → H3. Go to the next atom – H1. 
Change multipole parameters to order 1 and define the coordinate system x → O1 and 
y → C1. Go to the next atom – H2. 
Change multipole parameters to order 1 and define the coordinate system x → O3 and 
y → H3. Go to the next atom – H3. 
Change multipole parameters to order 1 and define the coordinate system x → O3 and 
y → H2. 
OK; OK; Yes to the question “Do you want rewrite changed files?” 
[On the screen: Basic Jana window] 
Right click on the icon “Refine”; 
In the page “Basic” select the number of cycles 100 and damping factor 0.1; 
In the page “Various” press “Fixed commands” and fix the following parameters: 
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“Set individual”, P00[*], “Set to” 0; 
“Individual”, kappa'[*]; 
[*] stands for all atoms. P000 wil be zero for all atoms while kappa’ will be fixed to the 
current value. 
OK; OK; YES+Start 
Refinement converges to R(obs)=1.75%. 

18. Multipole refinement including kappa' parameters 
[On the screen: Basic Jana window] 
Right click on the icon “Refine”; 
In the “Various” fix the following parameters: 
Delete or disable “Individual”, kappa'[*]; 
In the “Equation” define two equations for H atoms; 
kappa'[H2]=kappa'[H1] 
kappa'[H3]=kappa'[H1] 
OK; OK; Yes+start; 
Refinement converges to R(obs)=1.69%. 
It may happen that at this point R value is higher, around 1.75%. That means water 
molecule is in a false minimum. In such case: change number of multipoles for O3, H2 and 
H3 to zero; fix kappa’; repeat refinement; change number of multipoles back to 3,1,1 (for 
O3, H2, H3); repeat refinement; release kappa’, repeat refinement 

19. Fourier maps 
[On the screen: Basic Jana window] 
Double-click the icon Contour; Press the button “New plot” 
Select “Calculate new map” and “Draw a general section”;OK; 
[On the screen: Fourier commands] 
In “Basic” use default setting i.e. Map type F(obs)-F(calc) – difference Fourier; 
Keep all remaining parameters unchanged; OK; 
[On the screen: Plane/Volume] 
Select “Use old”;OK 
[On the screen: Difference Fourier map through the oxalic acid] 
Press the button “Atoms ON”. 
Press the button “Contours” and modify the positive and negative contours to 0.05 e-/Å3 

 
The map does not show any clear positive or negative maxima which means that the model 
explain the experimental density adequately. 
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20. Interpretation of multipole parameters – map visualization 
[On the screen: Basic Jana window] 
Double-click the icon Contour; Instead of “Fourier maps” select ”Charge density maps”;OK 
[On the screen: Define atoms and basic parameters for charge density maps] 
Select all atoms; Calculate “deformation density”;NEXT; 
[On the screen: Plane/Volume] 
Select “Use old”; NEXT 
[On the screen: Select individual atoms for charge density] 
Select all atoms; NEXT 
Press the button “Atoms ON”; 
After a short calculation the following map should appear. 

 
 

21. Topological analysis – critical points 
[On the screen: Basic Jana window] 
Run “Tools → Topological analysis → Find critical points” 
[On the screen: Define parametrs for CP search] 
Select “Type of search” “between all bonds within interval”; 
For all other parameters keep in default values; 
OK; 
[On the screen: Select atoms for distance check] 
Select all; OK 
[On the screen: Basic Jana window] 
Run “Edit/View → View of CP report”; 
[On the screen: Viewer for critical points] 
The listing contain information about critical point along all important bonds in the 
molecule. 
 

Bond 
Fractional coordinates 

ρ Laplacian Hess eigenvalues Ellipsity 
x y z 
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C1-C1[-x,-y,-
z] 0.0000 0.0000 0.0000 1.77 -13.55 

-
13.59 

-
11.04 

11.08 0.23 

C1-O1 0.0011 0.0187 0.0875 2.50 -31.96 
-

22.99 
-

20.38 
11.41 0.13 

C1-O2 -
0.1076 

0.1228 0.0465 2.97 -36.60 
-

30.34 
-

25.97 
19.71 0.17 

O1-H1 0.0331 
-

0.0015 
0.2065 1.62 -22.14 

-
22.47 

-
22.34 

22.66 0.01 

O3…H1 0.0041 0.0592 0.2493 0.54 5.16 -3.86 -3.36 12.38 0.15 
O3-H2 0.0499 0.1790 0.3755 2.21 -49.22 

-
36.74 

-
35.88 

23.40 0.02 

O3-H3 -
0.1228 

-
0.0092 

0.3421 2.30 -61.79 
-

43.69 
-

42.49 
24.39 0.03 

22. Topological analysis – Basin integration 
[On the screen: Basic Jana window] 
Run “Tools → Topological analysis → Basin integration” 
[On the screen: Select atoms for basic integration] 
Select all; OK 
[On the screen: Define parameters for integration] 
Use default values; OK 
Calculation can take some time … 
Run “Edit/View → View of Inb report”; 
The integrated values for individual atoms should be: 
 

Atom 
Number of 
electrons 

Charge 

C1 5.147 0.853 
O1 9.124 -1.124 
O2 8.773 -0.773 
O3 9.378 -1.378 
H1 0.396 0.604 
H2 0.407 0.593 
H3 0.419 0.581 
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Example 11.1: bezcox 
Composite structure 
 

Sr1.272CoO3 
Revised: 28 April 2014 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: bezcox.hkl, bezcox.cif_od 
Frame scaling, absorption correction: done by diffractometer software 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click bezcox 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction – CCD”; NEXT 
[On the screen: “Define basic input file:"] 
Select “Input from cif_od file”; file name “bezcox.cif_od”; OK 
[On the screen: “Complete/Correct experimental parameters”] 
Leave all settings unchanged; NEXT 
[On the screen: “Define the reference cell/split by twinning”] 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
OK; YES to accept the data set 
[On the screen: “Information about starting symmetry wizard”] 
NEXT 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Symmetry wizard can be started separately by “File → Reflection file → Make space group 
test”. 
Leave all settings default; NEXT 
[On the screen: Select Laue symmetry] 
Select Trigonal -3m1 Laue symmetry; NEXT 
[On the screen: Select cell centering] 
In the list we can see that R-reverse centering is almost fulfilled. 
Click on “Details” and examine strongest reflections contradicting R-reverse centering 
The most of printed reflections follow the rule -h+k+l=3n. Similarly, reflections contradicting 
R-obverse centering follow the rule h-k+l=3n. This can be a sign of obverse/reverse twinning. 
Return back to the page with tolerances and check there “Introduce twin laws in case of 
subgroup”  
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Follow steps of the symmetry wizard, select -3m1 Laue symmetry, NEXT 
Now, only 128 reflections contradicts the R (obverse or reverse) centering 
Select R-reverse; NEXT 
Before introducing the twinning, R-reverse centering was better fulfilled. This indicates that 
the major twin domain has R-reverse centering.  
Select R-3m; NEXT 
[On the screen: Select superspace group] 
R-3m(00g)0s 
[On the screen: Final step of the superspace test] 
Accept the superspace group in the standard setting: R-3m(00g)0s;  
Accept twinning matrices induced by the space group test; FINISH; OK 
Continue with creation of reflection file with default options; 
[On the screen: Structure solution] 
Press “Quit”; 

5.  Define W-matrix 
Using Tools → Reciprocal space viewer we can clearly distinguish the composite subsystems. 
This compound has the simplest W matrix, which only exchanges the “l” and “m” index. 
Than means that “h k l m” are reflections of the first subsystem while “h k m l” are 
reflections of the second subsystem.  
Open “Edit M50”, change number of composite parts to 2 and define W-matrix for the 
second subsystem: (1 0 0 0 | 0 1 0 0 | 0 0 0 1 | 0 0 1 0 ) 

 
“Induced cell paramemeters” are parameters of the second subsystem, as follow from the W 
matrix 

6. Structure Solution 
Double-click the icon “Structure solution”. 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for Sr1.272CoO3 : Sr Co O 
Select “use Superflip”; “Peaks from Jana2006 but first run Fourier” 
Select “Use a specific random seed” and type value “111” 
Press “Run solution”; 
The option “Peak from Jana2006 but first run Fourier” in necessary for proper interpretation 
of Fourier map for composite structure because we need to look for bot subsystems 
Superflip converges (after noise suppression) with R value 20%. It confirms the symmetry  
R-3m(00g)0s. 
Fixing the random seed to 111 guarantees for most processors that the Superflip returns 
exactly the same results like described in this cookbook. For this example finding proper 
solution would require many attempts with Superflip. 
Press “Quit” to leave the structure solution wizard 

7. Verification of the structure solution 
Double click on the icon “Edit atoms”; 
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Select oxygen atoms if present and delete them; 
At this stage found oxygen positions are not reliable; 
Double click on the Co1 atom and check its coordinates; 
Co1             0.333333 0.666667 0.166667  - in the first subsystem 
Move to the Co2 atom; 
Co2 0.000000 0.333333 0.250000 – in the second subsystem 
The solution program cannot distinguish at this stage between chemical types of heavy 
atoms because both atoms are placed in different subsystem and we cannot compare their 
electron densities directly.  
OK;OK; Yes to save the changes;  
 
Double click on the icon “Contour”;  
Press “New plot”; Select “Calculate new ones” and “Draw maps as calculated”; OK; 
[On the screen: window of Fourier commands]  
On the page “Basic” define Composite part no. 1;  
Map type “F(obs) – Fourier”; 
On the page “Scope” select the central point Co1;  select the x3-x4 section; scope 1 1 2; OK 
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Repeat the procedure for Co2;  

                   
  
             x3-x4 section for Co1              x3-x4 section for Co2 

Note: Both maps are summed over x1 and x2. 
Press “New plot”; Select “Calculate new ones” and “Draw maps as calculated”; OK; 
[On the screen: window of Fourier commands]  
On the page “Basic” define Composite part no. 2; 
Repeat map calculations for both atoms. 
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            x3-x4 section for Co1          x3-x4 section for Co2 

Start “Parameters → Twin fractions” and change the twin fraction to 0.5 
Activate refinement of twin fraction 
In Refinement options change number of cycles to 100 
Run refinement 
Refinement converges with R values 34%, 24%, 41%, 58%, 67% and 97% 
Start “Edit/View → View of Refine” and read information following the header “Composite 
part #2”. 
Here we can see unit cell and symmetry of the second composite subsystem. Note that the 
second subsystem has also different centering because centering vectors are also 
transformed by W matrix. 
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Double click on the icon “Edit atoms”; Double click on the atom Co2;  
The “Edit” page shows that the parameter Uiso is negative. It indicates that atom type is Sr.  
Go the “Define” page and change the atom type to Sr and rename it to Sr1;  
Run refinement 
Refinement converges with R values 32%,21%, 40%, 58%, 70% and 97% and the isotropic 
ADP parameters become positive. 

8. Making results compatible with Acta Cryst. (1999), B55, 841-848 
Start “Tools → Transformation → Origin shift” and move origin to the position of Co1. 
Position of Sr1 changes to -1/3, -1/3, 1/4. 
Start Edit atoms, select Sr1, Action: Transform selected atoms 
Select symmetry operator –x2 x1-x2 x3 x4 
Run Refinement 
R factors of the previous refinement are exactly repeated 
Now we are compatible with published positions of Co1 and Sr1. 

9. Oxygen 
Run refinement to obtain input for Fourier 
Run difference Fourier for composite part No 1, with Scope=”automatically”, default map 
orientation, independent parallelepiped 
We use composite part 1, because we expect oxygen belonging to Co coordination 
YES to start procedure for including atoms 
Locate the strongest maximum with reasonable distance to Co (probably Max2) 
Include this maximum as O1 in position about 0.17, 0.04, 0.5 
Start Contour and plot section x3-x4 through O1, scope 1 1 2, difference Fourier, using 
summation of x1, x2 over 1 Å; 
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                                                      section x3-x4 of O1 
 
The section reveals O1 should be described with crenel function, x40=0.75, delta=0.5 
 
Plot section x1-x2, difference Fourier, x4 from 0 to 1, scope 5 5 0, step 0.5A, center 0 0 0.5 
The section x1-x2 with center at (0,0,1/2) with scope about 5 Å as a function x4 shows the 
character of the modulation 

                                  
 
 
 : 
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Run “Movie” to see the discontinuous character of the modulation. 
The three oxygen positions are generated by the three fold axis. From the above figure on 
epossibility for oxygen position is about (0.157,0.157,0.5) (as indicated by the arrow) with 
crenel of length 0.5 with x4 center 0.25. 
Start Edit atoms and double-click O1  
Define the crenel function for O1 and delete its position modulation wave 
In page Edit press Occupancy and set x40=0.25 and delta=0.5 (page “Edit”).  
In page Edit modify the atomic position of O1 to the one found in the difference Fourier and 
reset size occupancy (it should be 0.5).  
Finally in the page “Define” define type of modulation functions – Legendre polynomials. 
Run refinement 
Refinement converges with R values 26%,13%, 36%, 58%, 66% and 88% 
Set harmonic ADP for all atoms 
Repeat refinement 
R values are almost unchanged 

10. More modulation waves 
Add one by one more position and ADP modulation waves. 
Co: 4 for position, 4 for ADP 
O1: 4 for position, 2 for ADP 
Sr1: 4 for position, 4 for ADP 
The last refinement will converge with R values 4.3%,2.5%, 4.2%, 9.2%, 21.5% and 59% 
With fourth order satellites it is doubtful if we could achieve better results because they are 
almost completely unobserved. However, the fit for 2nd and 3rd order satellites is not yet 
satisfactory 

11. Sawtooth for Sr1 
Start Contour and plot x3-x4 section (observed and difference Fourier) for Co1, O1 and x2-
x4 section for Sr1. Use 1 Å summation. Do not forget to switch composite subsystem in the 
Basic page of Fourier commands. 
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x3-x4 section for Co1   difference section, contour step 0.2 

  
x3-x4 section for O1   difference section, contour step 0.2 
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x2-x4 section for Sr1 difference section, contour step 0.2 

The largest different peaks are around Sr1 position. Now we shall attempt to describe 
modulation function of Sr1 with Lagrange polynomials, with crenel defined at x40=0 with 
delta=1 
 
Make backup copy (File → Structure → Save As) 
Start Edit atoms 
Remove all ADP and position modulation waves of Sr1 except the first position modulation 
wave; 
Activate in the Crenel for Sr1 and the the edit page set x40=0 and delta=1. Keep x40 and 
delta fixed 
In the page “Define” Parameters activate Legendre polynomials  
In refinement commands set Damping factor 0.1 
Run refinement 
During the refinement change Damping factor to 0.5 
Refinement converges with R values 10.3%, 4.0%, 9.3%, 37.7%, 46% and 53% 
Add one by one position and ADP modulation waves for Sr1 up to three position waves and 
three ADP waves. 
The last refinement will converge with R values 3.7%, 1.9%, 3.6%, 8.2%, 18.7% and 55%. This 
is significant improvement comparing with the structure model without sawtooth function. 

 

Anharmonic ADP for Co1 
 
“Start Contour → New plot → Calculate new ones” 
In Basic page select Difference Fourier and Composite part no. 1 
In Scope select central point Co1, section x1-x2, scope 6 6 1 
OK 
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In Contour make summation only along x3 (not x4) 
 

 
 

 
x1-x2 section through Co1, contour step 0.05, x4=0 
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 x1-x2 section through Co1, contour step 0.05, x4=0.26 
 
The neighborhood of Co1 is changing from octahedron to trigonal prisma (check it with 
drawing program). The trigonal coordination induces a slightly triangular shape of ADP. 
 
However, the region in x4 in which the effect is detectable is very narrow and the number of 
modulation waves for ADP’s of the order 3 would be very large to describe such abrupt 
change. 
 
The atom Co1 should therefore be split into two positions by crenel – the first one Co1 
(x40=0, delta=0.45) and the second one Co1’ (x40=0.25, delta 0.05). After adjusting of 
occupancies to  ai=1/6 for both atoms the two Legendre waves for position and harmonic 
ADP Co1 should be used. 
 
For the Co1’ only average parameters for position and ADP up to the third order. 
 
Final R values : 3.2%, 1.8%, 3.0%, 7.3%, 13.9% and 55%     
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Example 12.1: Ba5Co5 

Simple antiferromagnetic magnetic structure (k = 0) 
Revised: 6 May 2019 
 

Ba5Co5ClO13 
 

Powder data measured with the ILL neutron source at 1.4 K 
For more details: Mentré, O., Kauffmann, M., Ehora, G., Daviero-Minaud, S., Abraham F. & 
Roussel, P. (2008). Solid State Sciences 10, 471-475. 
 

Input files:  Ba5Co5.dat (powder profile data) 
Ba5Co5_nuclear.cif (nuclear structure) 
 

In order to facilitate the work with magnetic structures, Jana2006 offers special wizards and 
protects the basic file - the parent structure. However, for experienced users of Jana, all 
operations offered by wizards can be also done manually by starting the tools directly from the 
basic user interface. The standard work with magnetic structures based on powder data follows 
this scheme: 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Reading of powder profile and parent structure model 

Wizard for le Bail refinement of powder profile parameters 
Leaving this wizard automatically fixes all profile parameters except 

the background 

Wizard for Rietveld refinement of the parent structure 
Leaving this wizard automatically locks the parent structure in order 

to prevent its accidental refinement 

Wizard for selection of the magnetic symmetry 

Magnetic structure refinement using the selected  magnetic symmetry 
This runs under different jobname in order to keep the parent structure 
unchanged. Each magnetic symmetry should be tested under a unique 

jobname.  

Loading the parent structure for testing another magnetic 
symmetry 
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23. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click Ba5Co5 
[On the screen: Specify type of the file to be imported] 
Select “Magnetic parent structure: nuclear model from CIF”; NEXT 
[On the screen: Select input CIF file] 
Right pane: select (by the button with arrow) the input file Ba5Co5_nuclear.cif; OK 

24. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
For Number of non-zero magnetic propagation vectors select 0 
For “Atom type” select “Co”; check “Use as a magnetic atom” 
For “Magnetic formfactor <j0>” select Co4+; NEXT; Finish 
The parent structure has been created 

25. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Powder data - Various CW formats”; NEXT 
Check that the name of the input file is “Ba5Co5.dat” and the format is “Free format of 2th, 
I, [sig(I)]”; NEXT 
[On the screen: Complete/correct experimental parameters]; 
For “Wave length” type 2.52; NEXT; Finish 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 

Refining of profile parameters by le Bail technique. 
[On the screen: Information] 
NEXT; 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
As common for powder neutron data the background is strongly varying with the diffraction 
angle. It is recommended to estimate it manually and use just a few additional parameters. 
Manual background: “Create new”; Use default parameters; OK 
The automatic procedure has created a first estimation of the manual background, which 
can be modified manually: the points can be dragged by the left mouse button; dragging a 
point to the position of neighboring point deletes the point; clicking between two points 
creates a new point. 
Using "X+", "Y+", enlarge the profile plot 
Modify background point at high and low angles as indicated in the next figures: 
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“QUIT”; Select “Accept the new manual background” and “Reset polynomial coefficients to 
zeros”; OK 
This means that the polynomial background will be refined and combined with the manual 
background 
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“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Cell” activate refinement of a and c parameters; 
In the page “Profile” check if starting value of GW is 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter; OK; YES to save changes 
“Run Refine”; 
The refinement should converge to Rp~2.7%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” change activate refinement of GU and GV; OK; YES to save changes 
“Run Refine”; 
The refinement should converge to Rp~2.1%. 
"Show powder profile" to see the fit of the calculated profile; QUIT 
NEXT; 
YES to “Do you really want to leave the form for le Bail refinement?” 
Now we will refine the scale parameter for the nuclear structure 
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands; 
Check that the fixed commands “fixed all *” is present if not select “All parameters” and fill 
into the editing window “Atoms/parameters” by the wild character “*” which means all 
atoms   
Press "Add";  
The command will appear in the panel as “fixed all *” 
OK; OK; 
“Run Refine”; 
The refinement should converge to Rp~3.4%. 
NEXT; 
YES to “Do you really want to leave the form for Rietveld refinement?” 
NEXT to accept the Information 

26. Testing different irreps to get the best single irrep model 
[On the screen: Representation analysis] 
This window has an informative character. You can see here all irreps leading to magnetic 
ordering. The “details” buttons provide more information about an individual irrep and its 
connection to the kernel magnetic symmetry. 
Press “Display representations” and look at the representation “mGM5-”. 
Individual 2x2 representation matrices of each of 24 operations:  
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Close the window; NEXT; 
[On the screen: List of kernels and epikernels] 
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Select e.g. magnetic group Cmcm’ and press “Show details”. 

 
 
It shows symmetry operators of the selected magnetic group, transformation to the 
standard setting and the relevant order parameter.  
 
Close; 
Select one of the hexagonal magnetic space groups; NEXT 
This will pass all present hexagonal magnetic space groups to further testing. 
[On the screen: Select Shubnikov space group] 
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For an individual Shubnikov space group the tool shows components of the magnetic vector 
of all magnetic atoms in the structure. The button “Show details” gives a more detailed 
analysis. In our case only two Shubnikov space groups – P63/mm'c' and P63' /m'm'c – allow 
magnetic ordering for all Co atoms. Note that for the first of them the global magnetic 
moment for is generally non-zero, which means that this arrangement allows a 
ferromagnetic ordering. As ferromagnetism has not been detected for this compound, the 
first model can be excluded from the analysis. However, we shall test both models to check if 
such a decision can also be based on the diffraction experiment.  
 
Select the Shubnikov space group P63/mm'c' and press “Start profile simulation”. Use "Go 
to 2th/hkl" textbox and find position of the reflection  2 -1 3 . Click on the tick 
corresponding to the reflection 2 -1 3: 
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Although the peak is clearly visible, the calculated structure factor is zero. 
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ESC; Press “Quit” and the select Shubnikov space groups P63'/m'm'c and investigate again 
the reflection 2 -1 3:  

 

However, in making such conclusion we have to take into account that the simulation 
procedure uses randomly generated magnetic moments and that the result can be affected 
by an actual random choice. This is why we recommend repeating the simulation when 
some doubt exists. 
 
For this Shubnikov space group the intensity of (2,-1,3) is non-zero in accordance with the 
diffraction pattern. As this reflection is systematically absent for the nuclear structure (c 
glide plane), it is clear that it originates from magnetic scattering. As apparent from the 
Shubnikov space group test, all magnetic moments are directed along the z-axis. This leads 
to the systematic extinctions 12 += nl  for reflections ( )lhhh ,,,2 −−  but only in the case that 
the glide plane ”c” is combined with the time inversion operation. The fact that the peak 
(2,-1,3) is clearly detectable gives us another support for the Shubnikov space group 
P63'/m'm'c. 
 
Select again the Shubnikov space group P63/mm'c' and press “Start graphic simulation”; 
Select “Use Vesta to draw the magnetic structure”;  
Press "Draw+return" or "Draw+continue"; 
In the case that bond between atoms are created go to “Edit→Bonds…” and delete all 
automatically generated bond limits  
If necessary, you can modify the length of the displayed vectors by “Edit→Vectors…”   
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You can see that in this case the magnetic moments, which are in the simulation chosen 
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identical for the independent magnetic atoms, are not compensated in the unit cell. 
 
 

Repeat this procedure for P63'/m'm'c 
 

 
27. Refinement of the magnetic structure in P63/mm'c'(GM2+) 

[On the screen: Select Shubnikov space group] 
Select the Shubnikov space group P63/mm'c' and press the button “Continue with the 
selected Shubnikov space group”; 
Finish; YES to the question “Do you want to continue with the last kernel/epikernel?”; 
[On the screen: Select structure name] 
Use the default name "Ba5Co5_01"; OK 
The test will be done under the new job name in order to keep the parent structure 
unchanged. The program will open another Jana window, which can be used to refine the 
selected model. The Jana window with the parent structure remains active.    
[On the screen: Basic window] 
Right-click the icon of Refine and select the page “Various”. 
Click “Fixed commands” and make sure the coordinates of all atoms are fixed:  

 
Click “Restrictions” and make sure ADP parameters all atoms are restricted to be the same: 

  
The “Fixed commands” and “Restrictions” are created automatically by the program when 
preparing the testing structure.  
OK; select the page "Basic" 
Check if the “Number of cycles” is 100 and the “Damping factor” is 0.1; 
“Use Marquart technique” check that the Fudge factor is 0.001;  
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OK; Start refinement; 
Refinement converges with Rp~3.3%, R(obs)~8.5%. 

28. Refinement of the magnetic structure in P63'/m'm'c (GM4+) 
Return the Jana window with the parent structure.  
[On the screen: Select Shubnikov space group] 
Select P63'/m'm'c and press the button “Continue with the selected Shubnikov space 
group”; 
[On the screen: Select structure name] 
Use the default name; OK 
The program will open another Jana window which can be used to refine the selected model. 
The Jana window with the parent structure remains active. 
[On the screen: Basic window] 
Right-click the icon of Refine and select the page “Various”. 
Click “Fixed commands” and make sure the coordinates of all atoms are fixed:  

 
Click “Restrictions” and make sure ADP parameters all atoms are restricted to be the same: 

  
OK; select the page "Basic" 
Check that the “Number of cycles” is 100 and the “Damping factor” is 0.1;  
“Use Marquart technique” check that the Fudge factor is 0.001; 
OK; Start refinement; 
Refinement converges with Rp~3.0%, R(obs)~6.3, 6.5, 2.3 % for all, nuclear and magnetic 
reflections, respectively.  

29. Drawing of the magnetic structure 
[On the screen: Basic window] 
Double click on the icon “Plot structure”; 
Press "Draw+return" or "Draw+continue"; 
Select “Objects→Structural models” and choose “Polyhedral” 
Select “Edit→Bonds”; Delete bonds Ba O and Ba Cl; Apply; OK; 
Select “Objects→Properties→Polyhedra”;  
Choose new polyhedral style and reduce the opacity to 50:  
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The magnetic moments of atoms Co4 and Co5 are negligible. The atom Co6 is tetrahedrally 
coordinated by O atoms while the others have octahedral coordination. 
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Example 12.2: Ba6Co6 
Commensurate magnetic structure – modulation (propagation) vector (0,0,1/2) 
Revised: 5 May 2019 
 

Ba6Co6ClO16 
 

Powder data measured with the ILL neutron source at 1.4 K 
 
For more details: Mentré, O., Kauffmann, M., Ehora, G., Daviero-Minaud, S., Abraham F. & 
Roussel, P. (2008). Solid State Sciences 10, 471-475. 
 
Input files:  Ba6Co6.dat (powder profile data) 

Ba6Co6_nuclear.cif (nuclear structure) 

30. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click Ba6Co6 

31. Import Wizard 
Select “Magnetic: nuclear model from CIF”; NEXT 
Right pane: select the input file Ba6Co6_nuclear.cif; OK 

32. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Check “Use non-zero magnetic propagation vector” and fill its value: 0 0 1/2 
Select atom type Co; check “Use as a magnetic atom”; select “Magnetic formfactor <j0>” 
Co4+; NEXT; FINISH 
The parent structure is created 

33. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Various CW format”; NEXT; 
Check that the name of the input file is “Ba6Co6.dat” and the data format is “Free format of 
2th, I, [sig(I)]”; NEXT 
[On the screen: Complete/correct experimental parameters]; 
Fill used wavelength 2.394; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 

34. Refining of profile parameters by the le Bail technique. 
[On the screen: Information] 
NEXT 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
Although the background is often strongly varying with the diffraction angle for powder 
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neutron data,  in this case it is relatively smooth and it can be described without introducing 
a manual background. 
“Quit”; “Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Cell” activate refinement of a and c parameters; 
In the page “Profile” change the starting value of GW to 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter; for background  enlarge 
the number of used Legendre polynomials to 10 
OK; YES to save the changes 
“Edit refinement commands”; In the page “Basic” change the number of cycles to 100; OK 
“Run Refine”; 
The refinement should converge to Rp~9.3%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” change activate refinement of GU and GV 
Change the peak-shape function to pseudo-Voigt and activate refinement LY 
OK; YES to save the changes 
“Run Refine” 
The refinement should converge to Rp~5.5%. 
NEXT; YES to leave the form for le Bail refinement 

35. Refinement of the scale parameter for the nuclear structure 
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands”; 
Fix all parameters for all atoms (wild character *); “Add”; OK; OK 
“Run Refine” 
The refinement should converge to Rp=9.7%, R(obs)=6.5% 
NEXT; YES to leave the for for Rietveld refinement 

 

36. Testing different irreps to get the best single irrep model 
[On the screen: Information] 
NEXT 
[On the screen: Representation analysis] 
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This window has an informative character and shows all irreps leading to magnetic ordering. 
The “Details” buttons provides more information about an individual irrep. There are four 
highest symmetrical hexagonal Shubnikov space groups; two of them differ only in the origin 
position, but this may lead to different solutions in commensurate cases. 
NEXT 
[On screen: List of kernels and epikernels] 
 

      
 
 
Select one of the hexagonal Shubnikov groups; NEXT 
This will pass all present hexagonal Shubnikov groups to further testing. 
[On the screen: Select Shubnikov space group] 
 

          
 
Only the second and the fourth Shubnikov group allows for non-zero magnetic moments for 
the Co atoms.  
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Select the Shubnikov group: P[c]-6c2 
Press “Start profile simulation”;  
Press "X exactly" and focus the region 18-40 degrees; Press “Fit Y”: 
 

 
 
Press “Quit” and repeat this procedure for the next magnetic Shubnikov group P[c]-6c2 with 
origin shifted by  (0,0,1/4): 

 
At this stage none of them can be excluded. 

37. Refinement of the magnetic structure – P[c]-6c2 
[On the screen: Select Shubnikov space group] 
Select the Shubnikov space group P[c]-6c2 and press the button “Continue with the selected 
Shubnikov space group”; 
[On the screen: Select structure name] 
Use the default name; OK 
[On the screen: Basic window of Jana2006] 
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Right-click the icon of Refine and select the page “Various” 
Use the button “Restrictions” and ensure that all atoms (i.e. *) have been restricted to have 
identical ADP parameters. 
The restriction “restric * 12” has been set automatically when the program created the 
testing structure. To see the meaning of the restriction focus it by mouse and press “Load”.  
“Load” opens the restriction for editing. Make sure that "Coordinates" and "Modulations" 
boxes are cleared and press “Rewrite” to close the editing mode.  
OK 
Select the page “Fixed commands” and (similarly like in the previous step) ensure that all 
atomic positions are fixed in their current values (“fixed xyz *”).  
OK 
Select the page “Basic” and check if the “Number of cycles” is 100 and the “Damping factor” 
is 0.1; OK; Start refinement 
Refinement converges with Rp~8.8%, R(obs)~ 6.5%, 6.5%, 6.5% for all, nuclear and magnetic 
reflections, respectively. 
 

38. Drawing the resulting magnetic structure 
[On the screen: Basic window] 
Double click on the icon “Plot structure” 
Select “Use Vesta to draw the magnetic structure” 
Press "Draw+return" or "Draw+continue" 
Select “Objects→Structural models” and choose “Polyhedral” 
Select “Edit→Bonds”; Delete bonds Ba-O, Ba-Cl and O-O; Apply;OK; 
Select “Objecs→Properties→Polyhedra”;  
Choose new polyhedral style and reduce the opacity to 50:  
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39. Refinement of the magnetic structure – P[c]-6c2 origin shifted by (0,0,1/4)  
Return to the Jana window with the parent structure.  
[On the screen: Select Shubnikov space group] 
Select P[c]-6c2+(0,0,1/4) and press the button “Continue with the selected Shubnikov space 
group”; 
YES to the question “Do you want to continue with the last kernel/epikernel?”; 
[On the screen: Select structure name] 
Use the default name; OK 
[On the screen: The following transformation can bring the structure to the standard 
setting] 
NO to refuse the suggested origin shift 
[On the screen: Basic window] 
Right-click the icon of Refine and select the page “Various”.  
Similarly like in the previous test ensure (under “Restrictions”) that all atoms are restricted 
to have identical ADP and ensure (under “Fixed commands”) that coordinates of all atoms 
are fixed.  
Select  the page "Basic" and check that the "Number of cycles" is 100 and the "Damping 
factor" is 0.1; OK; Start refinement; 
Refinement converges with Rp~8.9%, R(obs)~ 6.6%, 6.5%, 7.7% for all, nuclear and magnetic 
reflections, respectively. 
 

40. Comparing of two different results 
[On screen: Basic window] 
Double click on the icon “Plot structure”; 
Select “Use Vesta to draw the magnetic structure”; OK 
Press "Draw+return" or "Draw+continue" 
In VESTA select “Objects→Structural models” and choose “Polyhedral” 
Select “Edit→Bonds”; Delete bonds Ba-O, Ba-Cl and O-O; Apply;OK; 
Select “Objecs→Properties→Polyhedra”;  
Choose new polyhedral style and reduce the opacity to 50; 
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The models are very different. In the first model the only significant magnetic moment was 
localized at the tetrahedrally coordinated Co atom, while in the second one the significantly 
non-zero magnetic moment was localized at the octahedrally coordinated site.  
 
The first structure model has better R values. Moreover, the presence of magnetic moments 
at the tetrahedral site corresponds to the result in Example 12.1  
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Example 12.3: PrSrMnO 
Commensurate magnetic structure – modulation (propagation) vector (1,0,0) 
Revised: 28 November 2014 
 

Powder data measured the ILL neutron source at 10 K 

For more details: K. Knížek, J. Hejtmánek, and Z. Jirák, C. Martin, M. Hervieu, and B. Raveau, 
G. André and F. Bourée, Chemistry of Materials, (2004), 1104-1110. 
 
Input files:  PrSrMnO.dat (powder profile data) 

PrSrMnO_nuclear.cif (nuclear structure) 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click PrSrMnO 

2. Import Wizard 
Select “Magnetic: nuclear model from CIF”; NEXT 
[On the screen: Select input CIF file] 
Right pane: select the input file PrSrMnO_basic.cif; OK 

3. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Check “Use non-zero magnetic propagation vector” and fill its value: 1 0 0 
For “Atom type” select “Mn”; check “Use as a magnetic atom” 
For “Magnetic formfactor <j0>” select Mn3+; NEXT; FINISH 
The parent structure is created 

4. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Various CW format”; NEXT 
Check that the name of the input file is “PrSrMnO.dat” and the format is “ILL D1A/D2B 
(Rietveld-Hewat format)”; NEXT 
[On the screen: Complete/correct experimental parameters]; 
For “Wave length” type 1.227; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 

5. Refining of profile parameters by le Bail technique. 
[On the screen: Information] 
NEXT; 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
The background is relatively smooth and it can be described without introducing manual 
background. 
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“Quit”; 
“Edit profile parameters”; 
[On the screen: Powder options] 
In page “Cell” activate refinement of a, b and c parameters; 
In the page “Profile” change the starting value of GW to 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter and change the number 
of used Legendre polynomials to 10 
OK; YES to rewrite the changes 
“Edit refinement command”; In the page “Basic” change the number of cycles to 20 
OK; “Run Refine”; 
The refinement should end with Rp~7.8%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” activate refinement of GU and GV; Change the peak-shape function to 
pseudo-Voigt and activate refinement of LY; OK; YES to the question about rewriting; 
“Run Refine” 
The refinement should converge to Rp~5.9%. 
“Show powder profile”; Select the region 2θ from 7 to 22 degs – use the button “X exactly”. 
 

  
 
The first peak has a strong asymmetry. For neutron and synchrotron cases, such asymmetry 
can be described by the correction for divergence as introduced by Finger-Cox-Jephcoat, J. 
Appl. Cryst. (1994). 27, 892-900. 
“Quit” 
“Edit profile parameters” 
[On the screen: Powder options] 
In the page “Asymmetry” select “correction by divergence” 
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Activate refinement of HpS/L and HmS /L keeping their default values 
OK; YES to save changes 
“Run Refine”; 
The refinement should end with Rp~4.7%. 
“Show powder profile”; Select the region 2θ from about 7 to 22 degs. 
 

 
 
The correction considerably improved the profile 
“Quit”; NEXT; YES to leave the form for le Bail refinement 

6. Refinement of the scale parameter for the nuclear structure 
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands”; 
Fix all parameters for all atoms (“*” for “Atoms/Parameters” textbox ); “Add”; OK; OK; 
The command will appear in the panel as “fixed all *” 
“Run Refine” 
The refinement should converge to Rp~11.6%, R(obs)~3.6%. 
NEXT; YES to leave the form for Rietvel refinement 

Testing different irreps to get the best single irrep model 
[On the screen: Information] 
NEXT 
[On the screen: Representation analysis] 
This window has an information character. You can see here all irreps leading to non-
paramagnetic ordering. The “details” buttons provide more information about an individual 
irrep and its connection to the kernel magnetic symmetry. 
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NEXT 
[On the screen: List of kernels and epikernels] 
 

  
 
NEXT 
[On the screen: Select Shubnikov space group] 
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This form shows that only for Shubnikov space group № 2, № 4, № 6 and № 8 allows non-
zero magnetic moment for the Mn1 atom.In the following we shall test all four possibilities.     
Pr1 Sr1 

7. Refinement in the Shubnikov space group C[B]cce  (№ 2 in the list) 
[On the screen: Select Shubnikov space group] 
Select the second line in the left panel; FINISH 
YES to the question “Do you want to continue with the last kernel/epikernel”; 
[On screen: Select structure name] 
Use the default name i.e. PrSrMnO_01; OK 
After selection of the actual Shubnikov group you can use either the cell and origin selection 
as follows from the setting of the parent structure or you can apply transformation to get a 
standard setting.  
NO to the question “Do you want to apply this transformation?”. 
Right click on the icon “Refine”; Select the “Basic” and change the “Number of cycles” to 
100 and the “Damping factor” to 0.1; 
Select the page “Various” and use the button “Restrictions” 
Check that all atoms are restricted to have identical ADP parameters and not restricted 
occupancies; 
Restrict atoms Pr1 and Sr1, occupying the same position in the nuclear structure: identical 
Coordinates ADP parameters and “keep overall sum” for occupancies; Add;  
 

 
 
OK; “Yes+start”; 
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Refinement converges with Rp~10.1%, R(obs)~3.7%. 
This refinement is very unstable. 
 
Double click on the icon “Plot structure” and select Vesta to draw the structure: 
 

                      

 
Use “Tools → Powder → Profile viewer” and check fit of the calculated powder profile: 
 

 
 
The model cannot explain the peak at (1,0,0) 
“Quit” 
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1Sr1 
 

8. Refinement in the Shubnikov superspace group C[B]mcm with the origin shift (0,1/4,1/4) 
(№ 4 in the list) 
[On screen: Basic window] 
“File → Structure → History” and select the parent structure PrSrMnO; OK; 
[On screen: Basic window] 
“Tools → Special tools → Representation analysis for magnetic structures”; 
[On screen: Representation analysis] 
NEXT; NEXT; Select the fourth Shubnikov superspace group “C[B]mcm+(0,1/4,1/4)”; FINISH 
YES to the question “Do you want to continue with the last kernel/epikernel?”; 
[On screen: Select structure name] 
Use the default name i.e. PrSrMnO_02; OK 
No to the question “Do you want to apply this transformation”. 
Right click on the icon “Refine”; Select the “Basic” and change the “Number of cycles” to 
100 and the “Damping factor” to 0.1; 
Select the page “Various” and use the button “Restrictions” 
Check that all atoms are restricted to have identical ADP parameters and not restricted 
occupancies; 
Restrict atoms Pr1 and Sr1, occupying the same position in the nuclear structure: identical 
Coordinates ADP parameters and “keep overall sum” for occupancies; Add;  
OK; OK; “Yes+start”; 
Refinement converges with Rp~6.0%, R(obs)~3.2%. 
Double click on the icon “Plot structure” and select Vesta to draw the structure:: 
 

           

 
 
Use “Tools → Powder → Profile” viewer and check fit of the calculated powder profile: 
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The profile fit is very good. 
 

9. Refinement in the Shubnikov superspace group C[B]mcm with the origin shift (0,1/4,1/4) 
(№ 6 in the list) 
The symbol in the table is the same as for the № 4 but both epikernels are generally 
different. Compare details for both. The first one has in the original setting the symbol 
A[C]mma and the second one A[C]mam. Both give the same symbol when transformed to 
the standard setting.  
Make the same steps and calculation as in the previous test.  
 
Rp~8.1%, R(obs)~ 3.9%. 
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10. Refinement in the Shubnikov superspace group C[B]mme+(0,1/4,1/4) (№ 8 in the list) 
Make the same calculation for the last Shubnikov superspace group with sin wave (Line 
eight in “Select Shubnikov space group” dialogue). 
 
Rp~11.5%, R(obs)~ 3.1%. 
 
This refinement is very unstable. 
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Example 12.4: MnWO4 

Incommensurate magnetic structure 
Revised: 28 November 2014 
  

Powder data measured the ILL neutron source at 10 K 

For more details: L. Meddar, M. Josse, P. Deniard, C. La, G. Andre, F. Damay, V. Petříček, S. 
Jobic, M.H. Whangbo, M. Maglione & C. Payen: Effect of Nonmagnetic Substituents Mg and Zn 
on the Phase Competitionin the Multiferroic Antiferromagnet MnWO4 
Chemistry of Materials, 21, (2009), 5203-5214. 
 
Input files:  MnWO4.dat (powder profile data) 

MnWO4_nuclear.cif (nuclear structure) 

1. Creating new jobname 
Start Jana2006 
“File →  Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click MnWO4 

2. Import Wizard 
Select “Magnetic: nuclear model from CIF”, NEXT 
Right pane: select the input file MnWO4_nuclear.cif 

3. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Check “Use non-zero magnetic propagation vector” and fill its value: -0.209 0.5 0.453 
Select atom type Mn; check “Use as a magnetic atom”; select “Magnetic form factor <j0>” 
Mn2+; NEXT; FINISH 
The parent structure is created 

4. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Various CW format”; NEXT; 
Check that the name of the input file is “MnWO4.dat” and the data format is “Free format 
of 2th, I, [sig(I)]”; NEXT 
[On the screen: Complete/correct experimental parameters]; 
Fill used wavelength 2.4226; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 

5. Refining of profile parameters by the le Bail technique. 
[On the screen: Information] 
NEXT 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
The background is relatively smooth and it can be described without introducing manual 
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background. 
“Quit”; “Edit profile parameters”; 
[On the screen: Powder options] 
In page “Cell” activate refinement of a, b, c parameters and beta angle; 
Activate refinement of component q1 and q3 of the modulation vector. The q2 component 
is fixed for planar monoclinic superspace groups to 0.5;   
Check that the maximal satellite index is set to 1; 
In the page “Profile” change the starting value of GW to 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter and enlarge the number 
of used Legendre polynomials to 20 
OK; YES to save the changes 
“Edit refinement commands”; In the page “Basic” change the number of cycles to 100 and 
the damping factor to 0.5; OK 
“Run Refine”; 
The refinement should converge to Rp~5.2%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” change activate refinement of GU and GV 
Change the peak-shape function to pseudo-Voigt and activate refinement LY 
OK; YES to save the changes 
“Run Refine” 
The refinement should converge to Rp~3.4%. 
NEXT; YES to leave the form for le Bail refinement 

6. Refinement of the scale parameter for the nuclear structure  
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands”; 
Fix all parameters for all atoms (wild character *); “Add”; OK; OK 
“Run Refine” 
The refinement should converge to Rp=12.8%, R(obs)=5.5%. 
NEXT; YES to leave the form for Rietveld refinement  

7. Testing different irreps to get the best single irrep model 
[On the screen: Information] 
NEXT 
[On the screen: Representation analysis] 
This window has an information character. You can see here all irreps leading to non-
paramagnetic ordering. The “details” buttons provide more information about an individual 
irrep and its connection to the kernel magnetic symmetry. 
 

 
 
NEXT 
[On the screen: List of kernels and epikernels] 
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NEXT 
[On the screen: Select Shubnikov superspace group] 
 

 

 
Notice that for both SSG’s there are non-zero amplitudes for sine and cosine waves. 
However only three amplitudes are independent as can be found from “Details”: 

 

     
The cosine amplitudes have generally non-zero values but they are related with the sine 
amplitudes. However the coefficients are functions of y coordinate of the Mn1 atom, which 
means that these restrictions are non-linear. Later we shall see how these restrictions can be 
simplified.  
In this case, both possibilities yield similar diffraction patterns and we cannot decide at this 
stage which solution makes a better fit. 
 

Note: The presence of a rational non-zero modulation vector component qy = 0.5 leads to a 
specific problem of the origin selection. While for the space group cP 2 the c glide planes 
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located at y=0 and y=1/2 are equivalent, in the SSG ( ) scP 00211.2 γα′ they are not. In 
this SSG the first glide plane is connected with zero shift along the internal space while the 
second one with 1/2 shift. This means that the origin selection used for the starting structure 
model solved and refined from the main reflections, must be reconsidered for solution of 
modulated structure. Here two models shifted by 1/2 in y must be tested. Another possibility 
is to use non-standard SSG symbol ( ) sscP 0211.2 γα′ , which would generate reverse 
order of c glide planes. The second method is used in this example.         

                    

8. Refinement in the first Shubnikov superspace group – P2/c.1'(a1/2g)00s 
[On the screen: Select Shubnikov space group] 
Select the first line in the left panel; FINISH 
YES to the question “Do you want to continue with the last kernel/epikernel”; 
[On screen: Select structure name] 
Use the default name i.e. MnWO4_01; OK 
Right click on the icon “Refine”; Select the page “Basic” and change the “Number of cycles” 
to 100 and the “Damping factor” to 0.1; 
Select the page “Various”. Use the button “Restrictions”. All atoms are restricted to have  
identical ADP parameters; 
Restrict atoms Zn1 and Mn1, occupying the same position in the nuclear structure: identical 
Coordinates + Modulations + ADP parameters and “keep overall sum” for occupancies 
Use button “Fixed commands” and fix all coordinates and delete or disable fixing of ADP’s 
(if present).    
OK; OK; “Yes+start”; 
The refinement should end with Rp~4.9% and Bragg R factors R(obs)=5.3%, 2.9% and 9.1% 
for all, main and satellite reflections, respectively.    
Use “Tools → Powder → Profile” viewer and check fit of the calculated powder profile and 
focus to the interval (38.5,47):  
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Quit 
 

9. Refinement in the second Shubnikov superspace group – P2/c.1'(a1/2g)0ss 
[On the screen: Basic window] 
“File → Structure → History” and select the parent structure MnWO4; OK; 
[On screen: Basic window] 
“Tools → Special tools → Representation analysis for magnetic structures”; 
Continue with representation analysis; OK; 
[On the screen: Representation analysis] 
NEXT; NEXT; Select P2/c.1’(a1/2g)0ss; FINISH; 
YES to the question “Do you want to continue with the last kernel/epikernel?”; 
[On the screen: Select structure name] 
Use the default name; OK 
[On the screen: Basic window] 
Right click on the icon “Refine”; Select the “Basic” and change the “Number of cycles” to 
100 and the “Damping factor” to 0.1; 
Select the page “Various”. Use the button “Restrictions”. All atoms are restricted to have  
identical ADP parameters; 
Restrict atoms Zn1 and Mn1, occupying the same position in the nuclear structure: identical 
Coordinates + Modulations + ADP parameters and “keep overall sum” for occupancies 
Use button “Fixed commands” and fix all coordinates and delete or disable fixing of ADP’s 
(if present).    
OK; OK; “Yes+start”; 
The refinement should end with Rp~4.3% and Bragg R factors R(obs)=3.8%, 2.3% and 5.5% 
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for all, main and satellite reflections, respectively.    
Use “Tools → Powder → Profile” viewer and check fit of the calculated powder and focus to 
the interval (38.5,47): 
 

 
The second solution gives significantly better profile fit and also better Bragg R values.  
Quit 

10. Transforming the final solution to the supercentered cell.    
[On the screen: Basic window] 
“Tools→Transformation→Transform to the X-centered cell”;  
Create new structure e.g. “MnWO4_02_X”; 
YES to the question “Do you want to continue with the new structure?”; 

11. Refinement in the supercentered setting 
[On the screen: Basic window] 
Run EditM50, go to “Symmetry”; Check the new SSG symbol; "X" stands for the 
supercentered setting. For more details about centering vectors expand the list of centering 
symbols at “cell centering” and re-select the symbol X 
The generated supercell centering (0,1/2,0,1/2) is in accordance with the values from 
“findSSG” (except that the  monoclinic axis is now "b") 
ESC; ESC; 
Right click on the icon “Refine”; Select the “Basic” and change the “Number of cycles” to 
100 and the “Damping factor” to 0.1; 
Select the page “Various”; Use the button “Restrictions” and restrict all atoms to have 
identical ADP parameters and not restricted occupancies; Add; 
Restrict atoms Zn1 and Mn1, occupying the same position in the nuclear structure: identical 
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Coordinates + Modulation + ADP parameters and “keep overall sum” for occupancies;  
Add; OK  
Use button “Fixed commands” and fix coordinates for all atoms, i.e. *.    
OK; OK; “Yes+start”; 
The refinement should finish with Rp~5.0% and Bragg R factors R(obs)=4.3%, 3.0% and 6.4% 
for all, main and satellite reflections, respectively.  
YES to the question “Open the listing”; Check the symmetry restrictions: 
 

 
 
Now the y component of the sine wave and x and z components of the cos wave are fixed to 
zero values. This setting makes a full separation of internal and external space (before the 
transformation some wave components depended on the y coordinate). 
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Example 12.5: HoNi 
Magnetic structure refined from single crystal data – k=(0,0,1)  
Revised: 23 October 2017 
  

Single crystal data 

For more details: not yet published 
 
Input files:  HoNi.hkl (powder profile data) 

HoNi_nuclear.cif (nuclear structure) 

1. Creating new jobname 
Start Jana2006 
“File →  Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click HoNi 

2. Import Wizard 
Select “Magnetic: nuclear model from CIF”, NEXT 
Right pane: select the input file HoNi_nuclear.cif 

3. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Check “Use non-zero magnetic propagation vector” and fill its value: 0 0 1 
Select atom type Ho; check “Use as a magnetic atom”; select “Magnetic form factor 
<j0>+c<j2>” Ho3+; NEXT; FINISH 
The parent structure is created 

4. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “reflection file corrected for LP and absorption”; NEXT; 
Check that the name of the input file is “HoNi.hkl” and the data format is “General file on I”; 
Type in the “Input format:” (3i5,2f10.2); NEXT 
[On the screen: Complete/correct experimental parameters]; 
Fill used wavelength 0.794 Å ; NEXT; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 

5. Testing different irreps to get the best single irrep model 
[On the screen: Information] 
NEXT 
[On the screen: Representation analysis] 
This window has an information character. You can see here all irreps leading to non-
paramagnetic ordering. The “details” buttons provide more information about an individual 
irrep and its connection to the kernel magnetic symmetry. 
 



662 Jana2006 Cookbook, version September 2019 
 
 

 
 
NEXT 
[On the screen: List of kernels and epikernels] 
 

 
 
Select one of the tetragonal Shubnikov space groups; NEXT 
This will pass all present tetragonal Shubnikov space groups to further testing. 
NEXT 

6. Testing tetragonal Shubnikov space groups  
[On the screen: Select Shubnikov superspace group] 
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Note that only the second ShSG P[I]4nc allows for a non-zero magnetic moment. 
Select it and press ‘Continue with the selected Shubnikov space group’;  
 [On the screen: Select structure name] 
Use the default name "HoNi_01"; OK 
[On the screen: Basic window of Jana2006] 
Right-click the icon of Refine and select the page “Various” 
Use the button “Restrictions” and ensure that all atoms (i.e. *) have been restricted to have 
identical ADP parameters. 
OK 
Select the page “Fixed commands” and (similarly like in the previous step) ensure that all 
atomic positions are fixed in their current values (“fixed xyz *”).  
OK 
Select the page “Basic” and check if the “Number of cycles” is 100 and the “Damping factor” 
is 0.1; OK;  
 

7. Refinement in the tetragonal Shubnikov space group – P[I]4nc 
[On the screen: Basic window] 
Start refinement; 
Refinement converges with R(obs)~ 20.8%, 12.8%, 40.8% for all, nuclear and magnetic 
reflections, respectively.  
[On the screen: Basic window] 
“Parameters → Extinction”  
[On the screen: Extinction model] 
Start “Parameters → Extinction” 
Select Isotropic, Type1, Gaussian; OK; Yes to rewrite changes 
Run refinement 
Refinement converges with R(obs)~ 17.4%, 8.2%, 40.8% for all, nuclear and magnetic 
reflections, respectively.  
Right click on the icon “Refine”;  
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Select the page “Various” and use the button “Restrictions”; 
Disable the command “restrict * 12” which keeps ADP's of all atoms identical. OK; 
Use the button “Fixed commands” and disable the command “fixed xyz *” which fixes 
coordinates of all atoms. OK; OK; Yes+start;     
Refinement converges with R(obs)~ 16.7%, 7.7%, 39.4% for all, nuclear and magnetic 
reflections, respectively.  
[On the screen: Basic window] 
Double click on the icon “Plot structure”; Use the Vesta program to draw the structure; 
Press "Draw+return" or "Draw+continue"; 
In Vesta enlarge the boundaries in z direction: 
 

 
 

  
                                   

8. Testing orthorhombic Shubnikov space group C[B]mc21  
[On the screen: Basic window of the parent structure, with the representation analysis] 
“Back → Select the space group C[B]mc21 → Next; 

Select the only space group and press ‘Continue with the selected Shubnikov space group’;  
 [On the screen: Select structure name] 
Use the default name "HoNi_02"; OK 
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NO to the question “Do you want to apply this transformation?”; 
[On the screen: Basic window] 
Start refinement; 
Refinement converges with R(obs)~ 12.8%, 12.3%, 14.3% for all, nuclear and magnetic 
reflections, respectively.  
[On the screen: Basic window] 
“Parameters → Extinction”  
[On the screen: Extinction model] 
Start “Parameters → Extinction” 
Select Isotropic, Type1, Gaussian; OK; Yes to rewrite changes 
[On the screen: Basic window] 
Run refinement 
Refinement converges with R(obs)~ 9.6%, 7.8%, 14.6% for all, nuclear and magnetic 
reflections, respectively.  
Right click on the icon “Refine”;  
Select the page “Various” and use the button “Restrictions”; 
Disable the command “restrict * 12” which keeps ADP's of all atoms identical. OK; 
Use the button “Fixed” and disable the command “fixed xyz *” which fixes coordinates of all 
atoms. OK; OK; Yes+start;     
Refinement converges with R(obs)~ 8.4%, 6.7%, 13.0% for all, nuclear and magnetic 
reflections, respectively. 
Start “Parameters → Twin fractions”; 
[On the screen: Edit twin fraction] 
Selection of the orthorhombic Shubnikov space group represents a lowering symmetry from 
the original one (parent symmetry. This can create different magnetic domains related by 
the lost symmetry operations. The lost symmetry operation has been automatically created 
by the program as a twinning operation. The default value of the relative fraction was 0.5 
which means 1:1 ratio. In the final stage this value can be refined.  
Press the button “Show twinning matrix”.           
[On the screen: Twinning matrix #2] 
As expected the twinning operation is the four-fold axis, which was present in the tetragonal 
description but it is missing in the orthorhombic description. 
OK;    
[On the screen: Edit twin fraction] 
Change the volume fraction to zero and activate the refinement key for the volume fraction. 
OK; Yes to the question “Do you want to rewrite changed files?”. 
[On the screen: Basic window] 
Run refinement 
Refinement converges with R(obs)~ 8.3%, 6.7%, 12.6% for all, nuclear and magnetic 
reflections, respectively.  
 [On the screen: Basic window] 
Start “Parameters → Twin fractions”; 
[On the screen: Edit twin fraction] 
Check that the volume fraction return to the value close to 0.41.  
[On the screen: Basic window] 
Double click on the icon “Plot structure”; Use the Vesta program to draw the structure; 
Press "Draw+return" or "Draw+continue"; 
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In Vesta enlarge the boundaries in z direction (like in the previous plot): 
 
 

 
 
 

               

9. Testing orthorhombic Shubnikov space group P[I]mn21  
[On the screen: Basic window] 
Repeat the procedure from the previous point but now for the Shubnikov space group 
P[I]mn21. 
Refinement converges with R(obs)~ 8.8%, 7.4%, 12.4% for all, nuclear and magnetic 
reflections, respectively. 
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Example 12.6: ISODISTORT 
Practical introduction to Jana2006-ISODISTORTcommunication  
Revised: 05 May 2019 
  

Input files:  Ba5Co5.m40, Ba5Co5.m41, Ba5Co5.m50, Ba5Co5.m90, Ba5Co5.m95 

10. Creating CIF file from the parent structure 
[On the screen: Basic window] 
Start Jana2006 
Start “File →  Structure → Open” and open the structure Ba5Co5; 
“Tools for magnetic structures → Run ISODISTORT wizard”; 
 

11. Start ISODISTORT home page 
[On the screen: ISODISTORT=>Jana2006] 
Press “Run ISODISTORT”; 
Your Internet default browser will open the page: 
http://stokes.byu.edu/iso/isodistort.php 
 

 
 
Browse for the CIF file “Ba5Co5.cif”; OK 
  
 
 
 
 

 
 
[On the screen: ISODISTORT search] 

 

http://stokes.byu.edu/iso/isodistort.php
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Define distortions to be considered: 
In our case we are interested just in magnetic ordering;  
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Press Change; 
In the box for "Method 2" select GM k16(0,0,0), which means k=(0,0,0): 

 
Press OK; 
Select irreducible representation  
[On the screen: ISODISTORT irreducible representation ] 
 

  
 
Comparing with the "Representation analysis" list of Jana2006, only irreducible 
representations allowing non-zero magnetic moments are listed. In the next step we will 
demonstrate two dimensional irreducible representation mGM5+.    
Select the representation mGM5+ and press OK; 
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Representation analysis of Jana2006 (for comparison): 

 
 
[On the screen: ISODISTORT: order parameter direction] 
 

 
Here we can see the kernel and the set of epikernels (isotropy subgroups) associated with 
mGM5+. 
 

  



671 Jana2006 Cookbook, version September 2019 
 
 

List of kernels and epikernels in Jana2006 (for comparison). The order parameters may differ 
depending on the setting of the basis.  
 

    
 
Return one step back in your Internet browser and select the representation mGM2+; OK; 
[On the screen: ISODISTORT: order parameter direction] 
 

  
Select the listed ODP and press OK 

 
[On the screen: ISODISTORT: distortion] 
Select a small starting values (0.1) for magnetic moments of Co4, Co4 and Co6; 
Select “CIF file” and press OK;  
Save it as a Text Document with name GM2+ into the working directory.     
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Select “View distortion” and press OK;  
 

 
Make the steps related with usage of Java.  
If Java offers an update please do it, otherwise the applet may be blocked. In some cases the 
Java security level needs to be adjusted in Java Control Panel (and the browser restarted and 
the work repeated ...).  
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Using the sliders, magnetic moments of Co atoms can be changed to see mutual 
arrangement of magnetic moments of symmetry related atoms. 
  
Return back to the page ISODISTORT irreducible representation and select now mGM4+  
 

 
Repeat the work as for GM2+ and save the CIF file as a Text Document with name GM4+ 
into the working directory. 
Return to Jana2006 

12. Refining the model mGM2+ 
[On the screen: ISODISTORT => Jana2006] 
Press button “Refresh the list” 
Select the magnetic space group P63/mm’c’ irrep: mGM2+ 
Press button “Continue with the selected isotropic subgroup”;  
Select structure name e.g. Ba5Co5_01; 
[On the screen: Basic window] 
Run Refine; 
Refinement converges with Rp~2.9%, R(obs)~8.1%. 

13. Refining the model mGM4+ 
[On the screen: Basic window] 
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[On the screen: ISODISTORT => Jana2006] 
Select the magnetic space group P63’/m’m’c irrep: mGM4+ 
Press button “Continue with the selected isotropic subgroup”; 
Select structure name e.g. Ba5Co5_02; 
[On the screen: Basic window] 
Run Refine; 
Refinement converges with Rp~2.6%, R(obs)~5.4%.  

The results are identical with those from example 12.1. 
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Example 12.7: DyMn6Ge6 
Incommensurate magnetic structure – k=(0,0,0.1651); k=(0,0,0) 
Revised: 6 May 2019 
 

DyMn6Ge6 
 

Neutron powder data measured at 11K on DMC at PSI (Switzerland) 
Available at the Bilbao crystallographic server, database magndata, #1.1.10 
 
References:  
J. Rodríguez-Carvajal & F. Bourée,  EPJ Web of Conferences 22, 00010 (2012) 
 P. Schobinger-Papamantellos et al, Journal of Alloys and Compounds, 203 (1994) 243 
 
Input files:  dymn6ge6.dat (powder profile data) 

dymn6ge6_nuclear.cif (nuclear structure) 

14. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click dymn6ge6 

15. Import Wizard 
Select “Magnetic parent structure: nuclear model from CIF”; NEXT 
Right pane: select the input file dymn6ge6_nuclear.cif; OK 

16. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Choose the “Number of non-zero magnetic propagation vectors” to ‘1’ and fill its value: 0 0 
0.1651 
Select atom type Dy; check “Use as a magnetic atom”; select “Magnetic formfactor <j0>” 
Dy3+;  
Select atom type Mn; check “Use as a magnetic atom”; select “Magnetic formfactor <j0>” 
Mn3+;  
NEXT; FINISH 
The parent structure is created 

17. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Various CW format”; NEXT; 
Check that the name of the input file is “dymn6Ge6.dat” and the format is “PSI format”;  
Select “Debye-Scherrer method” 
NEXT 
[On the screen: Complete/correct experimental parameters]; 
Fill used wavelength 1.7037; Temperature 11; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 
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18. Refining of profile parameters by the le Bail technique. 
[On the screen: Information] 
NEXT 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
The background is relatively smooth and it can be described without introducing manual 
background. 
“Quit”; 
“Edit profile parameters”; 
 [On the screen: Powder options] 
In page “Cell” activate refinement of a and c parameters and the third component of the 
modulation vector – q3; 
In the page “Profile” keep the starting value of GW to 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter and change the number 
of used Legendre polynomials to 10 
OK; YES to save the changes 
“Edit refinement commands”; In the page “Basic” change the number of cycles to 20; OK 
“Run Refine”; 
The refinement should converge to Rp~4.95%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” activate refinement of GU and GV 
Change the peak-shape function to pseudo-Voigt and activate refinement LX 
OK; YES to save the changes 
“Run Refine” 
The refinement should converge to Rp~2.98%. 
“Show powder profile” 
Select the region 2θ from 30 to 45 degs – use the button “X exactly”. A couple of observed 
peaks may correspond to some impurity. Also at about 2θ= 5, an anomaly in the background 
is observed. No peaks are possible there. 
“Quit”; 
“Edit profile parameters”; 
 [On the screen: Powder options] 
In page “Corrections”, press button “Define excluded regions” : from 0 to 7; “Add”, 
“OK”,“OK”; 
 “Run Refine”; 
The refinement should end with Rp~2.90%. 
NEXT; YES to leave the form for le Bail refinement 

19. Refinement of the scale parameter for the nuclear structure 
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands”; 
In the case that the fixed command of form is “fixed all *” is already in the panel, do 
nothing. If not:  
Fix all parameters for all atoms (“*” for “Atoms/Parameters” textbox); “Add”; OK; OK 
“Run Refine” 
The refinement should converge to Rp=11.6%, R(obs)=7.5% 
NEXT; YES to leave the for for Rietveld refinement 
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20. Testing different irreps to get the best single irrep model 
[On the screen: Information]  
NEXT 
[On the screen: Representation analysis] 
 

   
 
This window has an information character. You can see here all irreps leading to magnetic 
ordering. The “details” buttons provide more information about an individual irrep and its 
connection to the kernel magnetic symmetry. 
NEXT 
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[On screen: List of kernels and epikernels] 
 

 
Select one of the hexagonal magnetic superspace groups based on average space group 
P6/mmm; NEXT; 
This will pass all present hexagonal magnetic superspace groups of type P6/mmm to further 
testing. We assume that both magnetic atoms should have non-zero magnetic moment. 
[On the screen: Select magnetic space group] 
 

 
 
Only the second magnetic superspace group allows for non-zero magnetic moments for Mn 
and Dy atoms.   
 
Select the second magnetic superspace group: P6/mmm.1’(00g)00sss and press “Start 
profile simulation”;  
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Press "X exactly" and focus the region 8-16 degrees; Press “Fit Y”:  
 

 
 

Two dominant magnetic peaks in this region have zero intensity. This means that the tested 
model does not describe the magnetic ordering correctly. However, in making such 
conclusion we have to take into account that the simulation procedure uses randomly 
generated magnetic moments and that the result can be affected by an actual random 
choice. This is why we recommend repeating the simulation when some doubt exists. 
“Quit”; “Back” and return to the “List of kernels and epikernels” and select one of 
hexagonal superspace groups based on P622.  
While the first one P622.1’(00g)t00s restricts the magnetic moments of the Dy atom to zero, 
the second one P622.1’(00g)-h00s allows non-zero magnetic moments for both magnetic 
atoms. The simulation profiles demonstrate that the intensity of both magnetic peaks in the 
interval (8-16) degs are generally non-zero:  
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21. Refinement of the magnetic structure in – P622.1'(00g)-h00s 
[On the screen: Select magnetic superspace group] 
Select the magnetic superspace group P622.1'(00g)-h00s 
Press ‘Continue with the selected magnetic superspace group’ 
[On the screen: Select structure name] 
Use the default name i.e. dymn6ge6_01 or any other; OK  
[On the screen: Basic window of Jana2006] 
Right-click the icon of Refine and select the page “Various” 
Use the button “Restrictions” and ensure that all atoms (i.e. *) are restricted to have 
identical ADP parameters. 
The restriction “restric * 13” has been set automatically when the program created the 
testing structure. To see the meaning of the restriction focus it by mouse and press “Load”.  
“Load” opens the restriction for editing. Make sure that "Coordinates" and "Modulations" 
boxes are cleared and press “Rewrite” to close the editing mode.  
OK 
Select the page “Fixed commands” and (similarly like in the previous step) ensure that all 
atomic positions are fixed in their current values (“fixed xyz *”).  
OK 
Select the page “Basic” and check if the “Number of cycles” is set to 100 and the “Damping 
factor” to 0.1; OK; Yes+start;  
Refinement converges with Rp~4.9%, R(obs)~ 4.1%, 3.7%, 4.9% for all, nuclear and magnetic 
reflections, respectively. 
Use “Profile viewer” and check the fit of the calculated powder profile 
Observe that some main reflections like (1 0 1 0) around 25 degrees or (2 -1 1 0) at about 40 
degrees are poorly fit. In order to exclude some additional nuclear effects we can allow the 
refinement of atomic positions: 
Right-click the icon of Refine and select the page “Various”. Use the button “fixed 
commands” and disable the command “fixed xyz”. Run refine again. 
Now the atom coordinates will also be refined. The refinement should end with Rp~4.8% and 
Bragg R factors R(obs)=4.0%, 3.5% and 4.9% for all, main and satellite reflections, 
respectively. (“View of Refine”). The improvement is minimal. Some of the main reflections 
remain poorly fit systematically with too low intensity. This fact can lead to the conclusion 
that an additional magnetic ordering with k=0 is present. 

22. Refinement in the subgroups allowing magnetic wave (0,0,0) 
[On the screen: Basic Jana window] 
We try then the possibility that magnetic scattering occurs also at main reflections, i.e. an 
additional magnetic ordering with k=(0 0 0) is taking place. In the language of the symmetry 
group of the phase this implies to lower it, dropping the operation {1’|0001/2} associated 
with the existence of a single primary incommensurate wave vector.  
 
There are several maximal subgroups without this operation. Then can be generated by the 
Jana tool “Tools→Transformations→Go to subgroup structure”. As generators for the 
working group until now can be used: 

      {6+|0 0 0 5/6}:   x1-x2, x1, x3, x4+5/6 
{2_xy| 0 0 0 0}:  x2, x1, -x3, -x4 
{1’|0001/2} :   x1, x2, x3 , x4+1/2 
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The possible maximal subgroups will then be generated by: 
 
P622(00g)-h00 
{6+|0 0 0 5/6}:   x1-x2, x1, x3, x4+5/6, m 
{2_xy| 0 0 0 0}:  x2, x1, -x3, -x4, m 
 
P6’22’(00g)t00 
{6+’|0 0 0 1/3}:   x1-x2, x1, x3, x4+1/3, -m 
{2_xy| 0 0 0 0}:  x2, x1, -x3, -x4, m 
 
P62’2’(00g)-h00  
{6+|0 0 0 5/6}:   x1-x2, x1, x3, x4+5/6, m 
{2’_xy| 0 0 0 1/2}:  x2, x1, -x3, -x4+1/2, -m 
 
P6’2’2(00g)t00 
{6+’|0 0 0 1/3}:   x1-x2, x1, x3, x4+1/3, -m 
{2’_xy| 0 0 0 1/2}:  x2, x1, -x3, -x4+1/2, -m 
 
Make sure that your actual structure is the final refined structure from the previous step. 
 
“Tools → Transformation → Go to subgroup structure”; 
Press the “Refresh” button and select the generators: 
 
x1-x2  x1  x3 x4+5/6 m 
x2 x1 -x3 -x4 m 
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Press the button “Complete subgroup”;   
 

 
   
NEXT; NEXT 
[On the screen: Select one representative of the 2nd coset] 
Select the first operation. 
Generally, all selections would give the same result.   
NEXT; 
[On the screen: Specify the output structure] 
Select “dymn6ge6_01_subgroup_1” or any other 
NEXT;FINISH;”Yes” to the question “Do you want to continue with the new structure?” 
[On the screen: Basic window] 
Run “Edit Atoms”; Select atoms Dy1 and Mn1; Press the button “Action” 
Select “Reset modulation/magnetic parameters” 
Deselect “Magnetic parameters k<>0” 
Choose “Reset parameters randomly in the interval (-pmax,pmax) 
OK;OK;”Yes” to the question “Do you want to rewrite changed files?” 
Run “Refine”; 
Repeat the procedure for all subgroups listed above 
Use the “File→ Structure → History” to return to the final refined structure in 
P622.1'(00g)-h00s.  
 
P622(00g)-h00 
Rp=4.7%, R(obs)=4.4%,4.1%,5.1% for all, nuclear and magnetic reflections, respectively.   
 
P6’22’(00g)t00 
Rp=4.6%, R(obs)=3.6%,3.1%,4.6% for all, nuclear and magnetic reflections, respectively. 
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P62’2’(00g)-h00  
Rp=4.1%, R(obs)=3.0%,2.6%,3.7% for all, nuclear and magnetic reflections, respectively. 
 
P6’2’2(00g)t00 
Rp=4.6%, R(obs)=4.0%,3.4%,5.1% for all, nuclear and magnetic reflections, respectively. 
  
 
One of the symmetries clearly fits the data better. Observe that the strong misfit of some of 
the main reflections has disappeared. 
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The final common Uiso is negative but its absolute value is very small. 
Right-click the icon of Refine and select the page “Various” 
Use the button “Fixed commands” 
Select “Set individual’; File the edit box by the text “Uiso[*]”; Define value “Set to” zero 
Add; OK; OK; Press Button “Yes+start” 
Rp=4.1 %, R(obs)=3.4%,3.2%,3.8% for all, nuclear and magnetic reflections, respectively. 
Run “EditM50”; Go to the page “Magnetic parameters”; Change the magnetic form factor 
for Dy to <j0>+c<j2>  and Dy3+ 
OK; ”Yes” to the question “Do you want to rewrite M50 file?” 
Run “Refine” 
Rp=4.1%, R(obs)=3.0%,2.8%,3.4% for all, nuclear and magnetic reflections, respectively. 

 
23. Visualize the refined model with MVISUALIZE (Jmol) – Internet connection needed 

[On the screen: Basic window] 
“File → CIF utilities →  Make mCIF file for MVisualize”; 
[On the screen: Define name for the out mcif file] 
Define here the name of a mcif file with the file extension “mcif” 
OK    
[On the screen: INFORMATION] 
OK    
The Jana will now start your default internet browser on the home page of Bilbao 
Crystallographic server. Select there the utility MVISUALIZE and follow their instructions.    
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24. Visualize the refined model with VESTA 
[On the screen: Basic window] 
Double click on the icon “Plot structure” 
Select “Draw approximant structure”; x from 0 to 1; y form 0 to 1; z from 0 to 6 (c* 
component of the propagation vector is close to 1/6)   
Select “Use Vesta to draw the magnetic structure” 
Press "Draw+return" or "Draw+continue" 
Select “Edit→Vectors” and modify “Scale factor for modulus” to 0.3 
 

 
OK 
Press button “Properties…”; Go the page “Atoms” and modify “Radius” for all atoms 
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25. Transformation to the standard setting as used in MAGNDATA - Internet connection 
needed 
[On the screen: Basic window] 
“Tools → Connect through internet to → Bilbao Crystallographic Server” 
Select “MAGNDATA”; Enter the label of the structure “1.1.10” 

 

  
The result as derived step by step from the representation theory is expressed in a different 
chiral domain than used in MAGNDATA. Therefore, we should transfer it to the equivalent 
chiral domain. 
[On the screen: Basic window] 
“Tools → Transformation → Change enantiomorph” 
Create a new structure with name e.g. “dymn6ge6_01_subgroup_3_chiral” 
OK; Yes to continue with the new structure 
Run EdiM50; Go the page “Symmetry” 
Now the superspace group is the same as used in MAGNDATA however there is a non-zero 
origin shift in x4 equal 1/6. 
ESC 
“Tools → Transformation → Origin shift” 
Use shift to the point 0 0 0 -1/6 
OK 
The last point that has to be checked for a full comparison is if we are using in the same 
symmetry positions for the magnetic atoms Dy1 and Mn1. The positions of these atoms 
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from 1.1.10 are: 
Dy1 (0,0,0) and Mn1 (0.5,0,0.251). 
[On the screen: Basic window] 
Run “Edit atoms”; Double click on Dy1 atom; Go to the page “Edit” 
The coordinates are (1,1,1) and this means that we can just rewrite them to (0,0,0) as such 
transformation does not change the modulation functions. 
In the case that the Mz0 is negative change it to positive.  
Move to the atom Mn1 
Its coordinates are (0.5,1,0.749). From the list of symmetry operations we can find that the 
symmetry operation: x1-x2,-x2,-x3,-x4+1/2 combined with the lattice translation (1,1,1,0) 
makes what is needed. 
OK; 
[On the screen: Select atoms to be used] 
Select the atom Mn1; Press button “Action”; Select “Transform selected atoms”   
Use the button “Fill by a symmetry operation”; Select x1-x2 -x2 -x3 -x4+1/2 –m; Modify the 
translation vector to 1 1 1 1/2 
OK; OK; Yes to rewrite files 
[On the screen: Basic window] 
Run “Refine” to check that all transformation did not change the solution 
[On the screen: Basic window] 
“Edit/View → View of Refine”; Press “Go to” and select “Changes overview” 
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 M0x M0y M0z |M| 

Dy1 
MAGNDATA 0.0 0.0 3.93 3.93 

Jana 0.0 0.0 3.83(12) 3.83(12) 

Mn1 
MAGNDATA 0.0 0.0 -1.15 1.15 

Jana 0.0 0.0 -0.84(9) 0.84(9) 
 

 

 
cos sin 

Mx My Mz Mx My Mz 

Dy1 
MAGNDATA 6.20 0.0 0.0 3.58 7.15 0.0 

Jana 6.09 0.0 0.0 3.51(5) 7.03 0.0 

Mn1 
MAGNDATA -1.88 -0.21 0.0 -0.85 -2.05 0.0 

Jana -1.43(12) -0.39(10) 0.0 -1.20(11) -2.38(10) 0.0 

26. Use of the option of polar coordinates for the moments to constraint further the Mn spin 
to have a circular modulation. 
[On the screen: Basic window] 
“File → Structure → Save as”; Use e.g. “dymn6ge6_01_subgroup_3_final” 
OK; No to the question “Do you want to continue with the new structure?”  
[On the screen: Basic window] 
Run “Edit atoms” 
[On the screen: Select atoms to be used] 
Double click on the atom Dy1; Activate option “in spherical coordinates”; 
Go the “Edit” page;  
For the magnetic moment k=0 only Mr0-amplitude is a free parameter. Both angles Mp0-φ 
angle and Mt0-θ angle are fixed by symmetry. 
Uncheck the refine flags for angular components if active. 
Press the button “Magnetic” to magnetic modulation waves. 
The only free parameter is the amplitude Mrsin1. The φ angle is fixed for cos wave to 90 and 
for sin wave to 0. This means that the circular modulation is fully induced by the symmetry.   
Uncheck the refine flags for angular components if active. 
Go to the atom Mn1 and activate option “in spherical coordinates”; 
Go the “Edit” page;  
For the magnetic moment k=0 only Mr0-amplitude is a free parameter. Both angles Mp0-φ 
angle and Mt0-θ angle are fixed by symmetry. 
Uncheck the refine flags for angular components if active. 
Press the button “Magnetic” to magnetic modulation waves. 
For Mn1, the modulation parameters except the θ angle are symmetry free. In order to force 
a circular modulation, the constraints must be used: Mrcos1=Mrsin1, Mpcos1=Mpsin1-90. 
These equations are only roughly satisfied by the previous refined model, as shown after the 
transformation. 
 
Right click on the “Refine” icon; Select the page Various; Click on the button “Equations”; 
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Define the equations mentioned above: 
  
Mp0[Dy1]=0 
Mt0[Dy1]=0 
Mrcos1[Dy1]=Mrsin1[Dy1] 
Mpsin1[Dy1]=90 
Mpcos1[Dy1]=0 
Mtsin1[Dy1]=90 
Mtcos1[Dy1]=90 
Mp0[Mn1]=0 
Mt0[Mn1]=180 
Mrcos1[Mn1]=Mrsin1[Mn1] 
Mpcos1[Mn1]= Mpsin1[Mn1]-90 
Mtsin1[Mn1]=90 
Mtcos1[Mn1]=90 
You can do either one by one or you can use pre-prepared file “Equations-circular.txt”. For 
the former method: 
Press the button “Edit” and use the copy-paste method from the file 
“Equations-circular.txt”.    
 
OK;OK; Yes+start 
Rp=3.83%, R(obs)=2.93%,2.43%,3.82% for all, nuclear and magnetic reflections, respectively. 
Which means that it is not significantly worse than the full refinement – see point 9. 
 
 

 M0x M0y M0z |M| 

Dy1 
MAGNDATA 0.0 0.0 3.93 3.93 

Jana 0.0 0.0 3.93(11) 3.93(11) 

Mn1 
MAGNDATA 0.0 0.0 -1.15 1.15 

Jana 0.0 0.0 -0.99(8) 0.99(8) 
 
After transforming from polar to crystallographic coordinates 
 

 
cos sin 

Mx My Mz Mx My Mz 

Dy1 
MAGNDATA 6.20 0.0 0.0 3.58 7.15 0.0 

Jana 6.17 0.0 0.0 3.56(5) 7.12 0.0 

Mn1 
MAGNDATA -1.88 -0.21 0.0 -0.85 -2.05 0.0 

Jana -1.85(10) -0.17(9) 0.0 -0.86(9) -2.04(8) 0.0 
 
 

General note: Two different strategies for handling refinement keys in Jana2006 
From Petříček, V., Dušek, M. & Palatinus, L. (2014) Z.Kristallogr. 229, 345-352. 
 
“All refinable parameters are divided into two groups: automatic and user-controlled ones. The 
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automatic parameters are those which can be usually refined without numerical problems: scale 
factors and extinction parameters; parameters describing position, ADP and their modulation 
for individual atoms as well as for molecules; background parameters of the powder profile; 
magnetic parameters. The user-controlled parameters are twin/phase volume fractions, atomic 
or molecular site occupancies, parameters of crenel modulation functions, parameters of 
multipole refinement and powder profile parameters for individual Bragg reflections. 
The automatic parameters are activated by default at the beginning of the refinement process 
while the user-controlled ones must be always explicitly activated by the user. The program 
always fixes the parameters which cannot be refined due to symmetry restrictions. In order to 
fix other automatic parameters the user is provided with a range of special fixing commands. 
This way is very useful for most cases because it minimizes mistakes in setting refinement flags. 
However, the program also allows switching to a completely manual mode, where all 
parameters are to be activated explicitly by the user, analogically to other refinement programs 
such as FullProf [29].” 
 
Handling of symmetry restrictions of magnetic moments in polar coordinates would be easier 
for most of users if the non-automatic procedure is used: 
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Example 12.8: Cr2WO6 
Commensurate magnetic structure – k=(0,0,0) 
Revised: 6 May 2019 
 

Neutron powder data measured at 4K on HB2A at HFIR, λ=2.4097Å 
Available at the Bilbao crystallographic server, database magndata, #0.75 
  
References:  
Zhu et al., PRL 113, 076406 (2014) 
                   PHYSICAL REVIEW B 92, 094419 (2015) 
 
 
Input files:  cr2wo6.dat (powder profile data) 

cr2wo6_nuclear.cif (nuclear structure) 
 
 

 
 
 
 
 
 
 
 
 
 
 

 

 

27. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click cr2wo6 

28. Import Wizard 
Select “Magnetic parent structure: nuclear model from CIF”; NEXT 
Right pane: select the input file cr2wo6_nuclear.cif; OK 

29. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Select “Number of non-zero magnetic propagation vectors” to 0 
Select atom type Cr; check “Use as a magnetic atom”; select “Magnetic formfactor <j0>” 
Cr3+;  

Parent space group: 
P4

2
/mnm (N. 136)  

Propagation vector: 
k= (0,0,0) 

Magnetic site: 
Cr 4e (0,0,z)  
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NEXT; FINISH 
The parent structure is created 

30. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Various CW format”; NEXT; 
Check that the name of the input file is “cr2wo6.dat” and the format is “free format of 2th, 
I, [sig(I)]”;  
NEXT 
[On the screen: Complete/correct experimental parameters]; 
Fill used wavelength 2.4097; Temperature 4; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 

31. Refining of profile parameters by the le Bail technique. 
[On the screen: Information] 
NEXT 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
The background is relatively smooth and it can be described without introducing manual 
background. 
“Quit”; 
“Edit profile parameters”; 
 [On the screen: Powder options] 
In page “Cell” activate refinement of a and c parameters; 
In the page “Profile” check that the starting value of GW is 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter and change the number 
of used Legendre polynomials to 8 
OK; YES to save the changes 
“Edit refinement commands”; In the page “Basic” change the number of cycles to 20; OK 
“Run Refine”; 
The refinement should converge to Rp~17.5%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” activate refinement of GU and GV 
Change the peak-shape function to pseudo-Voigt and activate refinement LX 
OK; YES to save the changes 
“Run Refine” 
The refinement should converge to Rp~7.2%. 
“Show powder profile” 
Select the region 2θ  from 10 to 20 degs – use the button “X exactly”. The peak (0 0 1) has 
some asymmetry. “Quit”; 
“Edit profile parameters”; 
 [On the screen: Powder options] 
In page “Asymmetry/Difractometer”  
Select “Berar-Baldinozzi correction”; Activate refinement of asym1, asym2, asym3, and 
asym4; “OK”; 
 “Run Refine”; 
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The refinement should end with Rp~6.5%. 
NEXT; YES to leave the form for le Bail refinement 

32. Refinement of the scale parameter for the nuclear structure 
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands”; 
In the case that the fixed command of form is “fixed all *” is already in the panel, do 
nothing. If not:  
Fix all parameters for all atoms (“*” for “Atoms/Parameters” textbox); “Add”; OK; OK 
“Run Refine” 
The refinement should converge to Rp=14.2%, R(obs)=6.8% 
NEXT; YES to leave the for for Rietveld refinement 

33. Testing different irreps to get the best single irrep model 
[On the screen: Information] 
NEXT 
[On the screen: Representation analysis] 
 

   
 
This window has an information character. You can see here all irreps leading to magnetic 
ordering. The “details” buttons provide more information about an individual irrep and its 
connection to the kernel magnetic symmetry. 
NEXT 
 
 
 
 
 
 
[On screen: List of kernels and epikernels] 
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Select one of the tetragonal Shubnikov space groups; NEXT; 
This will pass all present tetragonal Shubnikov space groups of type P42/mnm to further 
testing. We assume that Cr magnetic atoms should have non-zero magnetic moment. 
[On the screen: Select Shubnikov space group] 
 

 
 
 
Select the second Shubnikov superspace group: P42’/mnm’ and press “Start profile 
simulation”;  
Press "X exactly" and focus the region 12-33 degrees; Press “Fit Y”:  
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While for the strong magnetic reflection (0,0,1)the model gives zero, for the reflection 
(0,0,1) which seems to be very weak the model gives non-zero intensity. This can be 
reproduced for all tetragonal Shubnikov groups allowing non-zero magnetic moments for Cr 
atom – P42/mn’m’, P42/m’n’m’ and P42’/m’nm’. As a next step we should try orthorhombic 
space groups. 
Quit; 

34. Testing orthorhombic subgroups 
[On the screen: Basic window of the parent structure, with the representation analysis] 
“Back → Select one of the orthorhombic C centered Shubnikov space groups; 
The symbol of Shubnikov space group is related to the lattice defined by axes as expressed in 
the second column. However, the final transformation to the standard setting is offered only 
during the last step of the representation analysis to keep relationships of magnetic 
moments to the original call of the parent structure.   
 → Next; 
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The first listed Shubnikov space group allows ferromagnetic ordering as seen from non-zero 
the global magnetic moment. This global magnetic moment can be suppressed only if 
additional condition to relate the magnetic moments of two independent Cr positions is 
applied. This makes this model less probable as no tendency to make ferromagnetic ordering 
was detected.  
 
Switch to the second Shubnikov space group 
 

        
 
The second Shubnikov space group has the global magnetic moment zero. 
 
Select the first Shubnikov superspace group: Cm’mm’ and press “Start profile simulation”;  
Press "X exactly" and focus the region 12-33 degrees; Press “Fit Y”;  
 
Both reflections (1,0,0) and (0,0,1) have generally non-zero intensity and this means that we 
cannot reject this space groups only from violation of systematically absent reflection as for 
the tetragonal case. However, in making such conclusion we have to take into account that 
the simulation procedure uses randomly generated magnetic moments and that the result 
can be affected by an actual random choice. This is why we recommend repeating the 
simulation when some doubt exists.This is also true for Cmm’m. 
 
Select the Shubnikov space group Cm’mm’  
Press ‘Continue with the selected Shubnikov space group’ 
[On the screen: Select structure name] 
Use the default name i.e. cr2wo6_01 or any other; OK 
YES to the question “Do you want to apply this transformation?” 
This will transform the structure to the standard setting. Jana2006 can generally work at 
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non-standard setting.  
[On the screen: Basic window of Jana2006] 
Run “Edit profile” and activate refenment for a, b and c parameters; 
Right-click the icon of Refine and select the page “Various” 
Use the button “Restrictions” and ensure that all atoms (i.e. *) are restricted to have 
identical ADP parameters. 
The restriction “restric * 12” has been set automatically when the program created the 
testing structure. To see the meaning of the restriction focus it by mouse and press “Load”.  
“Load” opens the restriction for editing. Make sure that "Coordinates" box are cleared and 
press “Rewrite” to close the editing mode.  
OK 
Select “Fixed commands” and (similarly like in the previous step) ensure that all atomic 
positions are fixed in their current values (“fixed xyz *”).  
OK 
Select the page “Equation”; 
Introduce the equation b=a valid for diagonals in tetragonal lattice;  
Select the page “Basic” and check that the “Number of cycles” is set to 100 and the 
“Damping factor” to 0.1, “Use Marquart technique” check the Fudge factor 0.001; OK; 
Yes+start;  
Refinement converges with Rp~13.1%, R(obs)~ 11.3%. 
Return to the window of the parent structure; 
Repeat the same process for the second orthorhombic C centered Shubnikov space group 
Cmm’m and use the default name i.e. cr2wo6_02 or any other; 
Refinement converges with Rp~8.2%, R(obs)~ 5.7%. 
Repeat the process also for Pnn’m’ and Pnn’m; 
Use the same equation b=a as for the centered cell;  
Pnn’m’ (allows ferromagnetic ordering) : Rp~13.1%, R(obs)~ 10.5%,7.7%, 54.5%  for  all, 
nuclear and magnetic reflections, respectively.  
Pnn’m (doesn’t allows ferromagnetic ordering) : Rp~8.2% , R(obs)~ 5.2%,5.4%, 3.1%  for  all, 
nuclear and magnetic reflections, respectively.  

35. Comparing of two best results Pnn’m and Cmm’m 
[On the screen: Basic Jana window] 
Up to now atomic coordinates were kept fixed. 
Select the structure cr2wo6_02 (or any other) describing the Cmm’m model;  
Right-click the icon of Refine and select the page “Various” 
Select “Fixed commands” and disable the command “fixed xyz *”; 
OK;OK; Yes+start; 
Refinement converges with Rp~6.7%, R(obs)~ 2.3% for 10 profile and 12 structural 
parameters 
Repeat the process with Pnn’m 
Refinement converges with Rp~6.7%, R(obs)~ 2.2%,2.1%, 2.5 %  for  all, nuclear and 
magnetic reflections, respectively – number of 10 profile and 10 structural parameters  
Select the structure cr2wo6_02 (or any other) describing the Cmm’m model;  
Double click on the icon “Plot structure” 
Press the button “Atom filter” and select only Cr atoms;  
Select “Use Vesta to draw the magnetic structure” 
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Select the structure cr2wo6_04 (or any other) describing the Pnn’m model; 
Double click on the icon “Plot structure” 
Press the button “Atom filter” and select only Cr atoms;  
Select “Use Vesta to draw the magnetic structure”: 
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The model in Pnn’m gives slightly better R values but the difference is so small that it is 
difficult to make from it any final conclusion about the direction of the magnetic moment of 
Cr atoms.   
 

36. Orthorhombic strain for Pnn’m and Cmm’m  
 
While the P centered cell are identical with that used for the parent tetragonal cell the C 
centered cell is related to the original cell by equation: 
 
𝒂𝒂𝐶𝐶−𝑜𝑜𝑜𝑜𝑜𝑜ℎ𝑜𝑜 = 𝒂𝒂𝑜𝑜𝑡𝑡𝑜𝑜𝑜𝑜𝑡𝑡 + 𝒃𝒃𝑜𝑜𝑡𝑡𝑜𝑜𝑜𝑜𝑡𝑡        𝒃𝒃𝐶𝐶−𝑜𝑜𝑜𝑜𝑜𝑜ℎ𝑜𝑜 = −𝒂𝒂𝑜𝑜𝑡𝑡𝑜𝑜𝑜𝑜𝑡𝑡 + 𝒃𝒃𝑜𝑜𝑡𝑡𝑜𝑜𝑜𝑜𝑡𝑡      𝒄𝒄𝐶𝐶−𝑜𝑜𝑜𝑜𝑜𝑜ℎ𝑜𝑜 = 𝒄𝒄𝑜𝑜𝑡𝑡𝑜𝑜𝑜𝑜𝑡𝑡 
 
The orthogonal ordering of magnetic moments can have some influence to the cell 
parameters a and b which need not be same anymore. In order to test orthorhombic strain 
without mixing it with the refined magnetic structure we can use le Bail profile fitting. 
 
[On the screen: Basic Jana window] 
Select the structure cr2wo6_02 (or any other) describing the Cmm’m model; 
“File → Structure → Save as”; 
Select name e.g. cr2wo6_02_cell; OK; Yes to the question “Do you want to continue with 
the new structure?”; 
Right-click the icon of Refine and select the page “Basic”;  
Select “Make only profile matching (le Bail refinement)”; 
Go to the page “Various”; Press the button “Equation” and disable the equation b=a;  
OK; OK; Yes; 
Start “Edit profile”; Go to the page cell and activate there refinement of the b parameter 
and modify slightly its value to avoid full overlaps; 
OK; Yes to rewrite changed files; 
Run refinement;  
Refinement converges with Rp~6.5%,  
Yes to open listing; 
Press “Go to” and select “Changes overview”; 

 
The cell parameters are: a=6.4849(23) and b=6.4850(23) which means that there is no strain 
within the accuracy following from the refinement. 
   
Repeat the procedure with Pnn’m model; 
Refinement converges with Rp~6.4%, 
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The cell parameters are: a=4.5876(3)  and b=4.5837(3) which means that there is significant 
difference connected with orthorhombic strain . 

37. Final model Pnn’m 
The refined magnetic moment of the Cr atoms is: (0.19(14),2.13(2),0) Bohr magnetons, 
which means that the x component is negligible. In the final refinment we shall keep the x 
component 0. 
 
 [On the screen: Basic Jana window] 
Select the structure cr2wo6_04 describing the Pnn’m model; 
“File → Structure → Save as”; 
Select name e.g. cr2wo6_04_final; OK; Yes to the question “Do you want to continue with 
the new structure?”; 
Right-click the icon of Refine and select the page “Various” 
Press the button “Fixed commands” and select “Set individual”; 
Into the editing window “Atoms/parameters” write mx0[Cr1]; 
Add; OK;OK; Yes+start; 
Refinement converges with Rp~6.7%, R(obs)~ 2.0%,2.0%, 2.2%  for  all, nuclear and 
magnetic reflections, respectively – number of 11 profile and 10 structural parameters. 
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Example 13.1: TTB 
Solution of a tetragonal-tungsten-bronze type structure from EDT (electron diffraction 
tomography) data. Complete procedure from data reduction to structure refinement. 
 

Revised: 04 March 2015 
 
Chemical formula: K3Nb(5+x)O15 
Electron diffraction data was measured on a transmission electron microscope Philips CM120 
with a precession divice DigiStar. Accelerating voltage 120 kV.  
Input data: directory dp with the set of experimental data 
ttb.pts: input file for PETS – the data reduction of the  beam stop 
beamstop.xyz: file with the polygon defining the shape of the beam stop 
ttb_start.cif_pets: result of the data processing. This file is provided so that this example can be 
solved without the data processing part, and to warrant reproducibility of the second part.  
File ttb.cif_pets is the output of the data reduction. 

 
1. Preparing input file for PETS 

Make sure you correctly installed PETS and ImageJ. Check Chapter  “Installation notes” (page 
7) for details. File ttb.pts is the input to PETS. The file was prepared by the software used for 
the collection of the diffraction data, and most entries have been filled in. You have to enter 
two parameters: the information about the beam stop and the size of reflections. 
Open file ttb.pts in any plain-text editor (notepad, wordpad, notepad++, vim,…)  
Open file dp/001.tif in ImageJ  
In ImageJ go to “Image → Adjust → Brightness and Contrast”  
Click the button “Auto” to adjust the constrast.  
Go to “Image → Properties” and change the values of Pixel width and Pixel height from 0.005 
to 1.  
Measure the diameter of the reflections on the image.  
There are several ways to measure the diameter of the reflections, but the simplest and 
sufficient way is to place the cursor to the left of the reflection, remember or write down the 
x-coordinate, then place the cursor to the right of the reflection, again read the x-coordinate 
and subtract the two coordinates. The diameter should be large enough to encompass most 
of the reflections, but not too large, to prevent overlaps. Do not take into account the broad, 
weak TDS scattering around the strongest reflections! That would give you too large diameter. 
In this case, value 25 is a good choice.  
In ttb.pts, change the line “reflectionsize ??” to “reflectionsize 25”  
In ImageJ, determine the coordinates of the tip of the beamstop (white cross on the 
following image): 
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You should get coordinates very close to 913 1014. 
In ttb.pts change the line “beamstop ??(yes/no)” to “beamstop yes beamstop.xyz 913 1014” 
File beamstop.xyz contains the coordinates of the polygon describing the beamstop relative 
to a reference point. 913 and 1014 are the x- and y-coordinates of the reference point, 
which is in this case the tip of the beamstop. The reference point can change from one 
experiment to another, and must be therefore determined by the user. 
Save and close ttb.pts 

 
2. Run PETS and prepare files for indexation  

Make sure ImageJ is not running. If it is, close ImageJ.  
Run PETS with the file ttb.pts  
There are several ways of running PETS. See installation notes for detailed description. A 
window with initial menu of PETS opens, and ImageJ starts displaying a black image with a 
white circle.  
In the window of PETS, type p[Enter]  
The peak hunting procedure starts. ImageJ sequentially displays diffraction images with 
circles at points found by PETS as significant peaks. Note that PETS follows the position of 
the primary beam, and corrects for small shifts. Note also the significant diffuse streaks. 
Although they seem very intense, it is just due to the enhanced contrast of the images. 
Compared to the Bragg intensities, the diffuse streaks are weak and do not disturb the 
structure solution.  
At the end, the evolution of the x- and y-coordinates of the estimated primary-beam position 
is displayed (b&w inverted): 

 
[On screen: main menu of PETS]  

type r[Enter] 
As the first step after peak hunting, PETS needs to refine the azimuthal angle between the 
horizontal axis and the projection of the tilt axis. This angle depends on experimental 
parameters, and needs to be refined for each data set. ImageJ displays a cylindrical projection 
of the difference space of the extracted peak positions. For correct azimuthal angle, the image 
contains sharp peaks aligned on sinusoidal curves. This step provides a first estimate of the 
data quality. At the end of the refinement, you should get message: 
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Final values of the parameters:  
omega : 21.591  
and see this image (b&w inverted): 

 
[on screen: main menu of PETS]  
type a[Enter]  
PETS starts the analysis of the located peak positions. In the first step, distance distribution 
between peaks in the image plane is analyzed. A sorted plot of inter-peak distances is 
displayed (white curve on screen, black on the image below) with its derivative (grey curve): 

 

 
For good quality data set, the white curve contains distinct steps, and, consequently, the grey 
curve has distinct peaks.  
Press Enter  
In the next step an autoconvolution of the diffraction pattern (difference space) is analyzed, 
and the groups of peaks in the autoconvolution (clusters) are replaced by the cluster centers. 
Again, a distance distribution is displayed, and clear-cut steps on the curve indicate a well-
defined lattice.  
Press Enter 
Now the first step is finished and PETS prepared files needed for unit cell indexing. Keep the 
window of PETS open, you will need it later! 

 
3. Indexing with Jana2006  

Start Jana2006  
By default, Jana2006 starts with the last structure open. It may be cumbersome to change the 
directory every time. You may create a dummy (empty) file ttb.m40 in the example directory, 
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and use the command “Open with” from the file-manager context menu to launch Jana2006 
directly in this directory.  
“Tools → Graphics → Indexing”  
Locate and open file ttb.clust by double clicking it  
A 3D view of the reciprocal lattice opens. You can rotate the cloud by mouse. Use buttons   
and   to switch between free rotation and rotation around z-axis. Rotate with the lattice 
and try to determine the crystal system and the special axes of the lattice.  
You should come to the conclusion that the lattice is tetragonal (warning – the lattice has a 
few projections that look tetragonal, but are not exactly tetragonal). The following image 
shows the view along c*: 

 
IMPORTANT: before you continue, make sure you have the same orientation of the lattice on 
your computer as displayed on the picture above (check the direction of the axes on the right). 
If not, you may obtain slightly different results in the rest of the tutorial. While not necessarily 
wrong, it makes following this tutorial more difficult.  

Click the button in the lower-left corner  
Click, hold the mouse button, and drag the marker to obtain the result on this image: 
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Note that the vertical red line is on the tenth vertical row of peaks. By this action you defined 
the direction and length of the (direct-space) basis vector a. Note: if you make a mistake and 
need to redo this step, make sure that the radio button a is selected under the main window, 
otherwise you will modify another cell parameter.  
Repeat the action, this time drag the marker up vertically to define the vector b.  
Both vectors should have lengths close to 12.8 Å, and angle gamma is close to 90°.  
Click “View direction”, keep default selection “a”, Click OK  
The reciprocal space is now viewed along a, and b points to the right.  
In analogy to the procedure above, select the direction and length of the vector c (c points 
up in this view).  
When you are finished, at the bottom of the window you should see cell parameters close 
(within a fraction of angstrom and degree) to these values: 

 
“Refine cell → Refine UB+cell”  
The orienting matrix is refined. Note that 90.3% of all peaks were indexed.  
OK; Quit  
A file ttb.smr was now produced by Jana2006. This file contains the orientation matrix and 
the unit cell parameters.  
Close Jana2006  

 
4. Integrate the intensities with PETS  

Return to the window of PETS.  
Type u[Enter]  
PETS reads the orienting matrix from the smr file.  
Type i[Enter]  
The integration procedure starts. ImageJ displays images with circles drawn at positions 
predicted from the orienting matrix. A small circle inside large circle means that a peak with 
I>3𝜎𝜎(I) was found. The small circle is located on the maximum of the intensity. A diamond 
means that a reflection is expected on upcoming frame(s), square indicates reflection present 
on previous frame(s).  
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When the integration finishes, files ttb.cif_pets and ttb.hkl are created. Both can be used to 
import the data into Jana and to solve the structure. 

 
5. Create reciprocal-space sections  

In PETS, Type h[Enter]  
Type y[Enter]  
You just asked PETS to scan all images and reconstruct sections through reciprocal space at 
planes hk0, hk1, hk2, h0l, h1l, h2l, 0kl, 1kl, 2kl. We will use these sections as an aid to 
determine the space group.  
When the reconstruction finishes, type q[Enter] to close PETS. You may also close ImageJ. 

  
6. Create new structure  

Important! The data-processing procedure is almost never perfectly reproducible. Small 
differences in the indexing and cell refinement procedure may result in small differences of 
integrated intensities. If you want to be sure that you can exactly reproduce the following part 
of the tutorial, do not use the file ttb.cif_pets that you just created, but use the file 
ttb_start.cif_pets provided with the example files (Rename the file to ttb.cif_pets). Using your 
own cif_pets file is also possible, but your results may slightly differ from the results described 
in this tutorial.  
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate the directory with input files 
Right pane: double-click ttb 
Right pane detects possible Jana files and shows one jobname for each group of files  

 
7. Import Wizard 

Select “Known diffractometer formats”; NEXT 
Select “Pets electron diffractometer” 
The file name automatically changes to ttb.cif_pets, which is a file produced by PETS 
containing all important information, including the list of intensities.  
NEXT  
Leave all settings unchanged (note the wavelength of 120kV electrons!); NEXT 
Leave all settings unchanged; NEXT 
The program reads 3777 reflections from the file  
OK 
For absorption correction select “None or done before importing”; NEXT 
FINISH; OK; YES to accept the data set  
You just read in the cell parameters and the intensity list. If you do not have the data in the 
cif_pets format, you can read them in from a general hkl file using the option “reflection file 
corrected for LP and absorption” at the beginning of the import wizard. You then have to input 
the radiation type, wavelength and cell parameters by hand. 

 
8. Symmetry Wizard 

NEXT to close the information window and start the wizard 
Symmetry Wizard can be started separately by “File → Reflection file → Make space group 
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test. The default settings are prepared for x-ray diffraction. For electron diffraction we have 
to increase the tolerances. Change the tolerances according to this screenshot: 

 
Leave other settings default; NEXT; OK 
[On the screen: Select Laue symmetry] 
Select tetragonal Laue class 4/mmm; NEXT  
The internal R-values would be rather high for x-rays, but are normal for electron diffraction 
data, especially if measured in selected area mode. 
[On the screen: Select cell centering]  
Select primitive unit cell; NEXT 
[On the screen: Select space group] 
The window shows possible space groups. 
The list of the strongest reflections contradicting the selected space group can be displayed 
by “Details” button. 
It is difficult to select the correct space group. In particular, presence or absence of the b-glide 
is hard to asses, knowing that kinematically absent reflections may have significant intensities 
due to dynamical diffraction effect. Open the file h0l.bmp and h1l.bmp, and compare the 
intensities of reflections with h=2n (which should be absent in the h0l plane, but present in 
h1l). You will see that despite a number of violations, the b-glide absences are nevertheless 
clearly present in the h0l plane in comparison with the h1l plane. Space group with b-glide is 
thus a reasonable guess. Note that a wrong choice of the space group is not detrimental for 
the structure solution, because we will use Superflip, which will make additional check for the 
most probable space group.  
Select P4/mbm; NEXT 
Accept the space group in the standard setting; FINISH 
Symmetry is saved in file ttb.m50. 

 
9. Creating refinement reflection file 

 In this step program creates file ttb.m90 containing the data set merged by symmetry and 
with discarded forbidden reflections. M90 will be used for refinement. 
Proceed with the wizard, leaving all settings default  

10. Structure Solution Wizard 
OK to close the information window and start the wizard  
 [On the screen: window of Structure solution] Structure solution wizard can be executed 
separately through “Run → Solution”. Jana2006 does not contain solution procedures, it calls 
external programs. By default, Jana uses Superflip (using charge flipping as the solution 
method). Superflip is distributed with Jana2006. 
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In “Formula” textbox type just the list of chemical elements: K Nb O 
Superflip does not need information about chemical elements but they will be required for 
peak assignment based on electron density map calculated by Superflip. If Jana2006 is used 
for peak assignment, a list of expected chemical elements is sufficient. If you know the 
expected formula, you may enter it and use EDMA for peak picking (at the bottom of the 
window). If the formula is correct, EDMA often gives cleaner and more complete 
interpretations of the solution. 
Click the checkbox next to “Use a specific random seed”.  
Leave other settings default; Press “Run solution”  
The specific random seed is used just to guarantee reproducibility of the results. For standard 
work random seed need not be defined.  
[On the screen: window of Superflip appears with iteration running. After ten runs, open the 
listing of Superflip log file in “Open the listing”] 
Superflip performed ten solution attempts, and picked the best one. Its characteristics are 
displayed near the bottom of the listing:  
Properties of the saved density:  
Run Rvalue Peaks Symm. Der.SG  
8   24.46  2.71  3.24  P4/mbm  
The space group proposed by Superflip is the same as our initial guess. The space-group 
selection is confirmed. Small symmetry agreement factor (column Symm.) indicated good 
quality of the solution. In cases of doubts or difficult problems, it is worth checking the 
statistics, especially the symmetry analysis, for each of the ten runs, and seeking for the most 
probable one. 
Press “Close” to leave the listing  
Press “Accept last solution”  
The program creates file ttb.m40 with atoms of the structure model 

  
11. Verification and completion of the structure solution 

 Go to “Contour → New plot → OK → Run 3D maps“  
VESTA opens with a density shown as isosurfaces, and an atomic model overlaid. Rotate the 
view to inspect the structure. Do you think it is complete?  
You should come to the conclusion that the model is correct, all atoms were assigned correct 
chemical type, only one oxygen (between two atoms Nb2 is missing.  
Decrease the isosurface level to see weaker features in the density (“Properties → 
Isosurfaces”, set isosurface level to 1)  
You can see that there is a peak between the two Nb atoms, it just was not interpreted by 
Jana2006 as an atom. Take-home message: it is always worth checking the density (i.e. the 
raw result from Superflip), because it may contain features not considered in the interpreted 
structure model.  
Quit VESTA (do not save the file), quit Contour.  
Start “Parameters → Atoms → New → Peaks from last Fourier calculation”  
A list of maxima found in the density is displayed. In the right pane, the distances of the 
maximum to the nearest atoms are displayed. First eight maxima correspond to atoms 
interpreted by Jana2006. Max9 is a ghost peak, too close to Nb1. Max10 is at a correct 
distance from two Nb2 atoms – this is the oxygen atom missing in the model.  
Click “Include selected peak”, type O* in the field for name; OK; Finish; Yes to include the new 
atom in the model 
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You may now check the structure in Diamond to convince yourself that the structure is 
complete and chemically reasonable. 

12. Initial Refinement 
[On the screen: basic window of Jana]  
Right-click the icon of Refine.  
[On the screen: refinement options] 
Change the number of cycles to 100; OK 
Choose “Yes+start”  
Refinement converges with R value about 20.0%. At this moment you may check the 
refinement listing with a lot of information about the refinement procedure and results. 

 
13. Adding missing, partially occupied atom 

[On the screen: basic window of Jana]  
Right click the icon Fourier 
On the first card, select F(obs)-F(calc) – difference Fourier  
Modify the setting on the second card to agree with this screenshot: 

 
OK; Yes+Start; No; No  
Jana just calculated a difference Fourier map.  
View the map in VESTA: “Contour → New plot → OK Run → 3D maps”  
You will see that the difference map is dominated by one positive peak in the middle of an 
empty cage of oxygens. This position tends to be partially occupied in some TTB structures. In 
this case, the partial atom is Nb.  
Add the missing atom. The procedure is the same as when you added the missing oxygen 
atom after the solution. This time, the first maximum in the list is the correct maximum.  
When defining the atom, do not forget to define the name as Nb* and type as Nb. Define 
“Occupancy reduction” 0.2  
OK; Finish; Yes  
Now we will allow the occupancy of the niobium atom to be refined:  
Double click “Edit atoms”; double click Nb3; on card “Edit” check the check box next to the 
parameter “ai”; OK; OK; Yes  
Double click Refine  
The model refines to R-value about 19.4%. The improvement is very small, because the 
occupancy of the Nb3 atom is very small, too, actually less than 10%.  
This data set is exceptionally good. Normally, partial occupancies of atoms cannot be refined 
reliably from electron diffraction data. Even here the refined occupancy must be taken only 
as a rough indicator. 
At this moment the structure is essentially finished. You may try to refine anisotropic 
displacement parameters of the heavy atoms. The R-value decreases to ~18.3%. Again, with 
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this data set such refinement is possible, and the resulting parameters are reasonable. In 
many other cases, anisotropic displacement parameters refine to unrealistic or even non-
positive definite values. 
 
The resulting structure 
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Example 13.2: Kaňkite 
Solution of kaňkite – a hydrated Fe-bearing arsenate. 
 
Revised: 3 December 2013 
 
Expected chemical formula: Fe+++AsO4•3.5H2O 
Electron diffraction data measured on a transmission electron microscope Philips CM120 with 
precession device DigiStar. Accelerating voltage 120 kV.  
Input data: directory dp with the set of experimental data,  

kankite.pts: input file for PETS – the data reduction program  
beamstop.xyz: file with the polygon defining the shape of the beam stop  
kankite_start.cif_pets: result of the data processing. This file is provided so that this 

example can be solved without the data processing part, and to warrant 
reproducibility of the second part. File kankite.cif_pets is the output of the data 
reduction. 
 

1. Data reduction using PETS 
The data processing part follows exactly the procedure described in example 13.1. Please 
follow that tutorial. Here only key results are provided for your control, and comments are 
provided for stages that require special attention. 
Parameters filled in the prepared file kankite.pts:  
reflectionsize 25  
beamstop yes beamstop.xyz 927 1025  
Refined azimuthal angle omega of the tilt axis:  
omega : 11.752  
Unit cell is monoclinic, C-centered. The following screenshot is the view of the reciprocal lattice 
along the monoclinic axis b (a* horizontal, c* vertical, pointing down): 

 
The direction and length of the b-axis is difficult to determine. The lattice is obscured by quite 
a lot of noise. This noise comes from the diffuse nature of the reflections along b* and from 
the mosaicity of the crystal. If such noise is present, it is amplified by the data processing 
preceding the creation of the file .clust. In such cases it is useful to check the correctness of 



714 Jana2006 Cookbook, version September 2019 
 
 

the cell determination in the file .xyz. This file contains only the peak positions in reciprocal 
space, not their autoconvolution. It is thus cleaner, but much less complete.  
Click “New plot”  
Locate and open the file kankite.xyz  
You will see that the plot is less complete, but the noise is less abundant.  
Final refined cell parameters (refined against the peaks in kankite.clust): 

 
Quit the indexing plugin to create file kankite.smr with the orienting matrix, and continue 
data processing in PETS by typing u[Enter] to read in the orienting matrix, and i[Enter] to 
integrate the intensities.  
You will note significant overlap of integration boxes (white circles) in the images displayed 
by ImageJ. This is, however, not a real problem, because the lattice is C-centered, and every 
second reflection is systematically absent.  
PETS produced file kankite.cif_pets, which will be imported in Jana2006 in the next step.  
Type h[Enter] and y[Enter] ]to produce standard sections through reciprocal space.  
With this step the data processing in PETS is finished.  
Type q[Enter] to close PETS. You may also close ImageJ. 

2. Create new structure  
Important! The data-processing procedure is almost never perfectly reproducible. Small 
differences in the indexing and cell refinement procedure may result in small differences of 
integrated intensities. If you want to be sure that you can exactly reproduce the following part 
of the tutorial, do not use the file kankite.cif_pets that you just created, but use the file 
kankite_start.cif_pets provided with the example files (Rename the file to kankite.cif_pets). 
Using your own cif_pets file is possible, but your results may slightly differ from the results 
described in this tutorial.  
Start Jana2006 
 “File → Structure → New” opens a file manager  
Left pane: locate the directory with input files 
Right pane: double-click kankite  
Right pane detects possible Jana files and shows one jobname for each group of files 

3. Import Wizard  
Select “Known diffractometer formats”; NEXT 
Select “Pets electron diffractometer” 
The file name automatically changes to kankite.cif_pets, which is a file produced by PETS 
containing all important information, including the list of intensities.  
NEXT  
Leave all settings unchanged; NEXT  
Leave all settings unchanged; NEXT  
The program reads 5921 reflections from the file  
OK 
For absorption correction select “None or done before importing”; NEXT FINISH; OK; YES to 
accept the data set 
You just read in the experimental parameters, cell parameters and the intensity list.  

4. Symmetry Wizard 
NEXT to close the information window and start the wizard 
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Symmetry Wizard can be started separately by “File → Reflection file → Make space group 
test. The default settings are prepared from x-ray diffraction. For electron diffraction the 
tolerances should be increased. Change the tolerances according to this screenshot: 

 
Leave other settings default; NEXT  
Jana detected a seven times larger unit cell with orthorhombic metric. This is not likely to be 
the correct unit cell.  
NEXT  
[On the screen: Select Laue symmetry]  
Select monoclinic Laue symmetry; NEXT  
The internal R-value of 13.21 % is very good for electron diffraction data.  
[On the screen: Select cell centering]  
From the table the fact that the cell is C-centered is not obvious at all. This is due to the overlap 
of the reflection positions during the integration. But we know the centering from the data 
reduction and indexing step. You may convince yourself about the correctness of the centering 
by inspecting the reciprocal space sections hk0, hk1 and hk2 generated by PETS.  
Select C-centering; NEXT 
[On the screen: Select space group] The window shows possible space groups. It is not obvious, 
if the c-glide is present or not. Out of 60 reflections forbidden by the c-glide 33 have observed 
intensity. Again, you should use the reciprocal-space sections to check for the c-glide. 
However, do not use the h0l section! Due to the short b* axis and large mosaic spread, this 
section contain “ghosts” from neighboring sections, and the systematic absences are 
obscured. Inspection of the 0kl and 2kl section shows clearly that the reflections of the type 
h0l: l=2n are absent, and c-glide is thus most likely present.  
At this point we cannot decide, which of the choices Cc or C2/c is correct. Centrosymmetric 
space groups are, in general, more frequent, and we will use it as a first guess.  
Select C2/c; NEXT 
Note that a wrong choice of the space group is not detrimental for the structure solution, 
because we will use Superflip, which will make additional check for the most probable space 
group.  
Accept the space group in the standard setting; FINISH 
Symmetry is saved in file kankite.m50. 

5. Creating refinement reflection file 
In this step program creates file ttb.m90 containing the data set merged by symmetry and 
with discarded forbidden reflections. M90 will be used for refinement.  

Proceed with the wizard, leaving all settings default  
The internal R-value decreased from 13.21% To 10.02% due to the exclusion of the 
systematically absent reflections. 

6. Structure Solution Wizard 
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OK to close the information window and start the wizard 
[On the screen: window of Structure solution] 
Structure solution wizard can be executed separately through “Run → Solution”. Jana2006 
does not contain solution procedures, it calls external programs. By default, Jana uses 
Superflip (using charge flipping as the solution method). Superflip is distributed with 
Jana2006. 
In “Formula” textbox type the expected formula: Fe2 As2 O15  
In “Formula units” textbox type 4  
This value gives a reasonable value of density: 3.01 g/cm3  
Click the checkbox next to “Use a specific random seed” and leave the value 111.  
The specific random seed is used just to guarantee reproducibility of the results. For standard 
work, random seed need not be defined.  
Click the radio button “EDMA – take as it is”  
EDMA is an external program for interpretation of electron densities. It can take the chemical 
formula and interpret the density using this formula.  
Leave other settings default; OK 
[On the screen: window of Superflip appears with iteration running. After ten runs, listing of 
Superflip log file is displayed] 
Superflip performed ten solution attempts. Check the space groups derived by Superflip from 
each of the attempts. The most frequently proposed space group is Cc (eight of ten attempts). 
Inversion center and two-fold axis have much worse symmetry agreement factors. It is likely 
that the correct space group is Cc and not C2/c.  
Press CLOSE to leave the listing  
Press “Discard the result” 
Back in the structure solution window, change the space group to Cc and recreate the 
refinement reflection file  
OK  
[On the screen: Superflip runs again, this time creating output in Cc. EDMA is used to interpret 
the density]  
“Accept the result”  
The result is a file kankite.m40 with atoms of the structure model. 

7. Verification and completion of the structure solution  
Go to “Contour → New plot → OK → Run 3D maps“  
VESTA opens with a density shown as isosurfaces, and an atomic model overlaid. Rotate the 
view to inspect the structure. Try to recognize the structural motifs. The main expected motifs 
are AsO4 tetrahedra and FeO6 octahedra. The analysis will be simpler if you display the bonds 
between atoms:  
Go to Edit → Bonds, and set up the options according to this screenshot: 
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It is also useful to show only positive isosurfaces (Properties > Isosurfaces). Viewing the 
structure solution in VESTA has the advantage that you can directly check, if the raw density 
was correctly interpreted. In this case, atom As1 should be Fe, and Fe1 should be As. You may 
inspect the model also in Diamond. You should come to the conclusion that the model is 
almost complete. Two oxygen atoms are missing (around Fe2) and five oxygen atoms in the 
list (O10, O11, O12, O14 and O15) are ghost peaks. 

8. Delete ghost atoms and change atomic types 
Double click icon Edit atoms  
Select atoms O10, O11, O12, O14 and O15 (Click while holding Ctrl)  
“Action → Delete atoms → Yes to all”  
Select atom As1 
“Action → Edit/Define atoms → Type → Fe” 
Repeat the assignment process to atom Fe1 (type As) 
OK 
“Select all → Action → Rename selected atoms to “atom_type”+number”  
 OK; Yes 

9. Structure refinement 
[On the screen: basic window of Jana] 
Right-click the icon of Refine. 
[On the screen: refinement options] 
Set Number of cycles to 100; OK Choose “Yes+start” 
Refinement converges to an R value about 19%  

10. Adding the missing atom[On the screen: basic window of Jana] 
Right click the icon Fourier 
On the first card, select F(obs)-F(calc) – difference Fourier  
Modify the setting on the second card to agree with this screenshot: 
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OK; Yes+Start; No; No  
Jana just calculated a difference Fourier map.  
View the map in VESTA: “Contour → New plot → OK → Run 3D maps”  
You will see that the difference map is dominated by two positive peaks around the atom Fe2. 
These maxima correspond to the two missing atoms.  
Close VESTA and return to the main window of Jana2006  
“Parameters → Atoms → New → Peaks from last Fourier calculation”  
A list of maxima found in the density is displayed. In the right pane, the distances of the 
maximum to the nearest atoms are displayed. The first two maxima correspond to the missing 
oxygen – they have the right distance to Fe2.  
Select Max1, click “Include selected peak”, type O* in the field for name; OK;  
Select Max2, click “Include selected peak”, type O* in the field for name; OK;  
Finish; Yes to include the new atoms in the model 
Double click the icon Refine to refine the completed model.  
The structure refines to 15.89%. At this moment the refinement is finished. It is possible to 
refine anisotropic ADP parameter of the atoms. The R-value drops to 11.63%, but the ADPs 
are unrealistic – they have an extremely large component along b. This effect comes from the 
data quality – reflections with high k-index are systematically weakened. 

11. Identification of OH and H2O groups 
The data quality is by far not good enough to see directly the hydrogen atoms. However, we 
can estimate the positions of OH and H2O groups by the coordination and bond-valence sums 
of the oxygen atoms. 
Right-click icon Dist  
Click button “Define coefficients for bond valences”  
Define pair of atoms Fe, O; Click “From file → Fe3+ O2- (fourth in the list) → OK → Add”  
Repeat for pair As – O, select the entry As5+ O2- from the list → OK → Add 
OK;  
[On screen: main dialog window of the Dist module]  
Uncheck checkbox “dmax derived from atomic radii and typical distances”  
OK; Yes+start; Yes to open the listing  
At the end of the listing you will find the following table of bond-valence sums:  

Bond valence for : Fe1 2.48(6) 
Bond valence for : As1 4.32(12)  
Bond valence for : As2 5.46(19)  
Bond valence for : Fe2 2.33(6)  
Bond valence for : O1 1.42(8) 
Bond valence for : O2 1.86(8) 
Bond valence for : O3 1.53(7)  
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Bond valence for : O4 1.46(4)  
Bond valence for : O5 2.08(15)  
Bond valence for : O6 0.99(5)  
Bond valence for : O7 0.35(3)  
Bond valence for : O8 0.90(5)  
Bond valence for : O9 0.40(2)  
Bond valence for : O10 1.53(5)  
Bond valence for : O11 0.326(18)  
Bond valence for : O12 1.75(8)  
You can see three types of oxygen atoms. Most of oxygens have bond-valence sums above 
1.4, two around 0.9 (O6 and O8) and three very low – below 0.5 (O7, 09, 011). O6 and O8 
correspond to OH groups, and O7, O9, O11 are water molecules coordinating Fe atoms. This 
is a view of the structure with OH and H2O groups labeled:  

 
 

Thus, the published formula is not correct. The correct formula is 
Fe2(OH)(AsO4)(AsO3OH).3H2O or Fe2As2O7(OH)2.3H2O 
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Example 13.3: Orthopyroxene 
Refinement of atomic occupancies from electron diffraction data using 
dynamical diffraction theory 
Revised: October 2015 
 

Background information: 
Orthopyroxene (opx) is a rockforming mineral – iron-magnesium silicate (Fe,Mg)2Si2O6, 
Pbca, a=18.268, b= 8.868, c=5.202. It contains two symmetry-independent octahedral sites 
with Mg and Fe. The distribution of Mg and Fe in these two sites depends on the 
crystallization conditions, and it can therefore be used to infer information about the 
formation of the rock. 
Orthopyroxene often forms only microcrystalline aggregates or intergrowths with other 
minerals. It is thus desirable to determine the occupancies of Fe and Mg on the two sites 
from individual micro- or nano-crystals of opx. 
 
Electron diffraction data were measured on FEI Tecnai G2 20 operated at 200 kV with 
precession device DigiStar. 
 
Input data: opx_001.tif: the experimental diffraction pattern, zone axis [001] of 
orthopyroxene. 

opx_001.pts: input file for PETS with experimental information 
opx_xray.cif: cif file with the model of the opx structure refined against x-ray 
data set.  
opx_001_dyn_start.cif_pets: result of data processing with PETS. This file is 

provided so that this example can be solved without the data processing part. 
 

1. Data reduction using PETS 
File opx_001.pts contains instructions for PETS. Open the file and check the instructions. 
Compared to tomographic data, the input is much simpler in this case – the tilt-axis azimuth 
need not be defined, and the orientation angles can be set to 0. 
Note the line “background 32768”. The tif file was obtained by conversion of a dm3 file 
(Digital Micrograph format). By default, the zero level of such file is at 215=32768. The 
byword background 32768 corrects for this shifted zero level. 
 
Start PETS with the file opx_001.pts 
Type p[Enter] 
PETS will extract peaks from the image and save them in file opx_001.cor. Check the image 
shown by ImageJ. The central part is shown here: 
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The encircled black cross shows the predicted position of the primary beam. Obviously, the 
automatic location of the center failed. We have to provide the center explicitly. 
Type q[Enter] to quit PETS. 
Open the file opx_001.tif in ImageJ 
Go to “Image → Properties” and change the values of Pixel width and Pixel height from 
0.005 to 1. 
Read the coordinates of the direct beam. 
The coordinates are close to 1990 1393 
Close ImageJ 
Open file opx_001.pts in a plain-text editor (e.g. Notepad) and modify the line “center 
AUTO” to “center 1990 1393”  
Save and close opx_001.pts. 
Start PETS again with the updated file opx_001.pts 
Type p[Enter] 
This time the center is located properly. 
We will not use the peak-processing functions of PETS, because the amount of data is not 
sufficient. We will use directly the file opx_001.cor produced by PETS after the peak hunting. 
Start Jana2006 
Go to “Tools → Graphics → Indexing” 
Locate the example directory and select file opx_001.cor; OK 
You will see a plot of located peaks. The peaks form only a 2D layer. We have to use a 2D 
indexing option of the indexing plugin to index the layer. 
Click the button “2d section ON” 
Jana2006 finds the best plane through the peaks, and fixes the view on this plane.  
Click on the “indexing” button  in the lower left corner. 
Now if you drag the mouse with left button pressed, you will move an arrow on the screen. 
By this arrow, you should locate a reflection, of which you know the indices. This is a little 
tricky, because the plane [001] contains systematically absent reflections (due to the a-
glide), and, in addition, a pseudo n-glide. You should locate the vector a according to the 
following screenshot. Note that reflection 12 0 0 was selected: 
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Similarly, vector b is located as follows (reflection 0 6 0 selected, hence order 6): 

 
If you get lost, open the original diffraction pattern in ImageJ and compare the distribution 
of reflections with the peak positions in Jana2006.  
Once the two vectors are defined, the selected 2D cell can be refined: 
“Refine cell → Refine UB+cell” 
You should obtain a result very close to the following 2D cell: 
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OK to quit the refinement dialog 
This cell must be converted to a 3D cell to produce an orientation matrix: 
Click “2d section OFF” 
A dialog for the 2D to 3D transformation appears 
Type the cell parameters: 18.268 8.868 5.202 90 90 90 
In the line labeled “(h,k,l) for 2d axial direction #1” type 1 0 0 
In the line labeled “(h,k,l) for 2d axial direction #2” type 0 1 0 
Click “Calculate” 
You should obtain the following result: 

 
 
OK; Quit 
Now you have an orientation matrix that you can read back to PETS, and extract intensities. 
[On screen: window with PETS, main menu] 
Type u[Enter] 
PETS read in the orientation matrix calculated by Jana2006. 
Type d[Enter] 
D stands for “integration for dynamical refinement”. PETS extracts all intensities up to 
d*=1.4, and produces file opx_001_dyn.cif_pets. 
 

2. Import structure in jana2006 
Important! The data-processing procedure is almost never perfectly reproducible. Small 
differences in the indexing and cell refinement procedure may result in small differences of 
integrated intensities. If you want to be sure that you can exactly reproduce the following 
part of the tutorial, do not use the file opx_001_dyn.cif_pets that you just created, but use 
the file opx_001_dyn_start.cif_pets provided with the example files. Before continuing, 
make a copy of the file and name it opx_001_dyn.cif_pets. Using your own cif_pets file is 
also possible, but your results may slightly differ from the results described in this tutorial. 
Now we will import the file opx_001_dyn.cif_pets in Jana2006. 
Start Jana2006 
“File → Structure → New” 
In the left pane, locate the example directory 
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In the right pane, double click the label opx_001_dyn 
Select “Single crystal: known diffractometer format”; NEXT 
Select “Pets – electron diffractometer”; NEXT; NEXT; NEXT; OK; NEXT; FINISH; OK; Yes 
You have just imported the data from cif_pets using default options. At this point Jana offers 
symmetry determination wizard, but we will escape the standard procedure, which is not 
useful for us. 
Cancel; Cancel to cancel the symmetry wizard and the production of reflection file. 
Now we have to import the structure model from the provided CIF file: 
“File → Import model from → CIF” 
Locate file opx_001.cif and double click it 
OK to accept the new model 
Cancel to avoid production of the refinement reflection file 
If we accepted to produce the refinement reflection file at this stage, it would be prepared 
for kinematical refinement. We will use dynamical refinement. 

3. Setting up dynamical refinement 
[On screen: Main windows of Jana2006] 
“Parameters → Electron diffraction” 
You should see this dialog: 

 
This dialog contains experimental information relevant for the dynamical refinement, and 
information about the zone axis (or several zone axes, if there are more zone axes 
imported). Most options are now blank, because the reflection file for dynamical refinement 
has not yet been prepared. 
Check the box next to “Use dynamic approach” 
OK to create refinement reflection file 
Follow the wizard and accept default choices 
[On screen: Electron diffraction dialog] 
Now we have to find initial values for the sample thickness, scale factor and orientation. As 
a first quick check, we will calculate only the thickness curve, using fixed orientation. This 
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calculation is much faster that the optimization of orientation, and it provides first 
estimated of the data quality. 
Click “except of scale optimize also: Thickness  Run optimization”  
Jana2006 generates reflections and calls Dyngo.exe. Dyngo.exe calculates the reflection 
intensities using dynamical diffraction theory. 
[On screen: Electron diffraction dialog] 
Next to the indication of the zone number you see the best R-value: R(all)=8.1174%. This is a 
very promising value and indicates that already now the fit of the model to the data is quite 
good. 
Click “Show thickness plots” 
You should obtain the following plot: 

 
This plot shows a clearly defined minimum at the thickness 400 Å. This together with the low 
R-value shows that the starting point for the refinement is reasonable. 
Quit the display of the thickness plot 
Click “except of scale optimize also: orientation  Run optimization” 
The orientation of the experimental pattern is never perfect. Dyngo finds the parameters of 
the misalignment of the zone axis from the perfect orientation predicted by the orientation 
matrix. This calculation requires repeated evaluations of reflection intensities and may take 
some time. You may follow the progress of the simplex algorithm in the window of Dyngo. 
After the optimization, the zone axis parameters look like this: 

 
 
The R-value decreased only slightly to 7.9963%. Value 0.15 of EDtheta means that the 
diffraction pattern was recorded at an angle of 0.15 degrees away from the perfect 



727 Jana2006 Cookbook, version September 2019 
 
 

orientation. EDPhi is the azimuth of the tilt axis. Given the large precession angle, this value 
is within the precision of the method, and means that the pattern was essentially perfectly 
oriented. 
Quit the Electron diffraction dialog and confirm changes in the m42 file. 
 

4. Dynamical least-squares refinement 
We will first refine only the scale and thickness. 
“Right-click Refine → Various → Fixed commands” 
In the line labeled “Atoms/parameters” type * (star) 
Click the arrow next to “Add” 
You have fixed all structure parameters of all atoms. An exception is the atomic occupancy, 
which is not fixed by this command, but we did not explicitly allow its refinement either, and 
therefore the occupancies will remain, for the moment, fixed, too. 
OK; OK; Yes+Start 
Refinement converges smoothly to an R-value of 7.28%. 
Now we will allow the refinement of occupancies. 
“Right-click Refine → Various → Restrictions” 
In the line labeled Atoms/molecules type “Fe1 Mg1” 
Click radio button next to “Occupancies: keep overall sum” 
Click the arrow next to “Add” 
Repeat the action for the pair “Fe2 Mg2” 
OK; OK; Yes to save the changes, but do not start the refinement 
We have now restricted the occupancies of the two atoms to sum to 1. Only one occupancy 
for each pair will be refined. 
Now we have to allow the refinement of occupancies of Fe1 and Fe2: 
Double click the icon “Edit atoms” 
Double click atom Fe1 
On the card “Edit” check the box next to the parameter “ai”; OK 
Repeat for atom Fe2 
OK to close the Edit atoms dialog 
Double click Refine to start refinement 
Refinement converges smoothly. R-value decreases only very little to 7.25%. 
Refined occupancies are o(Fe1)=0.050(11), o(Fe2)=0.52(11). The occupancies refined from 
the same sample with x-ray data are o(Fe1)=0.035(3), o(Fe2)=0.552(3). In general, the 
refinement against electron diffraction data is in a good agreement with the refinement 
against bulk material using x-rays.  
If you wish, you may convince yourself that even from more distant starting values of the 
occupancies the refinement will converge to the same values. You may, however, need to 
use smaller damping factor (right-click Refine → Damping factor) to avoid oscillation or 
locking in a false minimum, if you start from too distant values. 
 

5. Kinematical least-squares refinement 
We will perform a kinematical refinement for comparison. 
[On screen: main window of Jana2006] 
”File → Structure → Save as” 
Type “opx_001_kin” in the window under the right pane; OK; Yes 
We saved the structure under another name to preserve the dynamical refinement. 
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 “Parameters → Electron diffraction” 
Uncheck the box next to “Use dynamic approach”; Yes to save changes 
Accept the proposal to recreate the refinement file and follow the instructions. Leave all 
settings default. 
Double click “Refine” to start refinement 
With a few clicks we switched from dynamical to kinematical refinement. The refinement R-
value is 31.03%, and the refined occupancies are o(Fe1)=0.280(87) and o(Fe2)=0.435(90). 
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Example 13.4: Silicon 
Complete procedure from structure solution to dynamical structure refinement 
from three zone-axis patterns. 

 
Revised 11 December 2013 
 
Input data: si_ZAPs.cif_pets: a cif_pets file containing the orientation matrix, positional angles 
and intensity information from three zone-axis patterns collected on the same sample – a 
wedge-shaped silicon single crystal. The file was obtained from raw diffraction patterns using 
the procedure analogical to example 13.1. 

1. Import data to Jana2006 
Start Jana2006 
“File → Structure → New” 
In the left pane, locate the example directory 
In the right pane, double click green label si_ZAPs 
Select “Single crystal: known diffractometer format”; NEXT 
Select “Pets – electron diffractometer”; NEXT; NEXT; NEXT; OK; NEXT; FINISH; OK; Yes 
You have just imported the data from cif_pets using default options.  
As a next step Jana starts the symmetry determination wizard. The data set we have is not 
really complete, but we may nevertheless attempt to proceed with the wizard: 
Next to start the wizard 
On the next screen, set up the tolerances according to this screenshot: 

 
Next; OK; 
You now look at a table of Rint values for various Laue classes. The cubic Laue classes have 
acceptable Rint values, and there is little doubt the structure is indeed cubic. 
Select Laue class m-3m; Next 
The data were already integrated assuming F-centering, therefore there are zero reflections 
matching the F-centering absences in the data set. 
Select centering F; Next 
On the next screen a list of possible space groups is presented. For the space group Fd-3m, 7 
out of 24 forbidden reflections have I>3σ(I). However, looking at the details (click the button 
“Details”) you will find that these reflections are in fact only two - 0 0 2 and 0 0 6. The d-
glide is thus likely to be present. Indeed, the space group of silicon is Fd-3m. 
Select “Fd-3m”; Next; Finish 
In the next step we prepare a “standard” reflection file suitable for structure solution.  
Next; OK; OK 
[On screen: the window with three radio buttons for the choice of the handling of scales] 
Jana treats can data from each zone axis on a separate scale. For the structure solution and 
kinematical refinement, we will, however, assume that the data are on the same scale. The 
number of common reflections is insufficient to determine a reliable common scale. 
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Select “Ignore scale flags”; Next; Next; OK; Finish 

2. Structure solution and kinematical refinement 
 [On screen: Information window explaining that the next step is structure solution] 
OK to open the structure solution dialog 
Type Si in the dialog box for formula; change the number of formula units to 8 
Leave all settings default 
OK to start solution by Superflip 
Superflip runs and produces a structure solution. 
When Superflip exits, accept the solution 
Plot structure in Diamond to make sure it has been correctly solved 
Right-click Refine; change number of cycles to 100; OK; Yes+start 
Jana2006 refines the structure using kinematical calculation of diffracted intensities. The 
structure refines to the following values (note that there are only 13 symmetry independent 
reflections!): 

 
Open the refinement listing (Edit → View of Refine) and check the statistics. 
The displacement parameter of silicon refines to -0.0106. 

3. Origin shift 
The default origin of the space group Fd-3m is at the point -43m, which does not contain 
inversion center. For the dynamical refinement it is desirable to have the origin in the 
inversion center, if possible. We will now shift the origin of the unit cell to the inversion 
center: 
[On screen: Main window of Jana2006] 
“Tools → Transformations → Origin shift” 
Type “1/8” in all three fields; OK 

4. Initiation of dynamical refinement 
[On screen: Main window of Jana2006] 
The displacement parameter of silicon did not refine to physically meaningful value. Before 
initiating the dynamical refinement it is good to reset it to a more correct value. It is not 
strictly necessary in this example, but it is generally a good practice. 
Double click the icon Edit atoms 
Double click Si1 
On the card Edit, change Uiso to 0.005 
OK; OK; Yes 
[On screen: Main window of Jana2006] 
“Parameters → Electron diffraction” 
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You will see the following dialog: 

 
 
Default excitation error is too small for the current data – it must be increased: 
Change Maximal excitation error to 0.03 
Check the box next to “Use dynamic approach” 
OK to create refinement reflection file 
Follow the wizard and accept default choices 
[On screen: Electron diffraction dialog] 
Now we have to find initial values for the sample thickness, scale factors and orientations of 
all three zones. As a first quick check, if the data quality is acceptable, we will calculate only 
the thickness curve, using fixed orientation. This calculation is much faster that the 
optimization of orientation, and it provides a first estimate of the data quality. 
Click “Optimize thickness and scale” 
Jana2006 generates reflections and calls Dyngo.exe for each zone separately. Dyngo.exe 
calculates the reflection intensities using dynamical diffraction theory. Wait until Dyngo.exe 
terminates. 
[On screen: Electron diffraction dialog] 
Click “Show thickness plots” 
Go through the thickness plots. You should see three curves with more-or-less well defined 
minima between 500 and 1000 Å. The best R-values are around 15%. This is a good start, 
but it is still not satisfactory. It is necessary to optimize the orientations: 
Quit the display of the thickness plot 
Click “optimize thickness, scale and orientation” 
This option optimizes all three parameters simultaneously, using a simplex algorithm. This 
calculation requires repeated evaluations of reflection intensities and is thus much longer 
that just the thickness optimization. Wait unil all three runs of Dyngo finish. 
[On screen: Electron diffraction dialog] 
Check the refined tilt angles. EDtheta is the azimuth of the tilt, EDphi is the amplitude. You 
will see that the refined misorientations range between 0.13 and 0.39 degrees – very 
reasonable values. 
Click “Optimize thickness and scale” 
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Repeat the thickness orientation to view the updated thickness curves. When viewing the 
thickness curves again, you will see much better defined minima. 
However, for zone 3 you will find the following curve: 

 
There is a clear and reasonable minimum at t=350 Å, but the lowest R-value is found for the 
thickness of 2000 Å. It is necessary to manually reset the thickness to 350 Å before the 
refinement. 
Quit; Locate zone 3 and set the thickness according to the following screenshot: 

 
 
The data are now checked and ready for least-squares refinement. 
OK; Yes to exit the Electron diffraction dialog 

5. Structure refinement 
[On screen: Main window of Jana2006] 
The dynamical refinement tends to be unstable with default damping factor, it is thus better 
to decrease it: 
Right click “Refine” 
Set damping factor to 0.2 
OK; Yes+Start 
The dynamical refinement starts. You may follow the progress in the window of Jana2006. 
You may also interrupt the refinement or change the parameters the same way as for the 
standard refinement. 
 
The refinement converges after 21 cycles to R(obs)=6.8%. (Compare with 23% obtained with 
kinematical refinement).  
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Uiso(Si1) refines to -0.0010(19). This is a much better value than the result of kinematical 
refinement, but it is, of course, not satisfactory. A detailed investigation shows that even if 
only one zone-axis at a time is used for the refinement, Uiso(Si1) remains slightly negative. It 
is thus probably a problem related to the experiment. Unfortunately, the sample used for 
the data collection was damaged, and we could not remeasure the data. Previous 
measurements on the same samples yielded correct Uiso around 0.005, but these 
measurements were single-zone only, and they are thus not so well suited for demonstration 
of the complete procedure. 
 
By repeating the optimization of orientation and rerefining the structure, the R-value can be 
decreased even more to 5.0%. However, Uiso(Si1) remains negative. 
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Example 13.5: Ni2Si 
Solution of nickel silicide Ni2Si by PEDT (precession electron diffraction 
tomography) data. Complete procedure from data reduction to structure 
refinement using the dynamical approach. 
Revised: February 2019 
 
Chemical formula: Ni2Si 
 
Electron diffraction data was measured on a transmission electron microscope Philips CM120 
with a precession divice DigiStar. Accelerating voltage of 120 kV. 
Input data: 

directory dp-150 with the set of experimental data (reflection images) 
directory img with the set of experimental images from the crystal tilt  
Ni2Si.pts: input file for PETS 
Ni2Si_start.cif_pets: result of the data processing. This file is provided so that this 

example can be solved without the data processing part, and to warrant 
reproducibility of the solution and refinement part. File Ni2Si.cif_pets will be the 
output of the data reduction. 

Ni2Si_start_dyn.cif_pets: result of the data processing for dynamical refinement. This 
file is provided so that the dynamical approach can be used without the processing 
part, and to warrant the reproducibility of the refinement. 

 
1. Preparing input file for PETS 

Make sure you correctly installed PETS and ImageJ. Check Chapter “Installation notes” 
(page 7) for details. File Ni2Si.pts is the input to PETS. The file was prepared by the 
software used for the collection of the diffraction data, and most entries have been filled 
in. You have to enter two parameters: the information about beam stop and the size of 
reflections. 
Open file Ni2Si.pts in any plain-text editor (notepad, wordpad, notepad++, vim,…)  
Open file dp-150/001.tif in ImageJ  
In ImageJ go to “Image → Adjust → Brightness and Contrast”  
Click the button “Auto” to adjust the contrast  
Go to “Image → Properties” and change the values of Pixel width and Pixel height from 
0.005 to 1 
Measure the diameter of the reflections on the image 
There are several ways to measure the diameter of the reflections, but the simplest and 
sufficient way is to place the cursor to the left of the reflection, remember or write down 
the x-coordinate, then place the cursor to the right of the reflection, again read the x-
coordinate and subtract the two coordinates. The diameter should be large enough to 
encompass most of the reflections, but not too large, to prevent overlaps. Do not take into 
account the broad, weak TDS scattering around the strongest reflections! That would give 
you a too large diameter. In this case, value 25 is a good choice.  
In Ni2Si.pts, change the line “reflectionsize ??” to “reflectionsize 25”  
This measurement was performed without beamstop (microdiffraction). In Ni2Si.pts 
change the line “beamstop ??(yes/no)” to “beamstop no” 
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Save and close Ni2Si.pts 
 

2. Run PETS and prepare files for indexing  
Make sure ImageJ is not running. If it is, close ImageJ.  
Run PETS with the file Ni2Si.pts  
There are several ways of running PETS. See installation notes for detailed description. A 
window with initial menu of PETS opens, and ImageJ starts displaying a black image with 
a white circle.  
In the window of PETS, type p[Enter]  
The peak hunting procedure starts. ImageJ sequentially displays diffraction images with 
circles at points found by PETS as significant peaks. Note that PETS follows the position of 
the primary beam, and corrects for small shifts. Note also the significant diffuse streaks. 
Although they seem very intense, it is just due to the enhanced contrast of the images. 
Compared to the Bragg intensities, the diffuse streaks are weak and do not disturb the 
structure solution.  
At the end, the evolution of the x- and y-coordinates of the estimated primary-beam 
position is displayed (b&w inverted): 

 
 
[On screen: main menu of PETS]  
type r[Enter] 
The next step after peak hunting is the refinement of the azimuthal angle between the 
horizontal axis (x axis of the micrograph) and the projection of the tilt axis. This angle 
depends on experimental setup, and needs to be refined for each data set. ImageJ displays 
a cylindrical projection of the difference space of the extracted peak positions. A correct 
azimuthal angle refinement results in the image containing sharp peaks aligned on 
sinusoidal curves. This step provides a first estimation of data quality. At the end of the 
refinement the omega angle should be close to 13°.  
On the screen: 

Final values of the parameters:  
omega : 13.165  
 
and see this image (b&w inverted): 
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[on screen: main menu of PETS]  
 
type a[Enter]  
PETS starts the analysis of the peak positions obtained in the peak hunting procedure. In 
the first step, distance distribution between peaks in the image plane is analyzed. A sorted 
plot of inter-peak distances is displayed (white curve on screen, black on the image below) 
with its derivative (grey curve): 

 

 
 
For good quality data set, the white curve contains distinct steps, and, consequently, the 
grey curve has distinct peaks.  
Press Enter  
In the next step an autoconvolution of the diffraction pattern (difference space) is 
analyzed, and the groups of peaks in the autoconvolution (clusters) are replaced by the 
cluster centers. Again, a distance distribution is displayed, and clear-cut steps on the curve 
indicate a well-defined lattice.  
Press Enter 
Now the first step is finished and PETS prepared the files needed for unit cell indexing. 
Keep the window of PETS open, you will need it later! 
 

3. Indexing with Jana2006  
Start Jana2006  
By default, Jana2006 starts with the last structure open. It may be cumbersome to change 
the directory every time. You may create a dummy (empty) file Ni2Si.m40 in the example 
directory, and use the command “Open with” from the file-manager context menu to 
launch Jana2006 directly in this directory.  
“Tools → Graphics → Indexing”  
Locate and open file Ni2Si.clust by double clicking it  
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A 3D view of the reciprocal lattice opens. You can rotate the cloud by mouse. Use buttons  
 and  to switch between free rotation and rotation around z-axis. Rotate with the 

lattice and try to determine the crystal system and the special axes of the lattice.  
You should come to the conclusion that the lattice is orthorhombic. The following image 
shows the view along c*: 

 
IMPORTANT: before you continue, make sure you have the same orientation of the lattice 
on your computer as displayed on the picture above (check the direction of the axes on the 
right). If not, you may obtain slightly different results in the rest of the tutorial. While not 
necessarily wrong, it makes following this tutorial more difficult.  

Click the button  in the lower-left corner and choose the radio button for a vector 

setting (right to the  button ). 
Click, hold the mouse button, and drag the marker to obtain the result on this image: 
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Set the order of the interplanar distance to 3. 
Note that the vertical red line is on the third vertical row of peaks. By this action you 
defined the direction and length of the (direct-space) basis vector a. Note: if you make a 
mistake and need to redo this step, make sure that the radio button a is selected bellow 
the main window, otherwise you will modify another cell parameter. 
Repeat the action, this time drag the marker up vertically to define the vector b.  
Vector a should have length close to 5.00 Å, vector b should have length close 3.73 Å, 
angles alpha and beta should be close to 90°. 
 
Click “View direction”, select “a”, Click OK  
The reciprocal space is now viewed along a, and c points up.  
In analogy to the procedure above, select the direction and length of the vector c.  
When you are finished, at the bottom of the window you should see cell parameters close 
(within a fraction of angstrom and degree) to these values: 

 
 
“Refine cell → Refine UB+cell”  
The orientation matrix is refined. Note that 44.9% of all peaks were indexed.  
OK; Quit  
The file Ni2Si.smr was now produced by Jana2006. This file contains the orientation matrix 
and the unit cell parameters.  
Close Jana2006  
 

4. Integrate the intensities with PETS  
Return to the window of PETS.  
Type u[Enter]  
PETS reads the orienting matrix from the Ni2Si.smr file.  
Type i[Enter]  
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The integration procedure starts. ImageJ displays images with circles drawn at positions 
predicted from the orienting matrix. A small circle inside large circle means that a peak 
with I>3𝜎𝜎(I) was found. The small circle is located on the maximum of the intensity. A 
diamond means that a reflection is expected on upcoming frame(s), square indicates 
reflection present on previous frame(s).  
When the integration finishes, files Ni2Si.cif_pets and Ni2Si.hkl are created. Both can be 
used to import the data into Jana and to solve the structure. 
 

5. Create reciprocal-space sections  
In PETS, Type h[Enter]  
Type y[Enter]  
You just asked PETS to scan all images and reconstruct sections through reciprocal space 
at planes hk0, hk1, hk2, h0l, h1l, h2l, 0kl, 1kl, 2kl. We will use these sections as an aid to 
determine the space group.  
When the reconstruction finishes, type q[Enter] to close PETS. You may also close ImageJ. 
  

6. Create new structure  
Important! The data-processing procedure is almost never perfectly reproducible. Small 
differences in the indexing and cell refinement procedure may result in small differences 
of integrated intensities. If you want to be sure that you can exactly reproduce the 
following part of the tutorial, do not use the file Ni2Si.cif_pets that you just created, but 
use the file Ni2Si_start.cif_pets provided with the example files (Rename the file to 
Ni2Si.cif_pets). Using your own cif_pets file is also possible, but your results may slightly 
differ from the results described in this tutorial.  
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate the directory with input files 
Right pane: double-click Ni2Si 
Right panel detects possible Jana files and shows one jobname for each group of files  
 

7. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Pets electron diffractometer” 
The file name automatically changes to Ni2Si.cif_pets, which is a file produced by PETS 
containing all important information, including the list of intensities.  
NEXT  
Leave all settings unchanged (note the wavelength of 120kV electrons!); NEXT 
Leave all settings unchanged; NEXT 
The program reads 614 reflections from the file  
OK 
For absorption correction select “None or done before importing”; NEXT 
FINISH; OK; YES to accept the data set  
You just read in the cell parameters and the intensity list. If you do not have the data in 
the cif_pets format, you can read them in from a general hkl file using the option 
“reflection file corrected for LP and absorption” at the beginning of the import wizard. You 
then have to input the radiation type, wavelength and cell parameters by hand. 
 

8. Symmetry Wizard 
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NEXT to close the information window and start the symmetry wizard. 
Symmetry Wizard can be started separately by “File → Reflection file → Make space group 
Test”. The default settings are prepared for x-ray diffraction. For electron diffraction we 
have to increase the tolerances. Change the tolerances according to this screenshot: 

 
Leave other settings default; NEXT; OK 
[On the screen: Select Laue symmetry] 
Select orthorhombic Laue class mmm; NEXT  
The internal R-values would be rather high for x-rays, but are low for electron diffraction 
data. 
[On the screen: Select cell centering]  
Select primitive unit cell; NEXT 
[On the screen: Select space group] 
The window shows possible space groups. 
The list of the strongest reflections contradicting the selected space group can be 
displayed by “Details” button. 
It is difficult to select the correct space group. In particular, presence or absence of the 
glide is hard to asses, knowing that kinematically absent reflections may have significant 
intensities due to dynamical diffraction effect. In this case the missing wedge leaves 
almost no information in hk0 reciprocal-space section. Open images 0kl and 1kl and check 
the intensities with k+l=2n+1 (which should be absent in the 0kl plane, but present in 1kl). 
You will see that despite some violations and the missing information in the center of the 
image, the n-glide absences are nevertheless clearly present in the 0kl plane in comparison 
with the 1kl plane. Space group with n-glide is thus a reasonable guess. 
Note that a wrong choice of the space group is not detrimental for the structure solution, 
because we will use Superflip, which will make additional check for the most probable 
space group. 
 
Select Pnma; NEXT 
Accept the space group in the standard setting; FINISH 
Symmetry is saved in file Ni2Si.m50. 
 

9. Creating refinement reflection file 
 In this step program creates file Ni2Si.m90 containing the data set merged by symmetry 
and with discarded forbidden reflections. .m90 will be used for refinement. 
Proceed with the wizard, leaving all settings default  

10. Structure Solution Wizard 
OK to close the information window and start the solution wizard  
 [On the screen: window of Structure solution] Structure solution wizard can be executed 
separately through “Run → Solution”. Jana2006 does not contain solution procedures, it 
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calls external programs. By default, Jana uses Superflip (using charge flipping as the 
solution method). Superflip is distributed with Jana2006. 

 
In “Formula” textbox type just the list of chemical elements: Ni Si 
Superflip does not need information about chemical elements but they will be required for 
peak assignment based on electron density map calculated by Superflip. If Jana2006 is 
used for peak assignment, a list of expected chemical elements is sufficient. If you know 
the expected formula, you may enter it and use EDMA for peak picking (at the bottom of 
the window). If the formula is correct, EDMA often gives cleaner and more complete 
interpretations of the solution. 
Click the checkbox next to “Use a specific random seed” and enter the value 111.  
Leave other settings default; “Run solution”. 
The specific random seed is used just to guarantee reproducibility of the results. For 
standard work random seed need not be defined.  
[On the screen: window of Superflip appears with iteration running. After ten runs, listing 
of Superflip log file is displayed] 
Superflip performed ten solution attempts, and picked the best one. Its characteristics are 
displayed near the bottom of the listing:  

Properties of the saved density:  
Run Rvalue Peaks Symm. Der.SG  
10   51.46  2.23  1.37  Pnma  

The space group proposed by Superflip is the same as our initial guess. The space-group 
selection is confirmed. Small symmetry agreement factor (column Symm.) indicated good 
quality of the solution. In cases of doubts or difficult problems, it is worth checking the 
statistics, especially the symmetry analysis, for each of the ten runs, and seeking for the 
most probable one. 
Press “Close” to leave the listing  
Press “Accept last solution”  
The program creates file Ni2Si.m40 with atoms of the structure model 
  

11. Verification of the structure solution 
 Go to “Contour → New plot → OK → Run 3D maps“  
VESTA opens with a density shown as isosurfaces, and an atomic model overlaid. Rotate 
the view to inspect the structure. Do you think it is complete?  
You should come to the conclusion that the model is correct, correct elements were 
assigned to all maxima.  
Quit VESTA (do not save the file), quit Contour.  
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You may now check the structure in Diamond to convince yourself that the structure is 
complete and chemically reasonable. 

12. Initial Refinement 
[On the screen: basic window of Jana]  
Right-click the icon of Refine.  
[On the screen: refinement options] 
Change the number of cycles to 100; OK 
Choose “Yes+start”   
Refinement converges with R value about 11.07%. At this moment you may check the 
refinement listing with a lot of information about the refinement procedure and results. 
As you can see, the refinement is already very good for electron diffraction. R values are 
low, all the ADPs were positive definite. Refinement of anisotropic atomic displacements 
would decrease the residue value (R=8.79%), but the ratio reflections per parameter is 
already low. 

 
 
 
The resulting structure 
 

 
 

13. Preparation of reflection file for the dynamical refinement 
Open Ni2Si.pts again. Type “o” to read the peak table, “u” to read the orientation matrix 
and “d” to integrate the intensities for the dynamical refinement.  
The integration for the dynamical refinement considers each diffraction image separately. 
The result is a list with the hkl indices, the measured intensity with the respective sigma 
and the number of the frame in which the intensity is present. PETS creates the file 
Ni2Si_dyn.cif_pets with all these information, which will be used in Jana2006. Note that 
the same hkl reflection might be present in several frames, with different intensity due to 
the multiple scattering relative to different crystal orientation and thickness at this 
condition. 
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Quit PETS and go back to Jana2006. “StructureSave as” and save a new structure 
Ni2Si_dyn for the dynamical refinement. Continue with the new structure. 
This will be the structure with the dynamical refinement 
 
“FileReflection fileImport/modify the reflection fileReimport” 
Again, if you want to be sure that you can exactly reproduce the following part of the 
tutorial, use the file Ni2Si_start_dyn.cif_pets provided with the example files. Rename this 
file to Ni2Si_dyn.cif_pets. 
Select the Ni2Si_dyn.cif_pets as the new reflection file. NEXT, NEXT, NEXT. 
Now, Jana reads 4825 reflections from all the frames. 
OK, NEXT, Finish, OK, Yes, Cancel. 
It is not necessary to average the intensities, because the intensities will be used 
independently for each frame during the dynamical refinement. 
 

14. Starting the dynamical refinement 
[On the screen: basic window of Jana]  
“Parameters”, “Electron diffraction”.  
[On the screen: Parameters for electron diffraction data] 
Enable “Use dynamic approach”. OK, NEXT, OK, OK, OK, Finish. 
Notice that now, 1673 reflections are symmetrically independent from the 4825 
reflections read. From these, 12 were rejected because they violate the systematic 
extinctions. You can see these information in the file .rre. In this same file you can see the 
completeness of the data (63% for theta full (0.76 °). 
[On the screen: Parameters for electron diffraction data] 
The default values for the selection of the intensities are: g(max)=2, maximal excitation 
error Sg(matrix)=0.01, maximal excitation error Sg(refine)=0.1 and Rsg=0.4. 
 

15. Optimization of thickness 
Enable “Except of scale optimize also: Thickness”, “Run optimizations”. 
[On the screen: Intensity calculation for optimizing of thickness]. 
Dyngo calculates wR-factor for the thickness varying from 0 to 2000 Å. 
“Show thickness plots”. Check the variation of the thickness of the crystal for the frames. 
Quit. 
Most frames have well defined wR-fator minima for one thickness. However, some frames 
either have poorly defined minimum or the minimum is defined for very different 
thickness. For example frames 13, 18, 22 and 44 have a plateau for thickness between 0 
and 400 Å. Frame 36 have minimum at very high thickness (around 1500 Å). Check the 
problematic frames. You will notice that for most frames there is no problem with the 
reflection image, in this case, and for some of them 1 or 2 reflections are stronger the all 
the rest. Notice also that the maximum R-factor is 17.64% for the last frame. You can 
check the wR(all) going through the zones in the main window of “parameters for electron 
diffraction data” or while seeing the graphs. The different thickness is not a problem now, 
but if the frame would have some problem (the crystal mostly moved from the beam, for 
example) it could be removed from the refinement. 
 

16. Defining all the zones with the same thickness 
 “Define zones of equal thickness”. “Select all”, OK. 
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The crystal is a nanowire and the thickness is mostly constant along the sample. However, 
the thickness changes according to the tilt of the sample, because the nanowire lies 
roughly perpendicular to the tilting axis of the sample holder. Then, it is possible to define 
the same thickness for all the frames but still refine the variations of the thickness 
according to the tilting of the sample. 
There are two ways of defining the same thickness of the crystal for all the frames. You 
can either estimate a reasonable thickness, based on the plots of wR versus thickness, and 
type it for all frames, or run 0 cycle of refinement and average the thickness. It will be used 
the first option here. From the plots the minima are well defined mostly for EDThick under 
200 Å. Also based on the image of the crystal (it can be measured using imageJ) 150 (15 
nm) for EDThick is a reasonable value. 
 
“Select zones for editing Select all  OK” and type 150 for “EDThick”. OK, Yes. 
 
Right-click on icon “Refine”, change the number of cycles to 100 and the damping factor 
to 0.3 in order to avoid instability of the refinement. 
The refinement runs 23 cycles, each cycle takes less than 2 minutes (depending on your 
computer). You can see the details of the refinement in the file Ni2Si.ref (Edit/View View 
of Refine). The refinement converges with R=7.79%. However, the ratio reflections per 
parameter refined is around 5 (454/84) and it is advisable to increase it. It can be done by 
changing RSg (selecting more reflections for the refinement). 
Another important thing to check is the number of observed reflections per zone. Also in 
the Ni2Si.ref file, you can see “R-factors for individual zones”, where it is shown the list of 
zones with the respective R-factors and number of reflections. 
 

17. Optimization of orientation 
Save a new structure “Filesave asNi2Si_dyn_ori”, OK, Yes. 
“Parameterelectron diffraction”, change the “Limit on RSg” to 0.75 
Enable “Run optimizations except of scale optimize also: Orientation”, “Run 
optimization”. 

 [On the screen: Intensity calculation for optimizing of orientation]. 
Check the EDTheta for the frames. As said before, the orientation of the crystal during the 
measurement plays an important role in the dynamical scatterings. Typically, a deviation 
of 0.5° is already considered high. The frames with high misorientation are: 8, 24, 32, 41, 
60, 61, 62 and 73. If you check these frames, most have few reflections (because the unit 
cell is small), the reflections are mostly weak (the nanowire is very thin) and some frames 
have 1 or 2 peaks visibly stronger than the rest. These stronger reflections dominate the 
optimization and hamper the correct estimative of orientation. Frames with EDTheta 
larger than 0.5° will be removed from the refinement. 
 
“Select zones for refinement” 
Disable the frames 8, 24, 32, 41, 60, 61, 62 and 73 (Ctrl + left mouse button). 
 
OK, OK, Yes. Double click on “Refine”. 
The refinement converges with R=7.11% after 13 cycles. Since there are more reflections, 
it is possible to refine the anisotropic displacement parameters. 
 

18. Refinement of anisotropic atomic displacement parameters 
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Save the structure as Ni2Si_dyn_ori_aniso, “Edit atomsselect alldouble click in one 
of the atomsADP parameter(s): harmonic”, OK, OK, Yes 

 [On the screen: Mains window of Jana2006]. 
Double-click on icon “Refine”. 
 
Now the refinement converges with R= 6.52% after 15 cycles. If you check the ellipsoid 
model, you will see that Si is elongated along a*, which was the noisiest direction when 
defining the unit cell. 
 
Final structure model: 
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Example 13.6:  
Orthopyroxene from EDT 
A complete procedure from structure solution to dynamical structure 
refinement from electron diffraction tomography data. 

 
Revised: 13 October 2015 

 
Warning: this is a complex and time-consuming example. The computations in the last stages 
may take up to several hours. 

 
Input data: directory dp with the set of experimental data,  
opx.pts: input file for PETS – the data reduction program 
opx_start.cif_pets and opx_dyn_start.cif_pets: results of the data processing. These files are 
provided so that this example can be solved without the data processing part, and to warrant 
reproducibility of the second part. Files opx.cif_pets and opx_dyn_start.cif_pets is the output of 
the data reduction. 

 

1. Data reduction using PETS 
The data processing part follows exactly the procedure described in example 13.1. Please 
follow that tutorial. Here only key results are provided for your control, and comments are 
provided for stages that require special attention. Be aware that the peak search and 
integration take a long time, because the original images are rather large. 
Parameters filled in the prepared file opx.pts: 
reflectionsize 30 
beamstop no 
 
Refined azimuthal angle omega of the tilt axis: 
omega  :   57.922 
 
Unit cell is orthorhombic, primitive. The following screenshot is the view of the reciprocal 
lattice along the axis c (a* horizontal, b* vertical): 
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Final refined cell parameters (refined against the peaks in opx.clust):  

 
Quit the indexing plugin to create file opx.smr with the orienting matrix, and continue data 
processing in PETS by typing u[Enter] to read in the orienting matrix, and i[Enter] to 
integrate the intensities. 
PETS produced file opx.cif_pets, which contains intensities suitable for structure solution and 
kinematical refinement. We have to produce another intensity set for dynamical refinement: 
In PETS type d[Enter] 
PETS will make another integration, this time producing file opx_dyn.cif_pets. 
Type h[Enter] and y[Enter] ]to produce a standard set of sections through reciprocal space. 
The sections will be useful for confirming the space group. 
With this step the data processing in PETS is finished.  
Type q[Enter] to close PETS. You may also close ImageJ. 

2. Create new structure 
Important! The data-processing procedure is almost never perfectly reproducible. Small 
differences in the indexing and cell refinement procedure may result in small differences of 
integrated intensities. If you want to be sure that you can exactly reproduce the following 
part of the tutorial, do not use the files opx.cif_pets and opx_dyn.cif_pets that you just 
created, but use the files opx_start.cif_pets and opx_dyn_start.cif_pets provided with the 
example files (Rename the files to opx.cif_pets and opx_dyn.cif_pets). Using your own 
cif_pets files is possible, but your results may slightly differ from the results described in this 
tutorial. 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate the directory with input files 
Right pane: double-click opx 
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3. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Pets electron diffractometer” 
The file name automatically changes to opx.cif_pets, which is a file produced by PETS 
containing all important information, including the list of intensities. 
NEXT 
Leave all settings unchanged; NEXT 
Leave all settings unchanged; NEXT 
The program reads 5232 reflections from the file 
OK 
For absorption correction select “None or done before importing”; NEXT 
FINISH; OK; YES to accept the data set 
You just read in the experimental parameters, cell parameters and the intensity list. 

4. Symmetry Wizard 
NEXT to close the information window and start the wizard 
Symmetry Wizard can be started separately by “File → Reflection file → Make space group 
test. 
The default settings are prepared from x-ray diffraction. For electron diffraction the 
tolerances should be increased so that Jana properly detect that the cell is orthorhombic. 
Change the tolerances according to this screenshot: 

 

Leave other settings default; NEXT; OK 
 [On the screen: Select Laue symmetry] 
Select orthorhombic Laue symmetry; NEXT 
The internal R-value of 23.68% is quite acceptable for EDT data.  
[On the screen: Select cell centering] 
The numbers in the table indicate that the only acceptable lattice type is primitive. In 
general it is a good practice to check the centering in the reciprocal-space reconstructions. 
Select centering P; NEXT 
[On the screen: Select space group] 
The window shows possible space groups. It can be quite tricky to determine the correct 
space group form EDT data, as the systematic absences can be violated in electron 
diffraction. You should use the reconstructions of the reciprocal-space layers to check, if you 
can see some systematic absences. From the inspection of the section hk0.pgm (open the 
file in ImageJ) the presence of the a-glide is quite obvious. The b-glide and c-glide conditions 
in the files 0kl.pgm and h0l.pgm are violated by a couple of weak reflections, but still their 
presence is very likely. Pbca is therefore a good first guess.  
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Select Pbca; NEXT 
Note that a wrong choice of the space group is not detrimental for the structure solution, 
because we will use Superflip, which will make additional check for the most probable space 
group. 
Accept the space group in the standard setting; FINISH 
Symmetry is saved in file opx.m50. 

5. Creating refinement reflection file 
In this step the program creates file opx.m90 containing the data set merged by symmetry 
and with discarded forbidden reflections. M90 will be used for refinement. 
Proceed with the wizard, leaving all settings default. 

6. Structure Solution Wizard 
OK to close the information window and start the wizard  
[On the screen: window of Structure solution] 
Structure solution wizard can be executed separately through “Run → Solution”. 
Jana2006 does not contain solution procedures, it calls external programs. By default, Jana 
uses Superflip (using charge flipping as the solution method). Superflip is distributed with 
Jana2006.  
In “Formula” textbox type the expected formula: Fe Mg Si2 O6 
In “Formula units” textbox type 8 
Click the checkbox next to “Use a specific random seed” and leave the value 111. 
The specific random seed is used just to guarantee reproducibility of the results. For 
standard work, random seed need not be defined. 
Click the radio button “EDMA – fixed composition” 
EDMA is an external program for interpretation of electron densities. It can take the 
chemical formula and interpret the density using this formula. 
Leave other settings default; OK 
 [On the screen: window of Superflip appears with iteration running. After ten runs, listing of 
Superflip log file is displayed] 
Superflip performed ten solution attempts. Check the space groups derived by Superflip from 
each of the attempts. In eight out of ten cases  the proposed space group is Pbca. It is thus 
likely (though not guaranteed!) that Pbca is indeed the correct space group. 
Press CLOSE to leave the listing but stay in the dialog “Structure solution 
The result is a file opx.m40 with atoms of the structure model. 

7. Verification of the structure solution 
Click “Draw 3D map“ 
VESTA opens with a density shown as isosurfaces, and an atomic model overlaid. Rotate the 
view to inspect the structure. Try to recognize the structural motifs. The main expected 
motifs are SiO4 tetrahedra and (FeMg)O6 octahedra. The analysis will be simpler if you 
display the atomic bonds: 
Go to Edit → Bonds, and set up the options according to this screenshot: 
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Viewing the structure solution in VESTA has the advantage that you can directly check, if the 
raw density was correctly interpreted. In this case, the solution is very good and all atoms 
are properly located. The only problem is that some cations have been assigned a wrong 
atomic type. By inspecting the structure you should come to the conclusion that the 
following two atoms need to be changed: 
Mg1 -> Si 
Si2 -> Mg or Fe – we will choose Mg for the moment 
Quit VESTA (do not save changes) 
Click “Accept last solution” 

8. Change the atomic types 
Double click icon Edit atoms 
Double click atom Si1 
Change its name to Mg2 
Change its atomic type to Mg 
OK 
Repeat the procedure for the atom Mg1 and rename it to Si2 
Close the dialog for editing atoms and confirm changes 

9. Structure refinement 
[On the screen: basic window of Jana] 
Double click the icon Refine. 
Refinement converges smoothly to an R value about 25%.  
 
The octahedral positions are not exclusively occupied by iron or magnesium, but by both 
elements. We have to refine the mixed occupancy in these sites. 
[On the screen: basic window of Jana] 
Double click icon Edit atoms 
Right-click atom Fe1 → Split atomic position 
Set up the dialog according to the following screen shot: 
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Apply 
Repeat the procedure with Mg2 to generate atom Fe2 at the same position. 
 
The procedure generated a pair of atoms with restricted ADP parameters and coordinates 
and with a restricted sum of occupancies. The only small problem (although rather esthetic 
than real) is that in one pair the Fe atom is the “Master” and Mg the “slave”, while for the 
other pair it is vice versa. We will modify the restrictions to be both the same. 
[On the screen: basic window of Jana] 
Right-click Refine → Various → Restrictions 
Load the restriction on atoms Mg2 and Fe2 
Exchange the order of atoms in the restriction (type Fe 2 Mg2 in the line 
“Atoms/molecules), so that Fe is the “master” atom. Rewrite the restriction. When finished, 
the dialog should look like this: 

 
OK; OK; Yes (do not start refinement yet!) 
Now we have restricted the atomic pairs, but the occupancies are still fixed and would not 
be refined. We have to allow their refinement explicitly: 
Double click the icon “Edit atoms” 
Double click atom Fe1 
On the card “Edit” check the box next to the parameter “ai”; OK 
Repeat for atom Fe2 
OK to close the Edit atoms dialog 
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Double click Refine to start refinement 
Refinement converges to R-value of 24.25%. The refined atomic occupancies are:  
Fe1: 0.44(5) 
Fe2: 0.44(5) 
Note that the equal occupancies and their e.s.d. is a pure coincidence and not a result of 
some restriction or symmetry. 

10. Set up dynamical refinement 

At this moment there is very little we can do with the kinematical refinement. We have a 
satisfactory refinement, the structure makes sense, the occupancies have been refined, but 
their accuracy cannot be estimated from the kinematical refinement. Furthermore, some 
ADPs are negative. We will now proceed to the structure refinement using dynamical 
diffraction theory. 
File → Structure → Save as 
Save the structure as opx_dyn 
Answer Yes to the question if you want to continue with the new structure 
File → Reflection file → Import/modify the reflection file 
Reimport; Browse for the file opx_dyn.cif_pets; NEXT; NEXT; NEXT; OK; NEXT; Finish; OK; 
Yes 
You have just replaced the previous reflection data with new data set suitable for dynamical 
refinement. 
Cancel to avoid the production of refinement reflection file 
If we continued, we would have produced a symmetry-averaged file for kinematical 
refinement. For dynamical refinement the intensities on each frame must be kept separate. 
We will now enable the dynamical refinement option: 
Go to “Parameters → Electron diffraction” 
Check the checkbox “Use dynamical approach” 
Proceed with creation of the reflection file, leave all settings default. 
 
At this point we are ready to start dynamical calculations. Because the calculations are very 
time consuming, we will not, in this example, use all 90 zones, but only nine selected zones. 
Click “Select zones for refinement”; In the line below the table, set the following: 

 
Click the button ; OK 
Only zones 10, 20, 30, 40, 50, 60, 70, 80 and 90 are now selected for refinement. 
 
The data collection was performed on one crystal and there is also no reason to expect that 
the thickness varies for each zone. We will therefore restrict the thickness to the sam value 
for all zones: 
Click “Define zones of equal thicknesses; Select all; OK 
 
Dyngo – the external executable that performs the heavy calculations – can run in a parallel 
mode. In the field “Number of threads” you can decide, how many parallel threads Dyngo 
may use. For the fastest performance set this number to the number of cores of your 
processor. Important! Most Intel processors indicate twice as many threads available than 
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they have cores due to the hyper-threading technology. Do not set the number of threads to 
the number of threads available on your processor, but to the number of ture distinct cores! 
 
As a first step we have to check, if our model fits the data sufficiently well to start the 
refinement. For that, we will run thickness optimization. This procedure is relatively fast, and 
for each selected zone it calculates an R-value as a function of thickness. For good data set 
and reasonable starting model, this curve should have a minimum at a meaningful 
thickness, and all curves should indicate approximately the same thickness. 
Check the checkbox next to “Thickness” and click  
Jana calls Dyngo for each zone. When the calculation is finished, each selected zone has next 
to the zone number in the dialog the best R-value, e.g.: 

 
All zones’ R-values are lower than 20%, some of them even lower than 10%. This is a pretty 
good start. 
Click “Show thickness plots” 
Now you can view the curves R-value vs. thickness for all zones. In most cases the curve has 
a well-defined minimum, only in zones 30 and 70 the minimum is at the lowest thickness. 
The best thickness varies in a relatively broad interval, but the minima are broad, and our 
structure model is far from perfect at this stage, so this is not surprising. 
Quit the viewer of the thickness curves 
 
We want the thickess to be the same for all zones in the refinement. Now the thicknesses 
are all different and we should reset them to a common most appropriate value. The best 
practice seems to be a visual estimation of the “typical” thickness in the thickness plots. In 
this case 500 angstroms seems to be a good guess. Do not worry about the inaccuracy of 
such guess – the thickness is a very robust parameter and it will refine to the correct value 
even from a quite distant start. 
Click “Select zones for editing”; “Select all”; OK 
Double click the yellow field EDThick and type “500” in the field 
This procedure reset the thickness of all zones to 500 angstroms. 
We have to recalculate the scale factors for each zone, because the scale changes with 
changing thickness: 
Click the button  without any other checkbox checked (neither thickness nor 
Orientation) 
When the calculation finishes,click OK to close the electron diffraction dialog. 
 
You can now start the structure refinement. 
[On the screen: basic window of Jana] 
Double click the icon Refine 
After the first cycle the refinement R-value Robs is 13.13%. After 5 cycles the refinement 
should converge to an R-value of 8.29%. 
 
In the next step we will optimize the orientation of each zone. Due to the inaccuracy of 
goniometer positioning and orientation matrix, the positional angles of each diffraction 
pattern are not exactly correct, and a correction should be found. 
Go to “Parameters → Electron diffraction” 
Check the checkbox next to “Orientation” 
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Click the button  
An optimization procedure starts that finds the best zone-axis orientation for each pattern.  
Wait until the calculation finishes. Now you can now run a few more cycles of structure 
refinement. 
Click OK to close the form “Electron diffraction” 
Double click the icon Refine 
The refinement converges after 10 cycles to an R-value of 5.10%. Inspection of the structure 
model shows that the occupancies of Fe1 and Fe2 refined to 0.33(3) and 0.06(2), 
respectively. This is still relatively far from the values from x-ray refinement, which are 
0.432(3) and 0.157(3). However, there are only 188 observed reflections in this limited 
dataset for the refinement of 52 parameters. The data to parameter ratio is thus poor. If all 
90 zones are included in the refinement and the whole procedure is repeated with them, the 
final result is: 
Robs=5.89% 
occ(Fe1)=0.389(7) 
occ(Fe2)=0.148(7) 
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Example 20.1: CeAsSe 

Merohedric twin with extinction imported from SHELX to Jana2006. 
 

Chemical formula: CeAsSe 
Reference: Structure provided by Max Planck Institute for Chemical Physics of Solids 
Input files: CeAsSe.hkl, CeAsSe.ins 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate the directory with input files 
Right pane: double-click CeAsCe 

2. Importing structure from SHELX 
[On the screen: Specify type of the file to be imported] 
Select “Structure – from SHELX”; Next 
In File manager double-click CeAsSe.ins 
The program reads the structure, detects the presence of CeAsSe.hkl and starts import of 
reflections 
Go through the usual steps of the Import Wizard 
Rint = 4.69% 

3. Checking the twinning of the imported structure 
Start EditM50 
The twinning check box must be selected 
Press “Matrices” 
The twinning matrix should be 0 1 0 | -1 0 0 | 0 0 1 
Leave EditM50 
Start “Parameters → Twin fractions” 
The parameter “twwol2” must be 0.46346 
Activate refinement of “twvol2” 
Save the changes and leave to the basic window 

4. Refinement 
Run refinement 
It converges with R=3.2% 
Open refinement listing, GoTo Statistics 
Higher R value for the strongest reflections indicates that extinction correction is needed 
Close the refinement listing 
Start “Parameters → Extinction” 
Activate Isotropic extinction with Gaussian model 
Save changes and leave to the basic window 
Repeat refinement 
In converges with R=2.75%. The reason extinction has not been imported from the ins file is 
that SHELX and Jana use different parameters for extinction correction 
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Example 20.2: HfPdGe 
Six-fold twin with reflections in HKLF5 format, imported from SHELX to 
Jana2006. 
 

Chemical formula: HfPdGe 
Reference: Structure provided by Max Planck Institute for Chemical Physics of Solids 
Input files: HfPdGe.hkl, HfPdGe.ins 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate the directory with input files 
Right pane: double-click HfPdGe 

2. Importing structure from SHELX 
[On the screen: Specify type of the file to be imported] 
Select “Structure – from SHELX”; Next 
In File manager double-click HfPdGe.ins 
The program reads the structure, detects the presence of HfPdGe.hkl, automatically 
recognizes HKLF5 format and starts import of reflections 
Go through the usual steps of the Import Wizard 
Rint = ---- 

3. Checking the twinning of the imported structure 
Start EditM50 
The twinning check box must be selected, number of twin domains should be six 
Press “Matrices” 
The twinning matrices are all unit matrices because for HKLF5 data they have just a formal 
meaning 
Leave EditM50 
Start Parameters → Twin fractions 
The parameters “twwol2”, …. “twvol6” must contain the numbers from the BASF commans 
of the ins file. 
Activate refinement of all twin volume fractions 
Save the changes and leave to the basic window 

4. Refinement 
Run refinement 
It converges with R=4.1% for 60 parameters. There were very large changes of the twin 
fractions during the refinement because probably the order of twin fractions in SHELX and 
Jana differs. 
Open refinement listing, GoTo Statistics 
There is no indication of extinction and at the bottom of the listing no warnings. 
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Example: U3Fe2Ge7 
Revised 9 March 2019 
 

Data Topic  Level 

X-ray single crystal data Highly absorbing compound Basic  

Tasks 
Data processing and absorption correction in Jana2006 

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
U3Fe2Ge7.hkl 
U3Fe2Ge7.cif_od 
Additional information: 
Chemical formula: U3Fe2Ge7 
Space group: Cmmm 
Unit cell: 4.1666 24.982 4.1557 90 90 90 
 

Notes  
The data reduction program CrysAlis contains an option for data format containing all 
information for frame scaling and absorption correction. The option can be activated in the 
Refinalization procedure: 

 
The created data are corrected by CrysAlis, and the format allows to undo the correction by 
CrysAlis and redo it using Jana2006. It is helpful e.g. in cases when structure solution leads to 
a different of expected absorption and the original measurement is unavailable. The option 
can also be applied to Bruker data because CrysAlis can work with Bruker frames.   

 
  



762 Jana2006 Cookbook, version September 2019 
 
 

Contents  

 
I. Data import and Solution ............................................................................................763 

1. Creating new jobname ..........................................................................................763 

2. Import wizard ........................................................................................................763 

3. Data Repository .....................................................................................................763 

4. Symmetry wizard ...................................................................................................763 

5. Creating refinement reflection file ........................................................................764 

6. Structure solutions wizard .....................................................................................764 

7. Refinement ............................................................................................................764 

II. Absorption correction .................................................................................................766 

1. Correction for a spherical sample + empirical correction + frame scaling ............766 

2. Correction for an indexed shape + empirical correction + frame scaling .............767 

3. Correction for refined indexed shape + empirical correction + frame scaling .....768 

References ...............................................................................................................................770 

 
 
  



763 Jana2006 Cookbook, version September 2019 
 
 

Instructions  

I. Data import and Solution  
Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager  
Left pane: locate directory with input files;  
Right pane: double-click U3Fe2Ge7  

Import wizard 

Select “Known diffractometer formats”; NEXT  
Select “Oxford Diffraction → CCD”; NEXT  
Select “Input from “cif_od” file”; OK  
Leave all settings unchanged; NEXT  
Leave all settings unchanged; NEXT; OK;  
The program reads 3932 reflections from hkl file 
For absorption correction select “None or done before importing”; NEXT (Step 1) 
FINISH;  

Step 1  

 

 

Data Repository 

OK; YES to accept the data set  
NEXT;  

Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Leave all settings default; NEXT; OK  
[On the screen: Select Laue symmetry] 
Select Orthorhombic Laue symmetry; NEXT (Step 2) 

  



764 Jana2006 Cookbook, version September 2019 
 
 

Notes  
The Rint statistics seems to suggest tetragonal symmetry. However, the lattice is C-centered 
(as will be confirmed on the next slide) and this excludes the tetragonal symmetries.  

Select centering C unit cell; NEXT (Step 3) 
[On the screen: Select space group] 
Select Cmmm; NEXT  
Leave all settings unchanged; FINISH  

Step 2 Step 3 

  
Creating refinement reflection file  

NEXT to confirm threshold 3sigma; OK; OK  
[On the screen: settings for merging of reflections] 
NEXT 
The program reports Rint 10.41% for 350 observed reflections merged from 371 observed 
reflections. 
OK;  
Select "Accept the new data block and calculate coverage"; FINISH; OK 

Structure solutions wizard 

[On the screen: Structure solution] 
In “Formula” textbox type list of chemical elements: U Ge Fe 
Select “Use Superflip”; 
Check “Repeat Superflip: Number of runs” leave 10  
Leave other settings default; press “Run solution.” 
[On the screen: the window of Superflip replaced after reaching the convergence with a 
listing of Superflip] 
Press CLOSE to leaving the listing 
Press Accept last solution 

Refinement 

Start EditM50;  
Go to page Composition; enter 2 for “Formula units,” press “Formula from M40.”  
OK; YES; OK; YES; 

 

Notes  
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It displays formula U3 Ge7 Fe2 (for Z=2) which correspond to the expected composition. If 
some atoms are missing in your case, run refinement and use a difference Fourier map to find 
missing atoms. 

 
 

Run Refine; 

Notes  
R factors [371=350+21/13] 
GoF(obs) ≈ 5.11;  
R(obs) ≈ 7.44; wR(obs) ≈ 9.70; R(all) ≈ 7.74; wR(all) ≈ 9.74  

Start Edit atoms; 
Press “Select all” then “Action” and select “Edit/Define atoms.”  
Change the ADP parameter(s) from isotropic to harmonic (anisotropic);  
OK; OK; YES 
Run Refine; 

 
Notes  
R factors [371=350+21/27] 
GoF(obs) ≈ 4.57;  
R(obs) ≈ 6.15; wR(obs) ≈ 8.49; R(all) ≈ 6.35; wR(all) ≈ 8.51  
Warning due to Negative ADP of atoms  

Start EditM50;  
Go to page Composition; press “Calculate density.” 
OK; OK;  

Notes  
Molecular weight = 1333.91 
Calculated density = 10.2477 g.cm**(-3) 
Absorption coefficient mi(Mo-Kalfa)= 83.063 mm**-1 
 
By default, CrysAlis uses very small value of μ because most measured structures are not 
strong absorbers. In Crysalis, μ can be edited to proper value and in such case the corrections 
would be done correctly. In this example, we have intentionally used small μ in CrysAlis in 
order to simulate the situation of wrongly corrected data.   

File -> structure -> Save as (Create backup copy) U3Fe2Ge7_s1 
NO (you don’t want to continue with the new structure) 
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II. Absorption correction 
 

1. Correction for a spherical sample + empirical correction + frame scaling 
Notes  
Here we simulate situation when crystal shape is unknown 

 
File -> Reflection file -> Import/modify the reflection file  
[On the screen: Data repository] 
Select “Modify” 
[On the screen: Define parameters for absorption and scaling procedure] 
Select “correction for spherical sample” and add radius of the sphere [mm] equal to 0.057 
Check “Empirical correction and/or frame scaling”; NEXT; (Step 1) 
[On the screen: Define parameters for frame scale and/or empirical absorption correction] 
Check “Scale frame”, “Optimize coefficients of spherical harmonics” using 8 harmonics and 
“Use odd harmonics”  using 7 harmonics (Step 2) 
For large absorption, we use maximal number of spherical harmonic functions 
Run optimization;  
 
This configuration gives a similar R(int) as the default absorption correction done in 
CrysAlis. 
 

Step 1 Step 2 

  
Press “Accept optimized parameters”;  
OK; Finish; OK; 

 

 Notes  
Here you can find the evolution of parameter as a function of spherical harmonics parameters  

Spherical 
harmonics 

Odd 
harmonics R(int) Rw(int) T(min) T(max) 

0 0 16.342 21.398 0.0016 0.0105 
2 0 13.415 17.718 0.0064 0.0407 
4 0 12.275 16.467 0.0065 0.0433 
6 0 12.023 15.824 0.0060 0.0407 
8 0 11.972 15.597 0.0058 0.0396 
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8 1 11.498 14.490 0.0065 0.0481 
8 3 11.190 13.863 0.0063 0.0582 
8 5 10.875 13.511 0.0064 0.0652 
8 7 10.598 13.448 0.0063 0.0859 

NEXT to confirm threshold 3sigma; OK; OK  
[On the screen: settings for merging of reflections] 
NEXT; OK;  
Select "Accept the new DatBlock and calculate coverage"; FINISH; OK 
Run Refinement  

Notes  
The resulting R value is similar like before but there are no warnings about ADP 

File -> structure -> Save as (Create backup copy) U3Fe2Ge7_s2 
NO (you don’t want to continue with the new structure) 

Correction for an indexed shape + empirical correction + frame scaling 
Notes  
Here we simulate situation when crystal shape is known. Unfortunately, the shape of this 
sample is not far of a sphere so the advantage of using the indexed shape is not convincing. 
For more anisotropic shape using of the indexed shape would bring a real benefit.  

 
File -> Reflection file -> Import/modify the reflection file  
[On the screen: Data repository] 
Select “Modify” 
[On the screen: Define parameters for absorption and scaling procedure] 
Select “Gaussian integration method.”  
Check “Empirical correction and/or frame scaling” (Step 3) 
 

Notes  
You can observe the crystal shape if you click on Edit Face  -> Show the shape  

NEXT; 
[On the screen: Define parameters for frame scale and/or empirical absorption correction 
Check “Scale frame”, “Optimize coefficients of spherical harmonics” using 8 harmonics and 
“Use odd harmonics”  using 7 harmonics (Step 4) 
Run optimization 
This configuration gives a better R(int) than the previous method. 
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Step 3 Step 4 

  
Press “Accept optimized parameters”;  
OK; Finish; OK;  

NEXT to confirm threshold 3sigma; OK; OK  
NEXT; OK;  
Select "Accept the new DatBlock and calculate coverage"; FINISH; OK 
Run Refinement  

Notes  
Refinement results are better than before 
R factors [371=350+21/27] 
GoF(obs) ≈ 4.40; R(obs) ≈ 5.35; wR(obs) ≈ 8.17; R(all) ≈ 5.54; wR(all) ≈ 8.19   

File -> structure -> Save as (Create backup copy) U3Fe2Ge7_s3 
NO (you don’t want to continue with the new structure) 

Correction for refined indexed shape + empirical correction + frame scaling  
File -> Reflection file -> Import/modify the reflection file  
[On the screen: Data repository] 
Select “Modify” 
[On the screen: Define parameters for absorption and scaling procedure] 
Select “Gaussian integration method.”  
Check “Empirical correction and/or frame scaling” (Step 5) 
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Press “Edit faces” 
[On the screen: Face specification] 
 

Notes  
The form allows for running the X-shape program. This is very practical software for 
refinement of the crystal shape to get a shape minimizing differences between intensities of 
symmetrically equivalent reflections. Unfortunately, X-Shape is a part of Stoe diffractometer 
software and cannot be freely distributed. For this reason, we provide result of the shape 
refinement as a crs file, which will be imported in the following step. 

 
 Press “Read from file” and import U2Fe3Ge7.crs file (Step 6) 
OK; OK; OK 
NEXT; 
 

Step 5 Step 6 

  
[On the screen: Define parameters for frame scale and/or empirical absorption correction 
Check “Scale frame”, “Optimize coefficients of spherical harmonics” using 8 harmonics and 
“Use odd harmonics”  using 7 harmonics  
Run optimization 
Resulting R(int) is slightly better compared with the original unrefined shape. 
Press “Accept optimized parameters”;  
OK; Finish; OK; 
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NEXT to confirm threshold 3sigma; OK; OK  
NEXT; OK;  
Select "Accept the new DatBlock and calculate coverage"; FINISH; OK 
Run Refinement  

Notes  
Refinement gives almost identical results like with the unrefined shape. Again, with more 
anisotropic shape the benefit of the shape refinement would be more convincing.  

 
File -> structure -> Save as (Create backup copy) U3Fe2Ge7_s4 
NO (you don’t want to continue with the new structure) 

 
Conclusion 
Because the real shape is close to a sphere, the three methods for data correction yield very 
similar results. Also difference Fourier maps are similar. 
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Appendix 1.1: File format PRF  
 
PRF file is used for powder refinement. It contains Bragg positions and profile 
points. 
 

Format of PRF is sometimes requested by users to obtain data points of powder 
profiles for different purposes. For work with powders in Jana2006, knowledge of 
the PRF format is not needed. 
 
Revised: 10 May 2015 
 
As Jana2006 allows refinement against more data sets, PRF file may consist of several data blocks: 
 
Block1 begin 
......................... 
......................... 
Block1 end 
Block2 begin 
......................... 
......................... 
Block2 end 
 
In the case that there is just one data block, the labels are omitted. 
 
Each block consists of three parts: header, Bragg positions and profile points:  
 
 
    2    0    0    2    3    3 
   1  -1   2   3.   1   10.9743    0.0237    0.0380   0.547364E+01 
   1   0  -2   3.   1   10.9743    0.0237    0.0380   0.547364E+01 
   1  -1  -4   3.   1   13.7339    0.0236    0.0414   0.698639E+01 
   1   0   4   3.   1   13.7339    0.0236    0.0414   0.698639E+01 
   0   0  -6   1.   1   14.2831    0.0236    0.0421   0.130568E+01 
   0   0   6   1.   1   14.2831    0.0236    0.0421   0.130568E+01 
   2  -1   0   6.   1   17.1683    0.0235    0.0456   0.668545E+01 
   2  -1  -3   6.   1   18.6097    0.0235    0.0474   0.768642E-01 
   2  -2   4   3.   1   22.0509    0.0234    0.0517   0.238082E+01 
   2   0  -4   3.   1   22.0509    0.0234    0.0517   0.238082E+01 
   2  -1   6   6.   1   22.4023    0.0234    0.0522   0.573109E+00 
   2  -1  -6   6.   1   22.4023    0.0234    0.0522   0.573109E+00 
   1   0   1   8.   2   25.3002    0.0232    0.0598   0.194769E+02                     
....................................                                                      
.................................... 
 999 
  6.000000   0.209300E+04   0.249015E+04   0.457493E+02  6.023784    0   0.000000E+00   0.000000E+00   0.249015E+04 
  6.016766   0.209500E+04   0.247949E+04   0.457712E+02  6.040549    0   0.000000E+00   0.000000E+00   0.247949E+04 
  6.033532   0.217100E+04   0.246891E+04   0.465940E+02  6.057315    0   0.000000E+00   0.000000E+00   0.246891E+04 
  6.050298   0.206100E+04   0.245839E+04   0.453982E+02  6.074081    0   0.000000E+00   0.000000E+00   0.245839E+04 
  6.067064   0.204200E+04   0.244793E+04   0.451885E+02  6.090847    0   0.000000E+00   0.000000E+00   0.244793E+04 
  6.083830   0.217300E+04   0.243755E+04   0.466154E+02  6.107612    0   0.000000E+00   0.000000E+00   0.243755E+04 
  6.100596   0.210500E+04   0.242723E+04   0.458803E+02  6.124378    0   0.000000E+00   0.000000E+00   0.242723E+04 
............... 
............... 
 10.593884   0.102600E+04   0.986969E+03   0.320312E+02 10.617599    1   0.000000E+00   0.000000E+00   0.986969E+03 
 10.610650   0.108400E+04   0.101817E+04   0.329242E+02 10.634364    1   0.340796E+02   0.000000E+00   0.984355E+03 
 10.627417   0.991000E+03   0.101999E+04   0.314802E+02 10.651131    1   0.385393E+02   0.000000E+00   0.981752E+03 
 10.644182   0.105600E+04   0.102260E+04   0.324962E+02 10.667895    1   0.437751E+02   0.000000E+00   0.979160E+03 
 10.660948   0.104400E+04   0.102623E+04   0.323110E+02 10.684661    1   0.500343E+02   0.000000E+00   0.976579E+03 
............... 
............... 
 24.710857   0.361000E+03   0.316545E+03   0.190000E+02 24.734123    1   0.000000E+00   0.000000E+00   0.316545E+03 
 24.727623   0.347000E+03   0.316369E+03   0.186279E+02 24.750887    1   0.000000E+00   0.000000E+00   0.316369E+03 
 24.744389   0.341000E+03   0.353730E+03   0.184662E+02 24.767653    1   0.000000E+00   0.378276E+02   0.316194E+03 
 24.761154   0.353000E+03   0.356299E+03   0.187883E+02 24.784416    1   0.000000E+00   0.405929E+02   0.316019E+03 
 24.777920   0.385000E+03   0.359047E+03   0.196214E+02 24.801182    1   0.000000E+00   0.435381E+02   0.315845E+03 
 24.878517   0.375000E+03   0.383491E+03   0.193649E+02 24.901773    1   0.000000E+00   0.692188E+02   0.314806E+03 
............... 
............... 
999. 
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Header 
kType 2 for Jana2006  
KADoublet     0  data for data measured with wave length 
 1  for Kα1 and Kα2  
DataType 0 X-ray/neutron CW data 
 1 TOF data as a function of time  
 2 TOF data in d values 
 3 energy dispersive data 
NPhases  number of phases 
(NDim(i),i=1,NPhases)  number of indices used for each phases 

 
Bragg positions 
h,k,l,... n diffraction indices, where n = max(NDim(1), …, NDim(NPhases)).  

For phases having the dimension smaller than n the indices are completed 
by zeros.  

Multiplicity multiplicity of the reflection following from the symmetry 
KPhase defines the phase the reflection belongs to 

The following four items are repeated twice if KADoublet=1. The first block corresponds to Kα1 
TwoTheta/Time
/d/energy 

angular position/time (or for TOF d value/energy) of the peak as calculated 
from cell parameters and modulation vectors 

Shift the angular shift of the peak position due to a zero shift, sycos and sysin 
parameters (it need not be constant for all reflections). The actual of 
reflections with respected to the profile should be calculated as: 
[TwoTheta/Time/d/energy] -Shift 

FWHM in the same units are previous values  
Icalc(h,k,l) intensity as calculated from Rietveld (corrected for multiplicity and 

preference orientation) or as extracted from the profile by le Bail fit. 
The list of Bragg peaks ends with the integer 999 at the position of the h index. 

 
Profile points 
TwoTheta/Time/d/energy diffraction angle/time for TOF/d value/energy of the profile 

point 
Iobs observed intensity 
Icalc calculated intensity 
sig(Iobs) standard uncertainty of Iobs 
TwoTheta-corr/Time-corr/ 
d-corr/energy-corr 

diffraction angle/time for TOF/d value/energy of the profile 
point corrected for zero shift, sysin and sycos 

Icalc calculated intensity 
Skip flag 0 if the profile point was used in the refinement 

1 if the profile point belongs to one of excluded region  
Icalc(1) calculated intensity of the first phase 

. . . . 
Icalc(NPhases) calculated intensity of the first phase 
Ib background intensity  

The list of peak points ends with the real number “999.”. 
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